21:03:13 <rbergeron> #startmeeting Cloud SIG
21:03:13 <zodbot> Meeting started Thu Feb  3 21:03:13 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:03:19 <rbergeron> #meetingname Cloud SIG
21:03:19 <zodbot> The meeting name has been set to 'cloud_sig'
21:03:26 <rbergeron> #topic Roll Call!
21:03:36 * skvidal is here
21:03:44 * ke4qqq 
21:03:44 * CodeBlock is too
21:03:45 * mgoldmann waves
21:03:50 <jdarcy> Present.
21:03:53 * jgreguske waves
21:03:55 * abadger1999 here
21:04:04 * jforbes is here
21:04:16 <rbergeron> greetings, all. :)
21:04:33 <smooge> was here
21:04:43 <rbergeron> yeah, i know.
21:04:58 * rbergeron killed the infra meeting again
21:05:04 <rbergeron> #topic Agenda
21:05:19 <rbergeron> Let's see here. I'm a little sleepy from some thing we had over the weekend called FUDCon, but:
21:05:50 <rbergeron> * FUDCon Wrapup * EC2 status * BG Status * CloudFS Status * Aeolus/Deltacloud updates * Anything else?
21:06:05 * rbergeron looks around for any additions to the agenda that anyone would like to add
21:06:13 <rbergeron> #topic FUDCon Wrapup
21:06:44 <rbergeron> So first off: After all my flogging of getting everyone to come to FUDCon, I would like to apologize for not actually attending anyone's presentations. :( I hope you all had a good time, got some stuff done, were able to meet each other.
21:07:00 <rbergeron> Does anyone have any takeaways / actions / etc. that they wanted to discuss?
21:07:18 <mgoldmann> yes, it was nice to meet all the other people, thanks rbergeron!
21:07:26 <smooge> sleep good. luke with alcohol bad
21:07:33 * rbergeron grins
21:07:34 <jgreguske> lolz
21:07:43 <jgreguske> skvidal: I need to get that incriminating evidence from you
21:07:49 <jforbes> We were supposed to sleep?
21:07:56 <skvidal> jgreguske: LA LA LA LA
21:08:04 <rbergeron> jforbes: first I've heard about that.
21:08:06 <jdarcy> No actions, but for the record it was awesome getting to meet and talk to (almost) everyone ftf.
21:08:40 * skvidal was quite pleased with the venue, the weather, most of the food oh and I guess it was nice to talk to folks in the project, too
21:09:15 <jforbes> I actually need to get some info from jgreguske this week, and get a couple of overhead bits on EC2 finished up
21:09:25 <rbergeron> ooh. what an excellent transition there.
21:09:28 <rbergeron> #topic EC2
21:09:35 <jgreguske> jforbes: what do you need?
21:09:40 <rbergeron> jforbes: how goes ec2?
21:09:57 <jforbes> jgreguske: internal repos locations
21:10:13 <skvidal> jforbes: I thought mirrormanager was magically handling that?
21:10:22 <jforbes> skvidal: not that kind of repos
21:10:27 <skvidal> oh, sorry.
21:10:44 <jgreguske> jforbes: for scripts?
21:10:56 <jforbes> jgreguske: scripts and ks
21:11:09 <jgreguske> jforbes: ah mail that to you momentarily
21:11:12 <jgreguske> *I'll
21:11:25 <jforbes> things went well, got a chance to sit down with jgreguske and dgilmore to go over some of the EC2 stuff
21:11:50 <jforbes> I need to edit a couple of script, and koji needs to be fixed to make image builds work again
21:12:14 <rbergeron> and I know you and I talked a bit about documentation bits as well.
21:12:23 <rbergeron> in the "outdoor track"
21:12:26 <rbergeron> :)
21:12:32 <jforbes> Yes, that too :)
21:12:42 <jgreguske> jforbes: mailed
21:12:54 <jforbes> We also need to get rel-eng some account information, but I need to get a link from spevack before I can do that
21:12:55 <rbergeron> and I still owe you a test day request, and now that I have time I can actually do that.
21:13:18 <jforbes> rbergeron: were you busy with something last week?
21:13:21 <jforbes> haha
21:13:27 <rbergeron> jforbes: does spevack know what you need? if you want - send it to me, and I'll make sure he gets it to you.
21:13:38 <rbergeron> he's in brussels atm and i odn't think he's getting back till next weekish.
21:14:05 <jgreguske> jforbes: dgilmore: I was able to reproduce the appliance-tools issue on my koji instance, hope to have a solution soon
21:14:06 <jforbes> rbergeron: he does, though I am sure he is a bit distracted, I need to send him an email about related things too, just going to remind him there
21:14:08 <rbergeron> and I think his current status is PTFO.
21:14:16 <jforbes> jgreguske: excellent
21:14:38 <jgreguske> jforbes: caught up on $dayjob after fudcon so I should be able to focus on it
21:14:54 <skvidal> PTFO?
21:15:06 * skvidal has an idea what the F is
21:15:13 <smooge> pissed the f off
21:15:27 <smooge> frick.. I hit return soryr
21:15:50 <rbergeron> passed the frick out :)
21:15:59 <smooge> anyway back to this. what does the test day cover?
21:16:11 <skvidal> ah, I was thinking something like "Paid Time, Frack Off"
21:16:22 <rbergeron> jforbes: would you like to elaborate on the test day idea?
21:16:43 <jforbes> smooge: EC2 images, BG, etc.  We have a few pieces that need test cases written
21:17:10 <rbergeron> (and I have to make a wiki page)
21:17:19 <rbergeron> and yes: i was busy with something last week ;)
21:17:20 <mgoldmann> btw, we're in the the process of cretating some test cases for BG now
21:17:37 <rbergeron> #action rbergeron to really make that test day wiki page for cloud
21:17:40 <jforbes> rbergeron: preferably not the week before or the week after virt test day
21:17:50 <mgoldmann> https://issues.jboss.org/browse/BGBUILD-143
21:17:56 <rbergeron> #action rbergeron to not schedule it the week before or after virt test day
21:18:02 <rbergeron> :)
21:18:17 <jforbes> mgoldmann: excellent
21:18:30 <rbergeron> #info test cases are being created for BG now - https://issues.jboss.org/browse/BGBUILD-143
21:18:45 <smooge> BG?
21:18:50 <mgoldmann> BoxGrinder
21:18:51 <rbergeron> boxgrinder
21:19:02 <mgoldmann> this will be more formal in the next days or so
21:19:05 <rbergeron> Anything else on ec2 from anyone?
21:19:09 <smooge> oh the monkey thing no one could answer
21:19:13 <smooge> I wanted the monkey
21:19:20 <smooge> but the stickers went away
21:19:21 <rbergeron> I can send you a monkey sticker, i have some
21:19:26 <smooge> oook
21:19:27 <mgoldmann> smooge: still in Tempe? :)
21:19:27 <rbergeron> and since I have your jacket and beefy miracle
21:19:29 <jforbes> Actually, it came up and I need to follow up with mdomsch on mirrors
21:19:39 <smooge> sadly not til April
21:19:46 <rbergeron> mgoldmann: are you still here???
21:19:46 <mdomsch> hallo
21:19:52 <mgoldmann> rbergeron: yes
21:20:02 <mgoldmann> my flight was cancelled
21:20:05 <rbergeron> when are you leaving?? /me woul dhave said hi last night when she was over
21:20:16 <jforbes> mdomsch: It has been a long while since we discussed it, but what is the status on getting mirrors set up?
21:20:17 <mgoldmann> I'm flying back tomorrow
21:20:41 <rbergeron> i didn't know that. sorry :(
21:20:41 <mdomsch> jforbes: I've been slowly fixing up MM to be able to handle it
21:20:49 <mdomsch> very slowly
21:20:56 <mgoldmann> rbergeron: not bad at all, warmer than in Poland, still
21:21:07 <jforbes> mdomsch: okay.  Just didn't want to forget about it (like I did)
21:21:18 <mdomsch> jforbes: I added the ability to put &location=(something) at the end of the mirrorlist query URL
21:21:31 <mdomsch> which will be ignored for now, but used once MM 1.4 is done
21:21:46 <rbergeron> #info mdomsch is working on getting mirrors up
21:21:48 <mdomsch> jforbes: you define the (something), I'll make it work
21:21:54 <rbergeron> welcome gholms :)
21:21:56 <gholms> Ooh, mirrors?
21:22:01 <mdomsch> that's MM.  As for the mirrors themselves, I've done nothing.
21:22:07 <rbergeron> #undo
21:22:07 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x2b025f8d89d0>
21:22:09 <gholms> Oh.  :-\
21:22:24 <rbergeron> #action mdomsch is doing things with MM.
21:22:27 <rbergeron> NO
21:22:28 <rbergeron> #undo
21:22:28 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x2b025fb22690>
21:22:33 <rbergeron> #info mdomsch is doing things with MM
21:22:34 <gholms> That's strike two.
21:22:38 <rbergeron> i know.
21:22:41 <rbergeron> #chair gholms
21:22:41 <zodbot> Current chairs: gholms rbergeron
21:22:47 <gholms> Heh
21:22:52 <rbergeron> just prepping for when I strike out.
21:23:02 * gholms readies the baseball bat
21:23:28 <rbergeron> okay. anything else ec2-ish?
21:23:37 <jforbes> nothing here
21:23:44 <rbergeron> #topic BoxGrinder status
21:23:51 <rbergeron> mgoldmann: how goes your feature?
21:24:06 <mgoldmann> AS you may know (or not) BoxGrinder feature is complete! http://fedoraproject.org/wiki/Features/BoxGrinder
21:24:15 <rbergeron> #info BG is complete! woot
21:24:27 <jforbes> mgoldmann: congrats! (and thanks)
21:24:30 <mgoldmann> now the testing part could start
21:24:52 <rbergeron> awesome. that is excellent news.
21:24:55 <mgoldmann> I'm working on new release 0.8.0
21:25:05 <gholms> What's special about that one?
21:25:06 <mgoldmann> I hoped for releasing it before FUDCon, but, well...
21:25:07 <smooge> ok is there a need or requirement for boxgrinder to be put/run/cared for by infrastructure
21:25:31 <mgoldmann> smooge: no
21:25:38 <gholms> smooge: Not unless you guys plan to build Fedora images
21:26:01 <mgoldmann> gholms: a lot of new features: https://issues.jboss.org/secure/IssueNavigator.jspa?reset=true&jqlQuery=project+%3D+BGBUILD+AND+fixVersion+%3D+%220.8.0%22+ORDER+BY+updated+DESC%2C+priority+DESC%2C+created+ASC&mode=hide
21:26:07 <mgoldmann> wow, what a nice url :)
21:26:14 <gholms> Holy long URI, Batman!
21:26:44 <smooge> ok cool
21:26:53 <mgoldmann> I wrote two post highlighting some of them
21:27:18 <gholms> Oh yeah, something about it being a proper ruby lib now.
21:27:19 <mgoldmann> http://cloudpress.org/2011/01/25/boxgrinder-build-0-8-0-features-new-configuration-and-cli/
21:27:25 <mgoldmann> http://cloudpress.org/2011/01/26/boxgrinder-build-0-8-0-features-using-boxgrinder-as-a-library/
21:27:28 <mgoldmann> yep
21:27:54 <mgoldmann> btw, slides from my FUDCon talk are avaialble here: http://cloudpress.org/2011/01/29/fudcon-2011-tempe-slides-from-boxgrinder-talk/
21:28:07 <gholms> What's up next?
21:28:28 <rbergeron> gholms: are you asking me or mgoldmann
21:28:42 <gholms> Either, I guess.
21:28:44 <rbergeron> mgoldmann: anything else? :)
21:28:59 <mgoldmann> I think that's all from my side, thanks!
21:29:07 <rbergeron> #topic CloudFS status
21:29:09 <mgoldmann> (I still have some stickers in Tempe if you need :))
21:29:12 <rbergeron> jdarcy: hi!
21:29:19 <jdarcy> Hi.  :)
21:29:29 <jdarcy> OK, I'm finally getting on top of the packaging stuff.
21:29:32 <rbergeron> how's things?
21:29:34 <rbergeron> :)
21:29:48 <jdarcy> I collared one of the Gluster maintainers, who is building and pushing the patches I need there as we speak.
21:30:20 <rbergeron> cool.
21:30:24 <jdarcy> Very soon after that, I'll push the cloudfs srpm that depends on those changes.
21:31:03 <jdarcy> There might be a magazine article coming out soon about CloudFS, since there was a magazine editor in the audience at my talk.
21:31:12 <rbergeron> amber?
21:31:23 <rbergeron> or someone else
21:31:33 <jdarcy> Someone else.  ;)
21:31:39 <ke4qqq> rik farrow?
21:31:44 <rbergeron> ahhh
21:31:55 <jdarcy> ke4qqq: That's the name I was trying to find, yeah.
21:32:33 <jdarcy> The second third full-time cloudfs developer at Red Hat will be starting mid-month, so there should be more steady progress.
21:32:53 <jdarcy> And I owe somebody something for test day.
21:32:55 <rbergeron> jdarcy: the second third?
21:33:01 <jdarcy> Second and possibly third.
21:33:06 <gholms> That's good news.
21:33:17 <rbergeron> jdarcy: you can tack it onto the wiki page i haven't made yet when i send out the page.
21:33:24 <jdarcy> OK.
21:33:30 <jdarcy> That's about it, I think.
21:33:30 <rbergeron> (after I make it.)
21:33:33 <rbergeron> cool.
21:33:53 <jdarcy> Sorry for taking this down to the wire deadline-wise.
21:33:54 <rbergeron> #topic Deltacloud / Aeolus
21:34:00 <gholms> Hehe
21:34:02 <rbergeron> jdarcy: it's all good.
21:34:40 * rbergeron looks around for clalance and mmorsi but doesn't see them
21:34:53 <jdarcy> Haven't seen Chris here in Westford today either.
21:35:05 <jforbes> possibly still stuck in transit?
21:35:15 <rbergeron> jdarcy: that's because nobody went into the office, except you, apparently. :)
21:35:35 <jgreguske> hey I'm here
21:35:43 * rbergeron hands jgreguske one american dollar
21:35:44 <jdarcy> Ah, he's on a train.
21:35:47 * jforbes got home by leaving early, but hasn't been able to leave the house since
21:35:49 <jgreguske> YES
21:35:56 <rbergeron> cherish it!
21:36:14 * rbergeron can't believe she even has dollars left after all the games max beat her at :(
21:36:40 <rbergeron> i'm poooooooo now
21:36:44 <rbergeron> err.
21:36:46 <rbergeron> poooooooooor
21:36:51 <rbergeron> there is a big difference.
21:36:58 <gholms> I saw you stomp him at bowling, at least.
21:36:59 <jforbes> Suppposed to be an excess of dollars here this weekend
21:37:11 <rbergeron> I didn't actually stomp him.
21:37:18 <rbergeron> He came back at the end with like 4 strikes in a row
21:37:31 <rbergeron> #topic Any other business??
21:38:04 <gholms> Oof
21:38:14 <jdarcy> None here.
21:39:09 <rbergeron> I have some beer leftover.
21:39:15 <gholms> Still?
21:39:26 <gholms> Geez, tell spot not to buy so much next time.
21:39:52 <rbergeron> no.
21:39:53 <rbergeron> :)
21:40:28 <rbergeron> okay.
21:40:36 <rbergeron> if there is nothing else, I'm gonna end this puppy. :)
21:41:13 <gholms> [The puppy barks]
21:41:20 <rbergeron> lol
21:41:23 <rbergeron> #endpuppy
21:41:25 <rbergeron> #endmeeting