21:00:17 <rbergeron> #startmeeting Cloud SIG
21:00:17 <zodbot> Meeting started Thu Feb 17 21:00:17 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:23 <rbergeron> #meetingname Cloud SIG
21:00:23 <zodbot> The meeting name has been set to 'cloud_sig'
21:00:40 <rbergeron> #topic Roll call!!
21:00:48 * rbergeron preps for an exciting meeting of fun.
21:00:55 <gholms> ROFLCOPTER POWNTERSKATES
21:01:17 <brianlamere> we should be funny and say there's nothing to discuss, then end the meeting - just because they ran out of time.  then talk about fudcon.  ;)
21:01:26 <rbergeron> lol
21:01:37 * rbergeron wonders what a pownterskates is, exactly.
21:01:51 <rbergeron> hello jgreguske, mgoldmann, brianlamere, gholms :)
21:01:57 <gholms> LOLOLOL
21:01:58 * obino wondering what's in the water today
21:02:05 <jgreguske> hey
21:02:09 <mgoldmann> morning again!
21:02:20 * rackerhacker ohai's
21:02:42 <rbergeron> hey rackerhacker
21:02:43 <jforbes> hai
21:02:45 <rbergeron> obino ;)
21:02:48 <rbergeron> mr. forbes
21:02:58 <rbergeron> Shall we have a meeting?
21:02:59 <brianlamere> obino: di-hydrogen monoxide.  really dangerous chemical, kills half a million per year, probably
21:03:23 <rbergeron> #topic EC2
21:03:31 <rbergeron> I figure i'll get the fun stuff out of the way first.
21:03:46 <rbergeron> jforbes: anything exciting in the world of ec2?
21:04:06 <gholms> Amazon is making more money than ever.  :3
21:04:08 <jforbes> Nothing too new to report at this moment, as of yesterday still waiting for koji
21:04:12 * brianlamere listens intently
21:04:13 <jgreguske> I sent a patch to dgilmore 20 minutes ago to work around the koji image building problem
21:04:26 <jforbes> jgreguske: you rock sir!
21:04:35 <dgilmore> i sent a request asking for ok to apply the patch
21:04:39 <jgreguske> jforbes: I'm glad you're the patient type
21:04:43 <jgreguske> :)
21:05:06 <rbergeron> gholms: lol
21:05:16 * rbergeron throws a rock at her vpn
21:05:19 * jforbes is under a mountain of virt stuff this week, so patience is easy
21:05:31 <jgreguske> jforbes: I'll petition bcl to build a fixed livecd-tools for f14 (or I'll do it myself)
21:05:38 <jgreguske> wasn't abel to reach him today
21:05:56 <jforbes> jgreguske: thanks
21:06:54 <gholms> Thanks for doing all that, guys.
21:06:54 <rbergeron> anything else? :)
21:06:59 <gholms> s3cmd?
21:07:04 <jgreguske> nothing from me
21:07:15 <gholms> LAst week we talked about testing that.
21:07:24 <rbergeron> Sure. s3cmd is something related to me asking around about testing money, which I've failed miserably to do.
21:07:33 <rbergeron> I think.
21:07:37 * rbergeron looks at her sent mails
21:07:41 <gholms> :-\
21:07:51 * tibbs|h scrolls back....
21:08:15 <rbergeron> Oh, wait - I think someone was going to send me a mail re: estimates, or something.
21:08:22 * rbergeron looks at brianlamere
21:08:28 <brianlamere> ha - and in the mean time, it died on a large file for me yesterday :P though that's not terribly much an issue...maybe.  280M, died at 250, had to restart
21:08:34 <brianlamere> oh...err...
21:08:52 <brianlamere> yeah.  let me...send that to you this afternoon.  :/
21:08:56 <mgoldmann> this is called ping-pong :)
21:09:15 * rbergeron knew something was going to trigger her memory
21:09:21 * rbergeron tosses a ball at mgoldmann
21:09:27 <rbergeron> Okay. Beyond the money angle:
21:09:51 * mgoldmann was killed by that ball
21:09:53 * rbergeron looks around for comments, questions, something about things dying up above from brianlamere
21:10:11 <gholms> #action brianlamere will send rbergeron cost estimates for S3 mirror testing
21:10:17 <rbergeron> #chair gholms
21:10:17 <zodbot> Current chairs: gholms rbergeron
21:11:14 <gholms> rbergeron: Anything actionable as far as accounts go?
21:11:40 * rbergeron thinks. Sorry, I'm incredibly slow today.
21:12:14 <rbergeron> #action rbergeron to still sort out "who has what accounts and what they are for and who pays for them"
21:12:35 <rbergeron> If that's what you're asking
21:12:50 * gholms nods
21:13:30 <rbergeron> Other than that, no.
21:13:36 * rbergeron will fire off that mail in short order here.
21:14:14 <gholms> What's next?
21:14:33 * rbergeron looks around for any other EC2-related comments, questions, etc.
21:14:38 <jgreguske> jforbes: update
21:14:38 <rbergeron> I'm not seeing much.
21:14:42 <rbergeron> oh, wait.
21:15:02 <jgreguske> jforbes: bcl is going to build an f14 livecd-tools tomorrow that should have the backported f15 fix
21:15:03 <brianlamere> anything I would say is followup to my own stuff, so...meh.
21:15:13 <jforbes> jgreguske: excellent, thanks
21:15:20 <jgreguske> sure thing
21:15:22 * jgreguske done
21:16:11 * rbergeron hugs brianlamere
21:16:42 <rbergeron> #info bcl is going to build an f14 livecd-tools tomorrow that should have the backported f15 fix
21:16:47 <rbergeron> Okay! movin on.
21:16:50 <gholms> Awesome
21:16:50 <rbergeron> #topic BoxGrinder
21:16:57 <rbergeron> mgoldmann: HELLO!
21:17:12 * mgoldmann raises his hand and says hello back
21:17:28 <mgoldmann> so, I have only 2 informations
21:17:38 <mgoldmann> we have new website! http://boxgrinder.org/
21:17:48 <obino> nice!
21:17:49 <gholms> Got sick of the old one?
21:17:54 <gholms> :P
21:18:19 <mgoldmann> the chat is logged, so I'll say – it was asking for a refresh :)
21:18:29 <gholms> Heh
21:18:49 <mgoldmann> but, now blog is under same domain, tutorials etc
21:18:53 <mgoldmann> everything in one place
21:19:08 <gholms> How has 0.8 seemed?
21:20:00 * mgoldmann is not sure what gholms is asking about :(
21:20:17 <gholms> BG 0.8?
21:20:27 <gholms> You know, the program you spend a lot of time working on it.
21:20:32 <mgoldmann> yes, BG 0.8.0, was released some time ago, after fudcon
21:20:39 <jgreguske> mgoldmann: how has reception/feedback for 0.8 been
21:20:40 <mgoldmann> http://boxgrinder.org/blog/2011/02/09/boxgrinder-build-0-8-0-released-finally/
21:20:46 <mgoldmann> ah, there we go
21:20:58 <gholms> Yeah, I meant what jgreguske said.  :)
21:21:18 <mgoldmann> so far I hadn't recevied any bug reports, and folks who use it and I know about it - like it
21:21:38 * ke4qqq appears late
21:21:38 * mgoldmann sucks with his English
21:21:52 <gholms> Excellent
21:21:58 <gholms> What's next?
21:22:07 * rbergeron hands gholms the whip
21:22:10 <rbergeron> ;)
21:22:14 <mgoldmann> I've built today CentOS 5 appliance on Fedora 14 without issues!
21:22:25 <gholms> rbergeron: I strictly use blades.
21:22:32 <rbergeron> gholms: interesting.
21:22:32 * gholms pulls out his rapier
21:22:40 <jgreguske> mgoldmann: you still using app-t behind the scenes?
21:22:43 <gholms> mgoldmann: That IS good news!
21:22:46 <mgoldmann> and the appliance works like a charm, no issues, warning, nothing
21:22:55 <gholms> With selinux on as well?
21:23:01 <mgoldmann> jgreguske: yes
21:23:08 <mgoldmann> gholms: yes!
21:23:11 <jgreguske> mgoldmann: how are you getting past rpm incompat?
21:23:13 <gholms> :D
21:23:22 <gholms> jgreguske: He rebuilds the rpm database.
21:23:24 <mgoldmann> simple RPM database dump + import
21:23:30 <jgreguske> ah ok
21:23:46 <jgreguske> mgoldmann: before and after?
21:23:51 <mgoldmann> this was possible because of gholms and skvidal
21:23:55 <mgoldmann> jgreguske: just after
21:24:05 <gholms> I did some… testing for skvidal.  :)
21:24:25 <mgoldmann> https://issues.jboss.org/browse/BGBUILD-148
21:24:26 <mgoldmann> jgreguske: ^
21:25:13 <jgreguske> thanks; was just curious
21:25:48 <mgoldmann> most probably this feature will be added to the next release, maybe 0.8.1
21:26:08 <mgoldmann> but more probably 0.9.0
21:26:25 <mgoldmann> this needs some tests of course :)
21:26:38 <mgoldmann> that's all from my side - any questions?
21:26:48 <obino> what do we need to do to help you with the eucalyptus plugin?
21:27:00 <mgoldmann> obino: fix bugs I reported :)
21:27:04 <gholms> Heh
21:27:10 <obino> :)
21:27:11 * rbergeron salutes mgoldmann for his insane levels of productivity, as always :)
21:27:13 <mgoldmann> one sec, compiling the list
21:27:14 * gholms looks for links
21:27:57 <mgoldmann> https://bugs.launchpad.net/euca2ools/+bug/704658
21:28:02 * rbergeron waves to the late ke4qqq in a delayed way
21:29:01 <gholms> Oh yeah, region support.
21:29:48 <mgoldmann> https://bugs.launchpad.net/euca2ools/+bug/711534
21:30:02 <gholms> Right now mgarnaat has euca2ools completely torn apart, so now is not a good time for me to be working on it.
21:30:17 <mgoldmann> sorry it took so long - searched for "list my bugs" link on launchpad
21:30:28 <obino> thanks for the list: I'll take as an action item to flog gholms publicly each week the bugs stays open
21:30:34 <mgoldmann> that's all I reported, so not so much
21:30:51 <mgoldmann> after this I can go further with eucalyptus support
21:31:02 <gholms> mgoldmann: Was the second of those the bug where the same command works with S3 but not Eucalyptus?
21:31:02 <mgoldmann> obino: thanks :)
21:31:14 <mgoldmann> gholms: yes
21:31:27 * gholms reassigns the bug
21:32:23 <gholms> What's next?
21:32:51 <rbergeron> hmmm.
21:32:55 * rbergeron looks around at who's here
21:33:09 <gholms> CloudFS/whatever?
21:33:12 <rbergeron> oh, wait, I shouldn't do that.
21:33:23 <gholms> Open floor?
21:33:24 <rbergeron> yeah, I don't see jdarcy. I'll go ring him in the cloud channel.
21:33:32 <rbergeron> All hail gholms? :)
21:33:34 <gholms> Aeoleus?  (Not sure how it's spelled)
21:33:57 <mgoldmann> ejlus (polish)
21:34:04 <mmorsi> aeolus*
21:34:06 <mgoldmann> but this doesn't help you either
21:34:28 * rbergeron waits for a jdarcy or a clalance
21:34:29 <gholms> mmorsi: I figured if I threw enough vowels in there I would be close.  :P
21:34:34 <mmorsi> heh
21:34:37 <rbergeron> oh
21:34:39 <rbergeron> mmorsi :)
21:34:41 <rbergeron> DUH
21:34:48 <mmorsi> don't worry, i'm easy to miss ;-)
21:34:59 <clalance> rbergeron just reminded me.
21:35:00 <clalance> Sorry.
21:35:00 <mmorsi> not too much more to report on that front anyways
21:35:06 <mmorsi> we just closed out a sprint
21:35:06 <gholms> Change /topic plzkthx
21:35:09 <rbergeron> I don't think I saw you walk in. ;)
21:35:15 <rbergeron> #topic Aeolus
21:35:25 <mmorsi> aight shall i repeat myself ;-)
21:35:41 <rbergeron> Sorry. I apparently suck today. :)
21:36:13 <clalance> Right, like mmorsi said, not a whole lot to report.
21:36:27 <mmorsi> just closed out our sprint finished ui revamp (removed old bit), initial security configuration, search integration, and published new rpms w/ a slew of changes to our repo
21:36:44 <mmorsi> http://repos.fedorapeople.org/repos/aeolus/packages/
21:37:40 <rbergeron> cool.
21:37:43 * rbergeron is looking at it now
21:38:11 * mgoldmann thinks some links should be noticed by our chairs
21:38:17 <mmorsi> ya we were able to remove a few deps (thx in part to boxgrinder pulling in euca2ools) and get a few into fedora as well
21:38:31 <gholms> mgoldmann: zodbot picks up every link these days.  :)
21:38:35 <rbergeron> mgoldmann: links get automagically added in now, IIRC, without having to add the #link
21:38:42 <mgoldmann> hey, nice!
21:38:46 * mgoldmann shut ups
21:38:50 <rbergeron> if only zodbot could read our minds more.
21:39:02 <mmorsi> we have various things in store for our next sprint included expanding on all these, more integration between components (such as warehouse integration into the ui and tighter integration w/ condor and the conductor), a more robust / automated test systems, etc
21:39:09 <gholms> rbergeron: I don't want zodbot to know what's in my mind.
21:39:09 <rbergeron> #chair mgoldmann
21:39:09 <zodbot> Current chairs: gholms mgoldmann rbergeron
21:39:19 <brianlamere> gholms +1
21:39:25 <clalance> Yeah, probably best that way ;).
21:39:26 <gholms> mmorsi: Sounds like you guys have a lot on your plate.
21:39:30 <rbergeron> no, we don't need a corrupted zodbot ;)
21:39:39 <mmorsi> gholms: yeh, but whats new ? ;-)
21:39:57 <gholms> mmorsi: AFAICT just BG 0.8.
21:40:04 <gholms> Everything else is old.
21:40:08 <clalance> Haha.
21:40:11 <mgoldmann> and website!
21:40:12 <mgoldmann> :)
21:40:23 * mgoldmann tries to pimp his work
21:40:26 <gholms> Open floor?
21:40:42 <rbergeron> Sure.
21:40:45 <mmorsi> sure, thats bout it 4 me
21:40:46 <rbergeron> #topic Open Floor
21:40:54 * gholms pets zodbot
21:41:38 <mgoldmann> What about test days?
21:41:50 <gholms> What would you like to test?
21:41:50 <brianlamere> ls
21:41:57 <brianlamere> (heh - sorry)
21:42:02 <rbergeron> oh, that's a good topic.
21:42:05 <rbergeron> #topic Test Days
21:42:07 <mgoldmann> BG feature?
21:42:11 <rbergeron> jforbes: you still about?
21:42:19 <rbergeron> Yeah, so we have a few things we can test.
21:42:21 <jforbes> rbergeron: I am
21:42:25 * rbergeron pulls out the schedule to see where we are.
21:42:29 <mgoldmann> we have here our QA guy - msavy which has done some BG testing for us
21:42:34 <gholms> mgoldmann: That's a decent idea.  Up for making a test day page?
21:42:37 <rbergeron> jforbes: test days
21:42:44 <rbergeron> gholms: there is already a Cloud SIG test day page.
21:42:52 <mgoldmann> gholms: cloud SIG test days page?
21:42:54 <rbergeron> or, well -
21:42:54 <jforbes> Right, so we need to start getting individual test plans done
21:42:58 <gholms> We have one, eh?
21:43:00 <rbergeron> I filed a ticket with QA
21:43:00 * gholms looks
21:43:04 <rbergeron> to get a test day
21:43:13 <mgoldmann> do we have a link to that page?
21:43:14 * rbergeron goes and looks in her tickets
21:43:18 <jforbes> This is similar to virtualization, in that we have several things to test that are loosely related under the cloud moniker
21:43:22 <mgoldmann> I'm happy to add some BG stuff there
21:43:42 <jforbes> Essentially we need individual test pages for the various features/items that link off of the main page
21:44:07 <mgoldmann> yep, god idea, are there any examples from previous releases?
21:44:13 <mgoldmann> good even :)
21:44:22 <jforbes> https://fedoraproject.org/wiki/Test_Day:2010-04-08_Virtualization is an example
21:44:38 <mgoldmann> jforbes: thanks
21:44:40 <rbergeron> Well, I filed a test day ticket, in any case.
21:44:47 <rbergeron> Maybe I'm missing a step here.
21:45:22 <jforbes> rbergeron: Umm, I updated the wiki page myself for Virt... The test day tickets have not been getting any response this cycle for some reason
21:45:23 * mgoldmann is new to Test Days
21:45:39 <rbergeron> jforbes: hopefully it's not something I'm supposed to be doing :) HAH
21:45:53 <rbergeron> adamw, jlaska: do I just need to make the wiki page myself for a cloud test day?
21:45:59 * rbergeron wonders if either are about by chance
21:46:11 <jforbes> not sure what the deal is on it now
21:46:20 <adamw> rbergeron: it's kinda up to you
21:46:30 <adamw> you can take as much or as little help from qa as you like
21:46:40 <adamw> if you'd like us to help you set up the page and test cases and so on, just yell out on the ticket
21:46:50 <jforbes> rbergeron: okay, so we can do the page/pages
21:47:00 <jforbes> Did the test day actually make it to the calendar?
21:47:08 <adamw> do use the template as a basis if you diy
21:47:18 <mgoldmann> https://fedoraproject.org/wiki/QA/Fedora_15_test_days
21:47:26 <jlaska> rbergeron: what adamw said :D
21:47:28 <rbergeron> jforbes: not that I see.
21:47:29 <jforbes> adamw: yup, it will end up being just like the virt ones
21:47:36 <rbergeron> Do I just steal a slot on the calendar?
21:47:56 <jforbes> rbergeron: that's what I did after there wasn't any response for a bit
21:48:02 * rbergeron was trying to follow the instructionz
21:48:04 <adamw> yup, go ahead and grab one
21:48:08 <adamw> what's the ticket for this day?
21:48:15 * adamw away selling stuff for a few mins
21:48:27 <rbergeron> adamw: i'll pull it back up
21:48:32 <rbergeron> adamw: what are you selling?
21:48:32 <mgoldmann> what things we have really to test?
21:49:15 <mgoldmann> I can see only BG from feature list
21:49:26 <mgoldmann> and CloudFS, but I'm not sure if this will go as F15 feature
21:49:38 <jforbes> mgoldmann: EC2 images, BG, some of the delta stuff
21:49:41 <brianlamere> didn't he say he was pushing back to 16?
21:49:47 <rbergeron> adamw, jforbes: https://fedorahosted.org/fedora-qa/ticket/169
21:49:52 <mgoldmann> jforbes: right
21:49:54 <rbergeron> CloudFS is getting pushed to 16, yes
21:50:06 <jforbes> rbergeron: are you updating the schedule page, or shall I?
21:50:23 <rbergeron> jforbes: I'll let you - I recall we wanted 4/28 as first choice
21:50:27 <rbergeron> or 3/24
21:50:35 <jforbes> 4/28 is good
21:50:55 <rbergeron> I know you have the virt stuff to work around :)
21:51:05 <mgoldmann> there is also 4/21 - one week after virt
21:51:41 <rbergeron> mgoldmann: Do you think msavy would want to participate (even if just from planning angle)?
21:51:50 <msavy> sure, the more I can learn the better
21:52:32 <mgoldmann> rbergeron: definitely!
21:52:34 <rbergeron> oh, hey msavy :)
21:52:45 <mgoldmann> the plan is to do some integration tests on EC2
21:52:48 <jforbes> Page updated
21:52:50 <rbergeron> jforbes: Want to just shoot the list a link when you have the page framed?
21:52:53 <rbergeron> oh
21:52:54 <rbergeron> you're *awesome*
21:53:03 <mgoldmann> automatic launch, do the test and gather results
21:53:04 <msavy> rbergeron, hi!
21:54:10 <msavy> yeah, just need to construct some tests that will give, with a high degree of accuracy, that the OS built is definitely working
21:54:36 * rbergeron nods
21:54:47 <gholms> Run an HTTP server for one of the tests.
21:54:52 <gholms> (with selinux on)
21:54:54 <brianlamere> ha
21:55:07 <brianlamere> sad, but true
21:55:29 <rbergeron> Do we want to talk about the possible tests in the wiki page itself, or start in email?
21:55:34 <msavy> Yeah, you can get some fairly insidious problems where everything ostensibly looks good, but is actually broken in some subtle way
21:55:35 * rbergeron sort of thinks wiki would probably work well
21:55:42 <msavy> agree, seems a good idea.
21:55:54 <brianlamere> yeah, do the basic stuff.  maybe set up a package that installs httpd, mysql-server, starts both, creates a database, launches a webpage, then tries to visit it...with a success being a page that pops up
21:56:04 <jforbes> yeah, will shoot a message when the outline is ready
21:56:10 <rbergeron> Coolio.
21:56:21 <rbergeron> #action jforbes to send mail when test day page is outlined
21:56:33 <rbergeron> #action Everyone: Put in your ideas to the wiki page once Justin sends out details for Cloud test day.
21:56:40 <brianlamere> msavy: there was a bug that most notably affected httpd, that's why it was mentioned
21:56:40 <gholms> Thanks
21:56:54 <mgoldmann> brianlamere: yep, fixed in BG
21:57:09 <gholms> We aren't using BG to spin the EC2 images.
21:57:14 <mgoldmann> (just for the record)
21:57:41 <mgoldmann> yep, that true too :)
21:58:00 <rbergeron> #topic Any other business?
21:58:16 <msavy> brianlamere, yeah i remember that we found it was to do with Amazon's ancient version of XEN
21:58:18 * rbergeron doesn't mean to move along but she's poofing in about 30 seconds :)
21:58:32 <brianlamere> msavy: aye
21:58:34 <msavy> I made some test appliances which have proven very useful for manual testing thusfar, verifying various bits of BG have executed properly et cetera https://github.com/msavy/boxgrinder-appliances/tree/master/testing-appliances/modular-appls
21:59:11 <gholms> #info msavy made some BG appliances we can use for testing:  https://github.com/msavy/boxgrinder-appliances/tree/master/testing-appliances/modular-appls
21:59:50 <gholms> Anything else?
22:00:13 <mgoldmann> Not from my side, thanks!
22:00:56 <gholms> Thanks for coming, everyone!
22:01:00 <gholms> #endmeeting