19:00:56 <stickster> #startmeeting Insight
19:00:56 <zodbot> Meeting started Thu Feb 17 19:00:56 2011 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:58 <stickster> #meetingname Insight
19:00:58 <zodbot> The meeting name has been set to 'insight'
19:01:01 <stickster> #topic Roll call!
19:01:03 * stickster 
19:02:29 <stickster> asrob: You still there?
19:02:41 * averi is here
19:02:48 <asrob> stickster: yeah
19:02:55 <stickster> Hi guys :-)
19:03:11 <stickster> I think pcalarco can't make it due to timing. We should probably reconsider that. Let's put that first
19:03:18 <stickster> #chair averi asrob
19:03:18 <zodbot> Current chairs: asrob averi stickster
19:03:18 <averi> hi there! :)
19:03:27 <stickster> #topic Meeting time adjustment?
19:03:59 <stickster> averi: asrob: pcalarco usually can't make this time but it's helpful to have him here, I'll ask on list to see if we want to reschedule this meeting to another open time. Also I think this time is hard on smooge
19:04:15 <asrob> stickster: okay
19:04:32 <averi> stickster, sure, please just don't move it too early
19:04:43 <stickster> averi: What TZ are you in?
19:04:45 <averi> I can make it on this time and later but not earlier
19:04:50 <averi> I'm on GMT+1
19:04:57 <asrob> me too
19:05:01 <stickster> averi: Don't worry, we'll use a meeting matrix to figure it out. I'll email the list and you can use the link :-)
19:05:09 <averi> perfect, thanks
19:05:21 <smooge> ok I am here sort of.
19:05:30 <smooge> I have just checked in the minimum of a module
19:05:47 <smooge> I need to know what files are copied over so I can put them in the puppet tree
19:06:23 <stickster> OK, we'll deal with the meeting time on list.
19:06:26 <stickster> #topic Development
19:06:37 <stickster> smooge: You said you've checked in some puppet config stuff?
19:06:51 <stickster> smooge: I can help with figuring out what needs to be copied over
19:06:55 <stickster> (oh, before I forget:)
19:07:02 <stickster> #action stickster raise meeting time issue & matrix on list
19:07:35 <stickster> smooge: Are you talking purely about things like the db, or other stuff not contained in RPM packages, and/or... ?
19:09:45 <stickster> smooge: ^^
19:10:23 <stickster> OK, looks like we'll need to come back to this :-)
19:10:43 <stickster> #action stickster talk to smooge about the module he checked in (for puppet?) and then help him flesh it out
19:11:32 <stickster> asrob: Did you get a chance to talk to Gabor about node translation workflow?
19:12:48 * gomix-fricky here
19:12:48 <asrob> stickster: yeah, I talked with Gabor, he said there is no Transifex module, I got a link from his
19:12:59 <asrob> stickster: http://drupal-translation.com/content/creating-translations
19:13:15 <asrob> stickster: this is a drupal-way
19:13:35 <stickster> asrob: Right, so this way Drupal would manage and store all translations.
19:13:49 <asrob> stickster: yeah, that's right
19:14:06 <stickster> asrob: Suggestion -- you might want to talk to glezos to see if there's a good reason to do this with Transifex
19:15:01 <stickster> It's a tricky situation... on one hand we can maximize number of translators, on the other we might be making maintenance harder.
19:15:42 <asrob> stickster: yeah, we have to write a custom module if we want to use Transifex, it's not easy
19:15:57 <stickster> asrob: I agree
19:16:19 <stickster> Perhaps for now we should stick with the in-Drupal methods, you can research the best way and present something to the list
19:16:24 <stickster> Does that sound good?
19:16:42 <asrob> yeah, it does
19:16:45 <stickster> OK.
19:16:47 <glezos> asrob: it depends what are the needs..
19:17:13 <glezos> asrob: if you want to engage the fedora translation community, integrating into Tx will get you a long way forward
19:18:08 <stickster> glezos: asrob is looking at how we might allow people to translate node content in this Drupal system. There is a set of well-supported Drupal modules for translation, on a per-node basis. It's less sophisticated than Tx in terms of the size of translatable objects, but it's a known quantity. To use Transifex, we would have to develop and support an additional custom module, which we are trying to avoid where possible.
19:18:22 <glezos> asrob: that website promotes a proprietary plugin which uses a specific translation agency, I believe?
19:18:44 <glezos> stickster: indeed, it will require some serious integration work.
19:19:06 <asrob> glezos: not exactly, http://drupal.org/project/translation_management#downloads
19:19:19 <averi> stickster, while I agree using tx would be great, I just know that creating a specific module for that would make things too hard. Using a built-in module for drupal should make the trick for now
19:19:23 <glezos> asrob: I was talking about drupal-translation.com
19:19:39 <stickster> glezos: asrob: I believe the module is not service-dependent
19:19:43 <averi> stickster, we did not have thousand people willing to help anyway on the l10n list
19:19:48 <stickster> averi: Correct
19:20:14 <averi> stickster, so maybe writing a module just for tx spending hour and hours of work and then no one will translate the content on tx at all
19:20:51 <stickster> averi: I think you have a very valid concern. That's why I think having asrob look into the supported community modules available for now, is a fine start. If we run into a scaling problem vs. Tx we can always re-evaluate.
19:21:26 <stickster> We do not want to spend the majority of our small amount of time on edge cases right now
19:21:51 <averi> sure, the starting idea is to have localization but if we find out it will impossible to apply (no one will want to help out or whatever) we should just move this on a second time
19:22:18 <stickster> I think we're agreed then
19:22:45 <averi> we should define guidelines, timelines and a lot of stuff if we decide lo localize so better if we postpone this item for a bit imho
19:22:47 <stickster> #agreed asrob will research community i18n/l10n module choices and write to the list with results and recommendation
19:22:58 <stickster> averi: +1
19:23:01 <averi> s/lo/to
19:23:03 <asrob> okay
19:23:27 <stickster> Is schendje_ around by any chance?
19:23:39 <schendje_> stickster: yes he is :)
19:23:42 <stickster> yay!
19:24:13 <stickster> schendje_: I saw you were cobbling away on something this morning, any update for us?
19:24:25 <stickster> #topic Theme
19:24:25 <schendje_> yep i'm working on the footer right now
19:24:29 <schendje_> theme is progressing nicely
19:24:45 <schendje_> i've had some other people express interest to help, so that's great
19:25:03 <schendje_> and leaves me to wonder if I should still do a blog post (I believe that was my action item)
19:25:04 <stickster> #info schendje_ is hard at work, and other people have expressed interest in helping!
19:25:06 <stickster> #chair schendje_
19:25:06 <zodbot> Current chairs: asrob averi schendje_ stickster
19:25:31 <schendje_> so yeah, not much to say, it's going well :)
19:25:34 <stickster> schendje_: If you have people serious about helping now and won't benefit from a lot more, it's up to you really
19:25:45 <stickster> I think I saw tatica hanging about, that is always a good sign! :-)
19:25:50 <tatica> o/
19:25:53 <stickster> :-)
19:25:56 * tatica just reading
19:26:03 <schendje_> hola tatica
19:26:09 <tatica> schendje_, hola :P
19:26:11 <asrob> hi :)
19:26:31 <tatica> hello to all :)
19:26:32 <stickster> Not sure if you all know tatica, but she is an awesome contributor in several places including the Design team
19:26:48 <averi> hi there tatica, happy to know you :)
19:27:00 <stickster> tatica: schendje_: Remember, if you ever need a new pull of the theme to the server, let me know and I'll make it happen.
19:27:08 <schendje_> stickster: yep, will do
19:27:16 <tatica> schendje_, if you need help with the theme I can help
19:27:28 <schendje_> tatica: did you get it working btw?
19:27:35 <tatica> schendje_, but I will need a fast tutorial on how you guys are working since I'm new at drupal
19:27:39 <stickster> #idea stickster could add a cron job to do this regularly, but he is not sure if smooge and the Infra team want any cron jobs running as root on a publictest host.
19:27:51 <tatica> schendje_, I couldn't keep on that after we talk (office-stuff :\ )
19:27:59 <smooge> sorry I got pulled away at home.
19:28:12 <stickster> tatica: schendje_ and I could get with you in #fedora-mktg to give you info right after this, if that's good
19:28:17 <schendje_> tatica: ok, well let's see if we can get it working after the meeting is over, ok?
19:28:24 <schendje_> ...what stickster said :)
19:28:28 * stickster has a hard stop at 2000 UTC
19:28:55 <tatica> schendje_, sure :D
19:28:56 <stickster> #agreed tatica and schendje_ (and hopefully stickster) will meet after this meeting to make sure tatica has the info she needs to help
19:29:21 <stickster> smooge: I want to switch back to talking about the module stuff, hang on
19:29:28 <stickster> #topic More on development/puppet
19:29:36 <smooge> stickster, its your box you can do stuff
19:29:49 <smooge> but thanks for asking
19:29:56 <stickster> smooge: Oh, OK! Cool. I didn't want to step on any rules
19:30:07 <smooge> ok so looking at /etc/drupal6 I see 1682 files that are not owned by an rpm
19:30:21 <stickster> #action stickster make a cron job to run every half hour to pull theme
19:30:31 <stickster> smooge: That sounds reasonably correct
19:30:39 <stickster> smooge: Some of those will be going away when new modules land in EL-6
19:31:10 <stickster> smooge: Most of them are in /etc/drupal6/all/modules to make up for things that haven't yet made it to stable repo
19:31:41 <stickster> smooge: There will be a few in /etc/drupal6/all/themes which are part of the ninesixty (base) theme and the specific Fedora Insight theme that schendje_ et al. are working on.
19:31:56 <smooge> ok cool. the more that are in RPMs the better even if we have to put them in the infrastructure repo starting out
19:32:45 <stickster> smooge: I'd be willing to package up the ninesixty theme since it's probably useful to a lot of developers and (in general) no one alters it directly, just subthemes off it.
19:33:38 <smooge> again cool. if there are rpms that are in waiting for review but could have a 0.9 in their version or something to upgrade when EPEL gets the finished ones.. that would help too.
19:34:01 <stickster> smooge: OK, can do
19:34:05 <smooge> the reason I say this is that currently the configuration management would need to copy and check all those files every time it runs
19:34:14 <smooge> which makes puppet sad
19:34:33 <stickster> #action stickster Package ninesixty base theme (drupal6-theme-ninesixty) to make puppet's job easier
19:34:35 <smooge> and while I am putting this on a dedicated box.. it still makes things sad
19:35:04 <stickster> smooge: The Insight theme, for now, really ought to be a git checkout while it's in development
19:35:20 <stickster> Too much work to keep packaging/pushing it while in flux.
19:35:42 <smooge> that may be hard to do in puppet.
19:35:43 <stickster> smooge: When it's done I'd suggest it live in the infrastructure repo anyway, because I think it might contain logos.
19:35:54 <smooge> which may just make that part "fragile, handle with care"
19:36:12 <smooge> no problem with it being in the infrastructure repo for that
19:36:19 <stickster> smooge: I agree. When it's done, we definitely *can* package it.
19:36:53 <stickster> #agreed While theme is in development, we won't package it, but when it's done, we'll package it for the infrastructure repo only, since (for example) it contains logos.
19:37:20 * stickster will as usual be happy to help with that part :-)
19:37:47 <smooge> ok thanks I will need help on that because my time is very tight for the next 2-3 months
19:37:59 <stickster> smooge: I will help as much as my tiny brain allows :-)
19:38:01 <stickster> averi: asrob: Also, reminder -- you guys and I probably still need to do Infrastructure orientation stuff.
19:38:06 <stickster> averi: Maybe you're already past that?
19:38:30 <averi> stickster, I'm already helping the FI since some weeks already :)
19:38:38 <asrob> stickster: how can I help?
19:38:41 <stickster> averi: I figured... I saw you in the admin channel :-)
19:38:50 <averi> stickster, :)
19:39:10 <stickster> asrob: I believe ricky mentioned earlier that for us to work on maintaining the production side, we need to complete some orientation tasks. I'll dig up the URL he gave us.
19:39:25 <asrob> stickster: okay ;)
19:39:54 <stickster> http://fedoraproject.org/wiki/Orientation_Infrastructure_SOP <-- orientation URL
19:40:14 <smooge> I am working on some extra items. I hope to have it done soon. Ugh smooge-hulk tired
19:40:16 <averi> stickster, would be nice if any of us would be able to ssh the testing machine for anything else we might need, from a package install or simply for a test
19:40:23 <stickster> #action asrob stickster complete the orientation at the URL above
19:40:30 <averi> stickster, especially the guys working on drupal development
19:40:49 <stickster> averi: You can do that if you are a member of sysadmin-test. I imagine you should apply via the normal process with the infra team
19:41:09 * stickster is a member and would be very happy to have the work spreadable to more people :-)
19:41:10 <asrob> stickster: okay but I am a simple drupal guy :)
19:41:28 <averi> asrob, I can help you with anything you might need FI-side
19:41:46 <averi> so feel free to ping me for anything else you might need
19:42:15 <stickster> averi: +1, and I will apply also so I can help. asrob, it's useful to do this if you're going to need to manage files on the server in some way, like reading logs when things go wrong.
19:42:28 <asrob> averi: thanks
19:42:46 <asrob> stickster: ah I see :)
19:42:48 <averi> stickster, will ask to CodeBlock later who manages -test so we can have asrob added
19:43:02 <stickster> averi: Great
19:43:07 * CodeBlock is alive
19:43:10 <CodeBlock> .sponsors sysadmin-test
19:43:12 <zodbot> CodeBlock: Sponsors for sysadmin-test: jkeating lmacken mdomsch @mmcgrath nb ricky @skvidal smooge toshio
19:43:24 <CodeBlock> Any of those can add him to sysadmin-test
19:44:15 <averi> CodeBlock, okay, will ping seth later
19:44:26 <asrob> stickster: averi, I am willing to help Infrastructure team to manage drupal installation or something like that ;)
19:44:29 <averi> stickster, add an item for this please and ill have it done asap
19:44:42 <smooge> so I need to know what files aren't going to be in an RPM so I can put those into the drupal puppet module.
19:44:53 <stickster> #action averi to help asrob get added to sysadmin-test so he can help manage the test server now
19:44:56 <smooge> basically the module if written correctly will do the minimal to get a system going
19:45:07 <stickster> smooge: I can get that for you pretty easily
19:45:19 <stickster> #action stickster compile list of files that aren't packaged so they can be added to the puppet modulle
19:45:24 <stickster> #undo
19:45:24 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x2b025f6e8910>
19:45:24 <averi> stickster, I have another item I would like to cover
19:45:26 <stickster> #action stickster compile list of files that aren't packaged so they can be added to the puppet module
19:45:43 <averi> stickster, at the end of the meeting better
19:45:56 <stickster> smooge: Anything else you need that I can note now for the minutes? Else we'll go to averi. I have to leave at 2000 UTC (top of the hour)
19:47:18 <smooge> O am done
19:47:21 <averi> asrob, you gonna receive a mail when sponsored, and please remember to ask if you need anything, I will be glad to help out
19:47:34 <asrob> averi: thanks again ;)
19:47:40 <averi> asrob, :)
19:48:12 <stickster> averi: It's all yours, use #topic for your topic and go for it :-)
19:48:40 <averi> #topic Planet JustFedora and Insight (pcalarco's idea)
19:48:46 <averi> stickster, did you like pcalarco's idea? about using planet 'justfedora' for Insight feeds?
19:49:00 <averi> and if yes, how should we handle that?
19:49:15 <stickster> averi: I think it's an interesting idea. You're talking about "Planet Edited"?
19:49:35 <stickster> Er, "justfedora" if that's the new name
19:49:53 <averi> yup, we changed its name after being flamed by multiple people not knowing how to read properly
19:50:34 <averi> so let's forget the edited name that caused so many problems and lets welcome 'justfedora' :)
19:50:44 <stickster> averi: Here's one issue I see -- is that only people who sign up for the new feed will be carried there.
19:51:08 <asrob> averi: has it a different url? like planet.fp.o/justfedora?
19:51:18 <averi> stickster, sure, but everyone can do
19:51:21 <averi> asrob, sure
19:51:38 <stickster> averi: Since we're already performing the function of looking for not just Fedora-related material, but very widely accessible Fedora material, if we start with a much smaller pool because people have not signed up, we may miss some good items.
19:51:49 <asrob> averi: okay, I'll change it in Feeds
19:51:55 <stickster> asrob: Hang on
19:52:01 <stickster> asrob: We're discussing it, we're not agreed to do it yet.
19:52:10 <asrob> stickster: oh, ok :)
19:52:17 <stickster> Thanks :-)
19:52:21 <asrob> np
19:52:21 <averi> stickster, having two feeds is possible?
19:52:26 <averi> stickster, on drupal I mean
19:52:32 <stickster> averi: So then we go through some things twice?
19:52:42 <averi> mmm...correct
19:52:46 <asrob> it's possible
19:52:52 <stickster> I guess I don't see the value then
19:53:05 <averi> the possibilities are:
19:53:14 <averi> 1. we add more people to have more good items
19:53:56 <averi> 2. we get two feeds since tags are different from planet-fedora and justfedora
19:54:14 <averi> we should not have double items since tags are completely different
19:54:41 <stickster> averi: Is the set of feed items on justfedora a subset of the feed items on the big planet?
19:55:15 <averi> stickster, yes, on justfedora people currently use blogname.smt/blog/fedora/feed
19:55:33 <averi> while the big planet usually have blogname/blog/feed
19:55:35 <averi> on most cases
19:56:04 <stickster> averi: So my point is that in case 2, the tags don't make a big difference to us as editors/choosers of material. We have to go through some posts twice.
19:56:32 <stickster> If we'd see them anyway on the main planet, why not just use the main planet as the source until we know that everyone is signed up on 'justfedora' who wants to be?
19:56:35 <averi> in some cases yes, unfortunately
19:56:46 <stickster> I do understand the reasoning behind using 'justfedora' as the source
19:56:58 <stickster> the problem is that *right now* we'd miss quite a bit of material doing that.
19:57:04 <stickster> (if it was the only source we used)
19:57:11 <averi> it has to be said we aren't going live so soon
19:57:23 <stickster> averi: So really, we can make this decision later.
19:57:23 <averi> so maybe things can change on justfedora and we gonna include more people
19:57:35 <averi> stickster, yes, sure :)
19:57:39 <stickster> OK
19:58:01 <stickster> #idea Let's revisit the idea of which source feed we use at a later meeting
19:58:11 * stickster has to go for a phone call now, guys
19:58:24 <asrob> OK, thanks stickster
19:58:24 <averi> okay! :)
19:58:32 <stickster> Should we close up?
19:58:35 <averi> thanks for the great chair
19:58:39 <averi> yes for me
19:58:42 <schendje_> +1
19:58:46 <stickster> #endmeeting