15:01:52 <jreznik> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2011-02-22
15:01:52 <zodbot> Meeting started Tue Feb 22 15:01:52 2011 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:00 <jreznik> #meetingname kde-sig
15:02:00 <zodbot> The meeting name has been set to 'kde-sig'
15:02:07 <jreznik> #topic roll call
15:02:14 <jreznik> who's present today?
15:02:23 * jreznik is present, obviously :)
15:02:27 <Kevin_Kofler> Present.
15:02:29 <rdieter_work> here
15:02:34 <rnovacek> Here
15:02:44 * than present
15:03:04 <jreznik> #chair jreznik Kevin_Kofler rdieter_work rnovacek than
15:03:04 <zodbot> Current chairs: Kevin_Kofler jreznik rdieter_work rnovacek than
15:03:29 <jreznik> anyone else?
15:03:49 <jreznik> #info jreznik Kevin_Kofler rdieter_work rnovacek than present
15:03:57 <jreznik> #topic agenda
15:04:12 <jreznik> #link http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2011-02-22
15:05:49 <Kevin_Kofler> Live image tweaks for Beta
15:06:48 <jreznik> all?
15:07:11 <jreznik> ok, let's start
15:07:19 <jreznik> #topic F15 alpha rc1 is out
15:07:38 <jreznik> rc1 is out, I've started with Desktop Validation tests
15:08:09 <jreznik> if anyone willing to help, feel free to join me :)
15:08:11 <jreznik> #link  https://fedoraproject.org/wiki/Test_Results:Current_Desktop_Test
15:09:07 <jreznik> as Kevin_Kofler reported on #fedora-kde, current spins size is evil 666 MiB for 64 bit, 667 MiB for 32 bit
15:09:36 <jreznik> so we have a free space - that leads us to another today's topic
15:09:38 <Kevin_Kofler> This is fine for Alpha, we'll do more tweaks on the contents for Beta.
15:10:14 <Kevin_Kofler> I don't want to touch the kickstart for Alpha now. Either RC1 is gold, then it's gold, or we'll have an RC2, and I don't want to do non-essential changes between RC1 and RC2.
15:10:21 <than> jreznik: we should add the change after f11 lpha is released
15:10:41 <jreznik> yep
15:10:42 <than> s/f11/f15
15:10:57 <jreznik> I agree - anything else for Alpha?
15:11:38 <Kevin_Kofler> I think we're good to go from our side, right?
15:11:56 <Kevin_Kofler> Or are there any fixes we want to get in if we can?
15:12:34 <jreznik> the crasher fix I've built for rawhide would be nice to have one probably
15:12:55 <rdieter_work> that's probably not blocker-worthy
15:13:04 <Kevin_Kofler> Yes, it can be fixed by updating.
15:13:09 <Kevin_Kofler> So not critical for Alpha.
15:13:17 <jreznik> rdieter_work: yep, it's just "nice to have" category, not a blocker
15:13:47 <jreznik> and question is - if there's sense to build it for updates as 4.6.1 will be released soon
15:14:02 <Kevin_Kofler> You can propose it as NTH, but if there aren't any real blockers, the Alpha will not slip for it.
15:14:04 <jreznik> (it was just patch for my rawhide installation to make me happy :D)
15:14:21 <Kevin_Kofler> (but of course slips are decided globally, so what counts is blockers ANYWHERE, not just in KDE)
15:14:29 <rdieter_work> 4.6.1 gets tagged Thu, let's just go with that
15:15:00 <jreznik> yep, otherwise I think we are fine - from the first rc1 testing...
15:16:40 <jreznik> ok, let's move on
15:16:51 <jreznik> #topic Live image tweaks for Beta
15:17:19 <jreznik> [15:51] <Kevin_Kofler> We should do any changes after the alpha goes out.
15:17:20 <jreznik> [15:52] <Kevin_Kofler> I think the only thing to agree on is the priority with which to readd things if there's not enough space for all of them.
15:17:22 <jreznik> [15:52] <Kevin_Kofler> We have 2 sets:
15:17:23 <jreznik> [15:52] <Kevin_Kofler> * stuff that's explicitly dropped from the CD: amarok, digikam, ktorrent
15:17:25 <jreznik> [15:52] <Kevin_Kofler> * new stuff that can be added: kamoso (once it passes review), krusader, ???
15:17:32 <jreznik> from #fedora-kde
15:19:20 <Kevin_Kofler> Right.
15:19:42 <Kevin_Kofler> So I think the first set should have higher priority than the second, we put the stuff into @kde-desktop for a reason.
15:20:11 <Kevin_Kofler> What we should decide is the priority between amarok, digikam and ktorrent.
15:20:48 <Kevin_Kofler> BTW, we should have some more space after https://bugzilla.redhat.com/show_bug.cgi?id=678909 is resolved.
15:20:50 <rdieter_work> size problably should matter a bit too
15:20:51 <ltinkl_> amarok and digikam first imho, I don't think it makes much sense to download something to a live system
15:21:07 <Kevin_Kofler> rdieter_work: Sure, if I can't fit a large package, I'll try to fit a small one instead.
15:21:08 <jreznik> I'd like to say Digikam, but with current state of JuK I have to say Amarok
15:21:38 <rdieter_work> digikam pulls in marble, so could a hefty
15:21:43 <jreznik> ltinkl_: it's not only about live system but also the default kde spin installation (what's on live is installed on disk)
15:21:54 <ltinkl> jreznik: right
15:22:08 <Kevin_Kofler> BTW, I'll do the kickstart tweaks, I have push access to spin-kickstarts now.
15:22:32 <Kevin_Kofler> rdieter_work: Uhm, yeah, Marble is huge indeed. :-(
15:22:43 <rdieter_work> still unhappy we need to make these sorts of bad compromises, are all these on the bigger (1gb) image yet?
15:22:47 <Kevin_Kofler> I guess I'll put in Amarok first of all, and see what's left there.
15:23:06 <jreznik> #action Kevin_Kofler to do kickstart tweaks
15:23:14 <jreznik> Kevin_Kofler: makes sense
15:23:15 <Kevin_Kofler> rdieter_work: The bigger image has Amarok, Digikam, KTorrent.
15:23:21 <rdieter_work> ok, good.
15:23:38 <jreznik> what about second set? krusader etc. for bigger image?
15:24:05 <Kevin_Kofler> So I think we agreed on priority being: 1. Amarok, 2. Digikam if it fits, 3. ktorrent, 4. other stuff, right?
15:24:13 <Kevin_Kofler> Or are there any objections to that plan?
15:24:40 <Kevin_Kofler> Let's discuss the "other stuff" once we agreed on the highest priority items. :-)
15:25:41 <jreznik> it's THE PLAN :) ok
15:27:25 <jreznik> everyone ok with it?
15:27:34 <ltinkl> yup
15:27:35 <Kevin_Kofler> +1 from me obviously. :-)
15:27:44 <rnovacek> yes
15:27:55 <jreznik> #agreed on priority being: 1. Amarok, 2. Digikam if it fits, 3. ktorrent, 4. other stuff
15:28:09 <jreznik> #info discuss the "other stuff" once we agreed on the highest priority items
15:28:40 <Kevin_Kofler> So for the other stuff, I propose krusader, kamoso, kde-partitionmanager as possible additions.
15:29:25 <rdieter_work> krusader... why?  (that's an alternative file manager, isn't it?)
15:29:54 <rdieter_work> the other 2, definitely.
15:30:11 <rnovacek> I'm for krusader, for me it's much better then dolphin
15:30:19 <Kevin_Kofler> Though I'm not sure kde-partitionmanager is good enough to be shipped by default. It's useful especially if you want to use the CD for rescue purposes. But a lot of stuff is only in the unreleased 1.1 series (e.g. GPT support etc.) or not implemented at all (e.g. LVM support).
15:30:25 <jreznik> at least for 1 gig image (if it's not already there)
15:30:58 <Kevin_Kofler> (SMART support is also only in 1.1, but gnome-disk-utility, which is now installed as part of @admin-tools, can do this)
15:31:17 <than> Kevin_Kofler: do we have konversation on live cd?
15:31:21 <Kevin_Kofler> Yes.
15:32:01 <than> Kevin_Kofler: it's "must have" for livecd :)
15:32:03 <Kevin_Kofler> rdieter_work: Because Dolphin is for new users, Krusader is for power users. :-)
15:32:37 <than> Krusader is clone of norton commander :)
15:33:36 <than> in my opinion i don't see the need for krusader on livecd
15:33:42 <rdieter_work> *maybe* could consider for @kde-desktop, and perhaps kde-live(1g), but not livecd.  adding largely duplicated functionality feels wrong there, esp since we're cramped for space eternally
15:34:06 <jreznik> +1 for kde-live(1g)
15:34:27 <jreznik> we will be happy if we fit Amarok and Digikam on live-cd
15:34:35 <jreznik> so it's useless to have this discussion now
15:34:42 <than> jreznik: +1
15:34:43 <Kevin_Kofler> OK, so kamoso and kde-partitionmanager on the CD if there's room left, krusader 1G only?
15:34:54 <jreznik> but then I'd like to see rekonq for 1G image :)
15:34:58 <Kevin_Kofler> jreznik: Chances are Digikam will be too large to fit while still leaving room for smaller stuff.
15:35:12 <jreznik> Kevin_Kofler: ok, you're right
15:35:27 <Kevin_Kofler> It requires the Marble lib which comes with tons of data.
15:37:30 <Kevin_Kofler> Re Krusader, personally, I use it all the time, I think it's much more useful than Dolphin.
15:37:46 <Kevin_Kofler> I think this boils down to the "are we a distro for new users or for power users?" question…
15:37:56 <Kevin_Kofler> And I'd like at least the KDE spin to have some respect for power users…
15:38:49 <Kevin_Kofler> Dolphin is a Nautilus-style file manager, Krusader is a Norton-Commander-style file manager, they have a very different feel.
15:39:31 <Kevin_Kofler> And I know you can force a split view in Dolphin (though it's not the default). It's still no Krusader. :-)
15:40:31 <Kevin_Kofler> And nobody is proposing to remove Dolphin, mind you.
15:40:47 <Kevin_Kofler> I think they both have their usecases, but they're just not the same. :-)
15:41:36 * jreznik uses mc
15:44:20 * than uses "command lines cp/rm/mv"
15:44:40 <jreznik> let's continue discussion based on data - after tweaks, and we will know free space
15:44:49 <Kevin_Kofler> Right.
15:45:00 <Kevin_Kofler> I'll try to fit the essential stuff first.
15:45:05 <jreznik> thanks
15:45:11 <Kevin_Kofler> BTW, what's the plan for Kamoso?
15:45:23 <Kevin_Kofler> Once it's in, should it be default or optional in @kde-desktop?
15:45:40 * ltinkl searches his brown paper bag
15:45:43 <than> Kevin_Kofler: is it for webcam?
15:45:43 <Kevin_Kofler> And what priority will it have for addition to the spins?
15:45:48 <Kevin_Kofler> than: Yes.
15:45:50 <nucleo> it is still aplha
15:45:52 * rdieter_work leans toward default, provided it works well
15:46:08 <rdieter_work> so, test first
15:46:25 <rdieter_work> make optional initially, then I guess.
15:46:32 <jreznik> rdieter_work: +1
15:46:37 <than> alpha software!, i think we have to test it first
15:46:51 <than> before add it on livecd
15:47:12 <jreznik> initially just optional one, with testing of course
15:47:17 <Kevin_Kofler> So optional for F15, discuss as default for F16?
15:47:24 <jreznik> otherwise it should be very easy app (once finished)
15:47:33 <jreznik> Kevin_Kofler: I think so
15:47:36 <Kevin_Kofler> Or try to get it into the F15 default KDE install?
15:47:49 <Kevin_Kofler> (i.e. live image, @kde-desktop)
15:48:04 <nucleo> then we have many bug reports about it
15:48:28 <Kevin_Kofler> So you're for the "optional for F15, maybe default for F16" plan?
15:48:36 <nucleo> like sound not works or crashes
15:49:12 <nucleo> maybe should be optional for F15
15:49:34 <Kevin_Kofler> OK.
15:49:38 <jreznik> not a problem for me
15:50:15 <Kevin_Kofler> So I guess we have only amarok, digikam, ktorrent as really agreed on NTH stuff for the CD, if we have more room left, I'll start another discussion.
15:50:16 <jreznik> #topic open floor
15:50:27 <jreznik> Kevin_Kofler: agreed
15:51:04 <Kevin_Kofler> The proposed other stuff was: krusader, deemed non-essential; kamoso, maybe too unstable; kde-partitionmanager, also concerns about its current state, and nobody really arguing for it.
15:51:28 <jreznik> akurtakov asked me for upnp support in amarok - we need kio-upnp-ms, that needs herqq (hupnp) and that bundles qtsoap - I finally prepared standalone qtsoap package
15:51:42 <nucleo> is kde-partitionmanager development continues?
15:52:04 <jreznik> .bug 679401
15:52:06 <zodbot> jreznik: Bug 679401 Review Request: qtsoap - The Simple Object Access Protocol Qt-based client side library - https://bugzilla.redhat.com/show_bug.cgi?id=679401
15:52:11 <jreznik> so feel free to review :)
15:52:39 <Kevin_Kofler> nucleo: There's a 1.1 branch which got some development, but no news since September.
15:52:40 <jreznik> herqq 0.9.0 tarball is broken right now, I've contacted maintainer (and unbundling is needed)
15:52:50 <Kevin_Kofler> (which also means 1.1 isn't released yet, we're still stuck with 1.0.3)
15:53:18 <Kevin_Kofler> There are also some design decisions which leave me perplex, such as using libatasmart directly for SMART, which requires root access, instead of going through udisks.
15:53:46 <nucleo> last commit was in September http://quickgit.kde.org/?p=scratch%2Fstikonas%2Fpartitionmanager.git&a=summary
15:53:57 <Kevin_Kofler> Plus, you need to run the whole app as root to do stuff which requires root access, there's no frontend-backend split with KAuth, it's all monolithic and uses libparted directly from the GUI app.
15:54:34 <Kevin_Kofler> nucleo: But the stuff developed until September is newer than what we ship, too. :-(
15:54:37 <Kevin_Kofler> 1.0 is even older.
15:55:19 <Kevin_Kofler> All this leaves me in a mood where I'd rather not ship it by default.
15:55:33 <jreznik> without kauth - it's just broken
15:55:41 <jreznik> and I'm not sure we want such application
15:55:47 <Kevin_Kofler> jreznik: Re qtsoap etc., good.
15:56:18 <Kevin_Kofler> If akurtakov wants the stuff in, is he going to do the reviews for you? Or should one of us KDE SIG folks do them?
15:56:31 <jreznik> qtsoap is abandoned by Nokia...
15:56:40 <jreznik> all qt solutions stuff
15:56:56 <Kevin_Kofler> Almost everything is abandoned by Nokia. :-(
15:57:09 <jreznik> Kevin_Kofler: we want it too - upnp support in Amarok would be nice
15:57:23 <Kevin_Kofler> Right, that's why I said "good".
15:58:17 <jreznik> ok, anything else?
15:58:24 <Kevin_Kofler> So, do you have a reviewer already?
15:58:36 <jreznik> Kevin_Kofler: not yet, hope someone step into :)
15:58:56 <jreznik> still I have to package herqq and kio-upnp-ms
15:59:17 <jreznik> and it's going to take some time
15:59:38 <jreznik> but feel free to review, should be easy
16:00:03 <Kevin_Kofler> qtsoap looks quite simple and I can't see anything wrong at first sight.
16:01:16 <jreznik> it's more hacks to build it as shared lib - there was no intention to use it as shared library
16:01:26 <jreznik> they recommend bundling :(((
16:01:34 <jreznik> ok, time is over
16:01:40 <jreznik> thanks all!
16:01:54 <jreznik> #endmeeting