22:00:20 <rbergeron> #startmeeting Fedora 15 Alpha Go/No-Go Meeting
22:00:20 <zodbot> Meeting started Wed Feb 23 22:00:20 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
22:00:21 <rbergeron> NO!
22:00:23 <rbergeron> Where's the bot
22:00:25 <rbergeron> There's the bot.
22:00:31 * rbergeron *whews*
22:00:37 * gomix lol
22:00:54 <rbergeron> Greetings, ladies and gentlemen.
22:01:12 <rbergeron> #topic Roll Call
22:01:21 * nirik is lurking around
22:01:37 * gomix lurking too
22:01:39 * rbergeron waves to nirik
22:01:55 * fcami waves
22:02:04 * jsmith is here
22:02:07 * Viking-Rawhide comes surfing in on rbergeron“s wave...
22:02:21 * rbergeron grins
22:02:34 * rbergeron waits patiently for adamw; jlaska is not able to make it.
22:02:53 <rbergeron> dgilmore: you about?
22:03:29 * red_alert waves
22:03:34 <rbergeron> hello red_alert :)
22:03:58 * mclasen is only here for a few minutes
22:04:00 <rbergeron> jsmith: I don't suppose you want to track down adamw for me :)
22:04:03 <rbergeron> Hey mclasen.
22:04:12 <jsmith> rbergeron: Will do...
22:04:37 * rbergeron was under the understanding that he was coming
22:04:40 <adamw> yo
22:04:48 <adamw> i was just having lunch
22:04:58 <jsmith> adamw: Awesome :-)
22:04:59 <fcami> yo adamw
22:05:05 <drago01> adamw: excuses!
22:05:10 <rbergeron> w0rd.
22:05:14 <rbergeron> Alrighty then.
22:05:42 <rbergeron> #topic To Go, or not to go? That is the question. :)
22:05:49 <rbergeron> Just some quick reminders for folks:
22:05:55 <dgilmore> rbergeron: im here
22:05:58 <rbergeron> #link https://fedoraproject.org/wiki/Go_No_Go_Meeting
22:06:23 <rbergeron> The purpose of this meeting is to ascertain whether or not the F15 Alpha is ready to go.
22:06:32 <rbergeron> The Criteria is as follows:
22:06:57 <rbergeron> 1) Have all the tests been run?
22:07:01 <rbergeron> 2) Are there any open F15 alpha blockers.
22:07:12 <rbergeron> Questions or comments?
22:07:16 <rbergeron> Otherwise, I'll move on.
22:07:29 * jsmith has nothing
22:07:30 <rbergeron> #topic Have all the tests been run?
22:07:39 <adamw> all the alpha required tests, yeah.
22:07:45 <rbergeron> #link https://fedoraproject.org/wiki/Test_Results:Current_Desktop_Test #link https://fedoraproject.org/wiki/Test_Results:Current_Installation_Test
22:07:47 <rbergeron> Ooh, fail.
22:08:04 <rbergeron> My cut and paste skills are horrible today.
22:08:04 <drago01> what about the r600 issue?
22:08:17 <adamw> drago01: wait, it'll come up.
22:08:36 <rbergeron> drago1: We'll get there.
22:08:45 * drago01 wairs
22:08:45 <drago01> *waits even
22:14:45 <adamw> rbergeron: i can do it but it'll take a minute to download the iso and run an install.
22:14:46 <rbergeron> Are any of the tests with warnings things that are going to block us?
22:15:34 <adamw> mostly, no. i have added all the bugs that are potentially worrying to the f15alpha tracker for us to look at
22:15:35 <red_alert> haven't seen any that would...but not everything from bugzilla made it into the matrix :/
22:16:05 <rbergeron> adamw: Okay, let's take a look at the blocker list, then.
22:16:10 <rbergeron> #topic Blocker List
22:16:21 <rbergeron> #link https://bugzilla.redhat.com/show_bug.cgi?id=F15Alpha
22:16:44 <rbergeron> adamw: I talked with James earlier, and it's my understanding that we've made some headway with a number of these.
22:16:55 <adamw> yeah, let's take 'em one at a time and i'll update
22:17:32 <dgilmore> im beng told 1 hr to download the kde iso
22:17:50 <adamw> dgilmore: take me about 3mins
22:17:58 <rbergeron> #chair adamw dgilmore jsmith
22:17:58 <zodbot> Current chairs: adamw dgilmore jsmith rbergeron
22:18:01 <dgilmore> stupid crapcast
22:18:02 <adamw> so, the two bugs marked as VERIFIED are fixed in rc1
22:18:09 <rbergeron> #topic https://bugzilla.redhat.com/show_bug.cgi?id=663294
22:18:10 <adamw> we can forget about those
22:18:13 <dgilmore> i mean comcast
22:18:21 <rbergeron> Oh, adamw: Do we want to go through one by one?
22:18:26 <adamw> yeah, aside from those two
22:18:27 <rbergeron> Maybe I should let you take the reins.
22:18:29 <rbergeron> lol
22:18:30 <adamw> sure
22:18:37 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=677842
22:18:45 <red_alert> adamw: XOpenDisplay was fixed in rc1?
22:18:59 <dgilmore> red_alert: yes
22:19:15 <red_alert> ah, right...the thing I saw was considered a serparate bug :)
22:19:21 <red_alert> ...and eventually no bug at all
22:19:32 <adamw> the KDE thing. yeah. that we separated out and downgraded this morning since we can't reproduce it any more
22:19:37 <adamw> so, 677842
22:19:42 <rbergeron> Okay. So... yes
22:19:57 <adamw> the big development here is we're now fairly sure this bug only happens with 32-bit
22:20:02 * rbergeron nods
22:20:07 * red_alert never did 32bit
22:20:13 <adamw> red_alert: 677842
22:20:16 <red_alert> oh
22:20:34 <adamw> we have the radeon test day going on today and there are many people reporting success with r600+ chips
22:20:45 <adamw> i went back to the bug and asked people to test x86-64 and got several reports of success
22:20:57 <rbergeron> adamw: Is this something we could document in Common_F15_Bugs?
22:21:01 <adamw> if we work on the basis that this only affects 32-bit, it makes it a lot less blocker-y in my eyes, as we have an obvious workaround
22:21:10 <adamw> rbergeron: i think probably yes, if it's 32-bit only
22:21:22 <adamw> i think just about any system with an r600 or later graphics adapter should be 64-bit capable
22:21:27 <dgilmore> adamw: if its only 32 bit im more than happy to document it and not accept it as a blocker
22:21:32 <rbergeron> jsmith: How do you feel about that?
22:21:41 <rbergeron> I thiunk that seems reasonable.
22:21:44 <red_alert> my >r900 worked smooth with x86_64...as smooth as never before :)
22:22:46 <rbergeron> Shall we agree?
22:22:56 <dgilmore> red_alert: si
22:23:00 <dgilmore> rbergeron: si
22:23:06 <adamw> fine by me
22:23:14 <red_alert> +1
22:23:31 <Viking-Rawhide> +1
22:23:32 <adamw> ok
22:23:35 <fcami> ditto
22:23:36 <rbergeron> #agreed 677842 affects only 32-bit installs, can document in Common_F15_bugs.
22:23:44 <rbergeron> Who will document?
22:23:56 <rbergeron> Do we need to document elsewhere (sorry, I'm still a noob here) ? :)
22:23:59 * dgilmore nominates adamw
22:24:01 <jsmith> rbergeron: Sorry for the latency -- I'm mostly OK w/ it
22:24:12 <adamw> yeah, as long as it has CommonBugs keyword we'll get it done
22:24:23 <rbergeron> Okay.
22:24:28 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=678927
22:24:56 <adamw> so, this is the one about encrypted partitions - in some circumstances, you don't get prompted to unlock them
22:25:13 <Viking-Rawhide> I dont think any selinux bugs are considered an alpha blocker let alone on encrypted partitions..
22:25:27 <Viking-Rawhide> workaround selinux=0
22:25:42 <dgilmore> Viking-Rawhide: thats never a workaround
22:25:46 <jsmith> This is not actually an SELinux issue
22:25:51 <dgilmore> putting into permissive maybe
22:25:53 <jsmith> It happens in permissive mode as well
22:25:54 <adamw> yeah, it seems you still hit this even with enforcing off
22:25:58 <fcami> the main problem is that said workaround is rather heavy-handed and could hide a plethora of bugs
22:26:04 <fcami> ah, ok
22:26:10 <adamw> but, jlaska just ran a test which suggests that in a default encrypted /home scenario, you won't hit this
22:26:32 <adamw> we couldn't quite reproduce it perfectly as we didn't have a vm with enough disk space handy, so he had to manually set up the layout, but that's our current info
22:26:36 <rbergeron> adamw: Yes, I think it seems that this is something that one wouldn't do through a regular installation method.
22:26:44 <Viking-Rawhide> agreed
22:26:47 <dgilmore> adamw: we default to lvm right and encypt the volume group correct?
22:26:56 <Viking-Rawhide> workaround document and dont encrypt :)
22:27:10 <adamw> dgilmore: jlaska thinks by default the PV will get encrypted, not the LV
22:27:19 <adamw> so he did a test with encrypted PV and it worked
22:27:27 <dgilmore> adamw: right pv/vg :)
22:27:29 <jsmith> Can we get any firmer details than "jlaska thinks"?
22:27:32 <adamw> dgilmore: ypu
22:27:33 <jsmith> It's not that I don't trust him...
22:27:43 <adamw> jsmith: i know what you mean. well, by the end of this meeting, possibly not =)
22:27:51 <adamw> does anyone have a 50GB+ disk they can do a quick install test on?
22:27:54 <dgilmore> jsmith: thats my understanding on how the encyption works
22:27:58 <adamw> my burner hard disk has died, unfortunately
22:28:10 <jsmith> dgilmore: OK, as long as you and jlaska agree, that makes me feel somewhat better :-)
22:28:28 <Viking-Rawhide> do encrypted partitions fall under alpha criteria?
22:28:33 <adamw> Viking-Ice: at present, yeah.
22:28:39 <dgilmore> VolGroup00   1  10   0 wz--n- 595.66g 143.22g
22:28:43 <dgilmore> adamw: i do
22:28:51 <adamw> jlaska and i agreed that it may not be horrible to move that to beta or final, but we may not need to discuss that now.
22:28:58 <jsmith> "The installer must be able to complete an installation using the entire disk, existing free space, or existing Linux partitions methods, with or without encryption enabled "
22:29:04 <adamw> dgilmore: if you could fire off a quick test and make the minimum possible changes to encrypt /home , that'd be appreciated
22:29:16 <adamw> then just boot it up and see if it works
22:29:32 <rbergeron> Do we want to hold on this one pending dgilmore's results?
22:29:50 <adamw> rbergeron: yeah. i think we can say that we expect the test to pass, and if it does, we don't consider this a blocker
22:29:51 <rbergeron> Or are we agreed that we trust their judgement and move on.
22:29:59 <adamw> but it'd be good to have direct confirmation
22:30:08 * jsmith would prefer to get confirmation, if we can do it quickly
22:30:27 <rbergeron> #agreed 678927 - We expect this to pass, dgilmore is testing now, if it does, Not a blocker. Will circle back at end of meeting.
22:30:33 <adamw> it shouldn't take long if dgilmore has everything lined up.
22:30:35 <red_alert> I think this should be a beta-criterion instead of alpha
22:30:36 <jsmith> WORKSFORME :-)
22:30:51 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=679171
22:30:51 <rbergeron> red_alert: I agree somewhat, but I'm not a fan of changing the rules at the meeting. That just sets bad precedents. :)
22:30:59 <jsmith> rbergeron: +1
22:31:06 <red_alert> rbergeron: agreed
22:31:10 <adamw> yeah, if someone wants to make a proposal to the list to move the criterion, please do
22:31:27 <adamw> jlaska and I couldn't find a specific justification for it being alpha, it's been there for a long time, since just around when we were revising the criteria
22:31:37 <red_alert> adamw: actually I think that'd mean to split the criterion into default encryption and specific cases
22:31:38 <adamw> the commit message just says 'add some more criteria' or something useless like that
22:31:53 <adamw> anyway! next bug
22:31:56 <dgilmore> adamw: should know soon
22:31:57 <red_alert> i.e. default should work in alpha
22:32:19 <adamw> so, this is the one where firstboot crashes if you hit 'tab', 'enter' to go to the next screen instead of using the mouse
22:32:23 <adamw> 'tab', 'space' also works, apparently
22:32:26 <rbergeron> Yup.
22:32:31 <adamw> we have a fix for this, but of course we'd need to respin to take it
22:32:57 <adamw> we haven't yet had this one at a meeting so we have no existing blocker/non-blocker determination for this
22:33:05 <rbergeron> yeah.
22:33:28 <adamw> so, any opinions?
22:33:37 <rbergeron> Are we unable to do a respin?
22:33:46 <adamw> rbergeron: i think if we respin at this point we slip
22:33:51 <adamw> because the respin would need to be tested
22:33:51 <rbergeron> Okay.
22:33:53 <Viking-Rawhide> yup
22:33:54 <rbergeron> Right
22:34:04 <red_alert> I'm a strong supporter of keyboard interactions myself...but the mouse is a valid workaround
22:34:10 <adamw> so, the impact is - if you hit this, you get no user account
22:34:11 <Viking-Rawhide> +1
22:34:13 <rbergeron> How many people have actually hit this?
22:34:27 <smooge> sorry my fault
22:34:28 <adamw> rbergeron: can't say for sure. how many have reported it to bugzilla? i think two.
22:34:44 <adamw> thing is, install has been pretty broken throughout tc phase, so i don't think many people actually have successfully installed f15 so far. =)
22:34:46 <fcami> the workaround is to login as root and use adduser if you hit it - or use the mouse not to hit it
22:34:48 <dgilmore> adamw: im ok for alpha it being mouse only
22:34:51 <fcami> common_bugs, me thinks
22:34:58 <dgilmore> i think we need to doccument in common bugs
22:35:00 <fcami> and yeah, not a blocker for alpha
22:35:13 <adamw> the main question is how many people will hit this without knowing about it and wind up with an un-login-able system
22:35:17 <dgilmore> if it were beta id think differently
22:35:18 <adamw> but it's a pretty impossible one to answer
22:35:25 <adamw> we have no data on how people interact with firstboot
22:35:27 * jsmith re-reads the alpha criteria
22:35:35 <fcami> adamw: virtual console + root login still works, right?
22:35:46 <dgilmore> adamw: between 0 and infinty
22:35:52 <dgilmore> fcami: yes
22:35:53 <adamw> jsmith: if you hit this bug, it constitutes an infringement of "In most cases, the installed system must boot to a functional graphical environment without user intervention (see Blocker_Bug_FAQ)"
22:35:53 <Viking-Rawhide> update that fixes this present
22:36:14 <fcami> yeah, but "in most cases".
22:36:21 <red_alert> I also think people who use their keyboard instead of their mouse in firstboot, they know how to add a user themselves ;)
22:36:21 <adamw> jsmith: the question is, does this satisfy the 'in most cases' wiggle clause, especially given there's a clear, documentable workaround (which is a factor we read as making the 'in most cases' test tougher)
22:36:40 <dgilmore> if you hit this you can manually create a user or you can wipe the file that says firstboot has run, reboot and do firstboot with a mouse
22:36:57 <adamw> dgilmore: right, it's not a horrible stopper bug - there's workarounds from various angles.
22:37:01 <Viking-Rawhide> and run update inn btween
22:37:05 <adamw> i don't have a strong feeling on this, i'm just happy to go with the general feeling.
22:37:09 <rbergeron> Are the workarounds relatively brainless?
22:37:16 <rbergeron> "Could robyn do it"
22:37:16 <adamw> dgilmore: i think that file doesn't get written
22:37:17 <rbergeron> :)
22:37:19 <jsmith> "relatively"
22:37:23 <dgilmore> rbergeron: reasonably yes
22:37:25 <adamw> so if you reboot you get firstboot again anyway and you get to try again
22:37:33 <red_alert> rbergeron: what's easier than using the mouse in firstboot instead of your keyboard?
22:37:35 <jsmith> adamw: That's good!
22:37:38 <dgilmore> adamw: even easier
22:37:39 <adamw> dgilmore: iirc the file gets written when firstboot exits with success
22:37:52 <adamw> from brian's report - "On the next boot
22:37:52 <adamw> firstboot runs again."
22:37:53 <Viking-Rawhide> I say not a blocker
22:37:56 <jsmith> OK, that's convinces me: +1 to not a blocker
22:38:02 <rbergeron> adamw: I'm in favor of not a blocker, common_F15_bugs, yo.
22:38:06 <adamw> ok
22:38:09 <adamw> seems we have agreement there then
22:38:14 * nb agrees
22:38:15 <red_alert> yes
22:38:19 <rbergeron> #agreed 679171 - Not a blocker, document in common_f15bugs
22:38:43 <rbergeron> Next plz!
22:39:02 <adamw> that's actually it
22:39:10 <adamw> the last two are just variations on the encrypted partition bug
22:39:33 <jsmith> OK :-)
22:39:36 <rbergeron> Ahh
22:39:36 <adamw> the other thing that was on the menu till recently was a bug which was preventing the live installer running on KDE imaegs
22:39:36 <rbergeron> Yes
22:39:40 <adamw> but we downgraded that because no-one can reproduce it today =)
22:39:44 <jsmith> adamw: And we removed it from the blocker list?
22:39:45 <red_alert> I still think the kde thingy should be a blocker...but instead it's been closed notabug :/
22:40:02 <jsmith> adamw: Ah, right... lack of reproduction
22:40:14 <jsmith> Can we still add it to the documentation, so that if folks do hit it, they know how to respond?
22:40:17 <adamw> well, let's chat about it if red_alert is worried
22:40:19 <adamw> jsmith: sure we can
22:40:32 <jsmith> Or help provide additional feedback?
22:40:32 * jsmith is all for chatting about it
22:40:34 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=679486
22:41:00 <adamw> jlaska argues "Should we know more about this issue later on, it's fairly
22:41:00 <adamw> straightforward to document the workaround, and we'll have updated nightly live
22:41:00 <adamw> images to fall-back to as well."
22:41:35 <adamw> the workaround is to run 'xhost +' as root before running the installer
22:41:36 <jsmith> I find it very strange that he could hit it multiple times yesterday, and not hit it at all today
22:41:50 <red_alert> documenting xhost + is a valid workaround for me ...but notabug is not :/
22:42:10 <Viking-Rawhide> ok let's documented as jsmith suggested encase other hit it with mentioning the workaround
22:42:43 <adamw> red_alert: reopen it if you're worried
22:42:53 <adamw> ok
22:48:55 <Viking-Rawhide> note that that satellite has the 1 megapixel zoom you so often see in movies and tv-shows...
22:49:17 <Viking-Rawhide> sorry 1 pixel zoom
22:49:19 <dgilmore> Viking-Rawhide: you need 1 gigapixel :)
22:49:23 <drago01> nirik: so lets slip for consistency ;)
22:49:26 <adamw> nirik: yeah, ever since i showed up it's been train wreck city
22:49:46 <nirik> adamw: :)
22:50:22 <dgilmore> why is it that installs are always slow when you want them fast
22:50:46 <rbergeron> I believe it's murphy's fault.
22:50:56 <adamw> oh, i have to run that kde test too.
22:51:05 <rbergeron> Yes. Let's do that
22:51:12 <dgilmore> adamw: si sehnor
22:51:15 <rbergeron> And by "let's" I mean you, of course :)
22:51:17 * rbergeron hugs adamw
22:51:47 <drago01> dgilmore: hah! lets slip "the install process is too slow"
22:52:10 <dgilmore> drago01: ill blame the encyption :)
22:52:14 <adamw> there's a superfluous period in the welcome text on the bootloader screen
22:52:15 <adamw> SKIP!
22:52:21 <adamw> SLIP!
22:52:24 <dgilmore> man oi cant type encrypt today
22:52:42 <drago01> dgilmore: aesni-intel should help with that assuming new enough hw
22:53:02 <Viking-Rawhide> Let' s slip so we wont break John's Poelstra heart..
22:53:13 <dgilmore> drago01: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
22:53:24 <drago01> dgilmore: too old
22:53:28 <poelcat> Viking-Rawhide: slip or ship? :)
22:53:55 <dgilmore> drago01: figured ive not upgraded my desktop for awhile now
22:53:56 <jsmith> poelcat: Couldn't find an excuse to miss the meeting, could you :-p
22:54:00 <tibbs|h> skip the slip and ship?
22:54:08 <jsmith> tibbs|h: Good one :-)
22:54:09 <Viking-Rawhide> poelcat:  Ship since you are still here ;)
22:54:12 <dgilmore> drago01: i could blame the software raid
22:54:19 <rbergeron> jsmith: He's just checking up on how the new version of him is working :)
22:54:21 <adamw> dgilmore: ooh, snap. mine runs at 3.36, though.
22:54:27 <drago01> dgilmore: or your mechanical harddisks
22:54:40 <dgilmore> dgilmore: i have 4 320gb drives in a raid 10
22:54:44 <jsmith> rbergeron: Glad to hear it :-)
22:54:46 <adamw> hey, waittaminute
22:54:54 <rbergeron> adamw: ?
22:54:56 <adamw> i just realized we forgot one bug. i thought i put it on the alpha list. huh.
22:54:59 <adamw> anyways, it's:
22:55:23 <rbergeron> ??
22:55:35 <fcami> *drumroll*
22:55:36 * jsmith holds his breath
22:55:37 <Viking-Rawhide> wait for it wait forrrrr iiiiittttt
22:55:51 * dgilmore watches jsmith pass out
22:56:07 <adamw> hurry up, lousy evolution
22:56:10 <Viking-Rawhide> prepares a slap
22:56:23 <dgilmore> 1001
22:56:53 <rbergeron> adamw: any keywords I can help find? lol
22:56:58 <heffer> probably closed by now :P
22:57:32 <adamw> hah. second computer.
22:57:34 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=676827
22:57:46 <rbergeron> Ah, the keyboard
22:57:48 <adamw> yup
22:57:55 <rbergeron> The workaround works.
22:58:06 <Viking-Rawhide> the workaround works
22:58:08 <adamw> if you install with at least french or I think german keyboard, no typey at gdm
22:58:10 <adamw> well, 'works'
22:58:16 <adamw> in the sense of gives you completely the wrong keyboard layout
22:58:18 <heffer> ah yes
22:58:19 <Viking-Rawhide> Icelandic works that should suffice
22:58:21 <adamw> that's not exactly optimal.
22:58:22 <drago01> adamw: argh
22:58:23 <heffer> that was the one i hit today
22:58:33 <drago01> adamw: did we have a release without such a bug
22:58:37 <drago01> *sigh*
22:58:39 <fcami> errr
22:58:46 <adamw> drago01: once or twice =)
22:59:01 <heffer> btw. it's no typey at any graphical interface
22:59:09 <adamw> so, i mean, you can workaround it, then you can try and use a us english keyboard layout on a french keyboard. which is super fun.
22:59:11 * drago01 goes to check whether it is his fault
22:59:11 <adamw> heffer: right
22:59:16 <heffer> i.e. when starting the session through startx
22:59:25 <adamw> heffer: found any way to actually get the keyboard layout you want?
22:59:27 <fcami> so the workaround is to boot in runlevel 3 and edit /etc/sysconfig/keyboard?
22:59:31 <adamw> maybe using the gnome applet?
22:59:35 <adamw> fcami: yes
22:59:35 <heffer> adamw: yes
22:59:43 <Viking-Rawhide> and this only affects upgrades right
22:59:46 <adamw> Viking-Ice: no
22:59:51 <adamw> Viking-Ice: new installs
22:59:52 <jsmith> Viking-Ice: No
23:00:01 <heffer> using the gnome regional settings and setting it to the desired layout worked
23:00:06 <adamw> heffer: aha, that helps
23:00:09 <fcami> I don't like it as some people will want lang-specific characters in passwords
23:00:20 <dgilmore> adamw: document the workarounds :)
23:00:33 <fcami> I find that one worse than the firstboot one, guys
23:00:33 <jsmith> Definitely something that needs to be documented
23:00:33 <adamw> this is probably the crappiest remaining bug, for me
23:00:38 <jsmith> fcami: I do too
23:00:39 <heffer> especially as special chars are quite different on other layouts
23:00:49 <adamw> heffer: even _non_ special characters are different
23:00:50 <Viking-Rawhide> did we not reach concious about this bug on last meeting ?
23:01:02 <adamw> as anyone non-french who's tried typing on a french keyboard knows
23:01:07 <heffer> we did, but we were lacking info
23:01:09 <adamw> Viking-Ice: at that time we were hoping it was upgrades only
23:01:26 <rbergeron> viking-ice: it was "need more info" basically
23:01:29 <heffer> now that i hit this bug myself I can say that this basically leaves you with a non working machine
23:01:30 <drago01> adamw: huh? I though I fixed this
23:01:44 <adamw> drago01: you may have done and it didn't go through the freeze?
23:01:45 <drago01> adamw: which version of s-s-k is shipped in the alpha?
23:02:04 <heffer> you need to boot into runlevel 3 from grub as Ctrl+Alt+F{1..12} don't work
23:02:05 <dgilmore> 50 packages to go
23:02:19 <dgilmore> i need to run in 10 minutes or ill have a nagry wife
23:02:20 <fcami> tbh it will affect kvm users as well
23:02:22 <heffer> or ssh into the machine
23:02:25 <dgilmore> angry
23:02:45 <adamw> drago01: just a sec
23:02:52 <Viking-Rawhide> if it has a workable keyboard in any layout and documented workaround. . . .
23:02:55 <fcami> because you install into a vm you will need to change the host keyboard to US before making everything work (IIRC)
23:03:44 <fcami> Viking-Ice: the workaround is rather convoluted if the user chose a password with non-ASCII characters for the root user
23:03:53 <adamw> drago01: should be the latest, 0.8.6-5
23:03:58 <adamw> drago01: hasn't been touched since freeze
23:04:04 <fcami> hmmm, in a VM, maybe
23:04:25 <drago01> adamw: hmm ok, will check with lennart what is wrong with it
23:04:25 <heffer> it's especially tricky as you need to choose the US layout during installation even if that's not what you want
23:04:36 <drago01> adamw: anyway shouldn't be that hard to fix
23:04:38 <heffer> otherwise you will hit this bug
23:05:06 * drago01 takes the bug
23:05:25 <adamw> so i'm sensing we're kinda on the fence with this one
23:05:39 <rbergeron> adamw: it seems that way.
23:05:39 * jsmith is squarely leaning on the fence
23:05:44 <Viking-Rawhide> I say document the workaround and ship
23:05:48 <adamw> would it help if i said...would we ship the alpha if you could only use the french keyboard layout?
23:05:56 <fcami> ty adamw
23:05:56 <jsmith> If I had to lean one way or the other, I'd lean towards slip
23:06:03 <adamw> because only being able to use us english is pretty similar for anyone who *doesn't* use us english
23:06:16 <jsmith> adamw: Well said
23:06:37 <adamw> heffer: btw, after you set the correct layout in GNOME's applet, does that layout get used in gdm on future boots? or is gdm always us english?
23:07:01 <jsmith> As much as I hate to slip, I hate making it hard on our international community to help us test the alpha even more
23:07:07 <fenrus02> is this the "user cannot type anything" in gdm bug?
23:07:14 <rbergeron> fenrus02: yes
23:07:21 <heffer> i'll test that right now, my password only uses chars that are the same on DE and US layouts
23:07:23 <fcami> the other thing about it is that the workaround only works on physical hosts and only if you can type your password using US chars
23:07:23 <rbergeron> oh, wait, that's a hefty statement
23:07:35 <jsmith> Yeah...
23:07:37 <rbergeron> fenrus02: it's the keyboard with german layout doesn't work in gdm
23:07:41 <dgilmore> rebooting
23:07:54 <fcami> it's not really a true workaround ala firstboot for instance
23:07:58 <fenrus02> rbergeron, oh, only de layout?  jp / es / fr are ok?
23:08:00 <jsmith> fenrus02: I think that one is separate, but supposedly fixed by ibus* updates in koji
23:08:06 <fcami> fenrus02: .fr seems fubared as well
23:08:06 <jsmith> fenrus02: I hit that one this morning :-(
23:08:07 <fenrus02> jsmith, oic.
23:08:15 <adamw> i think we have at least french and german affected
23:08:39 <fenrus02> jsmith, may sound stupid - but does the uk layout work?
23:08:40 <heffer> swiss will be affected then too i believe
23:08:41 <rbergeron> I haven't seen anything about french in the bug
23:08:52 <adamw> rbergeron: comment #14
23:08:58 <rbergeron> oh, yep
23:08:59 <drago01> adamw: it already does /bin/systemctl enable system-setup-keyboard.service >/dev/null 2>&1 || :
23:09:00 <Viking-Rawhide> if we are going to slip for one language layout not working we have to slip for them all
23:09:00 <jsmith> fenrus02: No clue...
23:09:02 <rbergeron> adamw: i was just going to say
23:09:14 <drago01> adamw: no one told me about the VARIANT issue
23:09:18 <drago01> adamw: hence no fix ...
23:09:31 <adamw> drago01: would this be a case of some layouts not setting the offending line in /etc/sysconfig/keyboard ?
23:09:44 <adamw> drago01: so the ones which don't need to set it work, the ones which do need to set it fail?
23:10:12 <drago01> adamw: given the information in the bug that seems likely yeah
23:10:20 <heffer> okay. rebooting to test if the correct layout is used in gdm
23:10:20 <adamw> drago01: for some reason the bug never got changed from xorg-x11-server :/
23:10:32 <dgilmore> ok i have a result
23:10:35 <adamw> dgilmore: yay
23:10:36 <fenrus02> adamw, imho, g8 really should work or it's a blocking item
23:10:51 <adamw> fenrus02: thanks for the vote
23:10:52 <fcami> let's say my login contains a localized character
23:11:13 <heffer> okay. gdm uses US layout
23:11:19 <dgilmore> rbergeron: adamw: jsmith: using the default partitioning and encrypting you get unencrypted /home
23:11:24 <adamw> heffer: ok. just gathering data
23:11:35 <fcami> ah, yeah, it works after the workaround... ok
23:11:37 <adamw> dgilmore: and it boots?
23:11:44 <dgilmore> adamw: yep
23:11:45 <nb> if a users's login contains a localized character and no workaround, i would think it would be ablocker
23:11:52 <dgilmore> booted logged in everything
23:11:52 <adamw> dgilmore: if it boots i think we're good on that bug. thanks for testing
23:12:07 <Viking-Rawhide> for alpha I say one working keyboard layout
23:12:11 <adamw> nb: given what we know, i think that's the case
23:12:17 <Viking-Rawhide> reporters really should read alpha release notes
23:12:34 <adamw> nb: because you can pick any layout you like during install, type a username with a localized character, then not be able to type it due to this bug, even with all known workarounds
23:12:52 <adamw> so, lemme see if i can summarize and we can get some votes
23:13:03 <nb> (question, who can vote?)
23:13:21 <adamw> anyone, but fpl+releng+qa votes carry most weight
23:13:21 <rbergeron> nb: anyone with a working keyboard layout
23:13:26 <adamw> we generally wind up with a pretty good consensus
23:13:28 <fcami> rbergeron ;)
23:13:29 <rbergeron> :D
23:13:35 <nb> rbergeron, lol
23:13:37 <dgilmore> adamw: i really need to go in 2 minutes
23:13:40 <jsmith> rbergeron: Good one :-)
23:13:40 * fcami uses the US layout on a .fr keyboard.
23:13:43 <jsmith> Thanks dgilmore
23:13:59 <jsmith> dgilmore: Can you give us your quick +1/-1 vote on Go/No Go?
23:14:04 <adamw> so, the issue is: you can pick any keyboard layout you like to install with, but any layout you pick which sets a VARIANT= line in /etc/sysconfig/keyboard will result in you being unable to type in X in the installed system. practical upshot: you can't login
23:14:41 <heffer> plus you can't fix it without booting to init 3 in grub
23:14:48 <adamw> our best known workaround is to boot to runlevel 3, edit /etc/sysconfig/keyboard , and remove the VARIANT= line, which will have the effect of giving you the en-us layout. you can then set a 'correct' layout within GNOME using GNOME's applet, but you cannot set a 'correct' layout for GDM
23:14:50 <dgilmore> adamw: upshoot is you cant use firstboot etc
23:14:52 <heffer> because you can't switch VT
23:14:57 <adamw> dgilmore: right
23:14:59 <Viking-Rawhide> read the release notes..
23:15:08 <Viking-Rawhide> before you install..
23:15:16 <dgilmore> adamw: soi you would need to boot in rescue mode or runlevel 3 and fix
23:15:35 <heffer> dgilmore: right
23:15:37 <dgilmore> adamw: then when starting firstboot will run and you can create a user
23:15:54 <dgilmore> to me that sucks but for alpha im ok with it
23:16:05 <adamw> given the firstboot impact, i'm not sure our scenarios about usernames with non-local characters stand up
23:16:12 <adamw> because you create users during firstboot, not install
23:16:29 <fcami> passwords with non-US chars maybe, but that's resettable in runlevel 3
23:16:42 <dgilmore> fcami: rescue mode
23:16:44 <heffer> firstboot worked fine for me, although i didn't check on layout
23:16:45 <adamw> heffer: did firstboot work for you?
23:16:47 <dgilmore> but recoverable
23:16:47 <adamw> ah
23:16:51 <adamw> so that's interesting
23:16:57 <heffer> but at least i could type
23:17:00 <fcami> dgilmore: indeed
23:17:13 <adamw> so, revision: firstboot works, gdm does not
23:17:14 <dgilmore> so i need to run
23:17:15 <dgilmore> my
23:17:19 <dgilmore> wife is going to kill me
23:17:20 <rbergeron> dgilmore: GO! :)
23:17:21 <adamw> we are currently unsure which keyboard layout is used for firstboot
23:17:25 <adamw> dgilmore: ok, go :) thanks a lot for helping
23:17:26 <rbergeron> We need you alive. :)
23:17:29 <dgilmore> but i think we ship
23:17:37 <heffer> neither my name nor my pw contain chars that would reveal a difference in layout (between DE/US)
23:17:39 <adamw> dgilmore: ok, we count your vote as a -1 blocker on this
23:17:50 <dgilmore> adamw: correct
23:17:59 <Viking-Rawhide> I'm also -1 blocker
23:18:01 <fcami> ty dgilmore
23:18:07 <adamw> Viking-Ice: we know, you voted six times already =)
23:18:11 <Viking-Rawhide> hehe
23:18:50 <adamw> so, we have a bit of an uncertainty which affects the impact
23:18:55 <fcami> I'm borderline. I don't care myself as I mostly use the US layout, but that will bit non-US users hard and will make people wonder if we only test US things.
23:19:03 <adamw> if firstboot uses US layout, it's always just an inconvenience - you can't get stuck in a non-usable setup
23:19:12 <red_alert> we're only thinking about the impact on the user so far - but what's the impact on developers/QA in terms of a few dozen people a day will report the same issue and will need support resolving it
23:19:15 <adamw> if firstboot uses the native layout, you could create an user account you couldn't login with via gdm at all
23:19:31 <adamw> either way it's very inconveniencing
23:19:35 <fcami> indeed
23:19:40 <adamw> and the initial impact of the bug looks very bad, and the workaround is not obvious.
23:19:41 <Viking-Rawhide> just out of curiosity what kind of experience level do you expect of our alpha users
23:19:43 <fcami> much more than what we've seen so far
23:19:46 <adamw> Viking-Ice: very variable.
23:19:51 <Viking-Rawhide> this is an alpha
23:20:06 <adamw> so, anyone else want to cast a definite vote?
23:20:20 <fcami> tbh I don't like this one.
23:20:21 <fenrus02> i would expect the system to boot, and display the desktop.  even for alpha.
23:20:22 <adamw> so far we have dgilmore -1 blocker, viking-ice -1 blocker.
23:20:31 <red_alert> we also need the feedback of non-experienced users because they do things differently and experiences users tend to miss certain bugs because they never do that actions
23:20:31 <fcami> +1 blocker for me.
23:20:31 <nb> I'm almost +1
23:20:33 <smooge> 0
23:20:45 <jsmith> +1 from me
23:20:48 <heffer> but then again most people do their installs like they always do, for me that means selecting the german layout
23:20:53 <adamw> rbergeron: ?
23:20:57 <heffer> i'd be +1 here too
23:21:00 <rbergeron> Tell me I'm not the tiebreaker.
23:21:05 <nb> yeah, i'm +1
23:21:15 <red_alert> for people in my regions that's mean swiss german layout which is affected too...I myself use US though
23:21:27 * smooge thinks about changing his vote to -1 for rbergeron to be tie-breaker
23:21:31 <red_alert> +1 blocker
23:21:35 <adamw> smooge: i didn't vote yet. ;)
23:21:35 <nb> smooge, :)
23:21:47 <smooge> now I am going ot have to be at -3
23:21:56 <adamw> as far as groups go, dgilmore represents releng, so releng is -1
23:22:01 <adamw> i'm representing QA and we didn't vote yet
23:22:10 <jsmith> FPL is at +1
23:22:13 <rbergeron> And we have the FPL vote. :)
23:22:15 <adamw> jsmith is fpl, we didn't actually pick someone to represent devel
23:22:30 <rbergeron> Nirik was here early on - not sure if he's still here
23:22:37 <nirik> yeah, still here...
23:22:44 <adamw> you have a vote on this one?
23:22:44 * nirik is reading back
23:23:26 <red_alert> community is +1 I think
23:23:37 * rbergeron feels rather +1ish, sadly
23:23:52 <nirik> it's a nasty one...
23:24:02 <fcami> indeed.
23:24:08 * nirik is trying to decide if a common bugs/workaround would be enough or not.
23:24:10 <VileGent> i installed in vmware using f15a rc1 and didnt see this problem
23:24:19 <adamw> VileGent: what keyboard layout?
23:24:22 <fenrus02> sorry, but i still think being able to login with any of the g8 keyboard layouts is a must.
23:24:32 <VileGent> default american
23:24:41 <fcami> VileGent: that's expected to work, yes
23:24:51 <adamw> VileGent: you hit this with other layouts.
23:25:04 <Viking-Rawhide> adamw:  not all
23:25:07 <VileGent> but i think that all major lanuages should work ootb so +1 on this being a blocker
23:25:07 <Viking-Rawhide> do we
23:25:13 <rbergeron> nirik: yeah, my issue is whether or not the workaround is just far too much
23:25:23 <adamw> Viking-Ice: i didn't say 'all other', i said 'other'. so far our best guess is 'layouts which use the VARIANT= keyword'.
23:25:29 <nirik> is there a chance we could fix this with an updates.img ?
23:25:30 <adamw> at least german and french.
23:25:31 <rbergeron> nirik: workaround/documentation
23:25:58 <VileGent> rbergeron,  for alpha i can see it flying for beta+ its definitley a blocker
23:25:58 <adamw> nirik: interesting question, i think the answer's 'no' though, since it's not an anaconda issue.
23:26:10 <nirik> whats the underlying component? X?
23:26:19 <adamw> nirik: system-setup-keyboard most likely.
23:26:19 <fenrus02> nirik, it's not firstboot that is afflicted.  likely ibus.
23:26:34 <adamw> some icky intersection of a few things, anyway.
23:26:50 <adamw> i think i'm gonna cast QA vote +1 on this one. we've set a reasonable standard for alphas lately that don't just bite you in the ass with really obvious messy bugs like this, i'd like to keep that going. a week on the alpha isn't a huge problem, as history shows.
23:27:23 <nirik> I guess I am sadly also a +1... but a weak +1. If the workaround could be easier/more obvious... ;(
23:27:43 <jsmith> nirik: I'm with you there
23:27:51 <fcami> sorry guys, I have to go catch some sleep. hf, and thanks.
23:28:02 <adamw> yeah, me too, it's a shame
23:28:03 <nirik> or if we could updates.img or otherwise fix it easily... ;(
23:28:21 <jsmith> Thanks fcami!
23:28:29 <adamw> i think fundamentally being able to do something perfectly normal in install and wind up sitting at a gdm screen you can't type into is just a bit much :/
23:28:41 <fcami> adamw: my thoughts exactly.
23:28:42 <fcami> you're welcome jsmith :)
23:28:57 <adamw> i think the votes put us at agreed blocker
23:29:05 * rbergeron nods
23:29:08 <nirik> yeah. ;( Many people would hit common bugs, but then 'reboot in runlevel3 , etc' might make many just give up
23:29:33 <adamw> and it just gives a bad impression, which is always something to keep in mind
23:29:49 <red_alert> sadly, but better a slip than keeping big junks of Europe from properly testing
23:29:53 <adamw> not to blow anyone's trumpet but i think we've been improving our reputation for quality with the last few release series, which is a good thing to keep up =)
23:30:01 <Viking-Rawhide> then let's update the alpha criteria to contain all keyboard layouts need to wrk
23:30:03 <jsmith> adamw: Couldn't have said it better myself
23:30:06 <red_alert> adamw: agreed
23:30:12 * nirik had really hoped we would for once not slip alpha. ;(
23:30:17 <fenrus02> adamw, :)
23:30:22 <rbergeron> nirik: me too.
23:30:23 <red_alert> Viking-Rawhide: "all" will be tough to test :)
23:30:29 <jsmith> Viking-Rawhide: We can do that, but let's consider that after the meeting, and not let that influence our decisions today
23:30:48 <Viking-Rawhide> the decition has already been made
23:30:56 <Viking-Rawhide> it a slip
23:31:10 <adamw> Viking-Ice: the criterion here is good old 'In most cases, the installed system must boot to a functional graphical environment without user intervention (see Blocker_Bug_FAQ) '
23:31:26 <rbergeron> #agreed Alpha will slip one week.
23:31:28 <jsmith> OK, any other questions/concerns/comments before I call it a NO-GO?
23:31:33 <adamw> i should reword that a bit to make more sense regarding firstboot and gdm, but ah well.
23:31:35 <rbergeron> Oh, you're calling that? :)
23:31:40 * rbergeron defers to jsmith
23:32:06 <jsmith> rbergeron: It's your meeting, but I feel it's my duty as the FPL to be the one to put the nail in it.
23:32:14 <jsmith> rbergeron: As ultimately, the buck stops here.
23:32:16 <rbergeron> jsmith: here is your hammer and nail. Feel free. :)
23:32:33 <fenrus02> adamw, firstboot / dm / desktop display ... because kde also matters, but does not use gdm.  the desktop should actually paint, menus should work etc..
23:32:47 <jsmith> Ok, Alpha is slipped one week.
23:32:50 <red_alert> jsmith: do it already! ;)
23:32:56 <red_alert> oh, /me laggy :/
23:33:14 <jsmith> Let's make sure we get things in better shape for next week :-)
23:33:31 <jsmith> We're at 90 minutes now -- anything else to address in the meeting?
23:33:55 <rbergeron> Not here.
23:34:00 * red_alert is going to address a sleep-related issue next :)
23:34:03 <Viking-Rawhide> not from me..
23:34:09 <rbergeron> We'll still be having a release readiness meeting tomorrow.
23:34:27 <rbergeron> #info The release readiness meeting will progress tomorrow as planned.
23:34:50 <red_alert> and another blocker bug meeting on friday :)
23:35:11 <rbergeron> red_alert: correct.
23:36:01 <rbergeron> Alrighty: Any other comments or questions?
23:36:07 * rbergeron will end the meeting otherwise.
23:36:40 <adamw> nope
23:37:04 <rbergeron> Allrighty then folks, see you next week. :)
23:37:11 <smooge> how much slippage are we looking at?
23:37:16 <nb> smooge, 1 week
23:37:19 <smooge> I need to let mirrors know
23:37:20 <rbergeron> And some of you tomorrow and friday.
23:37:26 <smooge> ok thanks
23:37:39 <heffer> okay
23:37:49 <rbergeron> #endmeeting