00:02:58 <jjmcd> #startmeeting Fedora Docs
00:02:58 <zodbot> Meeting started Thu Feb 24 00:02:58 2011 UTC.  The chair is jjmcd. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:02:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:03:09 <nb> #meetingname Fedora Docs
00:03:09 <zodbot> The meeting name has been set to 'fedora_docs'
00:03:17 <jjmcd> #topic roll call
00:03:20 * nb 
00:03:26 * jjmcd 
00:03:35 * jhradilek <--
00:04:30 * sgordon 
00:04:49 <jjmcd> OK, I see Zach didnt update the wiki but he did leave an agenda on the list
00:05:03 <jjmcd> #topic Follow up on last weeks action items
00:05:21 <jjmcd> jjmcd and nb to discuss redirect
00:05:26 <jjmcd> OK, that has been done.
00:05:30 * rudi_ is here
00:05:43 <jjmcd> nb agreed he could do it and also showed me how to do it
00:05:47 <nb> redirect issue is fixed, jjmcd knows how to update it on release day, and i can do it too
00:06:17 <jjmcd> I asked rbergeron to put it on the schedule since it needs to be done on release day, and that far off, and future releases, it will be easy to forget
00:06:31 <jjmcd> Haven't heard from her yet
00:06:39 * rbergeron got it, it was in her gmail and she just saw it yesterday :(
00:06:49 <jjmcd> Ahhhhh
00:06:59 <jjmcd> Well, it doesn't hit us until day zero anyway
00:07:00 <rbergeron> jjmcd: Putting it in my redhat mail tends to put it above a lot of spam :)
00:07:21 * noriko joins silent mode
00:07:27 <jjmcd> hi Noriko
00:07:36 <nb> hello noriko
00:07:44 <jjmcd> I put it on the release notes tracker so we are good for this release
00:07:47 <noriko> hi jjmcd, nb, rbergeron and rudi_ :-)
00:08:00 <jjmcd> But if it isn't on your schedule, we'll forget it next release probably
00:08:24 <jjmcd> There are 3 items for Zach.
00:08:40 <jjmcd> The other one not him is me loking into docs.old
00:08:49 <jjmcd> And I did poke around there a bit
00:09:07 <jjmcd> There is some stuff we want, but the stuff there is html and we want the source, if it exists
00:09:14 <jjmcd> I haven't found the source yet
00:09:28 <nb> jjmcd, is there stuff there that is not in /cvs/docs
00:09:33 <nb> or /cvs/fedora?
00:09:59 <jjmcd> I couldn't find my old links to cvs.  Is there a web presence I can browse to see if they are there?
00:10:06 <jjmcd> Or do I need to checkout?
00:10:38 * nb is asking
00:10:47 <nb> i think the web presence might have been killed
00:11:29 <jjmcd> OK, I'll have to get with you later to remember how to d/l that stuff
00:11:55 <jjmcd> There was a zoglesby/rudi around migration but we have an agenda item for that later
00:12:19 <jjmcd> So, lacking Zack, anything else on follow up?
00:13:08 <jjmcd> OK, next
00:13:17 <jjmcd> #topic Fedora 15 Schedule
00:13:42 <jjmcd> We've talked about this the past few meetings and nothing has changed, any issues, questions, etc.?
00:14:37 <jjmcd> OK, moving on
00:14:42 <jjmcd> #topic Release Notes
00:15:14 <jjmcd> We still need someone to take point
00:15:41 <jjmcd> And the tx issue has raised the need for this
00:15:45 <nb> jjmcd, i'm making a copy on people01 you can poke at
00:15:58 <jjmcd> nb - super, thanks
00:16:21 <jjmcd> #note nb rocks
00:16:26 <rudi_> +1
00:16:54 <jjmcd> On the schedule, we aren't officially behind yet, but I'm guessing tomorrow we will be
00:17:24 <nb> http://nb.fedorapeople.org/cvsdocs/
00:17:27 <jjmcd> I might shake an hour or two loose tomorrow, but I need to go off to Lansing yet again, so my time is limited
00:17:34 <nb> #link http://nb.fedorapeople.org/cvsdocs/ is /cvs/docs
00:17:40 <nb> #link http://nb.fedorapeople.org/cvsfedora/ is /cvs/fedora
00:17:54 <jjmcd> fantastic!
00:18:35 <jjmcd> Anything else on release notes?
00:19:05 <jjmcd> #topic Guide Status
00:19:16 <jjmcd> OK, so who needs what for F15 guides?
00:19:24 <nb> jjmcd, i'd like to add a topic to the agenda at the end: migration to tx.net
00:19:34 <rudi_> I think we're good; we have a new SystemTap guide coming up from RH
00:19:41 <jjmcd> That is the next thing on Zach's agenda actually
00:19:54 <nb> oh ok
00:20:02 <jjmcd> rudi_, way cool
00:20:15 <rudi_> But I think we're still waiting on the hosting request last I looked
00:20:20 <rudi_> No urgency there anyway
00:20:29 <nb> rudi_, link please?
00:20:30 <jjmcd> sgordon, jhradilek - need anything?
00:20:37 <sgordon> not currently
00:20:39 <nb> rudi_, note it with #link and i'll do it tonight
00:20:46 <rudi_> Apart from that, we're in for a little bit of a rough ride with the early branching,
00:20:48 <sgordon> as usual still really just need to find time to add something to the cloud guide
00:20:59 <sgordon> i would like to aim to have something for F16 on that
00:21:00 <rudi_> But I want to say a HUGE thanks to nb for his leadership and hard work :)
00:21:12 <nb> rudi_, well, the way i'm doing it this release at least, is people can feel free to make changes after docs are branched
00:21:14 <jjmcd> rudi_, boy, I second that
00:21:22 <nb> just *please* email me if you add any new .xml files
00:21:25 * jhradilek needs to find some time to start working on the systemd documentation in the Deployment Guide.
00:21:34 <nb> because i'll have to add them to the fedora-15-docs release in transifex
00:21:47 <rudi_> nb -- Oh yeah, this is absolutely the right strategy
00:21:50 <nb> #info please email nb if you add any new .xml files to a doc that is branched for f15 already
00:21:59 <jjmcd> Yeah, that time thing is a problem all over
00:22:39 <jjmcd> Has anyone been playing with the nightly composes to look for differences?
00:23:42 <jjmcd> Anything else on guides?
00:24:00 <jjmcd> OK, Nick
00:24:07 <jjmcd> #topic Trans Migration
00:24:14 <nb> Anyone can branch and add docs to transifex if they want, but please add "neb" as a maintainer, Although I'm the only one (other than the 4 regular l10n-admins) that can tag things into the fedora-15 and fedora-15-docs releases (which the translators look at)
00:24:22 <nb> like i said earlier, feel free to make changes to the f15 branch
00:24:27 <nb> since i am branching docs earlier than normal
00:24:35 <nb> you may want to merge changes into master also
00:25:01 <nb> although please email me if you add any .xml files, because they will generate new .po files which will need to be added to transifex's configs and to the fedora-15-docs release
00:25:12 <nb> there is an issue with publican and publican-fedora
00:25:23 <nb> jfearn does not want to accept translations from fedora.transifex.net
00:25:33 <rudi_> nb -- can I ask a really dumb question here -- what exactly is the purpose of the config file? I was surprised by glezos saying on Publican list that they're not necessary
00:25:51 <nb> rudi_, well they are necessary, but they don't *have* to be in the repo, having them in the repo just makes it much easier for us
00:25:56 <nb> to push and pull translations
00:26:08 <rudi_> Leave Publican and the brand package to me; I'll sort something out :)
00:26:21 <rudi_> nb -- easier in what way?
00:26:33 <nb> rudi_, otherwise we will have to each maintain our own .tx/config file
00:26:39 <nb> for each person that pushes or pulls translations
00:26:53 <jjmcd> rudi_, the config file seems to have all the mappings between tx names and publican names
00:27:09 <jjmcd> tx doesn't like Publican's hyphens
00:27:26 <jjmcd> and it wants a particular directory structure
00:27:39 <jjmcd> But with the config file, you tell it what's what
00:27:39 <nb> jjmcd, tx is flexible to any directory structure
00:27:47 <jjmcd> with the config file
00:27:47 <nb> you just have to adjust the tx set command(s)
00:27:56 <nb> jjmcd, yeah, the config file is what tells it what's what
00:28:21 <jjmcd> sort of overrides tx's obnoxious defaults
00:28:27 <rudi_> Ah OK; so it's basically a map
00:28:30 <jjmcd> yeah
00:28:40 <jjmcd> Its quite long, nothing like publican.cfg
00:28:59 <nb> rudi_, yeh
00:29:03 <jjmcd> I think there's like 3 or 4 lines per po
00:29:24 <nb> jjmcd, rudi_ yeah, it basically says "ok, this .po matches up with this resource on tx.net"
00:29:28 <rudi_> Heh -- so for the Install guide, it's a *4000 line config file* :D
00:29:35 <jjmcd> yepper
00:29:42 * nb wishes publican didn't make so many .po files
00:29:45 <jjmcd> But there is a tx set command that builds it
00:30:17 <jjmcd> but I couldn't make an awful lot of sense from the docs
00:30:32 <jjmcd> So I'm gonna need a lot of help
00:31:20 <jjmcd> nb, I assume we didn't figure out how to automate a new xml file?
00:31:33 <nb> jjmcd, not *yet* at least
00:31:38 <jjmcd> I know stickster_afk threatened to look into it
00:31:41 <nb> i figured i'd get the basics set up first
00:31:53 <nb> jjmcd, how often do we make new .xml files?
00:31:58 * jjmcd is a little ticked at the board
00:32:16 <jjmcd> The right approach would have been to identify the tasks and then adjust the schedule
00:32:25 * nb could probably set up some sort of a script, given that publican's structure is mainly the same, it probably wouldn't be that hard
00:32:33 <jjmcd> Instead of assuming we all have unlimited time
00:32:51 <jjmcd> Yeah, I suspect it is possible, its just finding the time to research it
00:33:26 <nb> #action nb to look into what is involved in adding a new .xml file (which makes a new .po)
00:33:32 <jjmcd> cool, thanks
00:33:43 <nb> jjmcd, how often do we add new files?
00:33:51 <jjmcd> Actually, makes a new pot which makes 1 po per lang
00:33:53 <jjmcd> Varies
00:34:01 <jjmcd> It isn't real often
00:34:04 <nb> i know relnotes makes a lot
00:34:09 <rudi_> nb -- generally, not all that often, but it does vary from book to book
00:34:17 <nb> jjmcd, if it isn't very often, i'm content to do it manually (at least for now)
00:34:21 <jjmcd> Which means there is almost no chance that someone will remember to do something on account of it
00:34:31 <nb> #info also, please notify nb if you remove a .xml file
00:34:39 <jjmcd> yes
00:35:17 <nb> is there anyone here that has a tx.net account so far?
00:35:19 <jjmcd> I'm hoping Paul will sort it out for us.  There is zero chance of me finding the time before we need to produce htmls
00:35:21 <jjmcd> I do
00:35:28 <nb> and would like to be added as maintainers to docs?
00:35:32 <nb> please also let me know which docs
00:35:40 <nb> there's not a way really for me to just say "add them to all of them"
00:36:05 <nb> but this can be handled out-of-meeting
00:36:26 <jjmcd> Hi shaunm
00:36:28 <nb> #info email nb@fedoraproject.org with your tx.net username to be added as maintainer to docs, please let him know what docs to add you as maintainer of also
00:36:33 <rudi_> jjmcd -- we can add a step to the branching procedure on the Wiki
00:36:44 <jjmcd> We'll want to do that
00:36:56 <rudi_> and maybe even create a script to double-check for this stuff just before we drop to translation each cycle
00:36:59 <jjmcd> I think the real problem will be the new xmls
00:37:07 <rudi_> Definitely
00:37:08 <nb> jjmcd, agreed
00:37:25 <rudi_> But we shouldn't be adding XML/POT/PO files after we drop
00:37:31 <rudi_> unless there's a severe exception
00:37:36 <nb> rudi_, very true
00:37:37 <jjmcd> Not that its necessarily hard, its just infrequent enough that people won't remember until they notice a chapter isn't getting translated
00:37:42 <rudi_> So that's a logical point at which the verify :)
00:38:01 <jjmcd> Well, depends.  Some guides discover something to add from time to time
00:38:20 <jjmcd> WIth RNs its usually the other way.  We start with lots and then drop those that have no content
00:38:53 <jjmcd> With ARG mostly what we will do is add XMLs
00:39:26 <nb> if you want to know how to add new xmls, i can show others also, the only thing they have to let me know about them for is to tag them into fedora-15-docs
00:39:47 <nb> only a "fedora" project maintainer can do that, which is basically restricted to l10n-admins
00:40:00 <nb> but i can show others how to add to tx/config
00:40:07 <rudi_> nb -- do you know if tx set removes files no longer present? Or just adds new ones to the map?
00:40:15 <nb> rudi_, i think it only adds new ones
00:40:26 <nb> rudi_, and i wouldn't run the for loop one except the first time
00:40:28 <jjmcd> nb, at one time we talked about doing the draft builds off in the cloud somewhere.  Do we still want to try that?
00:40:35 <nb> rudi_, well, you could rm .tx/config
00:40:36 <nb> tx init
00:40:39 <nb> then re-run tx set
00:40:45 <rudi_> Yeah
00:40:47 <nb> that would remove the old ones from .tx/config and add the new ones
00:40:52 <rudi_> That's probably the better workflow
00:40:56 <nb> rudi_, but removing the old ones from the web interface is still necessary
00:41:06 <nb> rudi_, but adding new ones to the web interface will be done automatically
00:41:08 <rudi_> Ah yeah, of course
00:41:09 <nb> the first time you tx push -s
00:41:35 <jjmcd> So, does that mean nb and rudi_ are going to come up with a cool wiki page for the rest of us?
00:41:41 <rudi_> Hmmm -- might need to look at some automation there too, down the track
00:41:51 <nb> no one should need to tx push -t except the first time, unless for some reason someone edits the .po's manually
00:41:51 <rudi_> jjmcd -- yes
00:41:56 <jjmcd> ;-)
00:42:26 * jjmcd intends to make an index for beat writers.  It is too hard to find stuff on the wiki
00:42:45 <nb> #info tx push -s or tx push --source will push the pot's to the server, this needs to be done every time the .pots are updated
00:43:14 <jjmcd> OK, anything else on tx?
00:43:15 <nb> #info tx push -t or tx push --translations will push your local copies of the translations to the server.  pretty much don't do this unless you are doing the initial import (or unless you are a translator translating them manually)
00:43:22 <nb> jjmcd, i think i'm done unless people have questions
00:43:48 * jjmcd doesn't know what his questions are yet
00:43:53 <nb> jjmcd, that's fine
00:44:13 <nb> rudi_, jjmcd what's the link to that hosting request you need done?
00:44:17 * nb didn't see that i don't think
00:44:29 <rudi_> Sorry -- fetching :)
00:44:36 <nb> rudi_, no problem
00:47:46 <nb> rudi_, https://fedorahosted.org/fedora-infrastructure/ticket/2635 ?
00:47:49 <nb> #link https://fedorahosted.org/fedora-infrastructure/ticket/2635
00:48:56 <rudi_> Yeah -- that's it! :)
00:51:03 <jjmcd> OK, lets move on, getting behind
00:51:12 <jjmcd> #topic Outstanding BZ Tickets
00:51:29 <jjmcd> Looks like one or two less than the last time I looked
00:51:38 <jjmcd> anyone need any help with bugs?
00:52:53 <jjmcd> OK, hearing nothing
00:53:00 <jjmcd> #topic Open floor discussion
00:53:24 <jjmcd> Does anyone have anything else for the good of the order?
00:53:59 * jjmcd would like some advice and counsel from rudi_ after the meeting
00:54:07 <jjmcd> ANything?
00:54:15 <nb> rudi_, i just texted CodeBlock and asked him if i could take that hosting request
00:54:22 <nb> he accepted the ticket a few days ago but hasn't done it yet
00:54:41 <jjmcd> OK, thanks everyone
00:54:49 <jjmcd> #endmeeting