21:00:31 <rbergeron> #startmeeting Cloud SIG
21:00:31 <zodbot> Meeting started Thu Mar 10 21:00:31 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:35 <rbergeron> #meetingname Cloud SIG
21:00:35 <zodbot> The meeting name has been set to 'cloud_sig'
21:00:41 <goozbach> rbergeron: we're moving to 1900 UTC
21:01:09 <goozbach> so we'll still be before your meeting
21:01:11 <rbergeron> goozbach: i'll have to look up what that means in like, US time
21:01:13 <goozbach> but we'll have two hourse
21:01:16 <rbergeron> but another hour?
21:01:17 <rbergeron> ahh kewl
21:01:21 <goozbach> rbergeron: one hour earlier
21:01:29 <rbergeron> #topic Roll call!
21:01:42 <goozbach> don't know what that does with daylight savings
21:01:45 <goozbach> I'll look it up
21:01:46 <jdarcy> Present.
21:01:48 * mgoldmann waves
21:01:57 * goozbach runs away before he's counted in the cloud sig
21:02:06 * mmorsi says hi
21:02:13 <rbergeron> hello
21:02:20 <rbergeron> hey jdarcy ;)
21:02:23 * rbergeron looks around for a jforbes
21:02:29 <rbergeron> ... or a gholms
21:02:54 * rbergeron holds a moment before proceeding
21:04:21 * mgoldmann wonders if meeting is over? :)
21:04:27 <rbergeron> not yet ;)
21:04:41 <gholms> bacon
21:04:52 <rbergeron> oh, thank beefy miracle, someone mentioned bacon.
21:05:02 <rbergeron> #topic Meeting Time after Time change next week
21:05:08 <rbergeron> ust wanted to cover this super quicklike:
21:05:38 <rbergeron> in the US next week we apparently change times for Daylight Savings.
21:05:49 <rbergeron> (This doesn't apply to me, of course, because I live in Arizona, where we are normal and don't change times.)
21:05:57 <gholms> Only part of AZ.
21:06:11 <mgoldmann> confusing
21:06:16 * gholms nods
21:06:23 <rbergeron> So I wanted to informally canvas folks and see if they wanted to stay at their time on their schedules, or if they wanted to keep the meeting at the same time, UTC.
21:06:55 <gholms> My potential for conflicts rises if we keep the same time.
21:06:56 <rbergeron> Thoughts, concerns, questions?
21:07:13 <rbergeron> If we keep the same time UTC?
21:07:16 <gholms> Yeah
21:07:28 <jdarcy> This times fine with me.
21:07:29 <gholms> I'm just one person, though.
21:07:40 <mmorsi> this time is fine w/ me too
21:08:01 <mmorsi> but am down to change it too
21:08:23 <rbergeron> gholms: so keeping it at your same relative time in the same spot on your schedule would be best?
21:08:28 <rbergeron> I think tha tworks best for everyone, mostly.
21:08:44 <jforbes> is here
21:08:51 <rbergeron> mgoldmann: do you switch time at any point?
21:08:54 <gholms> If the meeting were to move along with DST here then it would be better for me.
21:08:59 <mgoldmann> rbergeron: yes, one week later
21:09:06 <rbergeron> okay.
21:09:17 <gholms> That doesn't mean that I won't be able to attend any meetings if it remains the same.
21:09:28 <gholms> ...just that the potential for conflict rises.
21:09:51 <rbergeron> Sooo that means..... looking at everyone... we want to move the meeting from 2100 UTC to.... 2000UTC?
21:09:55 <rbergeron> or 2200?
21:09:56 <rbergeron> GOD I HATE TIME CHANGE
21:10:38 <jforbes> I thought the infrastructure meeting moves, so we have to or hold it somewhere else
21:10:50 <gholms> Didn't it move to 1900?
21:10:53 <rbergeron> infrastructure meeting has moved to 1900.
21:11:10 <mgoldmann> so, we can move to 20:00, no?
21:11:25 <mgoldmann> earlier is better for this part of the world...
21:11:33 <mmorsi> one hour earlier? i'm down w/ that
21:11:34 * gholms tries to map that to PDT in his head
21:11:42 <rbergeron> well, I think the idea behind infrastructure moving to 1900 was so that they'd have more than an hour.
21:11:49 <rbergeron> nirik: can you confirm or deny?
21:11:50 <gholms> I can't make any meetings at that time.
21:12:00 <nirik> yes, we wanted to leave more time between our meetings. ;)
21:12:03 * gholms has a weekly meeting at 1100 PDT
21:12:22 <nirik> if you go to 20 thats fine, we can figure something out.
21:12:23 * mgoldmann hides and agrees to whatever will be set
21:12:38 <rbergeron> Let's go with 2000. Even though I think that's what time we're at now.
21:12:45 <rbergeron> I'll send out a mail and see what flames I get. How's that?
21:13:06 <gholms> We're at 2000 now?
21:13:26 <gholms> Wait, no.  We're at 2100 now.
21:13:33 <rbergeron> Okay.
21:13:52 <rbergeron> oh, wait. Then we want to stick with 2100?
21:13:56 <gholms> If we move to 2000 I can't attend *any* meetings after DST turns on.
21:13:59 <gholms> That's just me, though.
21:14:19 <rbergeron> I'll mail the list. This math is far too hard for me to figure out in real time. Sadly.
21:14:26 <gholms> whenisgood.com?
21:14:29 <rbergeron> #action rbergeron to mail the list about the time change and meeting stuff.
21:14:32 <rbergeron> yeah, probably.
21:14:49 <rbergeron> #action rbergeron to use whenisgood, and make sure that the two hours when the infrastructure meeting is are blocked off. ;)
21:14:50 <gholms> Be sure to mention when the infrastructure meeting will move to.
21:14:56 <jforbes> haha
21:15:02 <rbergeron> YESSIR ;)
21:15:13 * gholms casts Mind Read
21:15:41 <rbergeron> #topic EC2, yo
21:15:46 <rbergeron> jforbes: what's the word ;)
21:15:49 * mgoldmann wonders if he can be first because he's short on time...
21:15:49 <rbergeron> Anything new or exciting?
21:15:56 <rbergeron> ohhh, sure. is tha tokay jforbes?
21:16:04 * rbergeron will switch to BG real quicklike
21:16:07 * gholms recommends #undo
21:16:10 <rbergeron> #undo
21:16:10 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x2b0260b1bd50>
21:16:14 <rbergeron> #topic BoxGrinder
21:16:20 <rbergeron> mgoldmann: take it away
21:16:31 <mgoldmann> so, 0.9.0 was released yesterday! http://boxgrinder.org/blog/2011/03/09/boxgrinder-build-0-9-0-is-out/
21:16:40 * rbergeron saw :) very nice!
21:17:02 <gholms> Is this the release that is api- and cli-compatible with 0.7?
21:17:05 <mgoldmann> this release has almost the same CLI compareed to 0.7.1, but with enhancements from 0.8
21:17:11 <mgoldmann> gholms: yep
21:17:15 <mgoldmann> this was the idea
21:17:46 <mgoldmann> it's currently in Rawhide
21:17:58 <mgoldmann> waiting for buildroot override to push it to F13/14/15
21:18:00 <rbergeron> #info this BG release has almost the same CLI compareed to 0.7.1, but with enhancements from 0.8
21:18:21 <mgoldmann> I've retired all -plugins packages
21:18:28 <rbergeron> mgoldmann: are you coming out for JUDCon/JBW/Summit?
21:18:35 <mgoldmann> rbergeron: yes!
21:18:47 <mgoldmann> I'll give a talk on BoxGrinder hopefully :)
21:18:51 <rbergeron> cool ;)
21:19:10 <mgoldmann> I have a question about removing packages from distro
21:19:25 <mgoldmann> how I should update BG in F13/14 ?
21:19:40 * rbergeron looks around to see if anyone knows the magic answer to that
21:19:51 <mgoldmann> I'm cool sending an email too
21:20:15 <gholms> The word you want to search for is "retiring"
21:20:36 <mgoldmann> right, I folowed the procedure
21:20:53 <mgoldmann> http://fedoraproject.org/wiki/How_to_remove_a_package_at_end_of_life
21:21:09 <mgoldmann> but this doesn't answer my problem
21:21:23 <gholms> File a rel-eng ticket to have the package blocked?
21:21:34 <mgoldmann> there is the magic
21:21:39 <jforbes> mgoldmann: you probably want to put an obsoletes in the new package right?
21:21:41 <mgoldmann> yep, I haven't done this so far
21:21:48 <mgoldmann> jforbes: already done
21:21:50 <gholms> That's the last step on that page you linked to.  :)
21:21:53 <jforbes> ahh, cool
21:22:06 <mgoldmann> ok, will do this
21:22:10 <mgoldmann> I have one more issue
21:22:33 <rbergeron> go for it :)
21:22:41 <mgoldmann> I cicked on retire package button before I cleaned the repo and added dead.package file
21:22:49 <gholms> Nice
21:23:02 <mgoldmann> now I don't have write access to repo for *some* plugin branches
21:23:09 <gholms> Ask rel-eng to do it for you.
21:23:11 <mgoldmann> it's done in ~80%
21:23:18 <mmorsi> ah ya
21:23:34 <mmorsi> ran into the same issue today w/ rubygem-merb-core, had required the pkg in pkgdb b4 adding dead.package
21:23:43 <mmorsi> just file a rel-eng ticket, they'll take care of it
21:23:53 <mmorsi> s/required/retired
21:24:04 <mgoldmann> ok, will create tomorrow tickets for this
21:24:09 <mgoldmann> thank you very much!
21:24:28 <mgoldmann> so, onward to 0.10.0!
21:24:36 <mgoldmann> (and BG REST)
21:24:41 <gholms> ;)
21:24:46 <mgoldmann> which is being updated silently :)
21:24:52 <rbergeron> Cool. :) thanks!
21:25:01 <gholms> Anything else for BG?
21:25:03 * rbergeron salutes mgoldmann
21:25:11 <rbergeron> #chair gholms
21:25:11 <zodbot> Current chairs: gholms rbergeron
21:25:13 <rbergeron> ;)
21:25:14 <mgoldmann> that's all, thank you!
21:25:17 <rbergeron> #topic EC2
21:25:27 <jforbes> dgilmore: ping
21:25:39 <mgoldmann> jforbes: sorry for taking your, time, but running out now
21:25:45 <rbergeron> dgilmore is asleep - he's in brisbane this week
21:25:46 <gholms> 'Night
21:25:48 <jforbes> mgoldmann: np at all
21:25:51 <jforbes> ahh... okay
21:25:54 <rbergeron> (at least, I think he is)
21:25:54 <mgoldmann> have a great day, laters!
21:26:02 <rbergeron> anything you need from him that we can pass along?
21:26:16 <jforbes> so we have the specs, and we have koji generating images, but I dont know that alpha images were created, I need to find out
21:26:29 <jforbes> I will try to ping him at more reasonable brisbane hours :)
21:26:31 * rbergeron usually talks to him late-night when he's there just to catch up on other fedora-y things
21:27:29 <rbergeron> jforbes: did you see the mail that gholms sent on the list about the spins stuff?
21:27:29 <jforbes> I am guesing since I haven't seen any announcement, or been asked to upload anything, that alpha images either dont exist, or just need to be pushed
21:27:36 <jforbes> rbergeron: I did
21:28:00 <rbergeron> thoughts on making said wiki page?
21:28:27 <jforbes> rbergeron: can do it when I have time, but I dont have an abundance of time ATM
21:28:41 * rbergeron nods
21:28:54 <jforbes> rbergeron: it will likely be middle of next week before I will get to it
21:29:10 <rbergeron> Is anyone else interested in getting this started up?
21:29:13 * rbergeron looks around
21:29:22 * jforbes hears crickets
21:29:25 <gholms> [Everyone stares at rbergeron]
21:29:48 <rbergeron> OH LORD
21:30:01 * rbergeron looks at the spins page to see if she's even remotely capable of doing that ;)
21:30:11 <gholms> Heh
21:30:41 <rbergeron> Well, I can, um, get it started, at least.
21:31:02 <rbergeron> I figure if it's just terrible, someone else will throw tomatoes at me and help fix it. :)
21:31:06 <gholms> #help The Spins SIG requested a wiki page for the EC2 "spin"
21:31:08 <jforbes> rbergeron: that would certainly be a help
21:31:21 <rbergeron> #action rbergeron to get the EC2 "spin" page started.
21:31:24 <gholms> A start would be awesome.
21:31:30 <gholms> rbergeron: Thanks
21:31:41 <gholms> Ugh, I can't tab-complete your name in here...
21:31:51 <rbergeron> #link http://lists.fedoraproject.org/pipermail/cloud/2011-March/000560.html
21:32:01 <rbergeron> gholms: why not? that's kind of weeeeeird
21:32:07 * jsmith still doesn't think EC2 is a spin
21:32:13 <gholms> rbergeron: Look around.  You have a clone.
21:32:26 <jforbes> jsmith: and I still agree
21:32:36 <rbergeron> jsmith: I'm happy to hear your suggestions - but I suppose we should do this in the interim as a very temporary fix ;)
21:32:37 <gholms> jsmith: Since it's in spin-kickstarts they just want it to go through *some* process.  I agree, it isn't really a spin.
21:32:53 <rbergeron> Maybe we should just have EC2 process.
21:32:56 <jforbes> jsmith: which was part of why I said I wasnt willing to drop everything and create the wiki page
21:32:59 <rbergeron> And say, "it ain't a spin"
21:33:10 <jforbes> we do have the cloud-kickstarts git repos
21:33:12 <rbergeron> "therefore, it doesn't follow the spin process, yo"
21:34:00 <jsmith> I'll work with dgilmore to remove the EC2 kickstart from the spins repo, and pull it from somewhere else
21:34:28 <jforbes> jsmith: yeah, we already have another repo on fedorahosted, I think koji just needs to know how to talk to it
21:34:46 <rbergeron> jsmith: can you send some sort of mail to the cloud list and spins list regarding that? and maybe rel-eng too... or maybe just cloud and logistics
21:34:48 <jsmith> jforbes: Yes, that's my understanding as well -- we just need a patch to koji
21:34:53 <jsmith> rbergeron: Can do!
21:34:55 * rbergeron just doesn't want the spins folks thinking we're just being ruuuuude.
21:35:15 <jsmith> #action jsmith to send an email to the cloud list and spins list and rel-eng regarding EC2 kickstart
21:35:18 <gholms> Is the spins process really that difficult?
21:35:22 <rbergeron> But I'd rather spend time writing a basic framework for documenting the EC2 process than writing a spins page that is temporary, know what I mean?
21:35:39 <gholms> rbergeron: That makes sense.
21:35:59 <jsmith> gholms: In a nutshell, yes.
21:36:10 <gholms> I see.
21:36:16 <jsmith> gholms: Shouldn't be that way, but it's currently pretty complicated
21:36:33 <gholms> Since half of the process simply doesn't apply I have no idea how hard it would be.
21:36:57 * gholms lets y'all decide
21:37:15 * rbergeron has no idea aobut complexity either.
21:37:49 * jlaska joins late
21:38:05 * jlaska has a TODO still on my list from last week ... I'd like to keep that item on there
21:38:18 * rbergeron nods
21:38:20 <gholms> Can we get any more action items out of this topic, or shall we move on?
21:38:25 <rbergeron> jsmith, jforbes: whatcha wanna do?
21:38:53 <rbergeron> #action jsmith to send an email to the cloud list and spins list and rel-eng regarding EC2 kickstart
21:38:57 <rbergeron> #chair jsmith
21:38:57 <zodbot> Current chairs: gholms jsmith rbergeron
21:38:58 <jforbes> well, I need to talk to dgilmore
21:39:04 * rbergeron nods
21:39:19 <jforbes> we need to get an alpha image published, I just dont know where it is in the process
21:39:28 <rbergeron> Do you want to chat with him, and then report back?
21:39:34 <jforbes> yes
21:39:43 <rbergeron> sounds good.
21:39:54 <rbergeron> #action jforbes to investigate with dgilmore about getting alpha image published
21:40:23 <rbergeron> #action rbergeron to do some basic framework about EC2-not-as-a-spin process on the wiki
21:40:49 <rbergeron> #action jlaska to follow up with some testing/QA info on EC2
21:40:53 <rbergeron> Anything else?
21:41:16 * gholms looks around
21:41:17 <rbergeron> gholms: did i miss anything? :)
21:41:23 * gholms shrugs
21:41:36 <rbergeron> feel free to add on
21:41:42 <jforbes> nothing else here
21:42:14 * rbergeron moves on before gholms calls in the tumbleweeds
21:42:22 <gholms> Heh
21:42:25 <rbergeron> #topic CloudFS
21:42:32 <rbergeron> jdarcy: anything you'd like to update on?
21:42:37 <gholms> It's too wet for tumbleweeds today.
21:42:37 <jdarcy> Not really.
21:42:51 <jdarcy> I spent a lot of time benchmarking GlusterFS vs. others.
21:43:02 <rbergeron> #info CloudFS continues forth. Benchmarking fun!
21:43:03 <jdarcy> PVFS/OrangeFS, MooseFS, Ceph.
21:43:08 <rbergeron> that sounds like FUN.
21:43:11 <rbergeron> :D
21:43:28 <jdarcy> Turns out that GlusterFS was the only one that even got through the tests, which makes me feel better about using it as the basis for CloudFS.  :)
21:43:44 <rbergeron> :)
21:43:45 <jdarcy> Other than that, it's mostly Kaleb and me grinding away on making the config experience better.
21:43:53 <rbergeron> Cool.
21:43:58 <rbergeron> Hey, where is kaleb? :)
21:44:05 * rbergeron grins
21:44:12 <jdarcy> Seems to be gone.  I'll bug him some more.
21:44:18 <rbergeron> Allrighty. I'll move onwards. :)
21:44:29 <rbergeron> #topic Aeolus
21:44:38 * obino is late as usual :(
21:44:38 <rbergeron> mmorsi: Anything fun going on?
21:44:42 <rbergeron> hey obino :)
21:44:48 <obino> o/
21:44:49 <mmorsi> hrm not too much to report this week
21:45:00 <mmorsi> we just began another sprint, and its a cleanup / planning one at that
21:45:41 <rbergeron> Cool.
21:45:47 <mmorsi> i sent the list of aeolus packages that are currently in flight as far as getting into fedora, help w/ any of those would be more than appreciated
21:45:54 <rbergeron> yes, I saw.
21:46:09 <rbergeron> #info mmorsi sent a list of aeolus packages that are working their way into Fedora - help is appreciated!
21:46:41 <rbergeron> #link http://lists.fedoraproject.org/pipermail/cloud/2011-March/000563.html
21:46:58 <rbergeron> Awesome. Thanks for the mail. Hopefully you can get some love there :)
21:47:03 <mmorsi> other than that, just keep an eye out for new commits and releases coming soon, also our ticket / feature management tool is going pubilc soon so everyone will be able to follow progress as it happens
21:47:08 <mmorsi> sure thing np
21:47:21 <rbergeron> very nice. :)
21:47:37 <rbergeron> thanks, mmorsi! :)
21:47:40 <mmorsi> np
21:47:55 <rbergeron> #topic Open Floor / Any other business
21:48:04 * rbergeron hopes she didn't skip anyone.
21:48:25 <gholms> #info Another euca2ools build for el5 is in epel-testing; please give karma
21:48:40 <gholms> mgoldmann was instrumental in testing it.
21:48:53 <rbergeron> gholms: Do you want me to add euca-stuff to the weekly agenda ongoing?
21:48:59 <gholms> Nope.
21:49:22 <gholms> It's too sporadic right now for that to be worth doing.
21:49:22 <rbergeron> Okay.
21:50:12 * rbergeron looks around for anything else, before closing out things.
21:50:18 <gholms> [A tumbleweed rolls past on a Segway]
21:50:51 <rbergeron> wow.
21:50:55 <rbergeron> Haven't seen that one before
21:51:01 <gholms> You wanted a tumbleweed.
21:51:03 <rbergeron> Thanks for coming, all ;)
21:51:04 <rbergeron> I did.
21:51:08 <rbergeron> And you delivered. :)
21:51:10 <rbergeron> ON A SEGWAY
21:51:21 <rbergeron> It's a miracle!
21:51:23 <gholms> :D
21:51:24 <rbergeron> Like a beefy miracle!
21:51:29 <obino> lol
21:51:36 <gholms> A beefy tumbleweed?
21:51:40 <rbergeron> Yes.
21:51:42 <rbergeron> :)
21:51:44 <rbergeron> #endmeeting