15:59:16 <spot> #startmeeting Fedora Packaging Committee
15:59:16 <zodbot> Meeting started Wed Apr  6 15:59:16 2011 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:59:22 <spot> #topic Roll Call
16:01:10 <spot> abadger1999, Rathann, limburgher, geppetto, rdieter, tibbs|h: ping
16:01:18 <Rathann> pong
16:01:25 <limburgher> ping
16:01:32 <tibbs|h> Howdy.
16:02:02 <limburgher> C:\
16:02:05 <limburgher> >
16:03:17 <spot> hm. thats not quite quorum
16:03:40 * Rathann suggests waiting a couple more minutes
16:04:21 * geppetto is here
16:04:22 <spot> sure.
16:04:31 * abadger1999 here
16:04:39 <spot> better! :)
16:04:52 * laxathom here
16:04:58 <spot> #topic systemd - new package guidelines - https://fedoraproject.org/wiki/TomCallaway/Systemd_Revised_Draft
16:05:16 * SmootherFrOgZ here(bis)
16:05:34 <spot> i have finished testing (documented here): https://fedoraproject.org/wiki/User:Spot/Testing_systemd
16:06:16 <spot> so, at this point, i'm comfortable with the systemd new package portion of the guidelines
16:07:26 <spot> does anyone have any remaining concerns on this draft?
16:07:34 <tibbs|h> OK, so the issue about running but not configured on at boot, then upgrading was not reproducible.
16:07:45 <tibbs|h> Hard to describe that in one line.
16:08:02 <spot> yep. it would happen in about 1 out of 10 tries in my VM, but on a bare-metal instance, it never happened
16:08:09 <tibbs|h> Interesting.
16:08:13 <spot> so i'm very willing to chalk that failure up to VM timing issues
16:08:43 <geppetto> Hmm … did you open a BZ?
16:08:55 <spot> geppetto: no, because i couldn't reproduce it reliably enough
16:08:57 <tibbs|h> It does point to a bug somewhere, but not any problem with this draft.
16:09:14 <geppetto> yeh, I guess
16:09:33 <spot> Lennart worked with me for an hour to try to get more data
16:09:37 <spot> but both of us came up empty
16:10:04 <spot> abadger1999, any remaining concerns on this half?
16:12:31 <spot> mmkay. i'm assuming abadger1999 is either furiously re-reading, or has been pulled away. ;)
16:12:41 <spot> either way, i think we can take a vote here:
16:12:48 <limburgher> Or been eaten.
16:12:49 <spot> +1 from me
16:12:51 * abadger1999 furiously reading
16:12:55 <limburgher> Whew.
16:13:17 <abadger1999> Are we okay with making changes that require people to change their scriptlets?
16:13:25 <SmootherFrOgZ> +1
16:13:25 <abadger1999> If so, I can vote for this.
16:13:37 <limburgher> +1
16:13:56 <geppetto> yeh, +1
16:13:56 <spot> abadger1999: you mean if we discover these scriptlets are not correct at some point in the future?
16:14:26 <abadger1999> Yeah -- b/c at some point (probably when we do the sysv=>systemd upgrade scriptlets) I'll test this stuff again.
16:14:43 <abadger1999> to see if there;s bugs.
16:14:47 <spot> abadger1999: yeah, i think so, but hopefully, these scriptlets will still be valid for the "new package" case.
16:14:48 <abadger1999> What's the VM problem?
16:15:28 <spot> abadger1999: sometimes, upon upgrade, the service would not restart cleanly, but it never happened on bare metal
16:15:45 <abadger1999> Hmmm..
16:15:50 <spot> abadger1999: systemd with debugging options turned all the way up reported no failures
16:16:11 <abadger1999> spot: Okay -- so that sounds like a bug.  We should not the bugzilla entry for it.
16:16:31 <spot> abadger1999: as i pointed out earlier, it doesn't seem to be a systemd bug, but rather something fishy happening on the VM
16:16:32 <abadger1999> b/c testers (and production shops like FI) run a ton of stuff in VMs.
16:16:37 <spot> and since i could not readily reproduce it
16:16:48 <abadger1999> ou're saying 1 out of 10 times?
16:17:02 <spot> abadger1999: thats a rough guess. sometimes it wouldn't happen in 50 attempts
16:17:13 <abadger1999> I think we should note a bug #
16:17:14 <spot> sometimes, twice in a row.
16:17:40 <abadger1999> running in VMs is quite common for both testing and production servers these days.
16:18:00 <spot> abadger1999: yes, but its also possible that the machine i was using for VM testing has memory issues
16:18:03 <tibbs|h> It definitely bears more testing, sure.
16:18:16 <tibbs|h> But I can't see how the stuff in this draft could cause that.
16:18:19 <geppetto> spot: Personally I doubt you can rule out a systemd bug … but if it's a real bug, someone will hit it anyway
16:18:22 <spot> neither i nor Lennart could get any useful debugging out of the problem whatsoever
16:18:26 <geppetto> Might be worth noting somewhere though
16:18:36 <abadger1999> spot: hmm... so we need other people to test the case on their VMs.
16:18:37 <spot> geppetto: yes, the logic was that if its a real bug, we'll see a lot more of it
16:18:43 * geppetto nods
16:18:44 <spot> abadger1999: Lennart was going to do that
16:18:56 <abadger1999> spot: What's the step-by-step?
16:19:02 <spot> https://fedoraproject.org/wiki/User:Spot/Testing_systemd
16:19:05 <abadger1999> We can test and if we can't reproduce we don't have to note.
16:19:09 <abadger1999> spot: Which of those?
16:19:18 <spot> either of the upgrade cases
16:19:33 <spot> there is a note at the bototm of 2.3
16:19:41 <spot> (In earlier testing, it failed, but it seems not to be reproducible.)
16:19:43 <abadger1999> Do you have binary rpms too?
16:20:13 <spot> abadger1999: yes, i could get them from the VM
16:20:26 <spot> either way, i don't think this should delay the draft
16:20:58 * spot counts... vote is at +4
16:21:16 <tibbs|h> +1
16:21:46 <abadger1999> I'lll +1 if we note the problem or I'll +1 later if we test and find no problem on other machines.
16:22:13 <Rathann> hm what was the final take on moving sysv/lsb initscripts to separate packages?
16:22:17 <spot> abadger1999: how would you like us to note the problem, i don't think it is appropriate to do so in the draft.
16:22:27 <abadger1999> spot: We've done so before.
16:22:38 <spot> abadger1999: yes, but only in far more tangible cases.
16:23:02 * spot isn't even comfortable filing it as a valid bug at this point
16:24:12 <abadger1999> Well that's fine, there's +5 now so you don't need my vote.
16:24:32 <spot> Rathann: the current draft, covering new packages, says: "Packages may also provide a SysV initscript file, but are not required to do so. This format is considered legacy, but Fedora still contains init mechanisms such as upstart which do not support the systemd unit file format. If present, the SysV initscript(s) must go into an optional subpackage, so as not to confuse sysadmins. The guidelines for SysV initscripts can be found here: Packaging:SysVInitS
16:24:32 <spot> cript"
16:25:17 <abadger1999> my feeling is just that there's too many VM installs to not note that something happens wrong.
16:25:30 <abadger1999> which we've done with a variety of other guidelines.
16:26:05 <spot> abadger1999: if you, or anyone else, can reproduce that issue in a VM, i'd be more inclined to agree with you
16:26:17 <abadger1999> spot: Which I can't do without testing :-)
16:26:28 <limburgher> At l least getting it out there will get more testers/eyeballs.
16:26:31 <spot> abadger1999: it is a trivial thing to add if testing later reveals it
16:26:33 <abadger1999> spot: Which is why I said, I'd be happy to vote +1 later after I test.
16:26:41 <abadger1999> I just can't +1 now.
16:26:47 <spot> abadger1999: fair enough.
16:26:57 <spot> as you pointed out, we're at +5.
16:27:06 <abadger1999> And there's +5 so it shouldn't be a problem.
16:27:07 <spot> Rathann: if you'd like to be on the record, feel free to chime in
16:27:08 <abadger1999> <nod>
16:27:39 <abadger1999> ( can record me as +0)
16:27:45 * spot nods
16:28:52 <spot> okay then
16:29:10 <spot> #action Systemd New Package Guidelines Approved (+1:5, 0:1, -1:0)
16:29:27 <spot> #topic Systemd Upgrades from SysV
16:29:50 <spot> abadger1999: lennart officially added /usr/bin/systemd-sysv-convert to a new systemd-sysv subpackage: http://koji.fedoraproject.org/koji/rpminfo?rpmID=2494858
16:29:54 <abadger1999> IIRC, the sysv upgrade scriptlets were in almost their final form (the script to save state was renamed)
16:30:08 <abadger1999> so those just need to be tested.
16:30:36 <spot> abadger1999: so we'll need to add Requires(postun): systemd-sysv
16:30:43 <spot> and fix the naming
16:31:57 <spot> we'll revisit this topic next week, i'll try to find some time to test these cases
16:32:24 <Rathann> sorry, got distracted by a phone call
16:32:57 <abadger1999> spot: I'll update my page that has the upgrade scriptlets right after this meeting.
16:33:45 <spot> Okay, moving on.
16:33:52 <spot> #topic MinGW - https://fedorahosted.org/fpc/ticket/71
16:34:32 <spot> rwmjones: if you're around, do you know if Erik is able to attend? he did not update the ticket...
16:36:37 <tibbs|h> ...
16:38:10 <spot> well. i suppose we'll table that to next week and hope he shows a little more interest.
16:38:15 <abadger1999> spot: okay, seems like this one jsut can't go ahead.
16:38:44 <spot> Moving on to the next stalled ticket...
16:38:55 <spot> #topic Perl @INC Change
16:38:59 <spot> This is https://fedorahosted.org/fpc/ticket/73
16:39:36 <spot> In order for us to move forward on this, we need to have some more specific details on why this change is beneficial.
16:39:57 <spot> I'm going to put that in the ticket, hopefully mmaslano will reply.
16:41:26 <spot> okay. i think those are all the pending tickets.
16:41:31 <spot> #topic Open Floor
16:42:33 <spot> If there are no items by say, oh, 16:46, i'll close out the meeting.
16:42:42 <tibbs|h> Nothing from me.
16:42:46 <abadger1999> I'm going on vacation -- I should make next meeting but miss the one after.
16:42:54 <tibbs|h> Have had so little time lately.
16:43:08 <limburgher> I got nothing.
16:43:14 <spot> abadger1999: thanks for the heads-up. :)
16:44:00 <abadger1999> we approved this in the ticket: https://fedorahosted.org/fpc/ticket/75  but if spot or laxathom want to register a vote before its announced they can.
16:44:10 <tibbs|h> Did everyone fill in their times on whenisgood?
16:44:14 * abadger1999 did
16:44:18 <spot> yeah, I'm +1 on that ticket.
16:44:20 * limburgher done
16:44:29 <spot> i just never quite got around to saying so. :)
16:44:32 * gholms|work raises hand
16:44:41 <abadger1999> gholms|work: Go ahead
16:44:51 <gholms|work> Just a little annoyance I mentioned on the list:
16:44:56 <SmootherFrOgZ> +1 from me
16:45:31 <spot> unsurprisingly, with seven of nine members on whenisgood, we have exactly 0 valid matches. :)
16:45:57 <gholms|work> Could the wording of the review guideline related to source tarball checksums be changed so it doesn't mention md5?
16:46:04 <tibbs|h> Best thing to do may be not to change, then.
16:46:10 <gholms|work> I realize it says "should", but it just bugs me.  ;)
16:46:12 <tibbs|h> Is something wrong with md5?
16:46:12 <abadger1999> <nod>
16:46:42 <gholms|work> Nothing's wrong with md5, but it reads as if Fedora doesn't want people to use stuff like sha.
16:46:59 <Southern_Gentlem> ??
16:47:06 <geppetto> I don't mind just removing it
16:47:32 <limburgher> We have to give some tool, or newbies won't know what to do.  Maybe a list?  (md5sum|sha256sum|. . .)
16:47:32 <spot> how about s/md5sum/a checksum tool such as md5sum or sha256sum/
16:47:52 <limburgher> Jinx
16:48:07 <Rathann> there's even sha512sum
16:48:11 <spot> gholms|work: ^ ?
16:48:21 <tibbs|h> Just pick one tool and go with it.
16:48:32 <tibbs|h> Honestly md5 is fine for this application.
16:48:37 <limburgher> It is.
16:48:42 <spot> i think md5sum is perfectly valid for this usecase.
16:48:53 <gholms|work> spot: I'm +1 on your suggestion.
16:48:55 <tibbs|h> Personally I use sha1 in my reiews.
16:49:11 <gholms|work> (Then again I can't vote)
16:49:19 <spot> but i won't lose sleep on changing it to reference a "checksum tool" as proposed above
16:49:25 <kalev> lookaside cache uses md5 afaik, so if reviewers also use md5, it's possible to later check if the same tarball was uploaded.
16:49:40 <spot> kalev: that is a valid point
16:49:50 <gholms|work> Oh, that's good to know.
16:50:27 <tibbs|h> It's possible to check in any case simply by using the same checksum tool.
16:50:37 <abadger1999> Using diff is the only thing that's slightly bad advice.  If you do a diff -uNr of the extracted contents you won't catch changes to permissions, for instance. (remembering what was mentioned on the list)
16:50:40 <spot> so, i think leaving it as is, is fine for now. i don't think people are interpreting that review guideline strictly and blocking reviews as a result
16:50:42 <limburgher> Slightly OT, Is there documentation out there on exactly how lookaside cache works?
16:50:58 <abadger1999> there isn't that I can recall.
16:50:59 <tibbs|h> The source.
16:51:11 <abadger1999> I had to look at the upload script to tell how it worked.
16:51:11 <tibbs|h> It's not really complicated.
16:51:24 <limburgher> I didn't figure, just idle curiosity.
16:51:34 <spot> limburgher: i have a basic idea of how it works, but honestly, it is Gafton-era code that i'm just content to leave alone
16:51:47 <abadger1999> limburgher: If you want to look, you can also fix it to return an http eror if the upload fails :-)
16:51:53 <tibbs|h> I've wanted to poke at it for some time.
16:52:09 <limburgher> spot: not broken, don't fix? :)
16:52:18 <limburgher> abadger1999: Look where?
16:52:21 <spot> limburgher: yeah, although as abadger1999 points out, it does need some love.
16:52:34 <limburgher> spot: Not volunteering yet. :)
16:52:58 <spot> SmootherFrOgZ: on the WhenIsGood, everyone but you was okay with moving the time on Wednesday from 1600 to 1500.
16:53:06 <spot> SmootherFrOgZ: is there any flexibility for you at 1500?
16:53:10 <abadger1999> limburgher: http://git.fedorahosted.org/git/?p=fedora-infrastructure.git;a=tree;f=scripts/upload.cgi;h=aad4fd7c14b88ff754f85ad4defef8eb3e5bf87d;hb=HEAD
16:53:44 <SmootherFrOgZ> spot, hm, I can maange to be there at this time
16:53:44 * spot notes that SmootherFrOgZ also marked 1600 on Wednesday as a bad time. :/
16:54:47 <abadger1999> we could switch things from md5 to shaX if we wanted to but it might just be busy work (have to re-checksum all the currently uploaded files as well).
16:55:23 <geppetto> In theory we can have it work it out based on the length, so we don't need to convert
16:55:31 <spot> i will send out an email to all FPC members to see if we all agree that 1500 UTC on Wednesday is a good time to meet.
16:57:59 <spot> okay, i think we're done
16:58:02 <spot> thanks everyone
16:58:04 <spot> #endmeeting