19:00:32 <rbergeron> #startmeeting Cloud SIG
19:00:32 <zodbot> Meeting started Fri May  6 19:00:32 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:36 <rbergeron> #meetingname Cloud SIG
19:00:36 <zodbot> The meeting name has been set to 'cloud_sig'
19:00:41 <rbergeron> #topic Roll call, yo
19:00:47 <jforbes> yo...
19:00:48 * kkeithley is here
19:01:23 <rbergeron> hey jforbes, kkeithley
19:01:40 * jgreguske waves
19:01:49 <rbergeron> hi jgreguske :)
19:01:51 <jdarcy> Hey all.
19:01:53 <rbergeron> mmorsi
19:01:54 * mmorsi says hi
19:01:58 <rbergeron> jdarcy :)
19:02:03 <rbergeron> sweet, lots of peepz here today
19:02:07 <gholms> :D
19:02:08 <rbergeron> shall we start?
19:02:13 <rbergeron> #topic EC2
19:02:23 <rbergeron> #chair jforbes gholms
19:02:23 <zodbot> Current chairs: gholms jforbes rbergeron
19:02:35 * jforbes is working through an SELinux issue with the current kickstarts
19:02:39 <gholms> rbergeron: Welcome back to our Cloud SIG meetings!  ;)
19:02:48 <rbergeron> gholms! thanks, it's good to be back.
19:03:00 <rbergeron> i promise that i won't be travelling for at least a month.
19:03:01 <rbergeron> :)
19:03:02 <jforbes> I think I have it figured out, but we will see when the next images get uploaded
19:03:12 <jforbes> rbergeron: back home already?
19:03:13 <gholms> jforbes: Is there perchance a bug open for it?
19:03:17 <rbergeron> jforbes: in hotel
19:03:40 <jforbes> gholms: no, we need to figure out the best place to put EC2 image bugs.  There isn't a clear component for them
19:03:44 * rbergeron wonders whre we'd track a bug if we had some filed?
19:03:53 <gholms> Distribution?
19:04:00 <rbergeron> yeah, i mean we could get a trac instance, or get it added to bugzilla
19:04:07 * jforbes has no desire to track all of the distribution queue
19:04:15 <rbergeron> jforbes: :)
19:04:24 <jforbes> Adding an EC2 sub to distribution sounds like a decent enough idea
19:04:37 <gholms> Well, the bugzappers can help, too...
19:04:41 <gholms> Yeah, there's an idea.
19:06:04 * rbergeron wonders who might want to take tha ttask on if everyone thinks it sounds reasonable
19:06:25 <gholms> I'm not even sure who one should ask about that sort of thing.
19:06:35 <jforbes> In other, less important news.  I am getting billed by amazon still, so the fedora image account needs some sort of responsible party... I can cover it until that is figured out.  It isnt hitting my card anymore
19:07:08 <jgreguske> gholms: bz admins... possibly dgilmore?
19:07:11 <jforbes> We dont get billed for the storage, and are not using machine time, but we do get billed for transfers still, so I am guessing on a regular release it will be less than $1
19:07:12 * rbergeron looks at spevack and points above to jforbes' line
19:07:33 <jforbes> last months bill was $0.30
19:07:37 <rbergeron> i can figure out how to get it added.
19:07:41 <rbergeron> jforbes: gumball and some change :)
19:07:47 <dgilmore> jgreguske: im no bugzilla admin
19:07:58 <jgreguske> ah ok. me either
19:08:05 <gholms> dgilmore: Never mind, then.  :(
19:08:13 <jforbes> rbergeron: Right, like I said, I dont mind paying it unitl we figure something out, but removing my credit card just means a bill sits there that has to be paid
19:08:14 * spevack chuckles at a monthly bill of 30 cents
19:08:18 * rbergeron thinks she knows who to talk to
19:08:24 <spevack> the bill for community-cloud@fedoraproject.org last month was $450
19:08:38 <spevack> s/last month/in April
19:08:38 <jforbes> spot: Probably costs them more to run the credit card
19:08:39 <rbergeron> spevack: i know, but can't we just figure out how to merge them?
19:08:39 <dgilmore> ouch
19:09:02 <rbergeron> i'm just puzzled why we seem to have multiples
19:09:05 <rbergeron> i guess
19:09:32 <rbergeron> #action rbergeron to figure out adding an ec2 component to bz
19:09:58 <jforbes> rbergeron: merging would be difficult because this account has free S3 tagged, they can't tag the other account because it hosts more than just official images
19:10:35 <rbergeron> I see they've made this very simple for everyone. no wonder amazon's stock is going up 89 dollars a day
19:10:39 * rbergeron grins
19:10:57 <jforbes> rbergeron: Though we have multiples I am guessing because when gregdek told me to create the account, I dont think he knew about the other.
19:11:23 <rbergeron> ooh.
19:11:34 * rbergeron makes a note to beat greg senseless sometime
19:11:35 <rbergeron> :)
19:11:39 <gholms> D:
19:11:56 <rbergeron> okay.
19:12:03 <rbergeron> ummm.... anything else then, i guess?
19:12:09 <gholms> Hang on a sec
19:12:11 <jforbes> nothing else at this point
19:12:24 * rbergeron hangs
19:12:26 <gholms> #info jforbes is working on resolving a SELinux issue on the EC2 image
19:12:30 <gholms> Carry on  :)
19:12:36 * rbergeron carries onward.
19:12:45 <rbergeron> #topic CloudFS
19:12:53 <rbergeron> jdarcy: how was your week? anything fun to report
19:13:02 <jdarcy> Nope, not really.  ;)
19:13:25 <jdarcy> Seriously, though, I have a talk at Summit which was pretty well received considering that it was at the end of a long day and there was free beer elsewhere in the building.
19:13:45 <jdarcy> That's another way to say that I was speaking to an empty room.
19:13:52 <kkeithley> hardly empty
19:14:06 <jdarcy> Well, about 40 people in a room that seats 200.
19:14:16 <jforbes> jdarcy: any attendance at all when competing with free beer is a great thing
19:14:19 <jdarcy> Blog post (with link to slides) here: http://cloudfs.org/2011/05/red-hat-summit-slides/
19:14:45 <jdarcy> There was actually some good back-and-forth with those who did attend, and some other good hallway conversations during the day.
19:15:15 * rbergeron nods
19:15:16 <jdarcy> Now that that's done I'm back to coding.  Almost done with the second version of the xattr-prefetch patch so it can be accepted upstream.
19:15:48 <gholms> The commentary on the first patch was quite enlightening.
19:15:53 <jdarcy> After that, I'll be working on SSL transport, packaging/merging, etc.  GlusterFS is at 3.1.4/3.2 now, we kind of need to update that.
19:16:09 <jdarcy> gholms: Yeah, Avati's thorough.
19:16:35 <jdarcy> Kaleb, anything you want to add>?
19:16:38 <kkeithley> I tried to build cloudfs against 3.2 on f14. They've done something that makes it unhappy
19:16:58 <jdarcy> Yay, more job security,.
19:17:38 <rbergeron> lol
19:17:53 <kkeithley> I'm working, oh, ~20% on migrating the UI I did into the bottle-based cloudfsd that Jeff started. The other ~80% I'm coding a new translator to do uid and gid mapping. Should have something worth playing with in a day or three
19:18:01 <gholms> #info Working on GlusterFS 3.2 support
19:18:20 <gholms> Yaay
19:18:36 <jdarcy> Edward popped up this week, still seems to be working on encryption stuff.
19:18:37 * rbergeron thanks gholms for being more meetingsavvy than she's feeling today
19:19:15 <jdarcy> Oh, and I wrote up some instructions for deploying some parts of GlusterFS/CloudFS as a personal not-really-Dropbox-like cloud file store.  Got so many hits that my host complained.
19:19:22 <rbergeron> wow
19:19:37 <gholms> #info Work on UI, encryption, xattr prefetching continues
19:19:43 <gholms> Nice
19:20:31 <mgoldmann> right, morning!
19:20:40 <mgoldmann> (I'm confused by the time)
19:20:43 <rbergeron> hey mgoldmann
19:20:49 <gholms> Time zones.  Meh.
19:20:57 <rbergeron> jdarcy: where are said instructions?
19:21:01 <jdarcy> Hey Marek.
19:21:12 <rbergeron> mgoldmann: but now you can have a friday night out ;)
19:21:13 <rbergeron> lol
19:21:21 <jdarcy> http://cloudfs.org/2011/05/building-your-own-dropbox-equivalent/
19:21:33 <rbergeron> kewlio
19:21:44 <mgoldmann> rbergeron: I had a friday night out for the last few days, but another one sounds good!
19:22:31 * kkeithley thinks rbergeron is either my dad or my daughter :-)
19:22:31 <rbergeron> mgoldmann: me too. and i don't leave till tomorrow
19:22:34 <rbergeron> hey msavy :)
19:22:40 <msavy> hey rbergeron
19:22:41 <mgoldmann> same here :)
19:22:46 <msavy> nice to meet you in person the other day
19:22:49 <rbergeron> kkeithley: so long as i'm not both cuz that'd be kind of weird :)
19:22:57 <rbergeron> okay. anything else on cloudfs? :)
19:23:05 <kkeithley> nope
19:23:19 <rbergeron> sweet. thanks jdarcy and kkeithley for coming :)
19:23:26 <rbergeron> #topic BoxGrinder
19:23:30 <mgoldmann> yay!
19:23:33 <rbergeron> hey guys :)
19:23:44 <rbergeron> what's new in BG land? :)
19:23:51 <mgoldmann> so, we released 0.9.1 http://boxgrinder.org/blog/2011/04/28/boxgrinder-build-0-9-1-released-and-fedora-test-day/
19:24:02 <mgoldmann> This version will go into F15
19:24:13 <mgoldmann> it's now in stable for F13/14/15
19:24:21 <mgoldmann> so, yay x 2!
19:24:44 <rbergeron> very nice. did you guys get anything new/interesting out of cloud day?
19:24:48 <rbergeron> (like new bugs, heh)
19:25:00 <mgoldmann> we have a nice parser that will tell you what's wrong with your appliance definition file is
19:25:04 <msavy> yeah a few bugs
19:25:04 <mgoldmann> -is*
19:25:25 <msavy> nothing too major, but a few useful items
19:25:32 <gholms> #info F15 will be released with BoxGrinder 0.9.1
19:25:34 <mgoldmann> https://fedoraproject.org/wiki/Test_Day:2011-04-28_Cloud_SIG_BoxGrinder_Build
19:25:58 <mgoldmann> fixes for this will go into 0.9.2
19:26:10 <mgoldmann> planning the release in one week or so
19:26:19 <mgoldmann> this will include fixes for F15
19:26:33 <rbergeron> sweet.
19:26:35 <mgoldmann> as currently F15 support is there, but not very great
19:26:45 <gholms> # 0.9.1 has bugs on F15; 0.9.2 should fix them
19:26:49 <mgoldmann> with 0.9.2 I'll add also cloudsigma support
19:26:59 * rbergeron throws gholms an "info"
19:27:03 <gholms> Crap
19:27:08 <gholms> #info 0.9.1 has bugs on F15; 0.9.2 should fix them
19:27:19 <rbergeron> :D
19:27:37 <gholms> #info 0.9.2 also adds CloudSigma support
19:27:40 <gholms> (whatever that is)
19:27:41 <mgoldmann> so, in general - Test Day was a very positive contribution from community
19:27:51 <mgoldmann> http://cloudsigma.com/
19:27:57 <rbergeron> gholms: cloud hosting provider in europe
19:27:59 <mgoldmann> gholms: switzerland cloud provider
19:28:02 <mgoldmann> heh
19:28:03 <gholms> Ah, cool
19:28:03 <mgoldmann> :)
19:28:08 * rbergeron grins at mgoldmann
19:28:26 <msavy> we met a few cloud providers at the conference who seemed interested in BoxGrinder
19:28:29 <msavy> so they are looking it up
19:28:43 <mgoldmann> and we're going to look at their API's
19:28:45 <rbergeron> nice!
19:29:16 <mgoldmann> I would thank you all the people who helped at BG test day
19:29:39 <gholms> #info Cloud Test Day had lots of BoxGrinder testing
19:30:26 <mgoldmann> that's it I think
19:30:57 <gholms> [Everyone stares at rbergeron]
19:31:51 <gholms> Ummm...
19:32:20 <gholms> Okay then:
19:32:20 <gholms> #topic Aeolus
19:32:40 <jgreguske> mmorsi: ^
19:32:50 <rbergeron> sorry
19:32:58 * rbergeron is like double booking in the Blocker meeting as well
19:33:17 <rbergeron> (thanks, mgoldmann and msavy)
19:33:35 <mgoldmann> you're welcome, was nice to see you again!
19:33:37 * rbergeron notes that she's hread something about a dude named justin who is the aeolus community manager
19:33:51 <mmorsi> hey
19:33:57 * rbergeron is kind of curious if he's maybe coming here sometime to say hi
19:33:58 <rbergeron> :D
19:34:01 <mmorsi> couple of updates to aeolus recently
19:34:05 <mmorsi> well lots of updates
19:34:09 <mmorsi> lots noteworthy
19:34:14 <mmorsi> but for brievity sake :-)
19:34:34 * rbergeron grins
19:34:55 <mmorsi> first off we've moved our planning / issue tracking tool to be public  https://www.aeolusproject.org/redmine/
19:35:27 <mmorsi> we've also written and integrated a selinux policy for aeolus which is one of the things required for us to get the components into fedora
19:35:43 <mmorsi> we're hoping to start integrating more of the components in for F15
19:36:16 <gholms> #info New SELinux policies moving Aeolus closer to inclusion in Fedora
19:36:17 <mmorsi> we're allocating some time in our upcoming sprint to do so, eg upate the app to rails 3 in F15
19:36:18 <rbergeron> woohoo
19:37:05 <rbergeron> :D
19:37:10 <mmorsi> additionally a bunch of nwe feature are going in such as pulp support, rhel/rhev support, better integration between components, alot better docs
19:37:29 <mmorsi> the site has been updated to include more of that docs http://www.aeolusproject.org/
19:38:02 <mmorsi> hrm and many various other things
19:38:11 <mmorsi> but tahts most of the major stuff
19:38:22 <rbergeron> very nice.
19:38:31 <gholms> #info Support for lots of services is on the roadmap; see website for details
19:39:12 <gholms> Anything else of note?
19:39:25 <mmorsi> hrm that about covers it for this week
19:39:44 <mmorsi> unless i'm forgettign anything (which wouldn't surprise me :-p)
19:39:50 <rbergeron> #opic Open Floor
19:39:54 <gholms> Fail
19:40:02 <mmorsi> hehe, at least it wasn't epic ;-)
19:40:04 <rbergeron> #Open Floor
19:40:05 <rbergeron> oh
19:40:08 <gholms> Fail #2
19:40:13 <mmorsi> lol
19:40:14 <rbergeron> #topic Open Floor. third time is a charm!
19:40:22 <gholms> I have a couple things.
19:40:28 <rbergeron> take it away, gholms.
19:41:04 <gholms> I desperately need +2 on a euca2ools update before F15 hits change freeze, as it includes a pile of bugfixes for important functionality.
19:41:10 <gholms> https://admin.fedoraproject.org/updates/euca2ools-1.3.1-10.fc15
19:41:25 <gholms> #help Testers needed for euca2ools before change freeze
19:42:05 <rbergeron> ahhhh. okay.
19:42:17 <gholms> Now of course if it doesn't work then by all means give it -1, too.  But I would appreciate testing either way.
19:42:53 * rbergeron nods
19:42:59 * rbergeron will ask around as well.
19:43:07 <gholms> mgoldmann: ^  ;)
19:43:09 <rbergeron> but hopefully some of the awesome folks here now can help out.
19:43:23 <mgoldmann> gholms: alright!
19:43:27 <gholms> Thanks!
19:43:29 <gholms> There's one other news-like thing you folks might be interested in:
19:43:50 <mgoldmann> you fixed my bugs?
19:43:52 <mgoldmann> :)
19:44:01 <gholms> Red Hat announced a IaaS initiative called CloudForms.
19:44:04 <gholms> https://www.redhat.com/solutions/cloud/cloudforms/
19:44:29 <mgoldmann> yep
19:44:33 <rbergeron> mmhmm
19:44:34 <gholms> It has a ridiculous number of independent moving parts, but it looks quite interesting and it ties a bunch of the things people here are working on together.
19:45:45 <rbergeron> Yup.
19:45:45 <gholms> Oh, one more thing:
19:46:21 <gholms> Eucalyptus finally announced the roadmap for their next major release:  http://open.eucalyptus.com/participate/roadmaps/eucalyptus_3.0
19:46:51 <gholms> obino: ^ (if you have something to say)
19:47:18 <obino> something
19:47:22 <obino> :)
19:47:25 <gholms> Thanks
19:47:26 <gholms> That should be it from me.
19:47:33 <mgoldmann> yy!
19:47:40 <mgoldmann> yay even :)
19:47:48 <rbergeron> awesome.
19:47:58 * rbergeron wonders if she missed out on some awesome swag at the eucalyptus booth. ;D
19:48:07 <gholms> There were shirts.
19:48:09 <rbergeron> alright.
19:48:12 <rbergeron> ohh.
19:48:17 <rbergeron> bummer.
19:48:27 <gholms> Shirts with 25 000 clouds on them.
19:48:31 <gholms> And you missed out.
19:48:38 <gholms> :'(
19:48:51 <obino> rbergeron: I'm sure gholms can arrange a shipment if you want :)
19:49:05 <rbergeron> obino: i'll be fine ;)
19:49:27 * rbergeron needs to arrange a shipment of dinner into her belly
19:49:38 <rbergeron> okay, folks. anyone else have anything they'd like to talk about?
19:49:57 * rbergeron looks around
19:50:21 <rbergeron> alrighty then.
19:50:23 * rbergeron waves
19:50:27 <rbergeron> see you folks next time :D
19:50:31 <rbergeron> #endmeeting