19:00:42 <rbergeron> #startmeeting Cloud SIG
19:00:42 <zodbot> Meeting started Fri May 13 19:00:42 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:42 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:47 <rbergeron> NEENER NEENER
19:00:52 <rbergeron> #meetingname Cloud SIG
19:00:52 <zodbot> The meeting name has been set to 'cloud_sig'
19:00:57 <rbergeron> #chair gholms|work
19:00:57 <zodbot> Current chairs: gholms|work rbergeron
19:00:57 <gholms|work> Crap, I spelled it wrong.
19:01:02 <rbergeron> #chair jforbes
19:01:02 <zodbot> Current chairs: gholms|work jforbes rbergeron
19:01:15 <rbergeron> Guys: I'm straddling two meetings (this and fudcon panama planning) so... I suck, sorry.
19:03:31 * quaid lurks
19:03:36 <gholms|work> Chirp, chirp
19:03:40 * ke4qqq shows up for once
19:03:42 * jgreguske waves
19:03:53 * kkeithley guess this is roll call
19:04:20 * jsmith lurks
19:05:12 <jforbes> rbergeron: multitalented
19:05:44 <rbergeron> yeah, sorry.
19:05:59 <rbergeron> okay, folks.
19:06:06 <rbergeron> Yeah, it's roll call.
19:06:14 * rbergeron smiles sheepishly
19:06:17 <quaid> so you said F16 features are due?
19:06:32 <rbergeron> quaid: i hope you're joking :)
19:06:34 <jforbes> present
19:06:37 <quaid> no, I mean ...
19:06:40 <rbergeron> a present? for me? :)
19:06:43 <jforbes> quaid: heh, we have a while for that tnakfully
19:06:46 <rbergeron> #topic EC2
19:07:03 <rbergeron> jforbes: please talk and be questioned by others
19:07:49 <jforbes> I tracked down the SELinux issue from last week, tweaked the kickstarts, and will get more koji images though (not a fast task)
19:08:37 <jforbes> provided things work as they should, I will be getting with dgilmore early next week to see about having rel-eng spin final images
19:08:58 <dgilmore> jforbes: :)
19:09:30 <dgilmore> jforbes: i shouldgive you the urls to use to use the same package set as the dvd and livescd get composed form
19:09:33 <jgreguske> \o/
19:09:45 <jforbes> dgilmore: that would be appreciated
19:10:54 <dgilmore> jforbes: --repo=http://infrastructure.fedoraproject.org/pub/fedora/linux/development/$VERSION/$BASEARCH/os/,http://kojipkgs.fedoraproject.org/mash/bleed/$BASEARCH/
19:11:28 <jforbes> dgilmore: thanks!
19:12:34 <jforbes> nothing else from this end
19:12:38 <rbergeron> cool.
19:12:45 <rbergeron> anyone have any other questions for jforbes :)
19:12:55 * rbergeron waits for the EBS question that always comes
19:13:13 <jforbes> EBS is in the conversion script
19:13:17 <rbergeron> ooh, not today.
19:13:24 <rbergeron> :D
19:13:34 * rbergeron hugs jforbes and moves onwards
19:13:44 <jgreguske> jforbes: when you build an image koji do you just run spin-livecd manually?
19:13:50 <rbergeron> oh, i'll wait
19:13:50 <jdarcy> Argh.  Sorry I'm late.
19:14:08 <jgreguske> jforbes: sorry I meant spin-appliance
19:14:10 <jforbes> jgreguske: spin-appliance, but yeah
19:14:39 <dgilmore> jgreguske: i have a script i use for livecds
19:14:48 <dgilmore> i should modify it a little for applicances
19:14:49 <jgreguske> jforbes: ok, I'm not far from getting a patch set proposed in upstream koji which will affect that synatx
19:15:10 <jforbes> jgreguske: okay, I will keep an eye out
19:15:39 <jgreguske> jforbes: I'll have more details next week. I just wanted to get a sense for how much the spin-* directory syntax was depended upon
19:15:50 <jgreguske> directive not directory
19:16:00 * jgreguske types faster than he thinks
19:16:27 * jforbes can adapt pretty easily, I dont have a bunch of code written around the koji command
19:16:49 <jgreguske> dgilmore: would that be a big deal for you? it'll certainly change after f15's release
19:17:22 * rbergeron wonders if someone would mind making action or infos if they're needed
19:17:26 <rbergeron> #chair quaid
19:17:26 <zodbot> Current chairs: gholms|work jforbes quaid rbergeron
19:17:42 <rbergeron> (perhaps quaid? :D)
19:18:01 <jgreguske> #info jgreguske working on koji patches to make image building a more complete feature. It will impact the image building commands.
19:18:17 <jgreguske> someone c+p that ;p
19:18:23 <jforbes> #info jgreguske working on koji patches to make image building a more complete feature. It will impact the image building commands.
19:18:30 <jgreguske> ty
19:18:34 * jgreguske returns to lurking
19:19:19 <gholms|work> Can't non-chairs use #info?
19:19:35 <jforbes> No clue
19:19:40 <jdarcy> #info Let's try it.
19:19:41 <dgilmore> gholms|work: no
19:19:41 <quaid> just chair the world!
19:19:54 <ke4qqq> gholms|work: they can #link iirc
19:20:07 <gholms|work> http://meetbot.debian.net/Manual.html  <-- doesn't say chairs only, FWIW
19:20:58 <rbergeron> I can chair everyone.
19:21:06 * rbergeron grins
19:21:09 * gholms|work throws a chair at rbergeron
19:21:37 <jforbes> It's Maury's cloud SIG!
19:21:54 <jforbes> Or was that Geraldo with the chair throwing"?
19:21:59 <jgreguske> Springer imo
19:22:16 <kkeithley> Balmer threw the chair
19:23:13 <gholms|work> [Meanwhile, back at the ranch...]
19:23:41 <rbergeron> developers, developers, developers!
19:23:46 <rbergeron> #topic CloudFS
19:23:50 <rbergeron> jdarcy: go
19:24:18 <jdarcy> We have a GUI!
19:24:25 <gholms|work> Does it work?
19:24:27 <jdarcy> http://cloudfs.org/2011/05/new-management-interface/
19:24:50 <gholms|work> Oh, a web UI.  Neato.
19:24:51 <jdarcy> gholms|work: Basically, yeah.  Well enough to do most useful things - and yes, there are CLI equivalents for everything.
19:25:07 <jdarcy> Kaleb should get practically all of the credit.  I just did some integration.
19:25:07 <gholms|work> This is a very good thing.
19:25:28 <kkeithley> integration and complete rewrite more like it
19:25:33 <jdarcy> It's the post-Summit sprint.  Now that that's wrapped up reasonably well, I'm going heads-down on the SSL transport.
19:25:56 <kkeithley> I'm not sure how much credit I really deserve, not much
19:25:57 <jdarcy> And that's pretty much it for me.
19:26:29 <rbergeron> that's making me feel all gooey inside. so proud. *sniff*
19:26:30 <rbergeron> :)
19:26:39 <rbergeron> thanks, guys. :)
19:26:45 <jdarcy> BTW, bottle.py *rocks*.
19:26:51 <kkeithley> and I've been writing the uidmap xlator, finding my way around the xlator APIs, got that working, been testing all the fops, a couple more days of work to do I'd say
19:27:18 <kkeithley> yeah, I was impressed with bottle.py
19:28:04 <jdarcy> Maybe by the end of the month we'll have something that's at least a cohesive and presentable whole, even if there's still plenty of work to be done.
19:28:12 <rbergeron> :)
19:30:22 <gholms|work> #info Working, though primitive web UI now exists
19:30:50 <rbergeron> Awesome.
19:30:53 <rbergeron> ....next up
19:30:57 <gholms|work> !
19:31:05 <gholms|work> #info Work on UID mapping and SSL transport continues
19:31:08 <gholms|work> There!
19:31:11 <rbergeron> okay ;)
19:31:14 <rbergeron> #topic Aeolus
19:31:19 <rbergeron> do we have a mmorsi or clalance?
19:33:57 <gholms|work> [Nothing happens.]
19:34:19 <rbergeron> ahh.
19:34:20 <rbergeron> yeah.
19:34:22 <quaid> does Justin Clift attend these meetings?
19:34:31 <rbergeron> quaid: no, but i think that's a fabulous idea.
19:34:38 <rbergeron> normally clalance or mmorsi have been.
19:35:08 <quaid> I think jclift has been doing his thing for just a short while, and the website facelift/fixes were probably first on the plate :0
19:35:15 * quaid could be wrong, tho'
19:35:45 <quaid> rbergeron: go ahead and invite him if you wish, I'll do the same separately
19:36:10 <quaid> #action quaid and rbergeron to invite jclift to Cloud SIG meetings
19:36:42 <rbergeron> sure.
19:36:53 <rbergeron> #topic Any other business?
19:37:23 <gholms|work> Any late-breaking news from the summit?
19:37:33 <ke4qqq> !
19:38:01 <gholms|work> ke4qqq: AFAIK you can just go ahead.  ;)
19:38:23 <ke4qqq> if there are any people in the cloud-sig that want to become packagers, please let me know. we have a dearth of them.
19:38:41 <ke4qqq> and I conned^H^H^H convinced others to let me be a packaging sponsor
19:38:47 * quaid does but has a dearth of time ... still, it's a skill he needs
19:38:59 <ke4qqq> in part by saying I wanted to sponsor people in the cloud sig
19:39:00 <quaid> ke4qqq: two things on that then ...
19:39:24 <quaid> ke4qqq: well, we may be getting sdziallas_afk to do some packaging of Red Hat Cloud stuff for Fedora
19:39:28 <quaid> and of course he knows how ...
19:39:31 <jdarcy> I don't exactly *want* to, but I sort of *need* to.
19:39:45 <ke4qqq> yeah he's already sponsored, so he doesn't need help.
19:39:58 <ke4qqq> jdarcy: you could always delegate :)
19:40:02 <quaid> but I really want him also to be teaching other RH cloud people how to package, spi, etc.
19:40:30 <quaid> ke4qqq: so perhaps he can work sort-of underneath you on the subset of RHCloud packages,and also do mentoring, teaching, how-to materials, etc.
19:40:30 <ke4qqq> spi?
19:40:37 <quaid> spin
19:40:53 <gholms|work> This guy working on Eucalyptus deps needs a sponsor.  :)  https://bugzilla.redhat.com/show_bug.cgi?id=700667
19:41:17 <ke4qqq> quaid: my plan for people who don't have existing packages they need to get in is to set them to work on aeololus packages and have them do unofficial reviews....so that would work well.
19:41:28 <quaid> +1
19:42:03 <quaid> ok, so Max and I had that idea for sdziallas_afk to do some packaging as part of his intern work this summer
19:42:14 <gholms|work> #help Packagers wanted; look for ke4qqq for sponsorship if needed
19:42:19 <quaid> so I'm not exactly volunteering him, I'm just recommending that he work with you, etc.
19:42:33 <ke4qqq> quaid: cool - shall we follow up via email and include sdz in the loop to see what we can work out?
19:42:44 <quaid> yep, mspevack too please
19:43:10 <quaid> #action ke4qqq quaid to follow up with sdziallas_afk about organizing cloud packaging mentoring for Cloud SIG folken cc: mspevack
19:43:22 <ke4qqq> quaid: ok, will do that later this afternoon.
19:43:26 <quaid> sweet
19:43:28 <ke4qqq> gholms|work: I'll follow up with him.
19:43:50 <ke4qqq> eof from me.
19:46:03 <rbergeron> thanks, ke4qqq, quaid :)
19:47:51 * rbergeron looks around
19:48:03 * quaid has to run
19:48:05 <gholms|work> [Everyone looks at rbergeron]
19:48:05 <rbergeron> Anything else?
19:48:14 <rbergeron> yeah, I'm the center of attention. It's my hair, really.
19:49:45 <rbergeron> alrighty.
19:49:52 <rbergeron> If there's nothing else, i'll end in about 87 seconds.
19:49:57 <gholms|work> Lies!
19:51:00 <rbergeron> #endmeeting