15:03:44 <jreznik> #startmeeting kde-sig -- https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2011-05-17
15:03:44 <zodbot> Meeting started Tue May 17 15:03:44 2011 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:53 <jreznik> #meetingname kde-sig
15:03:53 <zodbot> The meeting name has been set to 'kde-sig'
15:04:03 <jreznik> #topic roll call
15:04:10 <jreznik> who's present today?
15:04:20 * jreznik is obviously here :)
15:04:30 * ltinkl here
15:05:06 <Kevin_Kofler> Present.
15:06:30 * than present
15:07:34 <rdieter> here
15:08:06 * jsmith-busy lurks
15:08:06 <jreznik> #info jreznik ltinkl Kevin_Kofler than rdieter present
15:08:14 * rdieter hopes for short meeting, no agenda. :)
15:08:15 <jreznik> #info jsmith-busy lurks :)
15:08:28 <jreznik> rdieter is ahead :)
15:08:34 <jreznik> #topic Agenda
15:09:14 <rdieter> I suppose can include a quick kde-4.6.3 status report
15:11:08 <Kevin_Kofler> Yes please.
15:11:42 * rdieter can't think of anything else. ?
15:11:57 <Kevin_Kofler> FYI, the kde* stuff is golden for F15 (chances are all of F15 will be declared gold, even), so we can proceed with pushing 4.6.3 to F15 testing.
15:12:07 * rbergeron crosses fingers
15:12:17 <Kevin_Kofler> I'd like it to go out as 0 day.
15:12:31 <Kevin_Kofler> rdieter: Another possible discussion item is QtWebkit.
15:12:59 * rdieter hears yukon cornelius "gold!" in his head
15:13:04 <tdfischer> here but late
15:13:09 <jsmith-busy> rdieter: You too, eh?
15:13:11 <nucleo> 4.6.3 with oxygen-icon-theme 4.6.2?
15:13:18 <rdieter> tdfischer: hi!
15:13:21 <tdfischer> ahoy
15:13:26 <tdfischer> .fas tdfischer
15:13:27 <than> nucleo: yes
15:13:41 <rdieter> .fasinfo tdfischer
15:13:51 <rdieter> zodbot may be tired/slow today
15:13:53 <than> could you please add some update status about 4.6.3?
15:13:55 <tdfischer> must be
15:14:30 <zodbot> Announcement from my owner (jsmith): Public IRC meeting with the Fedora Board in approximately 45 minutes in #fedora-board-meeting
15:14:36 <rdieter> jreznik: I guess we can move on to 4.6.3 then
15:14:42 <Kevin_Kofler> Yes please.
15:14:52 <jreznik> #topic 4.6.3 status
15:15:10 <rdieter> k, kde-4.6.3 is queue'd for updates-testing, I think got pushed overnight too
15:15:37 <rdieter> notablely, we chose to omit oxygen-icon-theme, since it contained some notable regressions and work-in-progress icons
15:16:34 <rdieter> and, affecting f16+/kde-unstable, kde-l10n erroneously includes kdepim-runtime translations, which is still a TODO item for me to fix
15:16:44 <jreznik> #info kde-4.6.3 is queue'd for updates-testing, got pushed overnight
15:17:13 <jreznik> #info we omit oxygen-icon-theme as it contains regressions and work in progress
15:17:13 <rdieter> and thanks to autoqa doublechecking for me, I'm pretty sure I didn't include any broken deps this time.
15:17:28 <tibbs> Progress!
15:17:51 <rdieter> that's about it, any comments or questions?
15:17:55 <zodbot> tdfischer: tdfischer 'Trever Fischer' <wm161@wm161.net>
15:17:59 <zodbot> rdieter: User: tdfischer, Name: Trever Fischer, email: wm161@wm161.net, Creation: 2009-03-09, IRC Nick: tdfischer, Timezone: US/Eastern, Locale: en, Extension: 5126247, GPG key ID: 360E77FEC40F2998, Status: active
15:18:00 <tdfischer> \o/
15:18:03 <zodbot> rdieter: Approved Groups: @gitpython-skype fedorabugs packager @gitanchorman ambassadors cla_fedora cla_done
15:18:11 <than> rdieter: do we have bz-number?
15:18:14 <Kevin_Kofler> Do you want help for me blacklisting the kdepim-runtime translations from kde-l10n?
15:18:32 <Kevin_Kofler> Uhm, in better English: Do you want help from me with blacklisting the kdepim-runtime translations from kde-l10n?
15:18:34 <rdieter> Kevin_Kofler: would be appreciated, if you have nothing better to do. :)
15:18:35 <than> kde-l10n /kdepim* issue
15:18:55 <Kevin_Kofler> I can have a look.
15:19:03 <rdieter> than: only mentioned on kde-packager/kde-release-team lists, as far as I know
15:19:13 <rdieter> I did confirm the conflict is real
15:19:40 <Kevin_Kofler> It should be quite quick to blacklist stuff, there are already snippets to blacklist stuff in current and/or past specfile revisions.
15:19:44 <jreznik> #action Kevin_Kofler to take a look on kdepim-runtime translations blacklisting
15:21:18 <tdfischer> nothing else then, hmm?
15:21:52 <than> next topic please
15:21:55 <Kevin_Kofler> Well, looks like not; 4.6.3 looks good so far. :-)
15:22:05 <Kevin_Kofler> Next topic ++. :-)
15:22:39 <jreznik> #topic QtWebKit
15:23:10 <than> rdieter: is the docbook-style-xsl issue already fixed ?
15:23:11 <Kevin_Kofler> So, how's the packaging of the new standalone QtWebKit going?
15:23:14 <rdieter> than: no
15:23:18 <rdieter> .bug 651521
15:23:20 <zodbot> rdieter: Bug 651521 Review Request: qtwebkit - Qt WebKit bindings - https://bugzilla.redhat.com/show_bug.cgi?id=651521
15:23:33 <rdieter> than: tosky (upstream) is still working on it
15:24:42 <rdieter> wrt qtwebkit, thanks to some help from than, got a current 2.2 branch snapshot (slightly newer than tp1) built for kde-unstable
15:24:53 <rdieter> and pkg-review updated accordingly.
15:25:22 <rdieter> oops, looks like I didn't update pkg-review, will do so asap after meeting
15:25:28 <than> rdieter: does the qtwebkit-2.2 build correctly now?
15:25:48 <rdieter> than: yes, it was just a small typo in your patch to make it build on 4.6 too
15:26:05 <than> great!
15:26:10 <jreznik> rdieter: please update package review, I'll finish it
15:26:21 <rdieter> latest here, http://rdieter.fedorapeople.org/rpms/qtwebkit/
15:26:50 <jreznik> #info QtWebKit 2.2 branch snapshot builds now
15:26:59 <jreznik> #action rdieter to update package review
15:27:14 <rdieter> than: oh, and dropping -Werror compiler flag  :)
15:27:14 <jreznik> #action jreznik to finish package review
15:27:25 <than> rdieter: yes, i saw it
15:27:40 <Kevin_Kofler> -Werror is usually an error. ;-)
15:28:15 <than> rdieter: it won't build without disble -Werror compiler flag
15:28:27 <rdieter> tis true
15:29:59 <than> do we want to replace the qtwebkit in Qt in f16?
15:30:24 <rdieter> hopefully yes
15:30:26 <Kevin_Kofler> I want to do it even in F15 updates, possibly even F14. :-)
15:30:43 <Kevin_Kofler> There's a strong argument: QtWebKit is security-sensitive.
15:30:50 <than> Kevin_Kofler: yes, because of security issues
15:30:50 <Kevin_Kofler> So it'd be a rebase for security purposes.
15:31:25 <rdieter> tricky issue is how qtwebkit does media support.  It supports phonon, qt-mobility, gstreamer
15:31:29 <than> but we need to test it well before we do update for f14/f15
15:31:33 <jreznik> it's going to be much more easier to rebase...
15:31:59 <jreznik> #info qtwebkit media support is tricky: supports phonon, qt-mobility and gstreamer
15:32:01 * tdfischer mumbles something about phonon
15:32:27 <Kevin_Kofler> We need to find out which solution works best.
15:32:42 <Kevin_Kofler> QtWebKit upstream says Phonon has problems with QtWebKit.
15:32:49 <tdfischer> yup :/
15:32:50 <Kevin_Kofler> I know in particular that Phonon-xine doesn't work at all in QtWebKit.
15:32:54 <rdieter> some upstream dev's claim phonon support is essentially deprecated/unsupported
15:32:55 <tdfischer> phonon-xine is dead
15:33:03 <tdfischer> afaik, qt-mobility has the most promise because of it's support with qgraphicsview
15:33:03 <Kevin_Kofler> (but Phonon-GStreamer works at least to some extent and that's now the default)
15:33:04 <jreznik> #info we want standalone qtwebkit in previous releases too due security issues - easier to rebase to latest version
15:33:04 <rdieter> (qtwebkit upstream)
15:33:31 <rdieter> there seems to be code to support using gstreamer directly too, but I haven't figured out how to toggle that on yet
15:33:36 <tdfischer> yeah
15:33:48 <tdfischer> I'd advise against that if qtmm works
15:33:56 <rdieter> so, the pkg as submitted is currently using qt-mobility's qtmultimediakit
15:34:01 <Kevin_Kofler> Using GStreamer directly might also just mean using some bundled QtMultimedia(Kit) classes.
15:34:05 <tdfischer> one less semi-broken-maybe-working user of gstreamer
15:34:19 <Kevin_Kofler> I'd have to look at the code to see how it works, if at all.
15:34:20 <tdfischer> qtmm uses gstreamer anyways
15:34:31 <rdieter> tdfischer: good to know
15:34:33 <jreznik> is it qt-gstreamer or plain gstreamer?
15:34:38 <tdfischer> raw gstreamer
15:34:38 <rdieter> I wasn't entirely sure yet.
15:34:51 <Kevin_Kofler> Now the question is, do we want or need to split qt-mobility into subpackages?
15:34:52 <tdfischer> I'm not aware of anyone using qt-gstreamer yet
15:34:59 <Kevin_Kofler> tdfischer: Kamoso does.
15:35:09 <tdfischer> I'm now aware of one qt-gstreamer user
15:35:13 <Kevin_Kofler> :-)
15:35:32 <rdieter> given that qtwebkit could grow a new dep on qt-mobility, we may want to work on finer splitting of qt-mobility (heliocastro has repeatedly asked for that in the past, I just didn't get around to it)
15:35:54 <Kevin_Kofler> Right. It looks like QtWebKit wants the multimedia stuff and the location stuff.
15:36:04 <jreznik> rdieter: I can take a look at qt-mobility splitting
15:36:34 <tdfischer> it might make sense to poke thiago for his opinion on that
15:36:43 <rdieter> that said, I'm not sure it's entirely worth it.  qt-mobility isn't exactly big altogether, but I can see the use-case of small form-factors wanting to be as slim as possible
15:36:50 <jreznik> #info QtWebKit depends on Qt Mobility Multimedia and Location API, we will have to split it
15:37:02 <Kevin_Kofler> Speaking of splitting, I'd like to propose splitting a kdelibs-x11 from kdelibs. Right now, we can use QtCore apps without GUI deps, but not kdecore apps.
15:37:14 <jreznik> rdieter: it can drag more stuff - like we do not build it now with qmf etc.
15:37:24 <rdieter> Kevin_Kofler: are there any kdecore-only apps?
15:37:39 <Kevin_Kofler> And kdecore has nice things like command-line parsing. I know I've written a couple kdecore apps. :-)
15:37:39 <rdieter> I mean if there aren't any, then doing so would be not very fruitful
15:38:14 <rdieter> otherwise, I don't have a problem with it, esp if someone else is doing the work. :)
15:38:15 <Kevin_Kofler> It's a bit of a chicken&egg problem, distros don't split kdecore because there are no kdecore-only apps, and there are no kdecore-only apps because distros don't split kdecore…
15:38:44 <rdieter> Kevin_Kofler: go for it
15:38:55 <Kevin_Kofler> There are some things to sort out though, like where to put libkio.
15:38:57 <tdfischer> +1
15:38:59 <rdieter> as long as the main kdelibs Requires: it
15:39:05 <Kevin_Kofler> (I guess it can go to the core.)
15:39:23 <jreznik> +1
15:39:28 <Kevin_Kofler> rdieter: Well, I was thinking of doing it like we did for Qt, with kdelibs-x11 for the GUI stuff and kdelibs for core stuff only.
15:39:44 <Kevin_Kofler> GUI apps are going to drag in kdelibs-x11 through the libkdeui.so.5 dep.
15:39:52 <rdieter> Kevin_Kofler: ok
15:40:06 <rdieter> though may be worth looking into how other distros do it, for reference
15:40:19 <Kevin_Kofler> -devel would still drag in everything for now, like for Qt.
15:40:48 <Kevin_Kofler> (Some people may want splitting -devel too, but I'm not one who loves splitting everything.)
15:40:59 <rdieter> let's stick with runtime splitting only for now
15:41:25 <rdieter> developers have big disks (or should!). :)
15:41:44 <jreznik> #action Kevin_Kofler to split kdelibs-x11 from kdelibs (in the same way as Qt), -devel is going to stay untouched
15:41:45 * tdfischer giggles
15:42:39 <jreznik> so what about qt-mobility?
15:42:51 <rdieter> jreznik: up to you how to do it
15:43:02 <jreznik> ok
15:43:16 <jreznik> that leads me back to qt-qmf vs meego-qmf
15:43:24 <jreznik> task #1 :)
15:43:47 <rdieter> jreznik: for reference, here's helio's qt-mobility.spec http://fpaste.org/keBG/  (in mdv style)
15:43:54 <jreznik> I think we should have meego-qmf that provides qt-qmf, if they merge - we will continue with qt-qmf
15:43:59 <jreznik> rdieter: thanks
15:44:03 <rdieter> jreznik: sounds good to me
15:45:02 <jreznik> ok, I'll try it tmrw and I'll try to catch original packager who sent review
15:46:43 <Kevin_Kofler> Shouldn't we have qt-qmf with the official upstream qt-qmf and a separate meego-qmf with the stuff MeeGo added and with a Requires: qt-qmf (if it's not dragged in by sonames anyway)?
15:47:02 <Kevin_Kofler> Or are they bundling the additions into a big monolithic so?
15:47:25 <jreznik> Kevin_Kofler: looks like qt-qmf is subset of meego-qmf - so everything from qt-qmf is included there
15:47:28 <Kevin_Kofler> (Presumably, even that could be hacked around, but ugh…)
15:47:38 <Kevin_Kofler> But qt-qmf is probably newer…
15:47:45 <jreznik> two weeks
15:48:05 <jreznik> so it's not a big deal probably and if yes, we can backport
15:48:22 <jreznik> and probably we are going to have more meego-qmf consumers than just qt-qmf
15:48:45 <jreznik> I'll try to build qt mobility with both - if it will work, then meego-qmf is ok otherwise we need both
15:48:47 <rdieter> right, this is more driven by it's consumers
15:49:21 <jreznik> but it looks like it's monolithic, so... (first look into the code)
15:49:40 <rdieter> tdfischer: you should issue a f15 anchorman update too, btw
15:50:11 <jreznik> #action jreznik to take a look how to package qt/meego-qmf properly
15:50:29 <tdfischer> rdieter: yea
15:50:40 <tdfischer> I need a f15 install to play with though first
15:50:54 <rdieter> bah, it builds! ship it!
15:51:04 <tdfischer> no, this isn't phonon
15:51:05 <tdfischer> er
15:51:07 <tdfischer> wait
15:51:23 <rdieter> tee hee
15:53:07 <rdieter> let's wrap things up if possible, jreznik and I have an irc board meeting afterward
15:53:41 <jreznik> ok, anything else to discuss today?
15:53:52 <ltinkl> 1 thing :)
15:54:26 <Kevin_Kofler> ltinkl: Go ahead. :-)
15:54:32 <ltinkl> I just noticed that the nm09 branch of plasma-nm got an initial port to NM 0:9: https://projects.kde.org/projects/extragear/base/networkmanagement/repository/revisions/d9e214ce17ed2316dd2f5ceaaf282b9fd3430555
15:54:52 <tdfischer> will qt-mobility 1.2 be packaged for 15/14?
15:54:54 * rdieter noticed too
15:54:57 <rdieter> tdfischer: yes
15:54:59 <Kevin_Kofler> ltinkl: It's nice to see it getting some work.
15:55:03 <tdfischer> excellent
15:55:05 <jreznik> tdfischer: it's in updates-testing right now
15:55:09 <ltinkl> so there's hope we'll be able to ship a more recent (non compat) snapshot later as an update
15:55:13 <Kevin_Kofler> But currently it only works for showing info and not for any write things.
15:55:22 <tdfischer> that makes my gsoc project oodles easier I think
15:55:25 <jreznik> ltinkl: could you take a look how to port your secret agent to this branch?
15:55:27 <Kevin_Kofler> Yes, hopefully we can get this mess sorted out quickly.
15:55:29 <jreznik> it's still mossing
15:55:33 <jreznik> missing
15:55:47 <ltinkl> jreznik: yup, I'm currently compiling/installing the new stuff
15:56:02 <jreznik> #info there's initial port of plasma-nm to NM 0.9
15:56:16 <jreznik> ltinkl: ok, looks like it's the last missing part
15:56:18 <ltinkl> good thing is that all the stuff from kdebase-workspace got moved back into plasma-nm
15:56:34 <Kevin_Kofler> Oh, SOME write things seem working now even: "I am able
15:56:34 <Kevin_Kofler> to connect to my WPA wifi connection so I think it mostly works"
15:56:36 <jreznik> sad it's too late for os
15:56:38 <ltinkl> so there's no ABI issues, we don't have to wait for KDE 4.7
15:57:07 <ltinkl> Kevin_Kofler: yup, it's "supposed" to work, we'll see ;)
15:57:12 <Kevin_Kofler> Well, we should address this somehow:
15:57:13 <Kevin_Kofler> 4. User connections are ignored, so you will have to recreate them all
15:57:13 <Kevin_Kofler> from scratch. If you prefer you can convert them to system connection
15:57:13 <Kevin_Kofler> using Plasma NM for NM-0.8 before installing this version.
15:57:32 <Kevin_Kofler> NM-gnome converts the user connections to system connections, we need this to do the same.
15:57:47 <Kevin_Kofler> (system connections with user permissions only, of course)
15:58:01 <Kevin_Kofler> (You still have to explicitly share them if that's what you want.)
15:58:45 <jreznik> ok, migration is of course another issue
15:58:46 <Kevin_Kofler> Especially because the workaround doesn't work on F15 since you can't use system connections with the NM 0.8 interface there.
15:59:56 <rdieter> tdfischer: anything else that makes your life easier, just let us know. :)
16:00:15 <jreznik> ok, let's wrapt it, we have to move :)
16:00:19 <jreznik> #endmeeting