15:00:58 <spot> #startmeeting Fedora Packaging Committee
15:00:58 <zodbot> Meeting started Wed May 18 15:00:58 2011 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:04 <spot> #topic Roll Call
15:01:19 <tibbs|h> Howdy.
15:01:27 <geppetto> hey
15:02:08 * abadger1999 here
15:02:47 <spot> fpc ping: limburgher, rdieter, SmootherFrOgZ
15:03:15 * limburgher here, distracted, sorry.
15:05:21 <spot> well, we have a light agenda this week, so its not the end of the world that we don't have quorum
15:05:33 <spot> i will wait for a bit
15:07:01 <tibbs|h> I haven't been able to do anything Fedora-related this week anyway.
15:07:44 * SmootherFrOgZ here
15:11:21 <abadger1999> spot: okay, that's 6
15:13:28 <spot> since tibbs says he hasn't had time to do anything this week
15:13:41 <spot> and i'm still talking with perl folks
15:13:47 <spot> there are no pending items on the agenda
15:13:52 <spot> #topic Open Floor
15:14:25 <tibbs|h> Ouch.
15:14:42 <tibbs|h> The semester has now actually ended, so hopefully I'll have more free time.
15:15:38 <tibbs|h> There was the mingw thing.
15:15:53 <tibbs|h> It turns out that when I wrote the draft, I took the spec that was linked in our existing guidelines.
15:15:58 <tibbs|h> But that spec was terribly outdated.
15:16:17 <spot> yeah, i think the change modernizing that spec is a no-brainer
15:16:21 <abadger1999> Does the new spec still match the guidelines?  If so, +1 to updating
15:16:36 <spot> i had planned to simply apply that change
15:17:03 <tibbs|h> I did run a quick pass over all of the guidelines to take out %defattr.
15:19:32 <tibbs|h> That's all I have.
15:20:24 <spot> i have nothing...
15:20:32 <limburgher> nada.
15:20:45 <abadger1999> I have one: https://fedorahosted.org/fpc/ticket/84
15:20:58 * abadger1999 justwrote that up as requested from last meeting
15:21:02 <spot> oh, how did i miss that...
15:21:46 <spot> hmm, did we decide that EPEL guidelines were up to the EPEL folks?
15:21:51 <limburgher> Time machine broken?
15:21:55 <abadger1999> spot: I wrote that up just now.
15:22:02 <spot> abadger1999: that would be why. :)
15:22:05 <abadger1999> :-)
15:22:36 <tibbs|h> Yeah, the EPEL stuff might be better offloaded to an EPEL document with a note in the main guidelines that doesn't mention specifics.
15:22:58 <tibbs|h> That way EPEL gets to make its own policy without having to go through us.
15:23:00 <limburgher> Sort of a "yo, this is different in EPEL, go check that if applicable"
15:23:06 <spot> tibbs|h: *nod* that was my understanding
15:24:17 <spot> abadger1999: so, i think this one needs to go to EPEL
15:24:50 <spot> abadger1999: and if they are okay with it, you can go ahead and add a note pointing to the relevant section in the EPEL guidelines
15:25:07 <abadger1999> https://fedorahosted.org/fpc/ticket/84#comment:1
15:25:19 <tibbs|h> +1 to that.
15:25:25 <spot> +1
15:25:32 <abadger1999> +1
15:25:46 <limburgher> +1
15:26:32 <SmootherFrOgZ> +1
15:27:02 <geppetto> +1
15:27:24 <spot> #action EPEL note approved, meat to go to EPEL for consideration (+1:6, 0:0, -1:0)
15:27:52 <spot> So, perhaps we can talk about the perl ticket a bit
15:27:59 <spot> since i have some feedback from upstream now
15:28:27 <spot> #topic Perl paths @inc change - https://fedorahosted.org/fpc/ticket/73
15:28:59 <spot> The feedback from some perl committers has been basically that it is a no-op change
15:29:38 <spot> They're not quite sure why we would make the change, to be honest.
15:29:58 <spot> But so far, no one has been opposed to it
15:30:23 <tibbs|h> I don't think we're sure why we would make that change, either.
15:30:23 <limburgher> If it's no-op, why bother?  That implied no harm, but also no benefit.
15:30:38 <limburgher> Sell me the benfit.
15:30:43 <tibbs|h> There's nothing in the ticket that gives any kind of reasoning.
15:30:52 <spot> mmaslano thinks that having vendorlib and vendorarch as a separate directory is a benefit
15:31:09 <limburgher> tibbs|h: If you overlook "I'd like to"
15:31:17 <tibbs|h> But I'd expect that if so, someone would be able to articulate the benefit.
15:31:25 <limburgher> spot:  Right. Because. . . . . . .
15:31:26 <spot> it seems to me that is only true if you are worried about a third party package conflicting
15:31:43 <spot> and even then, i would think separating out the directory makes the problem... bigger
15:31:58 <tibbs|h> Is it possible there's some RHEL-related reason?
15:32:06 <tibbs|h> I got that impression from some other discussion.
15:32:17 <spot> tibbs|h: maybe. i'd like for those folks to be up front about that if so
15:32:27 <tibbs|h> Sure.
15:32:35 <spot> let me try to talk to people inside Red Hat and see if i can get more rationale
15:32:40 <spot> and we'll revisit this item
15:32:41 <tibbs|h> I wouldn't particularly have a problem with that, but maybe it can't be discussed in public for some reason.
15:32:47 <limburgher> spot:  They should be up front about the reasoning, period, RHEL or no.
15:33:06 <spot> i can't fathom how there would be any need for privacy here, but i guess i'll find out when i ask
15:33:18 <limburgher> tibbs|h:  Maybe a gag order from George Soros and the Reptilians?
15:33:32 * limburgher thinks:  good band name
15:33:37 <spot> that guy needs to stop calling me. he creeps me out with his forked tongue.
15:33:46 <tibbs|h> Ugh, I have a logged private discussion with some info but since it was in a /query I don't want to just dump it here.
15:33:53 <limburgher> spot: explains the lithp, though.
15:34:07 <spot> tibbs|h: if you are comfortable emailing it to me...
15:35:02 <geppetto> tibbs|h: Does it make sense?
15:35:28 <geppetto> tibbs|h: Or worded better … does it convince you of a benefit?
15:35:38 <tibbs|h> No.
15:36:05 <tibbs|h> Screw it.  All it really says is that people have asked for it.
15:36:17 <spot> okay, well, let me dig around and see what i can find out
15:36:25 <spot> if there is a reason for RHEL, we'll consider it fairly.
15:36:32 <limburgher> People have asked for patent-encumbered codec and unicorns, as well.
15:36:54 <geppetto> And those don't require rebuilding 666 packages :)
15:37:30 <spot> okay. back to open floor. :)
15:37:33 <spot> #topic Open Floor
15:38:28 <spot> If there is nothing by, oh, 1540 UTC, I'll close it out
15:38:40 <tibbs|h> Did the systemd stuff get written up?
15:38:54 <spot> except for last week's revisions, yes
15:39:06 <tibbs|h> I was looking for it but my ability to search the wiki is so poor for some reason.
15:39:09 <spot> i had intended to write it up sooner, but well, it will happen today
15:39:20 <tibbs|h> Are they linked off of the main guidelines page at all?
15:39:20 <spot> f-15 kindof took priority
15:39:28 * abadger1999 notes that some  systemd unit file containing packages don't conform.
15:39:29 <limburgher> spot: Oh, that.
15:39:45 <abadger1999> For instance, the rsyslog package that people were talking about (and Lennart made the patch for)
15:40:02 <spot> abadger1999: file bugs, i guess.
15:40:03 <tibbs|h> abadger1999: Well, judging from the number of problems that are cropping up, either we screwed up badly or people aren't following the guidelines.
15:40:18 <abadger1999> Can I fix them as a provenpackager?
15:40:26 <tibbs|h> Definitely.
15:40:34 <spot> i suppose so.
15:40:42 <tibbs|h> There was some abrt thing as well that broke the composes.
15:41:00 <tibbs|h> I'm concerned that people just aren't finding the guidelines for this.
15:41:02 <abadger1999> The reason I ask is some of it is the enable or don't enable if runlevel 3 thing.
15:41:16 <tibbs|h> Since I can't find them myself.
15:41:49 <tibbs|h> Oh, they're at the end of scriptletsnippets.
15:42:18 <spot> and https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
15:42:32 <spot> (which needs to be linked from the main page, yes)
15:42:49 <tibbs|h> And of course I was looking for Packaging:System{D,d}
15:43:02 <tibbs|h> Why the extra "Guidelines:" there?
15:43:04 <spot> I should move it to Packaging:Systemd
15:43:07 <spot> i don't know
15:43:07 <abadger1999> Also... rsyslog was converted for F15.
15:43:09 <spot> i'm moving it now
15:43:16 * abadger1999 sighs at the mess
15:43:44 <tibbs|h> Nobody should be surprised at the mess.
15:44:12 <tibbs|h> It's basically the cost of doing business when people can basically do what they want.
15:44:15 * abadger1999 not surprised just.... unhappy.
15:45:00 <tibbs|h> Some folks went off and did whatever instead of trying to follow the guidelines we put together.
15:47:43 <spot> okay, well, on that note, i think we're done for today
15:47:46 <spot> thanks everyone
15:47:58 <spot> #endmeeting