05:02:10 <tagoh> #startmeeting i18n
05:02:10 <zodbot> Meeting started Thu Jun  9 05:02:10 2011 UTC.  The chair is tagoh. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:02:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
05:02:13 <tagoh> #meetingname i18n
05:02:13 <zodbot> The meeting name has been set to 'i18n'
05:02:19 <juhp> hi
05:02:21 <tagoh> #topic agenda and roll call
05:02:30 <tagoh> https://fedoraproject.org/wiki/I18N/Meetings/2011-06-09
05:02:46 <tagoh> hi guys. time for i18n meeting.
05:03:23 <dueno> hi
05:03:24 <epico_laptop> hi
05:04:05 <paragan> hi
05:04:20 <pravins> hi
05:04:31 <fujiwarat> hi
05:05:21 <tagoh> okay, shall we start then
05:05:24 <tagoh> #topic F16
05:06:19 <tagoh> juhp: any updates for feature draft?
05:06:44 <juhp> ah sorry not yet... :(
05:06:54 <tagoh> okay
05:07:11 <juhp> let me try to post something soon to i18n list
05:07:23 <juhp> hmm time flies
05:07:28 <tagoh> ok, good
05:08:54 <dchen> hi
05:08:57 <tagoh> anything for f16 so far?
05:10:12 <tagoh> many bugs is being reported against rawhide. that would be nice to have any plans to get them fixed in f16. so good to have a little time to triage them once.
05:11:01 <tagoh> other than having a look at the eol time ;)
05:12:30 <tagoh> okay, shall we move on if no particular discussion about f16?
05:13:33 <juhp> any particular rawhide bugs standing out?
05:15:16 <tagoh> no particular I can bring up here so far, but there are some older bugs keeping open there.
05:16:16 <tagoh> once we've dealt with f13 bugs. will have some time to go through them though.
05:17:34 <tagoh> anyway, just fyi
05:17:41 <juhp> okay
05:17:55 <tagoh> #topic bugzilla house keeping
05:19:23 <tagoh> finally only 6 bugs keeps staying at f13 now. which was reported via abrt.
05:21:11 <juhp> epico_laptop, how about the ibus-pinyin abrt's?
05:21:35 <epico_laptop> can't re-produce it.
05:21:52 <tagoh> any clue from backtrace say?
05:22:04 <juhp> right hm
05:22:06 <epico_laptop> tagoh: no clue.
05:22:09 <epico_laptop> sorry
05:22:31 <juhp> maybe we could just close them insufficient_data?
05:22:47 <epico_laptop> juhp: ok.  will close it.
05:22:53 <tagoh> no similar report on f14, f15 or rawhide?
05:23:16 <epico_laptop> tagoh: report from f15 is closed, no  report from f14.
05:23:22 <tagoh> aha. ok
05:23:44 <epico_laptop> clost the two?
05:24:42 <juhp> if we can't do anything about maybe then better just to close to clean up
05:24:50 <juhp> then maybe
05:25:08 <juhp> them, even
05:25:51 * tagoh needs a real solution to avoid changing components accidentally
05:25:53 <tagoh> sigh
05:26:16 <juhp> ah chromium back?
05:26:26 <tagoh> is it a chrome specific?
05:26:34 <juhp> webkit I think
05:26:50 <tagoh> aha
05:27:00 <juhp> there is an upstream open for it (still?) I think
05:27:09 <juhp> very annoying yes...
05:27:18 <tagoh> I see
05:28:23 <tagoh> need some actions for stardict as well
05:29:12 <tagoh> tried to see them yesterday though, it works for me
05:31:26 <tagoh> okay, better move on
05:31:36 <tagoh> #topic Package Updates
05:32:37 <tagoh> anything?
05:33:31 <pravins> i build lohit assamese bengali and kannada with .conf update
05:33:44 <pravins> not pushed in bodhi
05:33:55 <pravins> since looks like its better to fix that issues from QT itself
05:34:01 <tagoh> right
05:34:22 <tagoh> maybe good to revert the change?
05:35:12 <pravins> yeah
05:35:14 <tagoh> so far at least.
05:35:16 <pravins> will do that
05:35:20 <tagoh> cool
05:35:22 <pravins> thanks tagoh
05:37:50 <tagoh> may need some testers for ibus perhaps?
05:38:00 <juhp> aha
05:38:09 <tagoh> https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-2.fc15
05:39:42 <fujiwarat> yes
05:40:29 <tagoh> ok
05:40:29 * epico_laptop will help on Chinese test.
05:41:16 <tagoh> anything else? otherwise let's move on to next topic then
05:42:42 <tagoh> #topic Input Methods
05:43:37 <tagoh> just reminds me we suspended a discussion about bug 452938 due to the time limitation though, need more discuss on it?
05:43:52 <tagoh> .bug 452938
05:43:54 <zodbot> tagoh: Bug 452938 gtk should handle missing multilib immodules more gracefully - https://bugzilla.redhat.com/show_bug.cgi?id=452938
05:44:52 <juhp> yeah
05:45:13 <juhp> actually I realised the problem seems to go beyond immodules even
05:45:42 <tagoh> right
05:45:43 <juhp> as in gtk can also have multilib problems with theme engines etc
05:46:03 <juhp> actually happens with XFCE which sets GTK_PATH by default...
05:46:17 <tagoh> so good to escalate it to yum then?
05:47:08 <juhp> well as xfce upstream also maintained gtk should really be a bit smarter than just loading modules for another arch regardless
05:47:20 <juhp> maintained->mentioned
05:47:53 <tagoh> aha
05:48:12 <juhp> but ok themes is somewhat different - since it is so much a fallback issue
05:48:53 <juhp> erm well - it is kind of same perhaps - fallback theme is about as simple as gtkinputcontextsimple
05:49:36 <juhp> not completely sure how to proceed though
05:49:46 <juhp> some options:
05:50:06 <juhp> - try to discuss upstream or with the gnome desktop team
05:50:46 <juhp> - well tagoh already posted a possible patch
05:50:56 <tagoh> wonder if other distros has same issue?
05:50:58 <juhp> - yum hacks?
05:51:11 <juhp> good question
05:52:27 <juhp> I suspect noone has patched gtk though
05:52:44 <juhp> and ubuntu defaults to xim?
05:53:45 <tagoh> debian-based system takes different way for multilib. not like fedora does.
05:53:49 <juhp> perhaps some hack could be added to yum-langpacks to slurp in missing multilib immodules
05:54:07 <juhp> yeah but with xim it doesn't really matter here :)
05:54:36 <tagoh> and it depends on packaging.
05:54:58 <juhp> ok
05:55:23 <tagoh> it won't appears at all if library and immodules are in the same package
05:58:00 <tagoh> so what action should we take for next step?
06:00:27 <tagoh> apparently no one upstream is interested in this issue according to a bug activity so it may be hard to see some progress even if we file a bug to improve handling of modules
06:00:42 <tagoh> if we have some suggestions for that
06:00:49 <tagoh> ^don't
06:03:01 <tagoh> maybe good to approach yum first and gtk in some cases then?
06:03:45 <tagoh> or any idea?
06:04:26 <juhp> then perhaps yum-langpacks is the most realistic short term solution
06:04:47 <juhp> though disappointing that upstream doesn't take the multilib issue seriously
06:04:55 <juhp> hm
06:05:09 <tagoh> aha. how to deal with it on yum-langpacks?
06:06:53 <juhp> well sure if it is feasible
06:06:57 <juhp> but might work
06:07:31 <juhp> also probably gtk or immodule would have to be in the transaction
06:07:40 <juhp> not sure
06:08:23 <tagoh> hm, ok. as you said it might be likely happening on other modules, sounds a bit hack to do it in yum-langpacks since all the modules isn't necessarily related to i18n.
06:08:31 <juhp> I still think 32bit apps even attempting to load 64bit modules is a bit insane though
06:08:41 <juhp> right
06:09:18 <juhp> your fallback patch approach seems like the cleanest way to solve the im issue anyway
06:09:28 <juhp> i posted a comment in the bug now btw
06:09:57 <tagoh> hm, ok. let's see how they want to do on this issue then.
06:10:03 <tagoh> thanks
06:10:16 <tagoh> better move on
06:10:21 <tagoh> #topic Fonts and Rendering
06:10:24 <juhp> fujiwarat expressed back compat concerns - though I don't really that as serious - immodules don't contain ':'s in their names anyway
06:10:42 <tagoh> ok
06:11:00 <juhp> (ah I see - guess problem is running fallback list on older gtk
06:11:01 <juhp> )
06:11:08 <juhp> hm
06:11:21 <fujiwarat> I think it's a problem.
06:11:25 <tagoh> not too much time to keep meeting open. so please update quickly if there are anything on fonts and rendering. sorry ;)
06:11:30 <juhp> but hopefully that should not happen
06:12:01 <juhp> fujiwarat, I guess it will fallback to contextsimple immodule then ;) :)
06:12:29 <juhp> I wanted to discuss about PANGO_LANGUAGE config tool but maybe we could do it next week?
06:12:29 <tagoh> juhp, fujiwarat: we could update bug if any concerns. let's leave it to upstream/gtk maintainer then
06:12:53 <tagoh> juhp: sure. let's add it as a topic in next agenda then.
06:12:58 <juhp> cool
06:13:50 <juhp> wonder if we could add it to desktop font config as an advanced option perhaps, hmmmm
06:13:52 <tagoh> #action tagoh to add a topic about PANGO_LANGUAGE config tool in next agenda
06:14:00 <juhp> thanks
06:14:17 <tagoh> pravins: anything for fonts?
06:14:35 <tagoh> if not particular, let's close the meeting shortly
06:16:12 <pravins> tagoh: nothing much, i have started working on Lohit Telugu
06:16:19 <tagoh> ok
06:16:50 <tagoh> okay, thanks everyone for the meeting!
06:17:08 <pravins> thanks
06:17:16 <tagoh> #endmeeting