21:04:07 <rbergeron> #startmeeting Fedora Bugzappers
21:04:07 <zodbot> Meeting started Tue Jul  5 21:04:07 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:04:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:04:16 <adamw> yo
21:04:16 <rbergeron> #meetingname Bugzappers
21:04:16 <zodbot> The meeting name has been set to 'bugzappers'
21:04:18 <rbergeron> YO!
21:04:20 <rbergeron> #chairadamw
21:04:22 <rbergeron> oh, fail
21:04:24 <rbergeron> #chair adamw
21:04:24 <zodbot> Current chairs: adamw rbergeron
21:04:35 <rbergeron> #topic Well, Hello there.
21:04:48 * adamw is absolutely not on his n900 on the way to the golf course
21:05:00 * rbergeron is absolutely somewhat jealous
21:05:14 <rbergeron> of your non-transport to the golf course
21:05:25 * nirik is lurking around in the background
21:05:26 <adamw> hehe
21:06:33 * rbergeron waves at nirik
21:06:35 <rbergeron> So.
21:06:45 <rbergeron> I guess we'll talk shop for a bit.
21:06:53 <rbergeron> #topic Bugzapping to-do's
21:07:36 <rbergeron> #link https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora16
21:07:41 <rbergeron> I started updating this page a bit.
21:07:56 <rbergeron> I need to pull the tracker bugs out of bugzilla and plop them in here. (thanks, adamw, for that.)
21:08:25 <rbergeron> Adamw has also suggested maybe having a separate bugzapper schedule, which I'm not opposed to, but would love having more feedback on.
21:08:29 <rbergeron> ;)
21:08:52 <adamw> mainly the key is to make sure all the housekeeping tasks are documented together
21:09:01 <adamw> and in one schedule or another
21:09:02 * rbergeron nods
21:09:12 <adamw> which schedule isn't terribly important
21:09:27 * nirik also nods.
21:09:31 <rbergeron> So, one thing we can do is have them in a separate schedule, and then also have them in a joint bz+qa schedule (and then also have a separate qa schedule)
21:09:31 <adamw> does anyone know of any tasks which aren't documented at all?
21:09:51 <rbergeron> Having them together in a joint one really helps as far as sanity checking, etc.
21:09:55 <adamw> sure, that'd work
21:10:01 <rbergeron> okay.
21:10:14 <rbergeron> #action rbergero to make a bugzappin' schedule.
21:10:23 <rbergeron> I don't know of any offhand.
21:10:44 <adamw> so then the biggest thing is to unify them
21:10:57 <adamw> and maybe make the docs more SOP-y
21:11:43 * rbergeron nods
21:12:17 <rbergeron> Do we want to keep what we have, and then ADD sop's? Or see where we can replace/simplify?
21:12:39 <adamw> edit/rename
21:12:44 <nirik> there seems like a fair bit of cruft on that page.
21:12:45 <adamw> is what i was thinking
21:12:49 <adamw> and combine
21:13:13 <adamw> one sop per task, linked to the schedule, properly categorized
21:13:32 * rbergeron nods
21:13:49 <rbergeron> okay
21:14:04 <rbergeron> with individual SOPs for each item, I assume
21:14:40 <adamw> item?
21:14:45 <rbergeron> well.
21:14:49 <rbergeron> Each task on the schedule
21:14:51 <rbergeron> each line item
21:14:58 <rbergeron> Sorry - was thinking ahead in my brain.
21:15:10 <adamw> one sop should be enough for the whole blocker bug crwation task, for eg, it shouldn't need one per bug
21:15:15 <rbergeron> I guess that's what you meant by one sop per task
21:15:16 <rbergeron> Right.
21:15:19 <adamw> but one sop per item on the schedule, sure
21:15:21 * rbergeron agrees
21:15:33 <adamw> ok
21:15:51 <rbergeron> Are there *any* existing SOPs arround any of the tasks that we know of, other than basic instructions on the Housekeeping/Version page?
21:16:31 <adamw> afaik all there is is the stuff i linked to on list originally
21:16:40 * rbergeron nods
21:16:45 <rbergeron> Okay.
21:17:23 <rbergeron> So, let's do this: I'll make the schedule. I'll leave the column open where we'll link the SOPs, and maybe write the first one or two.
21:17:33 <rbergeron> So that people get an idea of "Ohh, this is how it coudl be useful."
21:17:51 <rbergeron> And then see if other folks are interested, and if not, I can pick some of the remanining items up.
21:18:05 <adamw> i can do some too
21:18:06 <rbergeron> It helps to at least have people about to sanity-check things, though.
21:18:22 <rbergeron> :D
21:18:23 <adamw> sure
21:18:26 <rbergeron> Because I'm so sane.
21:18:32 * rbergeron clears her throat
21:19:07 * fenrus02 >_>
21:19:12 <rbergeron> hi fenrus02 :)
21:19:25 <fenrus02> hi!  I think i walked in at an odd moment there :)
21:19:49 <rbergeron> #action rbergeron to make schedule with spots for SOPs/process info, share with list in hopes of getting some participation / help on SOPs.
21:20:12 <adamw> yay, a plan
21:20:18 <rbergeron> And then as far as cutting some of the cruft that exists - I think that's just going to be a matter of working through it.
21:20:25 <fenrus02> the intro link has a bunch of packages that may/may not need triagers.  any possibility of updating that list?  or was that already discussed?
21:20:25 <rbergeron> Perhaps a little sprint at the next meeting could be a good idea.
21:20:54 <rbergeron> fenrus02: /me looks
21:20:57 <adamw> the package list is basically critpath list
21:21:11 <adamw> the list of triagers...hard to tell how accurate it is
21:21:15 <rbergeron> fenrus02: we just got started - we were just discussion creation of schedule.
21:21:30 <adamw> we don't really have much in the way of techniques to track zapper activity
21:21:32 <rbergeron> is there anything that isn't on critpath list on that page that should be there?
21:22:05 <thedonvaughn> I noticed upstart is on critpath.  shouldn't systemd be there now?
21:22:13 <thedonvaughn> I'm new.  might be a dumb question
21:22:17 <fenrus02> good call
21:22:44 <adamw> nope, you're right
21:22:50 <adamw> the list isn't dynamic
21:23:02 <adamw> so if it doesn't get manually updated it goes stale
21:23:05 * nirik is reminded of a critpath issue.
21:23:23 <rbergeron> is there another list elsewhere on the wiki of critical path stuff that is dynamic?
21:23:25 <nirik> adamw: it should be dynamic? or you mean on the page?
21:23:29 <rbergeron> or is this *the list* ?
21:23:39 <rbergeron> dynamic or otherwise? :)
21:24:10 <fenrus02> #link https://fedoraproject.org/wiki/BugZappers/Components_and_Triagers
21:24:15 <fenrus02> that one
21:24:18 <nirik> rawhide critpath has been broken of late. ;(
21:24:25 <adamw> a critpath list is generated daily by koji
21:24:34 <adamw> except see above
21:25:02 <adamw> but the table in bugzappers wiki space has always just been updated by hand
21:25:21 <rbergeron> Interesting. ALL THE THINGS I NEVER KNEW
21:25:47 <adamw> heh
21:25:48 <rbergeron> I should just be quiet before you all get scared.
21:25:51 <rbergeron> Ummm
21:26:05 <nirik> wonder if we could auto update it with magic from jlaska (since he figured out how to generate/update the blockers page)
21:26:47 <rbergeron> yeah.
21:27:15 <fenrus02> rbergeron, you want me to send you the same email that new bugzappers get?
21:27:25 <rbergeron> Sure.
21:28:06 <rbergeron> Thoughts on what to do with this list? Do we want to talk to Mr. Laska about making it more auto-updating-ish, or?
21:28:12 <rbergeron> Happy as it is, just needs a tune-up?
21:28:54 * rbergeron looks around
21:29:22 * rbergeron hums the theme to jeopardy
21:30:04 <rbergeron> Okay.
21:30:07 <nirik> not sure how hard dynamic would be
21:30:22 <rbergeron> nirik: would it just pull from koji? Or ... ?
21:30:26 <nirik> it would be easy to link to the critpath list.
21:30:33 <adamw> sorry, lost my connection
21:30:57 <fenrus02> rbergeron, sent.  comments / updates welcome.
21:31:10 <thedonvaughn> as a new bugzapper, the wiki page could definitely use some updating, but I can see where the logic to tie it all together will be difficult.  one thing to get the critpath in there, but then we also have bugzappers listed and if the componenet needs 'help' etc.
21:31:12 <nirik> when they work, they are at: http://kojipkgs.fedoraproject.org/mash/rawhide-YYYYMMDD/logs/critpath.log
21:31:48 * rbergeron nods
21:31:49 <fenrus02> nirik, if it's trivial to make dynamic, i would do that
21:31:59 <adamw> yeah dynamic might be tricky, and i'm noot sure it's worth the effort
21:32:12 <rbergeron> yeah
21:32:13 * nirik has no idea how trivial it would be. ;)
21:32:17 <adamw> it really only needs updating once every 6 months or so
21:32:22 <rbergeron> I think that even once every 6 months it would be .... a check-off item.
21:32:27 <rbergeron> Is this list still valid? Yes / no
21:32:29 <thedonvaughn> just once before a new branching right adamw ?
21:32:44 <adamw> yeah
21:32:48 <rbergeron> I just worry about when things like "rawhide is broken" and if that would foul up the list, etc
21:32:49 <adamw> or any time really
21:33:02 <adamw> it'd be close enough, doesn't really need to be perfect
21:33:02 <nirik> another possible approach: list critpath, but also post once a cycle or something to devel announce asking if any developers would like to sign their component up (critpath or not).
21:33:25 <adamw> that's kinda against the idea of the table
21:33:45 <fenrus02> adamw, sort of.  but the number of active members is under a dozen.
21:33:50 <rbergeron> `/win 3
21:34:06 <fenrus02> rbergeron, tri-winning is better than bi-winning, right?
21:34:11 <adamw> the table is to guide eople towards the most important packages
21:34:17 <rbergeron> fenrus02: I'll tri anything!
21:34:43 <adamw> fenrus02: sure, which makes a longer list even less necessary...
21:34:43 * fenrus02 refrains from comment
21:34:57 * j_dulaney waves at whats left of the meeting
21:35:24 <rbergeron> yeah.
21:35:25 <fenrus02> adamw, i'm just wondering how to get participation up
21:35:30 <rbergeron> I mean, the list is loonnnnnnng as it is.
21:35:57 * j_dulaney wonders what the topic is
21:36:08 <rbergeron> Maybe once the feature list is finalized we could highlight some of the features that are also on the list that also don't have triagers - more or less, "triage this core thing / feature"
21:36:12 <rbergeron> .....
21:36:13 * rbergeron shrugs
21:36:22 <fenrus02> j_dulaney, currently, how to update  <fenrus02> #link https://fedoraproject.org/wiki/BugZappers/Components_and_Triagers
21:37:00 <fenrus02> adamw, is there a list of most active components with the largest number of reports?
21:38:44 <adamw> not really
21:39:19 <adamw> i think we looked at that once, but a long time ago
21:39:35 * fenrus02 nods
21:40:03 <rbergeron> adamw: when you looked it it, was it to determine... what was most in need of a triager?
21:40:06 <rbergeron> or...
21:40:09 <rbergeron> ?
21:41:22 <adamw> i think so
21:41:30 <rbergeron> okay.
21:41:37 <rbergeron> ummm - was that just a bugzilla script somewhere?
21:41:44 <rbergeron> query
21:41:44 <adamw> you might wanna read thru some old logs
21:41:54 <rbergeron> adamw: you think? :)
21:42:10 <rbergeron> I'll see what I can find.
21:42:11 <adamw> yeah
21:42:12 <adamw> it's not too hard to do that kinda thing as a once off
21:42:27 <rbergeron> It might be a reasonable thing to do when we refresh the list every 6 months or so.
21:42:43 <rbergeron> make sure old assumptions are still good, people are still committed, ec.
21:42:46 <rbergeron> etc.
21:42:46 <adamw> sure.
21:43:16 <rbergeron> Anyone want to look into how to do that? :)
21:43:21 * rbergeron offers opportunities around
21:44:07 * adamw ducks
21:44:09 <fenrus02> bugzilla cli complains loudly when your query returns more than 100 or so entries
21:44:36 <fenrus02> needs more py foo than i posses ... (I've broken it *hard* dozens of times)
21:46:06 <rbergeron> okay.
21:46:10 <rbergeron> Welllll.
21:46:17 <adamw> you can use the web interface for a quick shot
21:47:27 <rbergeron> if nobody else is offering, I'll go digging through old stuff and see what I come up with.
21:49:04 <rbergeron> #action rbergeron to look into querying bugzilla for most active components
21:49:17 * rbergeron moves onwards
21:49:22 <rbergeron> #topic Other open floor stuff
21:49:32 <rbergeron> Does anyone have any cleanup they're interested in?
21:49:42 <rbergeron> Do we want to meet next week, or still stick with every-other-week?
21:50:12 <adamw> we used to run out of stuff to talk about quite quivk when we did it weekly
21:50:21 * rbergeron nods
21:50:23 <rbergeron> okay.
21:50:39 <rbergeron> #info We'll be meeting again in 2 weeks, same bat-time, same bat-channel.
21:51:06 <j_dulaney> Hopefully I won't have as much of a hangover as I do now...
21:51:14 <j_dulaney> And actually be useful.
21:51:29 <adamw> get a BIGGER hangover!
21:52:00 <fenrus02> an ical would sure be grand :)
21:52:36 <rbergeron> fenrus02: for ... bugzapping stuff?
21:52:41 <adamw> ahh, fedora calendaring, my other unicorn
21:52:43 <rbergeron> or qa stuff in general?
21:53:03 <fenrus02> meetings, all of them
21:53:27 <j_dulaney> Unicorns
21:53:40 * j_dulaney feels like he has a heard of them thundering around in his head.
21:53:50 * rbergeron notes there are .ics files in the schedule spot - http://rbergero.fedorapeople.org/schedules/f-16/
21:54:53 <adamw> cool
21:55:01 <rbergeron> if that's helpful
21:55:07 * rbergeron is starting to think maybe she should advertise that a bit more
21:55:17 <rbergeron> Okay. Well then.
21:55:24 <rbergeron> If there's nothing else, i'm gonna wrap it up here. ;)
21:55:33 * rbergeron holds for a minute before closing out
21:55:42 <adamw> fine by me
21:56:00 * j_dulaney wanders off to become horizontal once again
21:56:31 <rbergeron> lol
21:56:35 <rbergeron> Thanks, folks.
21:56:38 <rbergeron> #endmeeting