15:04:48 <rdieter> #startmeeting kde-sig -- https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2011-07-05
15:04:48 <zodbot> Meeting started Tue Jul  5 15:04:48 2011 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:55 <rdieter> #meetingname kde-sig
15:04:55 <zodbot> The meeting name has been set to 'kde-sig'
15:05:02 <rdieter> #topic roll call
15:05:22 <rdieter> who's present today?  ping: Kevin_Kofler, than, kde*foo
15:05:34 <rdieter> #info jreznik sent regrets
15:05:40 <Kevin_Kofler> Present.
15:06:24 <than_home> present
15:07:22 <rdieter> #chair Kevin_Kofler  than_home
15:07:22 <zodbot> Current chairs: Kevin_Kofler rdieter than_home
15:07:33 <rdieter> #topic agenda
15:07:49 <rdieter> so far, I just added status updates for 4.6.5, 4.6.90, anything else ?
15:08:13 <than_home> rdieter: kdebindings splits for 4.7
15:08:27 <Kevin_Kofler> What to do about 4.6.4, too… (Skip and move on to 4.6.5?)
15:08:31 <rdieter> ok, can include that when discussion 4.6.90
15:09:22 <rdieter> let's hit 4.6.5 then, looks like we have some subtopics
15:09:26 <rdieter> #topic kde 4.6.5
15:09:50 <rdieter> most of this is built, sans kde-l10n yet
15:10:00 <rdieter> I'll sync to kde-testing asap.
15:10:15 <rdieter> that leaves what to do with 4.6.4
15:10:26 <rdieter> I think we'll just have to skip it.
15:10:41 <than_home> rdieter: +1
15:11:06 <than_home> just move on to 4.6.5
15:11:11 * rdieter checks bodhi, looks like 4.6.4 is getting close to 7 days, but...
15:11:22 <Kevin_Kofler> It hit testing almost 7 days ago. We could push it tonight if we want.
15:11:58 <Kevin_Kofler> Heck, we could even push it now if we edit the karma threshold down to 1.
15:12:17 <Kevin_Kofler> But the 1-week timeout is in less than 6 hours anyway.
15:12:22 <rdieter> oh, hmm..
15:12:32 <nucleo> Is this bug can be fixed with 4.6.5 update? https://bugzilla.redhat.com/show_bug.cgi?id=715079
15:12:38 <rdieter> 2 important fixes, the dbus leak, and docbook fixes would be nice to get out asap
15:12:43 <Kevin_Kofler> The F15 update has a karma of +3, the F14 update has a karma of +1.
15:13:04 <Kevin_Kofler> Neither of the updates has any complaints.
15:13:24 <Kevin_Kofler> nucleo: https://bugzilla.redhat.com/show_bug.cgi?id=715079 is not fixed AFAIK.
15:14:03 <Kevin_Kofler> I don't know whether it's fixed in 4.6.5, we may have to fix it anyway.
15:14:10 <than_home> nucleo: it can be fixed in 4,6,5 update
15:14:24 <rdieter> OK, I'd rather push 4.6.4 stable then, even if it means a little more churn
15:15:24 <rdieter> than_home: any objection or concerns?
15:15:26 * than_home prefers to skip 4.6.4
15:15:45 <rdieter> ok, I don't feel strongly, would be nice to get a little extra testing
15:16:32 <rdieter> I'll move 4.6.4 to kde(stable) though, if it matters any.
15:16:43 <Kevin_Kofler> I'd say push it to stable, but I don't care strongly either.
15:16:45 <rdieter> and get 4.6.5 into kde-testing
15:16:52 <rdieter> :0
15:16:57 <Kevin_Kofler> I just think we have a few fixes accumulated (also the Okular landscape fix, and the upstream 4.6.4 fixes).
15:17:09 <Kevin_Kofler> So I'm not sure it's nice to wait longer.
15:17:15 <Kevin_Kofler> 4.6.5 isn't even queued yet.
15:17:27 <rdieter> #info tentatively skip 4.6.4 for official updates (keep for kde-stable), and get 4.6.5 into -testing asap
15:17:29 <Kevin_Kofler> Heck, it's not even fully built if we're missing kde-l10n.
15:17:48 <than_home> Kevin_Kofler: users still can update 4.6.4 from kde-redhat!
15:18:15 <rdieter> #topic kde 4.6.90
15:18:29 <rdieter> looks like we've got *most* of this built, sans kdebindings
15:18:52 <rdieter> than_home: ?  were you going to propose splitting kdebindings?
15:19:08 <rdieter> or at least consider it?
15:19:31 <nucleo> kdegraphics-4.6.90 built whout kipi-plugins support (plugins missing in gwenview)
15:19:32 <Kevin_Kofler> I think all that will lead to is going to be sweeping more kdebindings breakage under the carpet (because it will no longer be a dependency of anything).
15:19:44 <Kevin_Kofler> I think any update without a fully built kdebindings is a no go.
15:19:58 <Kevin_Kofler> We're getting complaints about the breakage in kde-unstable daily or more.
15:20:17 <than_home> yes, i prefer to split kdebindings
15:20:19 <rdieter> nucleo: I'm working on splitting kdegraphics, largely to fix that
15:20:20 <than_home> for 4.7
15:20:41 <than_home> it's easier to package it
15:20:45 <rdieter> than_home: I can support that
15:20:59 <Kevin_Kofler> Splitting out PyKDE4 will fix those complaints, sure, but I feat that it will also mean we're going to stay with broken kdebindings for weeks at times.
15:21:05 <Kevin_Kofler> s/feat/fear/
15:21:40 <than_home> Kevin_Kofler: we should start to split it ASAP
15:21:53 <rdieter> Kevin_Kofler: bindings somewhere will always be broken,but I'd rather it not block the world because of it.
15:22:46 * Kevin_Kofler wonders if upstream for kdebindings realizes that splitting their stuff up is going to reduce overall quality of distro support for it…
15:22:48 <rdieter> bindings at least is split fairly intelligently, not half-done like some other modules
15:23:15 <Kevin_Kofler> Few to no distro folks will care about breakage in anything other than PyKDE4.
15:23:16 <rdieter> Kevin_Kofler: it's pretty obvious that upstream splits for git repos did not have packaging in mind *at all* :(
15:23:37 <rdieter> only developer preference and convenience
15:25:02 <rdieter> for example, kdegraphics split is fairly well done too, and... I've been wanting to work on that for awhile anyway.
15:25:12 <than_home> i want to work on kdebinding splits soon, so we need decision now
15:25:26 <rdieter> than_home: I say go for it
15:25:42 <than_home> Kevin_Kofler: ?
15:25:44 <rdieter> esp if there's no possibility of an alternative short-term buildfix
15:25:55 <rdieter> short-term *and* easy
15:26:24 <Kevin_Kofler> I guess I'll have to support it here too, bindings for separate languages, based even on different binding technology (sip vs. smoke), having separate packages does make some sense.
15:26:36 <Kevin_Kofler> (Right now, kdebindings feels at times like BuildRequires: everything ;-) )
15:27:10 <Kevin_Kofler> I'm not so happy about the effects on update metadata, number of packages to build at each updates, and level of support for less commonly used bindings.
15:28:00 <rdieter> speaking of less common bindings, I didn't see php in there anywhere , did that get deprecated or dropped?
15:28:23 <rdieter> than_home: if so, make sure we have Obsoletes in place
15:28:30 <Kevin_Kofler> It might have been separated from KDE.
15:28:36 <Kevin_Kofler> It was only a Qt binding if I'm not mistaken.
15:28:50 <Kevin_Kofler> So it might have moved to a separate upstream (gitorious.org?).
15:28:51 <than_home> rdieter: i will check it
15:29:09 <rdieter> ok.
15:29:20 <than_home> or it could be missing in rc1
15:30:34 <rdieter> one caveat with *some* split packages, I'd advocate some sort of short-term meta-package parent, to ease upgrading.  For example, in the kdegraphics' case, keep some sort of 'kdegraphics' 'kdegraphics-devel' pkg around with appropriate Requires: for the spilt items
15:31:28 * rdieter has to afk for a few minutes, brb
15:33:09 <Kevin_Kofler> So I have no idea what happened to php-qt.
15:33:49 <Kevin_Kofler> I can't find it on projects.kde.org, their domain name expired, their old SourceForge page points to BerliOS and their old BerliOS page has a SVN last updated eons ago.
15:36:47 <Kevin_Kofler> Looks like there's no upstream for it anymore. :-(
15:36:48 <rdieter> #action than to work on splitting kdebindings-4.6.90 packaging a path-of-least-resistance to fix ftbfs
15:37:11 <rdieter> #topic open discussion
15:37:36 <rdieter> oh, wrt kde-4.6.5, anyone want to finish up working on builds/bodhi?  else, I can later today.
15:38:08 <than_home> rdieter: i can take care of it
15:38:51 <than_home> it seems the current kdegraphics-4.6.5 still has old okular version
15:39:10 <rdieter> seemed to include okular-0.12.4 for me. ?
15:39:21 <rdieter> 4.6.4 included 0.12.1 (or older)...
15:39:36 <Kevin_Kofler> Should be 0.12.5, upstream fixed the version number.
15:39:41 <than_home> it shoulde be 0,12.5
15:39:49 <Kevin_Kofler> But if it says 0.12.4, at least the code must be reasonably current.
15:40:07 <Kevin_Kofler> Still, we should rebuild with the respun tarball.
15:40:38 <rdieter> ah, yeah, I used the first one
15:40:50 <rdieter> I can respin it
15:40:57 <than_home> rdieter: it's donw
15:41:10 <than_home> but not built yet
15:41:15 <rdieter> oh ok
15:42:49 <rdieter> anything else for today?
15:42:50 <Kevin_Kofler> Hmmm, for Marble, wait… Does this even affect us? If so, it must have been affecting us since 4.6.2. We're shipping Marble 1.1.0, not the default 1.0.x from 4.6.x.
15:43:14 <rdieter> Kevin_Kofler: oh... oops hhmmm
15:43:31 <rdieter> nucleo: ^^ ?
15:44:08 <rdieter> Kevin_Kofler: looks like it, we (still) only have FindMarble.cmake
15:44:38 <Kevin_Kofler> The CMake files might be actually coming from somewhere else in kdeedu though.
15:44:45 <rdieter> may explain why not many folks saw the problem
15:45:14 <rdieter> most distros are probably still shipping stock marble-1.0.x
15:45:51 <Kevin_Kofler> Yeah, it might be a problem specific to 1.1.0.
15:46:03 <Kevin_Kofler> But I'm not sure.
15:46:12 <rdieter> I'll double-check after meeting
15:46:19 <Kevin_Kofler> We have to check our 4.6.2 builds, before and after I updated the Marble in them.
15:46:44 <nucleo> FindMarbleWidget.cmake was in kdeedu-4.6.3 sources but missing in kdeedu-4.6.5
15:46:50 <than_home> it don't remember anymore why we ship marble-1.1.0 instead default 1.0.x from 4.6.x
15:47:05 <Kevin_Kofler> than_home: Because it's newer? :-)
15:47:20 <Kevin_Kofler> It has more features, which couldn't be added to 1.0.x because of the feature freeze.
15:47:28 <Kevin_Kofler> 4.7.x will have Marble 1.2.x.
15:49:05 <rdieter> looks like FindMarbleWidget.cmake is indeed not in stock kdeedu-4.6.5 tarball either
15:49:21 <rdieter> may be easier to simply patch digikam at this point
15:49:45 <rdieter> plus any other pkg that used FindMarbleWidget
15:49:55 <Kevin_Kofler> So at least it's not my fault that it's missing now. :-)
15:51:17 <Kevin_Kofler> kdeedu-devel-4.6.3-1.fc15.i686.rpm included FindMarbleWidget.cmake too.
15:51:25 <rdieter> #info look into ongoing bug #715079 , and kdeedu's missing FindMarbleWidget.cmake
15:51:30 <Kevin_Kofler> So this must be getting installed from a global kdeedu directory in 4.6, not from Marble itself.
15:52:18 <Kevin_Kofler> It's missing in kdeedu-devel-4.6.4-1.fc15.i686.rpm which has the same Marble, but a different kdeedu tarball.
15:52:58 <rdieter> ok, will continue investigating after meeting, anything else before we run out of time today?
15:53:48 * rbergeron notes she's shipping along feature lists stuff to fesco
15:54:31 <Kevin_Kofler> Oh, features…
15:54:37 <rbergeron> OH FEATURES
15:54:40 <rbergeron> Yes. ;)
15:54:50 <Kevin_Kofler> There's the KDE47 feature, and then there's that KDE_Plasma_Desktop_by_default feature page I filed. :-)
15:55:07 <rbergeron> Yes, they're both getting shipped along.
15:55:10 <Kevin_Kofler> https://fedoraproject.org/wiki/Features/KDE47
15:55:16 <Kevin_Kofler> https://fedoraproject.org/wiki/Features/KDE_Plasma_Desktop_by_default
15:55:40 <rdieter> rbergeron: thanks.
15:56:03 * Kevin_Kofler doesn't expect FESCo to vote for the latter, but hey, one FESCo member asked me to propose such a feature. ;-)
15:56:31 <rbergeron> Kevin_Kofler: You might see if someone on the KDE sig wants to sweeten up the Benefit to Fedora section a bit. ;)
15:56:40 <rbergeron> Never hurts to have a second pair of eyeballs on such a thing. ;)
15:57:13 <rdieter> I think it worth mentioning that Kevin_Kofler's KDE_Plasma_Desktop_by_default feature is not endorsed by the kde-sig currently
15:57:21 <rbergeron> Oh.
15:59:46 <rdieter> I, personally, am a bit ambivolent, neither explicitly for or against it.
16:01:29 <rdieter> well, we're out of time for real now, thanks everyone.
16:01:32 <rdieter> #endmeeting