23:10:28 <jjmcd> #startmeeting #Fedora Docs Project
23:10:28 <zodbot> Meeting started Wed Jul  6 23:10:28 2011 UTC.  The chair is jjmcd. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:10:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:10:36 <jjmcd> #topic Roll Call
23:10:40 * jjmcd 
23:10:47 * rudi is here
23:11:39 <fnadge1> me too
23:11:41 * jsmith is here (at least for a few minutes)
23:12:15 * rbergeron wanders in
23:12:27 <jjmcd> Ahhh, there's sgordon and Robyn, too
23:12:42 * jhradilek is here too.
23:12:43 <jjmcd> OK, lets get rudi on stage here quick
23:12:55 <jjmcd> #topic Last week's action items
23:13:05 <jjmcd> rudi - FOP?
23:13:43 <rudi> FOP still kaput. One last avenue of enquiry upstream available
23:13:44 * sgordon is here
23:14:12 <jjmcd> OK, on UTF-8 I had some thought but failed to get with rudi, but I gather rudi has some news
23:14:41 <rudi> Yeah, we finally tracked down the issue to a Publican bug
23:14:48 <rudi> :)
23:15:22 <jsmith> Oh?
23:15:26 <jsmith> That's good news, I guess...
23:15:27 <jjmcd> So, will it be straightforward to repair?
23:15:32 <rudi> Yes! Easy fix!
23:15:48 <jsmith> rudi: Any idea when we'll see the next 2.x version packaged up for Fedora?
23:16:17 <rudi> The docs packages include some perl commands in %post that are apparently executed a little differently in OSes newer than RHEL5
23:16:39 <jjmcd> Don't tell me, you added a -C in the spec
23:16:47 <rudi> Not quite ;)
23:16:52 <rudi> "use utf-8"
23:16:53 <rudi> !
23:17:01 <jjmcd> heh
23:17:19 <jjmcd> Well, that's good news
23:17:25 <rudi> jsmith -- we're trying to lock down a timeframe for 2.6 release
23:17:38 <jsmith> OK, good to know
23:17:46 <jjmcd> #info UTF-8 issues has been tracked down.  Hope for a fix in Publican 2.6
23:17:55 <rudi> (for those not following Publican list, we've decided to go for one last 2.x release since 3.0 will be a longer while away)
23:18:02 <jjmcd> Oh yeah, I forgot
23:18:15 <jjmcd> #todo rudi to continue to follow up on FOP issue
23:18:30 <rudi> I'm hoping that we'll get 2.6 out in the next few weeks
23:18:37 <jjmcd> outstanding
23:18:44 <rudi> There's a long laundry list of annoying little bugs that we'd love to clear
23:19:04 <jjmcd> I just realized today I've been staring at a publican bug for weeks
23:19:32 <rudi> Oh? Which one?
23:19:37 <jjmcd> Proly should visit BZ with it
23:19:40 <rudi> (lots to choose from right now...:( )
23:19:55 <rudi> Oh, a new one? If so, yeah, get it in fast! :)
23:19:57 <jjmcd> If you use a entity in the heading, it is blank in the filename
23:20:27 <jjmcd> Specifically &PRODUCT; and &PRODVER; are used to componse filenames
23:20:29 <sgordon> is it blank or just not expanded?
23:20:36 <jjmcd> null
23:20:42 <sgordon> i have noticed for instance just getting PRODUCT in the filename
23:20:53 <jjmcd> so you get a filename starting with -- pretty inconvenient
23:20:59 <sgordon> :o
23:21:16 <rudi> That... may not be an easy fix. But bug please! :)
23:21:28 <jjmcd> Wilco
23:21:45 <jjmcd> #todo jjmcd to file bug on PRODUCT/PRODVER in Publican
23:22:03 <jjmcd> OK, other to-do's
23:22:18 <jjmcd> #todo jjmcd to check with dgrift on Ubuntu migration / policycoreutils
23:22:35 <jjmcd> Still haven't moved on that one beyond asking in the bug
23:22:45 <jjmcd> which I couldn't find the other day :-(
23:22:56 <jjmcd> I think the rest belong to Eric
23:23:38 <jjmcd> Shoot
23:23:47 <jjmcd> I'm supposed to be saying action
23:23:57 <jjmcd> #action rudi to continue to follow up on FOP issue
23:24:06 <jjmcd> #action jjmcd to file bug on PRODUCT/PRODVER in Publican
23:24:14 <jjmcd> #action jjmcd to check with dgrift on Ubuntu migration / policycoreutils
23:24:41 <jjmcd> #action Sparks to work with OLF folks to figure out a good time for the event
23:25:01 <jjmcd> #action Sparks to work on teleconference setup for OLF
23:25:15 <jjmcd> #action Sparks to update the DOcs list on Docs QA
23:25:34 <jjmcd> Sorry I'm slow, I have to type these - the email is on a different computer
23:26:13 <jjmcd> Unfortunately, thinks like Copyright changes from previous agendas Eric was kind of running point,
23:26:24 <jjmcd> but prolly worthwhile talking about FAD @ OLF
23:26:38 <jjmcd> #topic Goals for FAD @ OLF
23:27:08 <jjmcd> OK, so I guess the timing is such that we are in a good position for F16 Guides
23:27:24 <jjmcd> Does anyone have thoughts on what we should try to accomplish specifically?
23:28:07 <jjmcd> DOn't everyone junp at once!
23:29:02 <jjmcd> Are there specific guides that a bunch of hands would help on?
23:29:22 <jjmcd> Or perhaps having some experienced folks guide newer contributors?
23:29:50 <jjmcd> Nothing?
23:30:08 <rudi> Taking a look at the guides table...
23:30:30 <rudi> statuses out of date, but the catalog should still be about right:
23:30:37 <rudi> https://fedoraproject.org/wiki/Docs_Project_guides_table
23:31:34 * gomix here
23:31:42 <rudi> Maybe another question we could think about is what areas of Fedora are not well documented right now?
23:31:43 <jjmcd> I would be all for simply crashing on the user guide simply because there is still so much work there
23:31:58 <jjmcd> Good point, rudi
23:32:19 <rudi> I mean, we have the "core" of the OS broadly covered
23:32:38 * jjmcd has been making a lot of headway lately on an R guide, but that is kind of a niche thing
23:32:47 <rudi> But, to me, the real gems are things like the Amateur Radio Guide and Musician's Guide
23:32:54 <rudi> They are pure gold!
23:33:03 <jjmcd> True, nobody else has them
23:33:06 <gomix> +
23:33:13 <rudi> And there must be other specific use cases where Fedora shines
23:33:17 <jjmcd> I was surprised at the Musician's guide
23:33:19 <rudi> and we just need to tell people about it.
23:33:34 <gomix> i was trying to convince an astrophysicist who uses fedora to actually write a doc
23:33:42 <gomix> he uses fedora for his work
23:33:51 <jjmcd> A while back I looked for little concentration of things like stamp collectors, quilters, anything.  Didn't see anything non-geeky
23:33:52 <gomix> but im still failing :/
23:33:54 <rudi> Yeah, Astronomy is a notable omission
23:34:06 <jjmcd> rudi, yes, and we have an active SIG, too
23:34:15 <gomix> he's an argentinan guy living in brazil (skytux)
23:34:16 <rudi> I know! No excuse! :)
23:34:32 <rudi> gomix -- wow, love the handle :)
23:34:45 <gomix> so maybe someelse can help me on convince him
23:34:57 * gomix sees jsmith playing a role there ;)
23:35:09 <jjmcd> A lot of the astronomy apps are really something else
23:35:21 <jjmcd> like radio or photography
23:36:07 <jjmcd> rudi, do you have any insight as to whether any of the Astronomy SIG folks will be at OLF?
23:36:25 <rudi> No, but I can look into that.
23:36:38 <jjmcd> gomix, I missed that way up there.  Is your astrophysicist guy coming to OLF?
23:36:47 <gomix> no idea jjmcd
23:37:07 <jjmcd> If we could get an SME in the same room as a bunch of Docs guys for a while we probably could do something neat
23:37:24 <gomix> what do you mean SME ?
23:37:31 <jjmcd> subject matter expert
23:37:34 <rudi> Yeah, if subject matter experts don't have the time or interest to write a guide themselves, writers can interview them
23:37:42 <jjmcd> Whatever the subject
23:37:47 <gomix> Oh...  (small medium enterprises is my usual translation to that)
23:37:47 <Sparks> .
23:38:07 <jjmcd> rudi, exactly.  Whether an astrophysicist, photographer, bird watcher, whatever
23:38:11 <jjmcd> HEY SPARKS!
23:38:19 <rudi> Hi Sparks :)
23:38:25 <jjmcd> gomix, yes, I've seen that usage, too
23:38:37 <Sparks> Sorry, had a meeting
23:39:01 <jjmcd> Well, we needed you for most of the topics so we moved on to OLF
23:39:26 <Sparks> sry
23:39:33 <jjmcd> We were discussing whether we could capture someone expert in some field where we could use a guide .. like astrophysics
23:39:49 <jjmcd> We have a recent rash of particle physics app, too
23:39:52 <Sparks> capture?
23:40:00 <rudi> Yeah, lasso
23:40:04 <Sparks> Can we keep them at jsmith's house?
23:40:15 <jjmcd> If we had an expert in the same room as the writers, we could probably do some cool stuff
23:40:27 * Sparks agrees
23:40:55 <jjmcd> The experts might not be interested in writing, but I bet they would be interested in seeing a guide for their area
23:41:12 <rudi> We noted that Astronomy almost certainly has scope for a guide a la the Musician's or ARG
23:41:22 <jjmcd> Yes, absolutely
23:41:22 <Sparks> Yeah.  If we could interview them and talk to them about the software and their usage...
23:41:41 <rudi> and there are no doubt other areas that aren't as immediately visible
23:41:42 <Sparks> There used to be an astronomy spin, I think
23:41:44 <jjmcd> But we could say the same for Chemistry, Genomics, ....
23:41:45 <Sparks> and SIG
23:41:58 <jjmcd> Yeah that's the advantage Astronomy has
23:42:08 <jjmcd> there is a place where we might find the expert
23:42:41 <jjmcd> ANother active SIG is the ARM guys
23:42:55 <Sparks> Are we doing this as a psuedo marketting ploy?
23:43:01 * gomix would like to shake up ruby-sig
23:43:17 * gomix but it's definetly geek area
23:43:37 <jjmcd> Well, as rudi pointed out, the Musician, and ARG guides are real gems that are meaningful to their audiences
23:43:46 <Sparks> I could see a potential for lots of articles helping x-developers get started using Fedora whether it be ruby or C or python or...
23:43:56 <jjmcd> ANd it makes Fedora, and Linux for that matter, more approachable
23:44:09 <rudi> Sparks +1
23:44:25 <Sparks> It wouldn't have to be a large guide...
23:44:26 <rudi> It's an answer to "why would I want to use /that/"?
23:44:32 <Sparks> yep
23:44:37 <jjmcd> You know, I know a guy who did a great presentation on Python programming last OLF
23:44:52 <gomix> i would love to start a ruby@fedora doc.. if i have the time.. i already started something.. but it will definetly takes time.. (f16 is too close)
23:44:54 <jjmcd> And we all know him, too
23:44:57 <Sparks> probably the same guy that did one at SELF
23:45:35 <jjmcd> probably
23:45:57 <jjmcd> Kind of a round-ish guy that plays the guitar
23:46:16 <Sparks> wow
23:46:48 <jjmcd> So, who wants to take point on identifying a victim or two?
23:48:10 <Sparks> <crickets>
23:48:15 * rbergeron is looking at pseudo-marketing ploy
23:48:18 <jjmcd> Tell you what ... I'll reach out and see if I can find a science type for a Chem or Physics guide
23:48:33 <jjmcd> And perhaps Sparks can try to recruit a Python guy?
23:48:44 <gomix> i can try to talk again to skytux...
23:48:52 <jjmcd> gomix - great
23:49:04 * rudi has to bow out of the meeting... I have another IRL to scurry off to
23:49:11 <jjmcd> #action jjmcd to look for a Chem/Physics expert for OLF
23:49:17 <Sparks> jjmcd: bcotton would probably be a good person to find academic types
23:49:17 <jjmcd> Seeya rudi thanks
23:49:25 <rudi> Back later today.
23:49:39 <jjmcd> #action gomix to look for an astrophysics expert for OLF
23:50:09 <jjmcd> Sparks, cool.  I think I have a few contacts from Release Notes contributors
23:50:24 <jjmcd> So are you willing to lean on stickster?
23:50:58 <Sparks> sure
23:51:16 <jjmcd> #action Sparks to look for an Python expert for OLF
23:51:28 <jjmcd> good deal ... we might end up doing some good
23:51:55 <gomix> sorry .. but what's OLF ?
23:51:59 <jjmcd> Sparks, you may have missed, but rudi identified the UTF-8 bug
23:52:05 <jjmcd> Ohio Linux Fest
23:52:20 <Sparks> jjmcd: Awesome
23:52:28 <Sparks> and he fixed it?
23:52:29 <jjmcd> I know you won't be there, but I am looking forward to meeting you at FUDcon
23:52:45 <jjmcd> Sparks, next release of Publican
23:52:54 <Sparks> +1
23:53:10 <jjmcd> gomix, I read your ticket, I can't believe they would turn you down with that pitch
23:53:42 <jjmcd> OK, anything else on FAD@OLF?
23:53:49 <jjmcd> (we are running out the clock)
23:54:47 <jjmcd> In fact, in spite of the fact we have lots else to talk about, we prolly should just go to our closing topic
23:55:03 <jjmcd> #topic Open floor discussion
23:55:10 <jjmcd> Anything else for the good of the order?
23:55:40 * gomix smg (es-ES) will the se light today if im lucky with publican ;)
23:55:58 <jjmcd> gomix, I did push it the other day
23:56:08 <gomix> :o
23:56:29 <jjmcd> Monday
23:56:41 <jjmcd> Sorry, I should have mentioned it
23:56:44 <gomix> :)
23:56:47 <gomix> thank u so much
23:56:51 <jjmcd> No prob
23:57:24 <jjmcd> Sparks, we didn't get to talk copyright, QA.  Those will have to wait for next week if they need more discussion
23:57:26 <gomix> we should work on the draft watermark
23:57:45 <Sparks> jjmcd: Yeah...  :/
23:57:57 <Sparks> jjmcd: I "fixed" the copyright on several documents the other day.
23:58:06 <jjmcd> gomix, back on like F10 I did draft watermarks for like 15-20 langs.  But the next publican brand wiped them out
23:58:12 <jjmcd> Sparks, excellent
23:58:26 <jjmcd> Is there a brand with the fix?
23:58:42 <Sparks> jjmcd: There isn't.  I don't think it is in the Brand.
23:58:48 <Sparks> I couldn't find it anyway
23:58:58 * Sparks can look again, though.
23:59:16 <jjmcd> hmmmm, my ARPSC dox have a copyright notice in them
23:59:39 <jjmcd> Talks about CC-by-SA and how Michigan Section ... yada yada
23:59:48 <Sparks> Okay, I'll look again and find it and provide a patch
00:00:20 <jjmcd> I did overwrite it for a FOUO document, but by default I put it in the brand
00:00:41 <Sparks> okay
00:00:55 <jjmcd> OK, we are a minute to 8 ... any last minute additions?
00:01:22 <jjmcd> I take that back, I looked at the wrong clock, we're late
00:01:33 <jjmcd> Thanks everyone for coming and contributing
00:01:38 <gomix> .)
00:01:46 <jjmcd> I think we got some good stuff started here
00:02:06 <jjmcd> #endmeeting