19:00:02 <rbergeron> #startmeeting Fedora Cloud SIG
19:00:02 <zodbot> Meeting started Fri Jul 15 19:00:02 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:10 <rbergeron> #meetingname Cloud SIG
19:00:10 <zodbot> The meeting name has been set to 'cloud_sig'
19:00:18 <rbergeron> #topic Roll call
19:00:24 * gholms passes out bagels
19:00:29 * kkeithley is here
19:00:59 <jforbes> mememe
19:01:06 <rbergeron> youyouyou
19:01:10 * athmane is here but not for long :(
19:01:18 <rbergeron> hey athmane. thanks for joining again :)
19:01:22 * tflink is present
19:01:29 <rbergeron> tflink: hey! :)
19:01:34 <rbergeron> #topic EC2 status
19:02:01 <rbergeron> So i know jforbes has sent this off in the way of release engineering.
19:02:03 * jsmith lurks
19:02:18 <rbergeron> I'm not sure what the status is there, no updates in the ticket.
19:02:36 <rbergeron> jforbes: have you heard anything else?
19:02:40 <rbergeron> from dgilmore
19:03:00 <jforbes> jgreguske has been looking at it
19:03:33 <jforbes> Dont know much past that
19:03:38 * rbergeron nods
19:03:57 <jforbes> I have talked to him a couple of times on it, but dont know where he is on it
19:04:11 <rbergeron> jgreguske? or dgilmore
19:04:37 <jforbes> jgreguske, havent heard from dgilmore since jgreguske got involved
19:05:03 <rbergeron> okay.
19:06:29 <rrix> Hi
19:06:40 <rbergeron> hi.
19:06:45 <rbergeron> Well, I guess that's where that's at, then.
19:07:08 <rbergeron> I can't remember if we decided if we wanted to proceed with just testing the existing images that were created with BG or not, or what.
19:07:29 <jforbes> I didn't see an answer on that
19:08:00 <gholms> Either way we still need people to test stuff.
19:08:08 <gholms> Do we have a test plan?
19:08:24 <jforbes> When there is stuff to test, yeah
19:08:29 <rbergeron> Okay. So, let's do this: Let's say we're going to test the stuff made with BG.
19:08:33 <rbergeron> Can we do that? I think we can do that.
19:08:43 <dgilmore> jforbes: jay gave me some stuff that should work
19:08:47 <dgilmore> need some testing
19:09:01 <jforbes> We can do that
19:09:42 <rbergeron> dgilmore: from koji?
19:10:07 <rbergeron> or got created from koji?
19:10:09 <rbergeron> i should say?
19:10:18 <dgilmore> rbergeron: yes
19:10:24 <dgilmore> using koji
19:10:34 <jforbes> awesome
19:10:48 <rbergeron> dgilmore: how did we fix the output from post-processing?
19:11:00 <rbergeron> can we post the information on that somewhere so others know for future reference
19:11:10 <dgilmore> rbergeron: its all in the scripts from jay
19:11:31 <dgilmore> he ported them from the propietory amazon bits to euca2tools and boto
19:11:50 <gholms> Yay!
19:11:50 <jforbes> Oh great
19:11:53 <rbergeron> are the scripts somewhere we can find them so that if jay falls off the earth we can survive?
19:12:32 <gholms> dgilmore: If you guys need stuff like EBS registration support in euca2ools I can backport them.
19:12:38 <dgilmore> rbergeron: there in my email right now
19:12:44 <gholms> That particular feature is easy.
19:12:53 <dgilmore> rbergeron: i need to check over them then ill be adding to the releng git repo
19:12:59 <rbergeron> dgilmore: sweet
19:13:08 <dgilmore> gholms: i think he did that using boto
19:13:11 * jsmith loves it when progress happens
19:13:33 <rbergeron> dgilmore: so what needs testing exactly?
19:13:35 * gholms hands jsmith a jar of mustard
19:13:46 <rbergeron> gholms: you win a ribbon for that comment
19:13:52 <gholms> :D
19:13:56 <dgilmore> rbergeron: uploading the image and making sure its working fine
19:13:57 <jsmith> gholms: Yellow, dijon, or brown?
19:14:12 <gholms> jsmith: This one's dijon.  The Cloud SIG is high-class.
19:14:22 <kkeithley> no wasabi?
19:14:23 <rbergeron> dgilmore: yes, but where is the image getting sent to... etc?
19:14:28 <jsmith> gholms: If you say "brown, on a bratwurst", then you'd have really won :-p
19:14:34 <gholms> Heh
19:14:36 <rbergeron> same place justin was sending it?
19:14:38 <rbergeron> is it already there?
19:15:00 <spstarr> :)
19:15:04 <jforbes> should be, I gave them account info, ahvent checked
19:15:21 <rbergeron> jforbes: i owe you a change on the account still, crap
19:15:41 <jforbes> rbergeron: doh
19:15:51 <rbergeron> jforbes: yeah, i suck
19:16:04 <rbergeron> so - testing
19:16:31 <rbergeron> we have the test plans - do we just want to have an informal test day of some sort early next week, assuming the images are up and someone can do a quick run-through on if they work?
19:16:41 <rbergeron> or at least sanity check
19:16:54 * rbergeron isn't sure how to proceed here
19:17:12 <jforbes> Pick a day, I can help out
19:17:23 <athmane> just ensure that it's booting and network is ok
19:17:49 <gholms> Please make sure applications can run so we don't have more Xen-related fun.
19:17:53 <rbergeron> lol
19:17:54 <gholms> e.g. httpd
19:18:13 <rbergeron> gholms: what, i was just going to use it for a terminal in teh CLOUUUUUUUUUUUUUUD
19:18:15 <jdarcy> I remember that one.  Blech.
19:18:25 <tflink> httpd is part of the suggested test cases
19:18:31 <rbergeron> yup.
19:18:32 <tflink> https://fedoraproject.org/wiki/User:Athmane/Draft_Test_Day_Cloud_SIG_Fedora_EC2
19:19:08 <athmane> gholms: https://fedoraproject.org/wiki/User:Athmane/Draft_Test_Day_Cloud_SIG_Fedora_EC2#Test_Cases
19:19:24 <rbergeron> tflink, athmane: do you have any objections to helping out lightly with a test day next week at some point for the f15 images?
19:19:34 <tflink> not at all
19:19:40 <rbergeron> it would be nice to have some help. I thik these test cases look reasonably solid and agreed on at this point.
19:19:44 <athmane> np
19:20:07 <rbergeron> Okay. So let's do this: Monday is the QA meeting - how about Tuesday?
19:20:32 <rbergeron> We can do some advertising at the QA meeting, I guess.
19:20:47 <rbergeron> In the meantime:
19:20:56 <athmane> if it's after 18:00 (utc+1)
19:21:27 <rbergeron> I'm still happy to pay people a few bucks for their ec2 usage or whatever, if they want it. I'd like to get a little estimate from someone on whether or not they think that amount is reasonable.
19:21:35 <rbergeron> Or Too Much, or Too Little.
19:21:50 <tflink> are we trying to make this more of an official test day or just to get people to test the AMIs?
19:22:13 <rbergeron> We just need to make sure the AMIs work before we put them up.
19:22:29 <athmane> sort of pre-testing
19:22:29 <rbergeron> I don't care, at this point. We can call it Official Unofficial Testing of Hot Dogs and AMIs day, at this point.
19:22:47 <rbergeron> I can't imagine we'd have more than 10-15 people.
19:22:58 <rbergeron> I don't know what QA needs in the way of approvals from the Cloud SIG on spins.
19:23:03 <rbergeron> for trademark approval.
19:23:03 <jforbes> I'll bring the relish :)
19:23:10 <tflink> I'm not sure, either
19:23:27 <rbergeron> Which at this point I'm not even sure I need anyway, but I'll just pretend for now that I do.
19:23:41 <rbergeron> Since I asked for help, I just want to make sure you QA folks are happy, since ew're grateful for your help.
19:23:56 <rbergeron> If *one* person can sanity check it, before we invite a bunch of people, that would be great.
19:24:09 <rbergeron> We also need the AMI id's in the test day page.
19:24:13 <tflink> are the AMI numbers up somewhere?
19:24:36 <rbergeron> dgilmore or jforbes can probably get that. dgilmore said the images are up, so I assume that info is in the account.
19:24:56 <rbergeron> tflink: not the same as the community account, incidentally
19:25:01 <rbergeron> afaik
19:25:09 <tflink> yeah, I think that was discussed last week
19:25:13 <rbergeron> so
19:25:20 <tflink> a different account is registered with amazon for images
19:25:37 <rbergeron> jforbes: can you maybe stick the ami id's somewhere, or at least in a mail so we can get them in whatever?
19:26:23 <rbergeron> tflink, athmane: what are your thoughts on official testing, or can we just do an informal "test day" and not have to wait 48 years for an available test day for something from last release? :)
19:26:52 <jforbes> rbergeron: sure
19:27:10 <tflink> at this point the F15 test days are over, so it'll be outside the normal processes
19:27:26 <athmane> I agree with tflink
19:27:31 <rbergeron> tflink: so we can just do an "unofficial" test day, and then we'll plan something normalish for F16.
19:27:52 <rbergeron> So let's call it Tuesday. Does that work for everyone? /me prays
19:27:54 <tflink> sounds good to me
19:28:07 <athmane> rbergeron: yes, but afaik it does not work if ami should are based on stable f16
19:28:18 <rbergeron> athmane: it's the F15 ami.
19:29:03 <jsmith> WORKFORME
19:29:06 <rbergeron> jforbes: can you just post the ami and maybe sanity check it to make sure it boots and has networking before we get to tuesday?
19:29:17 * rbergeron hugs jforbes
19:29:20 <tflink> I'm not sure that QA has given a whole lot of thought to what constitutes approval for AMIs
19:29:31 * tflink might have missed something, though
19:29:39 <jforbes> rbergeron: absolutely
19:29:40 <rbergeron> tflink: well, we'll all consider this learning, at tihs point.
19:29:54 <rbergeron> #action jforbes to post ami ID, sanity check it.
19:30:03 <rbergeron> #info F15 "test day" will be Tuesday.
19:30:22 <rbergeron> Does anyone want to announce our "test day" via email, etc. to cloud and QA and perhaps blog about it?
19:30:46 <jforbes> I can if noone else
19:31:03 * rbergeron hates to lay it all on you
19:31:11 <tflink> I can do the emails
19:31:35 <rbergeron> tflink: that would be great - do we just want to move the draft test day page to an F15 ec2 test day page?
19:31:38 <rbergeron> err
19:31:40 <rbergeron> copy
19:31:45 <rbergeron> jforbes: blog would still be awesome if you wnt to do that
19:31:57 <rbergeron> i think tflink has the whole notification of test days thing down fairly solid
19:32:05 <rbergeron> tflink: where do we wnat to do the test day?
19:32:14 <jforbes> will do
19:32:27 <rbergeron> jforbes: thanks! :)
19:32:29 <tflink> if it's done, sure. I think that athmane was planning to do that this week anyways
19:32:39 <rbergeron> tflink and athmane: thank you *both* a TON, your help has been super.
19:32:52 <rbergeron> #action tflink to announce test day Tuesday.
19:33:11 <rbergeron> #action tflink or athmane to copy draft page to F15 ec2 test day page
19:33:11 <tflink> rbergeron: I assume that you mean IRC? I don't think that it much matters where. Either #fedora-cloud or #fedora-test-day
19:33:43 <rbergeron> tflink: yes, IRC - just wanted to know channel. I'm happy to do it wherever.
19:33:49 <rbergeron> if you think one or the other might get better traffic, let's do that.
19:33:58 <rbergeron> #fedora-test-day i think is more standard
19:34:19 <tflink> yeah, it is
19:34:23 <rbergeron> okay.
19:34:31 <rbergeron> #info test day to happen in #fedora-test-day
19:34:34 <rbergeron> Okay.
19:34:53 <rbergeron> I think we're good there. Let's just be sure to keep up with each other on the mailng list, so we can keep all hte moving parts moving between now and Tuesday. :)
19:35:06 * athmane notes that we need ami id to update draft page
19:36:01 <rbergeron> athmane: yup. jforbes will get that to us.
19:36:11 <rbergeron> he's got the action on it already.
19:36:21 <rbergeron> #topic Aeolus
19:36:25 <rbergeron> mmorsi: you about?
19:36:33 * rbergeron knows clalance is taking some well-deserved breathing time
19:36:46 <rbergeron> oh, he's not here.
19:36:47 <rbergeron> Fooey.
19:36:51 <rbergeron> Well, i'll update real quick:
19:36:58 <rbergeron> There was a mail to the cloud sig list today you may have seen.
19:37:10 <rbergeron> They're under quite a time crunch, with a ton of packages still in the queue.
19:37:14 <rbergeron> Any help there is appreciated.
19:37:16 * rbergeron digs up link to mail
19:38:24 <rbergeron> #link http://lists.fedoraproject.org/pipermail/cloud/2011-July/000665.html
19:38:44 <rbergeron> #info Please help out if you can with Aeolus reviews - it's one of the F16 features!
19:38:57 <rbergeron> #topic CloudFS
19:39:09 <rbergeron> kkeithley, jdarcy: HI.
19:39:13 <kkeithley> howdy
19:39:18 <jdarcy> Hi.
19:39:23 <rbergeron> jdarcy: i saw your most excellent blog post on status. VERY NICE STUFF SIR
19:39:29 <jdarcy> Thanks.
19:39:43 <jdarcy> AFAIK we're good to go except for package review.
19:40:20 <kkeithley> there's a bunch that happens after we got the go-ahead, but it's not hard
19:40:26 <jdarcy> http://cloudfs.org/2011/07/status-report-2011-07/ for those who didn't see it
19:40:30 <rbergeron> yup. I think ke4qqq has it in his court, doesn't he?
19:40:40 <jdarcy> Yeah, he got distracted by being bought and all.
19:40:41 <kkeithley> yup, waiting on him
19:41:27 <rbergeron> LOL
19:41:52 <rbergeron> alrighty. kkeithley, he said yesterday he'd get n it, right?
19:42:08 * rbergeron expects he'll probably have more time this weekend and such
19:42:11 <kkeithley> he said he hasn't forgotten about it, I guess that's the same thing
19:42:18 <rbergeron> LOL
19:42:22 <rbergeron> I hope so.
19:42:23 <rbergeron> ;)
19:42:25 <rbergeron> okay.
19:42:35 <rbergeron> well, you know where to make noise if you're feeling more worried. :)
19:42:42 * rbergeron cheers you guys on.
19:42:50 <kkeithley> oh, I can make lots of noise when I want to
19:42:53 <rbergeron> jdarcy: hw are you going to handle the whole name-changing thing?
19:43:11 <jdarcy> rbergeron: Still need to find out why everything I send to legal falls into a black hole.
19:43:25 <rbergeron> jdarcy: as far as they dn't like it or they're not responding?
19:43:41 <jdarcy> Haven't heard back on either the first batch of names or the CLA for a while.  Time to be more annoying . . . CHALLENGE ACCEPTED.
19:43:50 <rbergeron> spot: ping
19:44:43 <rbergeron> jdarcy: what desk is it on, do yo uknow?
19:44:47 <rbergeron> or whose, I should say
19:44:54 <rbergeron> or is it just in a ticket tracking hell somewhere
19:44:55 <kkeithley> let's see how your text IRC deals with ϠFS
19:45:00 <jdarcy> rbergeron: Trademark stuff is Pam and Erin, CLA stuff is Richard.
19:45:21 <rbergeron> you have your own cla?
19:45:47 <rbergeron> Fancy stuff.
19:46:02 <jdarcy> rbergeron: Gluster has a CLA, which they want for the pieces (e.g. SSL transport) that are supposed to go into GlusterFS instead of remaining separate.
19:46:13 <rbergeron> hhhhhhh.
19:46:14 <rbergeron> yeah.
19:46:23 <rbergeron> Hrmm.
19:46:26 <rbergeron> jsmith: ping
19:46:28 <jdarcy> rbergeron: I sent it to Richard, and he said "YUK" very loudly.
19:47:10 <rbergeron> jdarcy: i'm just wondering how this is ging to affect like... stuff
19:47:12 <rbergeron> a name change
19:47:17 <rbergeron> i think is not as critical
19:47:22 <jdarcy> Now that we're a bit out of the woods in terms of code and such, I can spend part of next week chasing that stuff down.
19:47:22 <rbergeron> nt even sure how to handle the CLA stuff
19:47:41 <rbergeron> jdarcy: do that. If we need to rely on someone to escalate / add pressure, we can do that.
19:47:43 <jdarcy> The CLA stuff is long term, I don't think we need to worry about it.
19:47:43 <jsmith> rbergeron: Pong (sorry, non-maskable interrupt)
19:47:47 <rbergeron> okay.
19:47:56 <rbergeron> CARRY ON THEN
19:48:12 <rbergeron> #topic Open Floor unless others have shown up
19:48:23 <spot> rbergeron: hm?
19:48:30 <jdarcy> The name-change stuff will be a bit of a pain, but I sort of think we have to cross that bridge when we get there.  We're not precluded from *using* the name AFAIK, just from trademarking it.
19:49:05 <rbergeron> spot: jdarcy is waiting on some stuff from legal about how he has to change the name of CloudFS - is that something that can theoretically block a feature, or break things if he has to change the name later in the cycle
19:49:22 <rbergeron> (i asked because he's waiting on legal, waiting, waiting, waiting)
19:49:44 <spot> rbergeron: i suppose thats a fesco question.
19:50:20 <rbergeron> Alrighty. Well, I suppose we can harass them Monday about it.
19:50:20 <spot> best advice i can give about RH Legal is to not assume they're working on it and to keep poking them
19:50:27 <rbergeron> LOL
19:50:35 <rbergeron> jdarcy: see advice
19:50:51 <jdarcy> Fair enough.  I can be *very* annoying, and it's even better if it's in a good cause.
19:51:07 <rbergeron> spot: thanks :)
19:51:23 <rbergeron> spstarr: you had an agenda item you wanted to add?
19:52:22 <gholms> [There is a sound of bubblewrap from upstairs]
19:52:23 * rbergeron looks around for any other comments, questions, etc etc
19:52:36 * rbergeron needs a gholms bracketbot to capture that stuff
19:53:15 <rbergeron> Alrighty.
19:53:28 <rbergeron> Well then, that's all, folks. Thanks for coming :)
19:53:44 <rbergeron> #endmeeting