15:07:46 <rdieter> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2011-07-19
15:07:46 <zodbot> Meeting started Tue Jul 19 15:07:46 2011 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:07:53 <rdieter> #topic roll call
15:07:57 <rdieter> hi, who's present today?
15:08:22 * jreznik is here
15:08:32 * rnovacek here
15:09:05 <rnovacek> Kevin_Kofler said he might not get it on time or at all
15:09:52 <rdieter> #chair jreznik rnovacek
15:09:52 <zodbot> Current chairs: jreznik rdieter rnovacek
15:09:53 * than is present
15:09:56 <rdieter> #chair than
15:09:56 <zodbot> Current chairs: jreznik rdieter rnovacek than
15:10:07 <rdieter> #info jreznik rnovacek than rdieter present
15:10:15 <rdieter> #topic agenda
15:10:20 <rdieter> what to discuss today?
15:10:33 <rdieter> brb, afk for a couple min...
15:10:43 <than> 4.7rc1 status
15:13:47 <than> i have appointment at 5:30 and,  leave the meeting early
15:13:59 <rdieter> looks like we'll have a short meeting then
15:14:09 <rdieter> #topic 4.7rc1 status
15:15:04 <rdieter> see also our tracking bug, https://bugzilla.redhat.com/showdependencytree.cgi?id=kde-4.7&hide_resolved=1
15:15:32 * jreznik gave up building monolithic kdebingings - some parts are already splitted - so it has to be finished...
15:15:44 <rdieter> jreznik: agreed
15:16:00 <than> jreznik: it doesn't make sense to build monolithic kdebingings
15:16:09 <rdieter> I think we have the minimal required pieces of kdebindings done already
15:16:13 <than> it just makes more problem
15:16:35 <rdieter> is there anything else we ship that uses any of the missing kdebindings stuff?
15:17:36 * rdieter also submitted 2 more reviews for newer split tarballs
15:17:49 <rdieter> .bug 722993
15:17:51 <zodbot> rdieter: Bug 722993 Review Request: kate - Advanced Text Editor - https://bugzilla.redhat.com/show_bug.cgi?id=722993
15:18:04 <rdieter> .bug 723064
15:18:09 <zodbot> rdieter: Bug 723064 Review Request: konsole - KDE Terminal Emulator - https://bugzilla.redhat.com/show_bug.cgi?id=723064
15:18:19 * jreznik already took konsole
15:18:36 <rdieter> so kdelibs, kdebase at least no longer needs hacks
15:18:42 <jreznik> but I was finishing herqq review for the changed qtsoap
15:18:43 <rdieter> maybe kdesdk too, need another closer look
15:19:20 <rdieter> kate being packaged separately now, apps using/needing katepart will need to explicitly add some dependencies though
15:20:05 <than> do we already have review request for  smokegen, smokekde, smokeqt ?
15:20:24 <rdieter> alternatively, kdelibs can make a subpkg for libktexteditor, and *that* can have a dep on kate-part
15:20:34 <rdieter> than: no
15:21:01 <than> ok, i will do Review Request for those
15:21:21 <jreznik> we have kross-interpreters
15:21:36 <jreznik> https://bugzilla.redhat.com/show_bug.cgi?id=656997
15:21:41 <rdieter> PyKDE4, kross-interpreters are the only ones done so far
15:21:54 <jreznik> than: ping me and I'll do review
15:22:14 <than> jreznik: i will do, thanks :)
15:22:16 <rdieter> wrt kdelibs and kate, which approach seems better?  opinions?
15:22:51 <rdieter> 1.  explictly require apps to add Requires: kate-part, or 2.  make kdelibs-ktexteditor subpkg with Requires: kate-part ?
15:23:20 <rnovacek> Does it make any sense to have kdelibs without kate-part?
15:23:42 <rnovacek> I don't think so, so +1 to 1.
15:24:23 <rdieter> rnovacek: 2 implies apps that already link against libktexteditor will continue to "just work" without modification
15:24:32 <rdieter> 1.  requires packaging changes
15:25:43 <jreznik> but it's not a big packaging change...
15:26:15 * rdieter likes option 1 better, less work. :)
15:26:23 <jreznik> I think so
15:26:23 <rdieter> err... oops, make that 2
15:26:31 <rdieter> 2 is less work, less error-prone
15:26:53 <rnovacek> ok, +1 to 2. too :)
15:26:58 <jreznik> 1 is not so much work
15:27:14 <jreznik> 2 is better because of ktexteditor withou kate-part is nonsense
15:28:10 <rdieter> ok, once kate review is done, I'll implement option 2?
15:29:08 <rdieter> #action than will submit a few more kdebindings (smoke) related reviews
15:29:37 <rdieter> #action rdieter will implement kdelibs-ktexteditor subpkg once kate review is done
15:29:50 <rdieter> any bikeshedding for subpkg name, or is kdelibs-ktexteditor subpkg name ok?
15:30:08 <rdieter> :)
15:30:54 <jreznik> ok
15:31:05 <rdieter> anything else 4.7-related?
15:31:40 <Kevin_Kofler> I think kdelibs-ktexteditor is OK.
15:31:47 <Kevin_Kofler> I'm a bit worried because the dep is still circular to some extent.
15:32:11 <Kevin_Kofler> i.e. a subpackage of kdelibs depending on something that needs kdelibs-devel to build
15:32:29 <rdieter> Kevin_Kofler: good poing, I'll have to think about that a bit
15:32:38 <rdieter> good point even
15:33:32 <rdieter> maybe option 1 is better after all
15:34:09 * rdieter curses again for not having soft dependencies
15:34:52 <Kevin_Kofler> I'm not sure what the best solution is, both suck to some extent. :-(
15:35:15 <rdieter> Kevin_Kofler: could be a little more evil, and have libktexteditor *not* get pulled in via kdelibs-devel
15:35:34 <rdieter> and apps needing it will have to add another BR
15:36:11 <rdieter> but now we're getting back to having to modify all apps that need it, but that's a *little* safer than the original option 1, imo
15:36:50 <rdieter> I'll think about it some more, and make a proposal later.
15:37:00 <rdieter> #topic open discussion
15:37:04 <rdieter> anything else to discuss today?
15:37:52 <Kevin_Kofler> rdieter: That wouldn't help.
15:38:05 <Kevin_Kofler> The Kate stuff would need kdelibs-ktexteditor-devel anyway.
15:38:10 <Kevin_Kofler> So the dep would still be circular.
15:38:54 <rdieter> ok, but at least the breakage is limited to just kate (and anything that BR's it), instead of breaking everything that BR: kdelibs-devel
15:39:13 <Kevin_Kofler> TBH, I think the best solution is to just keep building that stuff as part of kdelibs.
15:39:34 <rdieter> kate/libktexteditor is best built together, true
15:39:57 <rdieter> I'll ping upstream and suggest something like that, this situation sucks
15:40:16 <Kevin_Kofler> I think it was a very bad idea from upstream to move the KatePart out of kdelibs. :-(
15:40:30 <rdieter> no argument from me
15:41:16 <rdieter> more fallout from the arbitrariness of producing split tarballs based on git repos, without forethought on packaging implications
15:42:02 <Kevin_Kofler> I think the repo organization is wrong to begin with.
15:42:09 <Kevin_Kofler> Plasma is doing just fine with libplasma in the kdelibs git.
15:42:24 <rdieter> calling it 'organization' is too kind. :)
15:43:54 <rdieter> to be clear, katepart is the only ktexteditor implementation ?
15:44:41 <Kevin_Kofler> Not sure. It's the only one actually used, in any case. :-)
15:46:03 * rdieter will close meeting if there's nothing else to discuss
15:47:08 <rdieter> thanks everyone!
15:47:09 <rdieter> #endmeeting