14:59:45 <j_dulaney> #startmeeting Fedora QA meeting
14:59:45 <zodbot> Meeting started Mon Jul 25 14:59:45 2011 UTC.  The chair is j_dulaney. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:59:54 <j_dulaney> #meetingname fedora-qa
14:59:54 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:04 <j_dulaney> #topic Roll Call
15:00:12 * jskladan is lurking
15:00:13 * tflink is present
15:00:16 <thedonvaughn> present
15:00:26 * mkrizek is here
15:00:28 * pschindl is here
15:00:51 * brunowolff is here
15:00:58 <j_dulaney> jskladan, tflink, thedonvaughn, mkrizek, pschindl, how are y'all doing?
15:01:03 * kparal joined
15:01:12 <j_dulaney> brunowolff, kparal, whatup?
15:01:21 <nido> would you mind my attendance despite having nothing to do with fedora-qa save being a fedora user?
15:01:25 <brunowolff> I need more sleep.
15:01:34 <j_dulaney> nido, welcome!
15:01:38 <jskladan> j_dulaney: good as usual? how about you?
15:01:44 <j_dulaney> brunowolff:  Don't we all?
15:01:59 <j_dulaney> jskladan:  Hungry as usual at this time of day
15:02:12 <thedonvaughn> j_dulaney: good, thanks.  Trying to wrestle this monday workload ;p
15:02:17 <tflink> nido: not at all. all are welcome
15:02:18 <kparal> nido: it's always good to see new faces
15:02:18 <j_dulaney> Couple more minutes, I do believe
15:02:51 <j_dulaney> thedonvaughn:  have fun with that
15:03:25 <j_dulaney> Alright, lets do this thing
15:03:31 <j_dulaney> #topic Previous meeting follow-up
15:03:48 <j_dulaney> j_dulaney volunteered to file bugs against s-c-* packages to recommend patching their .desktop file to avoid
15:04:03 <j_dulaney> And I failed at this; it will get done today, though.
15:04:47 <j_dulaney> Anyone want to toss in anything?
15:05:30 <kparal> j_dulaney: feel free to re-assign that task to yourself again with #action
15:05:49 <kparal> I think that should move it to the next meeting follow-up
15:05:56 <j_dulaney> #action j_dulaney will get this done this week and not slack off again
15:06:25 <j_dulaney> I think that's it for last meeting unless anyone else has anything to add
15:07:09 <j_dulaney> If nothing else?
15:07:29 <j_dulaney> #topic Cloud SIG - Fedora 15 on Amazon EC2
15:08:03 <j_dulaney> Athmane is not present today
15:08:06 <tflink> there isn't much to update on this, we're still waiting on rel-eng
15:08:15 <j_dulaney> Indeed
15:08:40 <tflink> I believe athmane's question was whether or not we could/should go forward with testing an EC2 AMI for F15 even if it wasn't blessed by rel-eng
15:08:57 <tflink> my understanding was that we were going to wait on the cloud SIG on that one
15:09:04 <j_dulaney> #info Awaiting rel-eng for this
15:09:28 <tflink> if they want to go ahead with an AMI, we'll follow but I don't think that we wanted to go ahead without their "blessing"
15:09:46 <j_dulaney> Indeed, makes sense
15:10:04 <tflink> from what I was hearing on friday, if there was no rel-eng AMI by today, they were going to go forward with the boxgrinder AMIs
15:10:07 <tflink> for F15
15:10:24 <j_dulaney> Righteo
15:10:39 * kparal asks what AMI is
15:10:51 <tflink> we hadn't discussed the test day date much, but I think that we might use an unclaimed F16 test day
15:10:59 <tflink> AMI -> Amazon Machine Image
15:11:09 <tflink> it is the VM image that is booted on EC2
15:11:15 <kparal> tflink: thanks
15:11:25 <j_dulaney> Proposal:  Go ahead with Boxgrinder AMIs for F15 test day since rel-eng doesn't have any yet
15:11:27 <tflink> pretty much a raw disk image with some modifications
15:11:47 <tflink> j_dulaney: I would modify that to say that we'll follow the Cloud SIG on that
15:11:56 <tflink> hmm, too many "that"s
15:12:01 <j_dulaney> +1 to modification
15:12:20 <j_dulaney> Vote?
15:12:29 <tflink> proposal: Schedule F15 EC2 test day when Cloud SIG decides to move forward with F15 AMI
15:12:44 <j_dulaney> Better wording
15:12:51 <j_dulaney> atmane!
15:13:00 <j_dulaney> c/atmane/athmane
15:13:03 * athmane_work is late, hay
15:13:13 <j_dulaney> Just in time for your gig
15:13:14 <tflink> athmane_work: good timing, we're just talking about AMI testing
15:13:56 <j_dulaney> tflink just said: proposal: Schedule F15 EC2 test day when Cloud SIG decides to move forward with F15 AMI
15:14:11 <j_dulaney> athmane_work:  Any thoughts on this?
15:14:30 <athmane_work> no, we're still wataing for cloud sig to release the amis
15:14:39 <athmane_work> *waiting
15:14:45 <tflink> I haven't heard anything since friday, but I believe that their plan was to go forward with the BG AMIs today if the rel-eng ticket wasn't done
15:15:08 * tflink will follow up today
15:15:19 <j_dulaney> We're getting really close to F16 test days here
15:15:27 <tflink> the first one is tomorrow
15:15:29 <j_dulaney> #action tflink will follow up today
15:15:36 <tflink> but I don't believe that it has been claimed yet
15:16:39 <j_dulaney> I'm thinking we might want to go ahead with Boxgrinder produced AMIs if rel-eng is going to be too much longer in creating AMIs for testing
15:17:04 <tflink> yep
15:17:16 <j_dulaney> I'm also thinking that we should set a test day, and make the day prior the final Rel-Eng deadline
15:17:25 <tflink> but I still think it comes back to the SIG/Spins leading the effort
15:18:16 <tflink> unless we want to set a deadline for the F15 EC2 test day
15:18:17 <j_dulaney> Indeed
15:18:26 <j_dulaney> I think that would be wise
15:18:39 <j_dulaney> Either this Thursday or the following; both are open
15:18:45 <tflink> 8/1 for scheduling, 8/4 test day at the latest?
15:18:52 <tflink> or earlier than that?
15:19:06 <j_dulaney> 8/4 at the latest
15:19:29 <j_dulaney> Hard deadline for images 8/1
15:19:43 <athmane_work> I guess f15 ami test day will be unofficial after f16 test days start
15:20:11 <tflink> so proposed #agreed - F15 EC2 test day must be done by 8/4 at the latest, AMI IDs must be received by 8/1
15:20:19 <jsmith> tflink, j_dulaney: Perhaps you should communicate with rel-eng and see if that's a reasonable hard deadline?
15:20:21 <j_dulaney> +1
15:20:40 <tflink> jsmith: I will confirm
15:20:46 <jsmith> tflink: Thanks :-)
15:20:56 <j_dulaney> jsmith:  We're encroaching on F16 is the problem
15:21:14 <jsmith> j_dulaney: I'm well aware of that -- I just don't think it's fair to surprise rel-eng with deadlines
15:21:18 <tflink> but my understanding was that if rel-eng wasn't done soon, the cloud SIG was going to just use the BG AMIs for F15 and wait until F16 for the rel-eng AMIs
15:21:41 <j_dulaney> #action tflink to confirm with rel-eng to see if 8/1 is a reasonable deadline
15:21:55 <j_dulaney> Indeed
15:21:56 <tflink> either way, I will coordinate this with the cloud SIG and rel-eng
15:22:14 <j_dulaney> Anyway, I'm +1 on hard deadline.  Anyone else?
15:22:30 <tflink> +1 on hard deadline for the F15 test day
15:22:38 <athmane_work> +1
15:22:55 <j_dulaney> Going
15:23:03 <j_dulaney> #agreed - F15 EC2 test day must be done by 8/4 at the latest, AMI IDs must be received by 8/1
15:23:24 <j_dulaney> #topic oVirt Node Fedora 16 Spin
15:23:37 <athmane_work> #link https://fedoraproject.org/wiki/User:Athmane/Draft_Ovirt_Node_validation_matrix
15:23:39 <j_dulaney> athmane_work:  I think this is you as well
15:23:57 <j_dulaney> #chair athmane_work
15:23:57 <zodbot> Current chairs: athmane_work j_dulaney
15:24:13 <j_dulaney> #link https://fedoraproject.org/wiki/User:Athmane/Draft_Ovirt_Node_validation_matrix
15:24:13 <j_dulaney> Take it away
15:24:38 <athmane_work> well, ovirt spin is not yet integrated to rel-eng (it will)
15:25:17 <athmane_work> so my question is: if qa should wait until it integrated to rel-eng
15:25:29 <j_dulaney> Will the matrix and test cases be 100% by freeze?
15:25:31 <athmane_work> to make testing official
15:26:28 <athmane_work> ovirt team are waiting for virt-manager-tui to be packaged in f16
15:26:30 <j_dulaney> The spin has to be official by freeze?
15:26:45 <athmane_work> so not yet
15:26:57 <jboggs> i've been working with athmane_work on them, I'll help get them done by the freeze, but yes just waiting on virt-manager-tui which will be in by tomorrow
15:27:24 <j_dulaney> So, it looks like it may be able to squeak in
15:27:56 <athmane_work> when it's done I'll integrate it into SOP
15:28:08 <j_dulaney> I'm thinking that we may want to review this next week to see if the spin has made it into F16
15:28:27 <athmane_work> j_dulaney: +1
15:29:37 <j_dulaney> #action athmane_work to continue work on Ovirt Node validation testing and matrix; next meeting review if the spin makes the freeze deadline
15:29:44 <j_dulaney> Anything else?
15:30:07 <jboggs> only problem is the spin sig is unresponsive, so we can't get an ack from them
15:30:31 <jboggs> it's at the point of going to the board to get it in, but we need an ack from QA, artwork has already ack'ed
15:31:01 <j_dulaney> jboggs:  The QA side of things seems covered
15:31:16 <j_dulaney> Anyone else +1 for ack?
15:31:16 <jboggs> possible to get an ack or conditional ack for formal porposes?
15:31:50 <j_dulaney> athmane_work:  There isn't anything hindering your test case creation?
15:32:28 <athmane_work> no, afaik
15:32:49 <jboggs> athmane_work, v-m-tui is working in the image, i'll get you a build out this afternoon, when autobuilder is fixed
15:32:50 <j_dulaney> In that case, I'm +1 for QA ACK
15:33:01 <j_dulaney> Anyone else?
15:33:07 <athmane_work> +1 for QA ack
15:33:36 <athmane_work> afaik, only condition is rel reng
15:33:40 <tflink> +1 for QA ACK
15:33:48 <athmane_work> *eng
15:33:56 <j_dulaney> Alright
15:34:27 <jboggs> thanks guys
15:34:27 <j_dulaney> #agreed ovirt spin gets the QA Okay.
15:34:50 <j_dulaney> #topic Upcoming QA Events
15:35:04 <j_dulaney> #info 2011-07-21 - Pre-Alpha Rawhide Acceptance Test Plan #3 - images available, testing in progress by twu
15:35:12 <j_dulaney> #info 2011-07-26 - Test Alpha 'Test Compose'
15:35:19 <j_dulaney> #info 2011-07-29 - Alpha Blocker Meeting (f16alpha) #3 - volunteers to announce blocker meeting?
15:35:39 <tflink> j_dulaney: I can do the blocker meeting announce
15:35:44 <j_dulaney> Anyone want to weigh in on this?
15:35:49 <j_dulaney> Thanks, tflink
15:36:03 <j_dulaney> #action tflink to announce blocker meeting #3
15:37:24 <tflink> when is the alpha TC due?
15:37:53 <jsmith> Tomorrow
15:37:56 <jsmith> I think...
15:38:14 <j_dulaney> Wed 2011-08-03
15:38:22 <j_dulaney> Is the end of TC testing
15:38:25 <jsmith> Hmmmn... the releng calendar has it as tomorrow
15:38:25 <tflink> assuming that the branching doesn't mess with anything :)
15:38:30 <jsmith> http://rbergero.fedorapeople.org/schedules/f-16/f-16-releng-tasks.html
15:38:45 <tflink> jsmith: I think j_dulaney was talking about the end of alpha testing
15:38:48 <j_dulaney> jsmith:  http://rbergero.fedorapeople.org/schedules/f-16/f-16-quality-tasks.html
15:39:05 <jsmith> Ah, gotcha
15:39:22 <j_dulaney> tflink:  It's a week prior to go/no go
15:39:23 <tflink> er, end of alpha TC testing
15:39:53 <j_dulaney> tflink:  Indeed
15:40:38 <j_dulaney> Anything else?
15:41:27 <j_dulaney> #topic Open Discussion - <your topic here>
15:41:57 <j_dulaney> Meeting ending in two
15:43:02 <Southern_Gentlem> ok are there any hackfest that someone for QA like to have at Fudcon blacksburg
15:43:13 <Southern_Gentlem> for/from
15:43:33 <tflink> that's an interesting thought
15:43:44 <j_dulaney> #topic FUDCon Blacksburg QA Hackfests
15:44:16 * j_dulaney was considering an AutoQA hackfest would be cool
15:44:20 <Southern_Gentlem> by that time we should be in the f17 devel cycle
15:44:49 <j_dulaney> Maybe have a 'MiniTestDay?
15:45:07 <j_dulaney> Especially if F17 is branched by that point
15:46:00 <tflink> IIRC, the last FUDCon NA was just before branching
15:46:08 <tflink> not sure about Blacksburg
15:46:30 <j_dulaney> Of course, F14 wound up slipping a wee bit
15:46:43 <Southern_Gentlem> so if you want a hackfest please put it the wiki https://fedoraproject.org/wiki/FUDCon:Blacksburg_2012#Hackfest-_Workshops
15:46:44 <j_dulaney> Even so, we could run a RAT
15:46:53 <tflink> Southern_Gentlem: is there a deadline?
15:47:25 <j_dulaney> #info FUDCon Blacksburg hackfests need to go on the wiki:  https://fedoraproject.org/wiki/FUDCon:Blacksburg_2012#Hackfest-_Workshops
15:47:34 <Southern_Gentlem> tflink,  i am getting the word out, at this point but no deadline has been set yet
15:48:02 <tflink> ok, just making sure. Either way, I assume that getting started earlier may be better :)
15:48:12 <Southern_Gentlem> if one is set it will proable be closer to the hotel cutoff (in my mind at this point Dec 28th)
15:48:33 <j_dulaney> Makes sense
15:49:23 <Southern_Gentlem> tflink,  if  i know about the hackfest i can generate signage eariler and dont have to scamble at the event
15:49:24 <j_dulaney> Anything else?
15:50:54 <j_dulaney> #topic Open Discussion - <your topic here> (#endmeeting in two)
15:52:41 <j_dulaney> Thanks y'all
15:52:45 <j_dulaney> #endmeeting