15:03:45 <jreznik> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2011-07-26
15:03:45 <zodbot> Meeting started Tue Jul 26 15:03:45 2011 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:50 * than is present
15:03:53 <jreznik> #topic roll call
15:03:58 * jreznik is here
15:04:02 <Kevin_Kofler> Present.
15:04:05 * nucleo is here
15:04:20 <rrix> hi
15:04:24 <rdieter> here
15:04:37 <jreznik> #chair than rdieter Kevin_Kofler nucleo rrix
15:04:37 <zodbot> Current chairs: Kevin_Kofler jreznik nucleo rdieter rrix than
15:04:51 <Kevin_Kofler> #meetingname kde-sig
15:04:51 <zodbot> The meeting name has been set to 'kde-sig'
15:05:05 <jreznik> #info Kevin_Kofler jreznik nucleo rdieter rrix than present
15:05:08 <jreznik> Kevin_Kofler: thanks
15:05:29 <jreznik> #topic agenda
15:06:29 <jreznik> kde 4.7
15:06:41 <jreznik> feature freeze/branching today
15:08:21 <jreznik> qt 4.8 issues
15:08:24 <jreznik> anything else?
15:09:12 <Kevin_Kofler> Stopping the splitting madness? ;-)
15:09:17 <rdieter> if there's nothing else, maybe mention raptor2 (and impending redland/soprano stack update)
15:11:01 <jreznik> ok, let's start then
15:11:10 <jreznik> #topic kde 4.7
15:11:30 <jreznik> it's related to the feature freeze/qt 4.8 too :)
15:13:20 <jreznik> so - more than 50% done, I'm still importing/building stuff
15:13:41 <jreznik> for now kdeaccessiblity and kdenetwork fails due to moc regression in qt 4.8
15:14:01 <jreznik> that's probably not regression as trolls thinks it's ok
15:15:02 <than> what is still missing in kdebindings spliting?
15:15:26 <rdieter> fyi, qt-4.8 tracking bug, https://bugzilla.redhat.com/showdependencytree.cgi?id=qt-4.8&hide_resolved=1
15:15:32 <than> i haven't checked it
15:15:36 <rdieter> .bug 712881
15:15:39 <zodbot> rdieter: Bug 712881 qt-4.8 tracker - https://bugzilla.redhat.com/show_bug.cgi?id=712881
15:16:34 <nucleo> KDE 4.7 (rc2) not have by default desktop folder widget (maybe because of problem with it resizing) also Dolphin not have menus by default and looks like rekonq -should we change this defaults?
15:16:36 <rdieter> and related Qt bug, https://bugreports.qt.nokia.com//browse/QTBUG-19717 (moc issue, though it may well get closed NOTABUG)
15:17:01 <rdieter> nucleo: maybe, let's revisit after 4.7.0 is done
15:17:07 <Kevin_Kofler> nucleo: IMHO yes to both, if it's possible.
15:17:19 <Kevin_Kofler> The Plasma stuff should be fixable with a Plasma initialization JavaScript.
15:17:36 <Kevin_Kofler> The Dolphin stuff, if it's configurable, should be one line in a rc file.
15:17:50 <rrix> it is configurable
15:18:24 <Kevin_Kofler> The new defaults look like something coming up from the guys with the foot logo… ;-(
15:18:35 <Kevin_Kofler> No folder view, WTF?!
15:18:56 <Kevin_Kofler> We might consider defaulting to the plain old "the desktop IS a folder view" though, while we are at it.
15:19:09 <jreznik> Kevin_Kofler: actually I'm not fan of folder view - it's better to set folder view as the whole desktop or nothing...
15:19:12 <rrix> Please done :)
15:19:16 <rrix> dont
15:19:44 <nucleo> Almot all apps have menus so maybe Dolphin should look by default the same as other apps
15:20:19 <Kevin_Kofler> So for Plasma: folder view as desktop +1, folder view on desktop +1 (no particular preference), no folder view at all -1 (hey this is not GNOME 3!)
15:20:26 <rdieter> i'm sure upstream had some (good?) reason to change dolphin like that, us arbitrarily second-guessing that without research would be folly, imo
15:20:27 <Kevin_Kofler> For Dolphin +1 to menu by default.
15:20:32 <Kevin_Kofler> Apps without menus suck.
15:20:57 <nucleo> without folderview installation icon on LiveCD will be not visible (should look for it in menus)
15:21:02 <jreznik> I'm fan of less clutter ui without menus (but not removing it completely)... let it as option
15:21:09 <rdieter> but let's postpone any talk about folderview until *after* 4.7.0 is done, it may well have just been a bug
15:21:10 <Kevin_Kofler> That's another argument for showing a folder view by default.
15:21:19 <jreznik> rdieter: +1
15:21:26 <Kevin_Kofler> And overriding upstream defaults is exactly what kde-settings is for.
15:21:30 <Kevin_Kofler> A bug? Not likely…
15:21:52 <rdieter> Kevin_Kofler: do you know for sure either way?  really? :)
15:22:17 <rdieter> if it *was* intentional, I'd like to find out why first.
15:22:17 <Kevin_Kofler> I can try to look up in the history what's going on…
15:22:40 <jreznik> rrix is from plasma land, maybe knows more :)
15:22:56 <rrix> jreznik: I've not done any plasma work for a few months now (not at all during 4.7)
15:23:10 <rrix> Haven't had time/will to work in that group lately
15:23:15 <jreznik> rrix: ok :(
15:23:23 <rrix> I can ask, though
15:24:11 <jreznik> another hit of qt moc bug - kdesdk
15:24:34 <rdieter> .bug 725077
15:24:36 <zodbot> rdieter: Bug 725077 kdesdk (umbrello) FTBFS against qt-4.8.0-beta1 - https://bugzilla.redhat.com/show_bug.cgi?id=725077
15:24:51 <rdieter> .bug 724846
15:24:53 <zodbot> rdieter: Bug 724846 kdenetwork FTBFS against qt-4.8.0-beta1 - https://bugzilla.redhat.com/show_bug.cgi?id=724846
15:25:00 <rdieter> I have these bugs open, nothing for kdeaccessibility ... yet
15:25:30 <rdieter> so much for hoping those would get fixed prior to 4.7.0
15:25:31 <jreznik> ok, I should clean my bugzilla inbox to not oversight this... :(
15:25:44 <jreznik> completely missed this one
15:25:45 <rdieter> I guess we might have to help fix it
15:27:21 <jreznik> but for now the question is - on which side? qt? kde?
15:27:39 <rdieter> jreznik: on kde side, by the looks of it.
15:27:54 <rdieter> https://bugreports.qt.nokia.com//browse/QTBUG-19717   thiago says it's a kde bug
15:28:03 <jreznik> rdieter: but for now we can try to look what has been changed on qt side
15:28:11 <rdieter> ie, kde code doing something that is unsupported
15:28:21 <jreznik> and forward-port it until fixed in kde
15:28:23 <Kevin_Kofler> The problem is, I don't know how easy it is to fix the KDE code which is doing the nasty stuff.
15:29:04 <Kevin_Kofler> This is where the folderview by default got dropped: https://projects.kde.org/projects/kde/kdebase/kde-workspace/repository/revisions/70e746d3fae467c52ab91cb7e8b5b10f2519248b
15:29:37 <Kevin_Kofler> I think we should add a 01-fedora-defaultLayout.js which adds the folder view.
15:30:01 <Kevin_Kofler> That or make the folder view the default containment in the first place.
15:30:02 <rrix> (re folder view: [08:29] <einar77_work> rrix: a release mistake,  as far as I can tell)
15:30:10 <rdieter> Kevin_Kofler: perhaps so, the commit message doesn't say why
15:30:17 <rrix> oh
15:30:22 <rrix> fun
15:30:34 <Kevin_Kofler> rrix: Please point them to this commit and ask them to explain what's going on.
15:30:40 * rrix just did
15:31:03 <Kevin_Kofler> OK
15:31:24 <rrix> Though I'm pretty sure einar isn't an actual plasma dev... I'm sure aseigo will have some nonsense opinion about why it was dropped etc etc eventually :)
15:31:41 <jreznik> rrix: :)
15:32:01 <Kevin_Kofler> As I said, I'm for the 01-fedora-defaultLayout.js solution.
15:32:08 <Kevin_Kofler> Just stick the folder view creation code in there.
15:32:41 <Kevin_Kofler> Allowing customization of defaults in distros is exactly what that JS mechanism is for.
15:32:42 <rdieter> yeah, though we can rethink what we want our default layout to be and include.  while we're customizing, we may as well consider going beyond simply adding a folderview
15:32:48 * rrix grumbles at #plasma being dorks
15:33:44 <rdieter> rrix: patience padawan
15:34:22 <Kevin_Kofler> What else would you want on the desktop by default? xkcd? ;-)
15:34:43 <jreznik> :)
15:35:00 <rdieter> perhaps we can brainstorm on that topic onlist this coming week
15:35:03 <jreznik> rdieter: +1!
15:35:20 <nucleo> also in rc2 was Dolphin and Konqueror launchers on panel added and no way to remove them (after restart they appears again) don't know is this bug or feature
15:35:51 <Kevin_Kofler> Uhm, if they reappear after each restarts, at least that is a bug.
15:35:54 <rdieter> nucleo: my f15 + kde-unstable box doesn't exhibit that behavior,odd
15:35:58 <Kevin_Kofler> *restart
15:36:07 <rrix> <ervin> was the result of discussions at tokamak 5 about the renewed desktop defaults
15:36:54 <jreznik> ah, "clean and lean"
15:37:16 <nucleo> rdieter: on nightly-composes  LiveCD this can be seen (last CD boots only with selinux=0)
15:37:25 <rrix> which is .. silly, but my opinion doesn't count for much these days
15:37:32 <jreznik> isn't the right time to start writing our own kde/qt based desktop? :)
15:37:37 <nucleo> start it, remove launchers and logout/login
15:37:49 <rdieter> rrix: yeah, I don't think it's practical for a distro to ship an empty desktop
15:38:02 <jreznik> rdieter: ask gnome guys :)
15:38:08 <jreznik> what they think :)
15:38:09 <rrix> rdieter: I agree, completely. Thankfully we have a javascript interface to easily fix that :)
15:38:09 <Kevin_Kofler> As I said, the init JS feature is exactly there for distros to customize the defaults.
15:38:15 <jreznik> Kevin_Kofler: +1
15:38:17 <rrix> Yup
15:38:18 <Kevin_Kofler> All we need to do is to ship a .js file.
15:38:21 <Kevin_Kofler> Let's just do that.
15:38:48 <jreznik> #agreed to enable folder view by default (or desktop folder view even?)
15:39:07 <Kevin_Kofler> Last I checked, Kubuntu had much more custom Plasma JS than us.
15:39:32 <Kevin_Kofler> We only have migration code, some of which is based on Kubuntu code.
15:39:35 <rdieter> true
15:39:39 <rrix> What about also replacing the task amanger with something like smooth tasks?
15:39:59 <rdieter> though I'd still propose not limiting ourselves to *just* a folderview widget yet, let's brainstorm, see if we can come up with something better
15:40:02 <jreznik> it should be easy to mimic gnome-shell :)
15:40:39 <jreznik> ok, let's move on
15:41:01 <rdieter> moveon++
15:41:09 <jreznik> #topic feature freeze/branching today
15:41:49 <jreznik> I hope I'll make initial import of 4.7 today, we still need at least smoke* splits (under review now)
15:42:32 <Kevin_Kofler> rrix: When I tried smooth tasks, it had some showstopper annoyances, IIRC one of them was even a crash.
15:42:53 <than> jreznik: i uploaded new smokegen-4.7.0-1
15:42:57 <rdieter> jreznik: do we really *need* smoke?  what functionality are we missing without it?
15:43:13 <rdieter> do any other packages/software in the distro use it?
15:43:16 <rrix> Ah. It mostly works on the machines I support, but I don't use it personally. i'll trust your use of it before my nonuse :)
15:43:49 <than> rdieter: it seems not, but we have to check
15:44:03 <rdieter> note, I'm not saying don't package smoke... just that it need not be a priority either (yet)
15:44:14 <rdieter> more... a nice-to-have
15:44:24 <than> rdieter: +1
15:44:26 <jreznik> with the rest of kdebindings
15:44:39 <jreznik> I've never seen anything using perl-kde :)
15:44:40 <Kevin_Kofler> Users who are using Korundum for their scripts will need it.
15:44:43 <jreznik> but ruby is needed
15:44:46 <than> jreznik: what is still missing in kdebindings splitting?
15:45:01 <than> except smoke*
15:45:25 <jreznik> than: kimono, korundum, perl*, qtruby, qyoto
15:45:33 <jreznik> and finish smoke
15:45:38 <Kevin_Kofler> That's basically all smoke-based, isn't it?
15:45:49 * rdieter thinks so
15:45:49 <than> Kevin_Kofler: yes
15:45:52 <Kevin_Kofler> I think Korundum is probably the most used of these.
15:46:12 <Kevin_Kofler> But there's at least one program written in Kimono/C# out there.
15:46:20 <rrix> there is?
15:46:28 * rrix has never seen one
15:46:53 <jreznik> ruby is the must, I know a few people using it
15:47:11 <Kevin_Kofler> I don't think we package that C# app.
15:47:18 <Kevin_Kofler> I just remember having seen one once.
15:47:36 <rdieter> jreznik: ok, I'll make sure to help out when I get back from vacation
15:48:16 <nucleo> by the way LiveCD size is 718 M
15:48:38 <jreznik> rdieter: thanks and have a nice vacation!
15:48:48 <Kevin_Kofler> Ugh, we need to fix that size mess too.
15:48:54 <Kevin_Kofler> I wonder where the bloat is coming from.
15:49:05 <Kevin_Kofler> We don't have any new stuff on it that I noticed.
15:49:23 <Kevin_Kofler> (except Kamoso, which is definitely not that large)
15:49:51 <Kevin_Kofler> We even have xine-lib removed.
15:50:07 <Kevin_Kofler> Where does the new bloat come from?
15:50:27 <rdieter> it'll take running/installing it, to see for sure.
15:50:56 <rdieter> or... we can revisit the 'make our spin bigger' topic
15:51:34 <Kevin_Kofler> We could also make use of the splits going on and remove some less needed apps, if we can identify them.
15:51:48 <rdieter> personally, I look forward to the day when fedora-kde spin and yum install @kde-desktop   are closer
15:51:59 <rdieter> Kevin_Kofler: yeah
15:52:00 <rrix> the problem is that the less needed apps are usually tiny :)
15:52:28 <Kevin_Kofler> Right.
15:52:42 <Kevin_Kofler> That's always the problem I'm running into when I need to fix size overruns.
15:52:52 <Kevin_Kofler> It's hard to find one offender.
15:53:15 <jsmith> Wait, we went from ~550mb to ~718mb?
15:53:25 <jsmith> That does sound a bit much...
15:53:45 * jsmith could be remembering the previous size wrong
15:54:16 <jreznik> jsmith: kde spin
15:54:35 <nucleo> F15 CD was 692 mb
15:55:00 <Kevin_Kofler> This creeping biggerism really annoys me. At each release, packages are getting slightly bigger, for no particular reason.
15:55:52 <Kevin_Kofler> I could try zapping Digikam to save some size.
15:56:04 <Kevin_Kofler> But it annoys me that I can't find the true source of the bloat.
15:56:40 * jreznik is getting bigger but he knows the reason...
15:56:41 <rdieter> another todo is analyze the size, look for odd dep tree issues.  i'll do that when I get a chance
15:57:41 <nucleo> hugin-base is needed for expoblending in kipi-plugins
15:58:06 <rdieter> ah, yeah, that's... huge.
15:58:27 <Kevin_Kofler> How large is hugin-base?
15:58:34 <rdieter> almost 24mb installed
15:58:39 <Kevin_Kofler> Is it larger in F16 than F15?
15:58:54 <rdieter> well, ~24mb on my f15 box
15:59:18 <rdieter> closer to ~23mv on my f14 box
15:59:24 <Kevin_Kofler> So what should I drop first? Digikam? kipi-plugins? Both?
15:59:24 <rdieter> mb even
15:59:25 <nucleo> almost the same 5.7 mb and 5.8 when compressed
15:59:33 <nucleo> in rpm
15:59:46 <Kevin_Kofler> I think we'll probably have to kill both anyway if we want to fit.
16:00:04 <nucleo> or leave at least kipi-plugins
16:00:06 <rdieter> nuke those 2 for starters, until we have a chance to look closer for better options
16:00:14 <jreznik> +1
16:00:24 <Kevin_Kofler> OK, so I'll disable them both and see where we stand.
16:00:56 <Kevin_Kofler> If we're still too big, Krusader will be the next thing to go, I only added it because there was room left. But removing it alone won't save 18 MiB.
16:01:09 <jreznik> ok, time is over today...
16:01:12 <nucleo> FYI I will be on vacation all August
16:01:13 <Kevin_Kofler> (It's the usual problem, the stuff which is easiest to remove is too small.)
16:01:25 <jreznik> nucleo: lucky guy :)
16:01:34 <jreznik> Kevin_Kofler: as always
16:02:01 <jreznik> ok, anything else? or I'll end it here -> #fedora-kde
16:02:09 <rdieter> that's good enough
16:02:25 <jreznik> thanks guys
16:02:28 <jreznik> #endmeeting