19:01:31 <rbergeron> #startmeeting Cloud SIG
19:01:31 <zodbot> Meeting started Fri Jul 29 19:01:31 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:35 <rbergeron> #meetingname Cloud SIG
19:01:35 <zodbot> The meeting name has been set to 'cloud_sig'
19:01:38 <rbergeron> #topic Roll call
19:01:44 * kkeithley yawns
19:01:50 * rbergeron sips on her delicious appletini, thanks Southern_Gentlem :)
19:01:55 * rbergeron thinks we may be thin today.
19:01:56 * tflink is present
19:02:02 <rbergeron> kkeithley: is jdarcy still out of town?
19:02:09 <kkeithley> he is
19:02:14 * athmane here
19:02:57 <jforbes> 3/me is here
19:03:04 <rbergeron> oh, there you are.
19:03:09 <rbergeron> Okay, let's get going.
19:03:10 <jforbes> indeed
19:03:12 <rbergeron> #topic EC2 status
19:03:24 <rbergeron> #info MY FAVORITE-EST TOPIC
19:03:35 <rbergeron> jforbes: any news from rel-eng at this point?
19:03:47 <jforbes> From what I have seen in the ticket, they are still working through script issues there, so nothing to test yet
19:03:59 <rbergeron> okay.
19:04:11 <jforbes> On the other hand, I did create some documentation to for others to follow in creating their own EC2 images using boxgrinder
19:04:14 * rbergeron saw jgreguske come in... thanks for your help there, along with dgilmore's.
19:04:14 <jforbes> https://fedoraproject.org/wiki/Cloud_SIG/EC2_Creation
19:04:19 <rbergeron> oh really.
19:04:21 * rbergeron checks it out
19:04:34 <rbergeron> #info rel-eng is still working through script issues on koji-->EC2 stuff.
19:04:36 <jgreguske> I've been working with dgilmore on it, but progress has been slow.
19:04:49 <rbergeron> jgreguske: is that a time issue, or just a technical issue?
19:04:55 <jforbes> Yes, it is a pretty simple process, and the appliance definition files are now being hosted in the cloud-kickstarts git tree on fedorahosted.org
19:05:37 <jgreguske> I have not found as much time to work on this as I hoped, and there are technical issues too that we're working through
19:05:50 * jgreguske lets jforbes finish
19:05:53 <rbergeron> jforbes: this is awesome, thanks!
19:06:22 <jforbes> No problem, I figure it lets the rest of the world move on instead of blocking on getting official images out there.
19:07:17 <tflink> it sounds like there is only one more outstanding issue - https://fedorahosted.org/rel-eng/ticket/4808
19:07:55 <rbergeron> yeah. So I guess that's the question. Ideally, in an ideal world, we'd have it all rolled into koji and automated. But it's starting to look, timewise, like that's going to take more time than we have if we want to get help from QA, since they're going into test-day mode, and we'd like to get this f15 test done before f16 kicks off.
19:08:31 <jforbes> Well, we also need F16 alpha images
19:08:31 <rbergeron> and QA noted 8/1 as a date. jgreguske, can i safely assume you want to have a life this weekend? I hate feeling like we've been pestering you and dgilmore to death, to just change tracks.
19:08:37 <rbergeron> I think one thing.. yeah, F16 alpha images.
19:08:49 <rbergeron> So maybe we could continue working with rel-eng towards F16 alpha image creation,
19:09:01 <rbergeron> and just use the BG-created ones for F15.
19:09:05 <rbergeron> thoughts?
19:09:12 * rbergeron is especially interested in what rel-eng, QA have to say here.
19:09:16 <rbergeron> not that i don't adore justin and all.
19:09:16 <rbergeron> :)
19:09:40 <tflink> QA seems to be fine with the idea of using the BG images for F15
19:09:48 <tflink> we just wanted to get the F15 test day done
19:09:53 <rbergeron> yeah.
19:09:55 <rbergeron> asap.
19:09:58 <jgreguske> I'm not Fedora Rel-Eng (dgilmore!) but if 8/1 is the drop-dead date and rel-eng doesn't have "official images" lets go with BG
19:10:00 * ke4qqq shows up late
19:10:02 <rbergeron> right
19:10:15 <rbergeron> dgilmore: are you about by chance?
19:10:17 <jgreguske> and hopefully rel-eng will have official ones for f16
19:10:47 <rbergeron> jgreguske: do you think it's reasonable to try and have koji-generated images by alpha time? (8/16)
19:10:57 <rbergeron> or do you think you/dgilmore will have to work on it
19:11:10 * rbergeron realizes you are not fedora rel-eng, but appreciates the help IMMENSELY
19:11:12 <jgreguske> koji builds them fine (imo) we're just stuck on uploading
19:11:17 <rbergeron> or perhaps we should just ping in the ticket
19:11:22 <jgreguske> I think that would be best
19:11:22 <rbergeron> what's stuck about uploading exactly?
19:11:26 <rbergeron> automating that part?
19:11:27 <rbergeron> Okay.
19:11:58 <jgreguske> presently when the upload script sends the partition image (.raw file) to an EBS volume, we run out of space
19:11:59 <rbergeron> So I think we can all agree that (a) We'll use BG-generated ones for F15, so we can get it done, and (b) work with rel-eng towards Alpha koji-generated images.
19:12:11 * rbergeron looks for nodding heads
19:12:30 * jforbes nods to the point of whiplash
19:12:45 <jforbes> Though that could just be the music playing here :)
19:12:53 <rbergeron> lol
19:13:00 <rbergeron> careful. don't hurt yourself
19:13:06 <tflink> works for me
19:13:12 <rbergeron> athmane: does that work for you?
19:13:31 <jgreguske> honestly since I'm flying across the country on Sunday, I'm not too convinced we'll have rel-eng sanctioned images
19:13:40 <rbergeron> #agreed We'll use BG-generated images for F15, and work with rel-eng towards alpha koji-generated images.
19:13:44 <rbergeron> sanctioned for F16?
19:13:48 <rbergeron> or sanctioned by 8/1
19:13:48 <jgreguske> for f15
19:13:50 <rbergeron> for F15
19:13:52 <rbergeron> okay
19:14:05 <rbergeron> yeah, i figured you/dennis weren't wanting to slave all weekend either. :)
19:14:33 <rbergeron> tflink, athmane: so let's proceed wiht a test day. when is good, how long do we need for advertising?
19:14:40 <rbergeron> Do we want to go back to the tuesday plan, or is there a good day in mind?
19:14:53 <tflink> the 8/4 test day is still unclaimed
19:15:42 <jforbes> That works, I will not be around from the 6th - 18th
19:15:44 <tflink> I don't see a problem with doing the test day any of 8/2 - 8/4 if we're using the BG AMIs
19:15:55 <athmane> sorry, I'm doing other stuff
19:16:11 <rbergeron> athmane: no worries
19:16:30 <rbergeron> tflink: is it best to use the 8/4 date for something that's actually F16?
19:16:44 <rbergeron> I think it would work well in terms of having time to advertise and such
19:16:58 <tflink> the odds of something coming together by then are slim
19:17:02 <tflink> something else, I mean
19:17:03 <athmane> note that we need some people during test day
19:17:05 * rbergeron nods
19:17:09 <rbergeron> yep, we do.
19:17:26 * rbergeron notes she can be around, because she's always so... um... helpful about this kind of stuff.
19:17:32 <jforbes> I will be around as long as it is next week
19:17:33 <athmane> from qa and cloud-sig
19:17:41 <rbergeron> knowing if gholms is around would probably be helpful.
19:17:42 * jgreguske will be gone
19:17:55 <rbergeron> oh, he's on vacation all next week.
19:18:03 <tflink> I'll be around next week
19:18:16 <rbergeron> Well, we'll have cloud folks around who will want to help. even if i have to learn via trial by fire. ;)
19:18:26 <jforbes> The week after that, I will be on vacation, followed by KVM Forum/Linuxconf
19:18:30 <rbergeron> jforbes: does 8/4 work for you? athmane?
19:18:41 <jforbes> rbergeron: 8/4 works for me
19:18:43 <rbergeron> jforbes: ooh, you'll be at linuxcon too? :)
19:18:48 * rbergeron will have to buy you a beeyor.
19:19:04 <athmane> I'm always available after 18:00 utc+1
19:19:38 <jforbes> rbergeron: Well, KVM Forum is co hosted with it, technically I will be in team meetings most of that time, but I will be around until 8/17
19:19:46 <rbergeron> cool.
19:19:54 <jforbes> And certainly in need of beer
19:20:04 <rbergeron> okay, let's schedule it for 8/4, and start advertising... Monday morning? tflink, athmane, does that work?
19:20:15 <tflink> works for me
19:20:18 <athmane> +1
19:21:01 <jforbes> Sounds good, I will get word out on the planet and socials
19:21:53 <rbergeron> okay.
19:22:08 <rbergeron> #agreed F15 EC2 test day will be 8/4.
19:22:17 <rbergeron> What do we need to do between now and then?
19:22:19 <rbergeron> tflink, thoughts?
19:22:39 <athmane> update wiki page
19:22:41 <tflink> mostly get the word out, I think
19:22:57 <athmane> prepare announcement
19:23:03 <tflink> and figure out what's going on with the credits for the first x testers
19:23:14 <tflink> what will happen, rather
19:23:49 <rbergeron> okay. who is taking responsibility for that stuff?
19:24:05 <tflink> I can do the announcements
19:24:17 <rbergeron> #action tflink to do announcements for F15 ec2 day
19:24:20 <athmane> I update the wiki
19:24:33 <rbergeron> #action athmane to update ec2 test day wiki
19:24:44 <rbergeron> #action rbergeron to praise everyone for their awesomeness
19:24:50 <rbergeron> anything else?
19:24:59 <rbergeron> oh.
19:25:17 <rbergeron> #action rbergeron to ping in rel-eng ticket about viability of producing something for F16 alpha from koji
19:25:18 <athmane> someone please send me ami ids
19:25:24 <jforbes> nothing else from me
19:25:26 <rbergeron> jforbes: same AMI ids?
19:25:35 <rbergeron> can you shoot them over to athmane?
19:25:39 <rbergeron> or the list, whatever?
19:25:45 <jforbes> athmane: AMI IDs are on https://fedoraproject.org/wiki/Cloud_SIG/EC2_Images
19:25:54 <athmane> ok, noted
19:26:00 <rbergeron> #info AMI IDs are on https://fedoraproject.org/wiki/Cloud_SIG/EC2_Images
19:26:07 <rbergeron> excellent. moving on
19:26:08 <rbergeron> #topic CloudFS
19:26:14 <rbergeron> kkeithley: hi
19:26:36 <rbergeron> kkeithley: any updates/issues/questions?
19:26:42 <kkeithley> one
19:27:11 <kkeithley> wondering if I'm playing the karma game to get the cloudfs (and gluster) rpms into f16 or not
19:27:25 <rbergeron> how is that?
19:27:26 <rbergeron> oh
19:27:39 <kkeithley> I didn't see the cloudfs in the f16 mail
19:27:43 * rbergeron has no idea. does it need love?
19:27:46 <rbergeron> okay.
19:27:55 <rbergeron> ummmm - anyone else have thoughts? ke4qqq perhaps?
19:29:11 * tflink isn't sure what you're talking about
19:29:17 <tflink> does cloudFS need testing/karma?
19:29:48 <rbergeron> yeah, i'm not quite sure what kkeithley means but.. :)
19:29:53 <athmane> tflink: I guess yes
19:30:08 <athmane> unless it pushed into rawhide
19:30:21 <rbergeron> if you need testing/karma, the best place to start is asking on the cloud-sig list, probably, or perhaps doing a blog post, etc.
19:30:28 <kkeithley> there was an email <trying to find it> for the f16 branch/build and I didn't see that CloudFS was part of the F16 build
19:30:29 <tflink> otherwise, I think we'd have to wait for the branching process to be finished
19:30:37 <rbergeron> hrmmm
19:30:56 <kkeithley> or maybe it was rawhide
19:31:31 <rbergeron> kkeithley: maybe a mail would be best at this point to the cloud-sig list just asking if someone can clarify maybe.
19:31:38 <kkeithley> okay
19:31:39 <rbergeron> perhaps fwd the mail you go?
19:31:40 <rbergeron> got
19:31:53 <rbergeron> and ask whatever you need to know.
19:31:57 <rbergeron> ;) sound good?
19:32:22 <kkeithley> I think I found the email, it's a broken deps list, so maybe a non-issue
19:32:27 <kkeithley> false alarm
19:32:34 <rbergeron> oh. okay
19:32:36 <tflink> it looks like cloudfs-0.7-5 is in f16
19:32:37 <rbergeron> ;)
19:32:41 <rbergeron> anything else then? ;)
19:32:44 <rbergeron> tflink: excellent
19:32:47 <tflink> http://koji.fedoraproject.org/koji/buildinfo?buildID=256218
19:33:11 <kkeithley> okay, good, thanks
19:33:12 <tflink> waiting for push into updates (if you can call it that)
19:33:36 <rbergeron> awesome. thanks, tflink, for the help there.
19:33:40 <tflink> np
19:33:41 * rbergeron shall move on
19:33:43 <kkeithley> what does that mean
19:33:48 <rbergeron> oh, i'll hold
19:33:55 <tflink> the push comment?
19:34:03 <kkeithley> yeah
19:34:20 <tflink> there isn't really an updates repo for pre-release
19:34:38 <kkeithley> so it's okay then?
19:34:41 <tflink> yet the build is tagged dist-f16-updates-candidate which usually means that it is about to get pushed to updates
19:34:50 <tflink> yeah, I imagine this is an artifact of the branching process
19:35:06 <rbergeron> okay.
19:35:08 <kkeithley> okay, I'll sit tight and hope everything is okay then
19:35:08 * tflink doesn't pretend to be a koji tag expert
19:35:13 * rbergeron grins
19:35:16 <rbergeron> #topic Other Business
19:35:28 <rbergeron> clalance sent some updates on aeolus to the list, iirc.
19:35:34 <rbergeron> anyone else have anything?
19:36:00 <athmane> is ovirt node cloud-sig business ?
19:36:43 <rbergeron> athmane: it's more spins-sig business, at the moment, or "what to do in lieu of lack of spins-sig movement" business
19:36:56 <rbergeron> i know jsmith is looking into it at the moment.
19:36:57 <athmane> ok
19:37:22 <rbergeron> if it's not getting traction, we could perhaps take a look at it, but let's hold off and see where it gets in the next few days.
19:37:37 <rbergeron> but technically it's spins-sig stuffs.
19:37:41 <jsmith> Gimme until early next week to try to get some consensus on what to do to move forward
19:38:12 <athmane> jsmith: ok
19:38:14 <rbergeron> anyone else?
19:38:35 <verdurin> rbergeron: just a reminder to post the minutes to the mailing list...
19:38:48 <rbergeron> verdurin: i've done that diligently-ish for the past 2 weeks :D
19:38:49 * rbergeron grins
19:39:24 <rbergeron> anyone else?
19:39:29 <rbergeron> anyone? bueller?
19:39:30 <rbergeron> okay.
19:39:38 * rbergeron waves and thanks everyone for coming
19:39:43 <rbergeron> cheers, have a good weekend, folks
19:39:48 <rbergeron> #endmeeting