21:05:45 <adamw> #startmeeting F16 Alpha Go/No-Go Meeting (redux)
21:05:45 <zodbot> Meeting started Wed Aug 17 21:05:45 2011 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:05:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:05:58 <adamw> #meetingname F16 Alpha Go/No-Go Meeting #2
21:05:58 <zodbot> The meeting name has been set to 'f16_alpha_go/no-go_meeting_#2'
21:06:18 <adamw> #topic roll call
21:06:22 <adamw> yeah so who's here
21:06:24 * nirik waves.
21:06:26 * tflink is present
21:06:29 * thedonvaughn is here
21:06:30 * pjones is extant
21:06:31 * athmane is around
21:06:34 <gr72> is here
21:06:41 * nb is around
21:06:47 * cebbert here
21:06:54 <adamw> ooh, big crowd.
21:06:54 * Viking_Alpha here
21:07:20 * BobLfoot waves
21:07:24 <gr72> how do you do the blue?
21:07:33 <adamw> #info present nirik tflink, thedonvaughn, pjones, athmane, gr72, nb, cebbert, viking_ice, boblfoot
21:07:37 <adamw> gr72: try /me something something
21:07:49 <adamw> #topic preamble
21:07:52 * gr72 here'
21:07:58 <gr72> oh thank you.
21:08:17 <adamw> so, to crib shamelessly from rbergeron:
21:08:18 <adamw> #info the Purpose of the Go/No-Go is to gather yay/nay's from Release Engineering, QA, and devel on whether or not what we have put together is ready for release and meets the release criteria.
21:08:31 <adamw> we seem to be missing release engineering. let me go rustle up a dgilmore, if i can.
21:08:52 <rbergeron> ugh!
21:09:02 <nb> rbergeron, welcome :)
21:09:08 <adamw> we have https://fedoraproject.org/wiki/Go_No_Go_Meeting to document the meeting
21:09:09 <rbergeron> sorry, my watch is apparently incorrect :(
21:09:13 <adamw> #chair rbergeron
21:09:13 <zodbot> Current chairs: adamw rbergeron
21:09:16 * rbergeron thanks adamw for starting things
21:09:17 <adamw> #chair jsmith
21:09:17 <zodbot> Current chairs: adamw jsmith rbergeron
21:09:20 <adamw> rbergeron: wanna take over?
21:09:47 <rbergeron> adamw: surely, though I don't know there is much to "take over with" :)
21:09:48 * jsmith is here
21:10:08 <rbergeron> So adam went over the purpose of us being here.
21:10:24 * rbergeron looks to QA to see if release criteria have been met.
21:10:36 <rbergeron> #link http://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria
21:10:49 <adamw> try that once more
21:10:58 <rbergeron> One of the major points in the Alpha release criteria is the status of blocker bugs, and specifically whether or not there are any remaining at this point.
21:11:02 <rbergeron> oh, lord.
21:11:13 <rbergeron> #link http://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
21:11:17 <rbergeron> My bad.
21:11:26 <adamw> right-ho!
21:11:32 <rbergeron> #link https://fedoraproject.org/wiki/Current_Release_Blockers
21:11:37 <adamw> yup
21:11:41 <adamw> and also the validation matrices:
21:11:42 <jsmith> Yeah, that looks good :-)
21:11:49 <adamw> https://fedoraproject.org/wiki/Test_Results:Fedora_16_Alpha_RC5_Install
21:11:58 <adamw> https://fedoraproject.org/wiki/Test_Results:Fedora_16_Alpha_RC5_Base
21:11:58 <rbergeron> #info There are no remaining proposed blockers, and no unresolved approved blockers.
21:12:11 <adamw> https://fedoraproject.org/wiki/Test_Results:Fedora_16_Alpha_RC5_Desktop
21:12:32 <adamw> as you can see from the references, there are no open unaddressed blockers; all blockers are in VERIFIED state, which means they're fixed in RC5 and the fix has been tested
21:12:41 * rbergeron nods
21:12:43 <adamw> (they're not CLOSED because the fixes haven't been pushed out to the f16 repo yet)
21:12:57 <adamw> and as you can also see, all the Alpha-level validation tests have been completed
21:13:13 <adamw> for at least one arch, in many cases two
21:13:36 <adamw> you may notice a few FAILs on tests that are marked as 'alpha', but we've reviewed all those and they're not blockers; some of the tests are miscategorized, which we'll fix later
21:13:51 <rbergeron> miscategorized as to alpha/beta?
21:14:02 <adamw> so...in conclusion, the criteria on https://fedoraproject.org/wiki/Go_No_Go_Meeting for QA to declare Alpha 'go' are met, hence, QA votes 'go'!
21:14:11 <adamw> rbergeron: yup
21:14:13 * rbergeron cheers.
21:14:25 * Viking_Alpha double cheers
21:14:29 <adamw> oh, there was one thing we wanted to bring up
21:14:30 * thedonvaughn tripple cheers
21:14:38 * gr72 quadrupile cheers
21:14:47 * rbergeron yields to adamw
21:14:53 <adamw> pjones alerted me to the bug https://bugzilla.redhat.com/show_bug.cgi?id=731529
21:15:06 <adamw> well, rather, to another bug which is the RHEL parent of that bug; i made a fedora copy of it for our purposes
21:15:24 <adamw> it's a showstopper for some systems when using EFI.
21:15:27 <thedonvaughn> hrm
21:15:33 <adamw> it kinda sucks, but...some considerations
21:15:38 <adamw> currently we consider EFI, broadly, to be Beta stuff
21:15:43 <adamw> the bug was in F15 as shipped
21:15:53 <rbergeron> but not documented specifically as part of criteria?
21:15:56 <adamw> and there's a workaround on most hardware: most EFI systems have a BIOS compatibility mode you could use
21:16:12 <adamw> rbergeron: it is, actually: beta "The installer must boot and run on systems using EFI other than Apple Macs "
21:16:23 <rbergeron> adamw: ah, very good
21:16:26 <adamw> i'm not entirely happy with the criteria 'logic' there (see test list posts today), but the intent is clear.
21:16:27 <Viking_Alpha> document in the alpha release notes have it fixed by beta?
21:16:34 * rbergeron didn't remember that one offhand
21:16:53 <rbergeron> yeah, documenting it as a known issue is probably a good idea.
21:16:54 <jsmith> Viking_Alpha: +1
21:16:58 <adamw> Viking-Ice: that was my inkling on this bug, yeah; if it had been found earlier certainly would've been NTH, but i don't think it quite merits blocker
21:17:04 <pjones> Viking_Alpha: that was the conclusion adamw and I came up with earlier, yes
21:17:09 <adamw> we wanted to bring it up in case others had a different view, though
21:17:25 * nirik agrees with document and fix by beta
21:17:30 <cebbert> yeah, i can't see holding the alpha for that
21:17:30 <thedonvaughn> the bug is also marked F16Beta; which i agree with
21:17:38 <rbergeron> I think it certainly seems to be a reasonable idea to include that in release notes, and note it is a beta blocker, and should be fixed by that time.
21:17:43 * gr72 agrees with document and fix by beta
21:17:53 * rbergeron seems to think everyone is in agreement here, so...
21:18:18 <rbergeron> propose agreed: document 731529 as a known bug, to be fixed by beta as it is a blocker, in alpha release notes
21:18:32 * gr72 concur
21:18:34 <tflink> ack
21:18:36 <jsmith> ACK
21:18:38 <nb> +1
21:18:41 <rbergeron> #agreed: document 731529 as a known bug, to be fixed by beta as it is a blocker, in alpha release notes
21:18:43 <thedonvaughn> ack
21:18:48 <Viking_Alpha> ack
21:18:56 <nb> rbergeron, i don't think you want the :
21:18:59 <nb> after agreed
21:19:02 * nirik makes an ack noise.
21:19:05 <rbergeron> #agreed document 731529 as a known bug, to be fixed by beta as it is a blocker, in alpha release notes
21:19:30 <rbergeron> #action rbergeron to copy docs for release notes purposes on meeting minutes
21:19:46 <rbergeron> adamw, anything else along those lines?
21:19:50 <adamw> nope, that's it
21:19:52 <rbergeron> otherwise, i'll move on to rel-eng.
21:19:53 <rbergeron> okay
21:19:56 <adamw> so we're good with rc5
21:20:20 <rbergeron> #info QA is a 'go' - no remaining unresolved blockers, test matrices look good.
21:20:24 <rbergeron> #topic release engineering
21:20:40 <rbergeron> dgilmore: any issues, problems, etc.?
21:21:33 <nirik> FWIW, I don't know of any rel-eng blockers.
21:22:02 <rbergeron> nirik: thanks. I'd assume as much at this point. :)
21:22:13 <adamw> me either
21:22:20 <adamw> i dunno if a grue's eaten him, but afaik dgilmore is go
21:22:22 <rbergeron> okay.
21:22:52 <rbergeron> #info release engineering is a 'go', no issues are known, nirik is channeling dgilmore. :)
21:22:58 <rbergeron> #topic Devel
21:23:11 <nirik> I know of no devel/fesco issues either. ;) We are go.
21:23:14 <rbergeron> nirik: I'll look to you to speak up for fesco/devel.
21:23:15 <rbergeron> ;)
21:23:19 <clumens> kick out the jams.
21:23:26 <rbergeron> #info Nirik is in for fesco/devel - he is a go.
21:23:34 <rbergeron> #topic It's a go!
21:23:37 <rbergeron> Okay, folks.
21:23:41 <jsmith> Woo hoo!
21:23:41 <nirik> hurray!
21:23:45 <thedonvaughn> huzzah!
21:23:48 * nirik throws confetti.
21:23:55 <rbergeron> #info Release will be tuesday, 2011-08-23.
21:23:58 * gr72 gives a whoot whoot
21:24:00 * jsmith celebrates by installing RC5 on another machine
21:24:05 <rbergeron> #action rbergeron to send out meeting notes to appropriate lists.
21:24:25 <thedonvaughn> just curious, why such a delay before the release?
21:24:27 <rbergeron> #info RC5 is our guy. All parties needed for this meeting agree that we are GO.
21:24:43 <nirik> thedonvaughn: mirrors need to sync up
21:24:48 <thedonvaughn> gotch'ya
21:25:05 <nirik> although I don't think it takes as long as it used to.
21:25:05 <robatino> why not release the signed checksum file and let BitTorrent take care of it?
21:25:17 <nirik> robatino: before mirrors?
21:25:33 <rbergeron> #topic Any other business?
21:25:35 <robatino> mirrors aren't really crucial
21:25:47 <pjones> o_O
21:25:58 * nirik disagrees. Torrent is nice and all, but downloads from mirrors are very crucial.
21:26:10 * gr72 concur
21:26:12 <pjones> yes.
21:26:32 * jsmith agrees
21:26:36 <robatino> but why not make it available by torrent before the mirrors?
21:26:39 * rbergeron doesn't want to go down a rabbit hole here, but thinks if people want to propose alternatives, they'd be welcome on mailing lists, etc. :) we aren't going to make vast changes today.
21:26:52 * rbergeron grins
21:27:14 <jforbes_kvmforum> people who really want it know where to get the RC, it is posted to the test list
21:27:55 <rbergeron> there are plenty of other activities that go with the alpha release as well - doccs needs time to add additional notes to release notes as a result of this meeting, marketing does things, things are very lined up at this point.
21:28:01 <nirik> robatino: in the past I seem to recall that mirrors disliked torrents happening before they release, because then they wonder why they bother. ;)
21:28:12 <nirik> yeah.
21:28:23 <nirik> I would like us to possibly consider making the go/no-go later tho.
21:28:28 <nirik> but thats outside the scope of this.
21:28:38 <adamw> i use the week to set up commonbugs, fwiw.
21:28:56 <adamw> the repo mirroring is also crucial for net installs
21:29:04 <rbergeron> so if there's nothing else for *this* meeting... :)
21:29:05 <adamw> we need to make sure mirrors have the rc5 package set so net installs work as intended
21:29:12 <adamw> not here!
21:29:17 * nirik has nothing.
21:29:22 * gr72 nothing here
21:29:22 <thedonvaughn> nada
21:29:30 <rbergeron> Alrighty folks.
21:29:46 <rbergeron> Thanks for coming, and GRATS on it being a Go.
21:29:49 <dgilmore> hi all
21:30:00 <Viking_Alpha> better late then never ,)
21:30:06 * gr72 true
21:30:08 <rbergeron> dgilmore: just to verify, releng is a GO, correct?
21:30:17 <dgilmore> rbergeron: yes maam
21:30:23 <rbergeron> excellent, thanks.
21:30:31 <rbergeron> #info dgilmore has verified that releng is a go.
21:30:44 <rbergeron> Thanks, guys!
21:30:52 <rbergeron> #endmeeting