15:04:15 <Kevin_Kofler> #startmeeting KDE SIG Meeting – https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2011-08-23
15:04:15 <zodbot> Meeting started Tue Aug 23 15:04:15 2011 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:30 <Kevin_Kofler> #meetingname kde-sig
15:04:30 <zodbot> The meeting name has been set to 'kde-sig'
15:04:42 <Kevin_Kofler> #topic Roll call
15:04:48 <Kevin_Kofler> Who's present?
15:04:51 * Kevin_Kofler is, obviously. ;-)
15:06:21 <Kevin_Kofler> than, rdieter, rnovacek, …: Ping?
15:06:29 * rnovacek is here
15:06:44 <rdieter> here
15:06:47 <rnovacek> jreznik is on vacation
15:06:56 <Kevin_Kofler> OK
15:07:02 <rnovacek> I'll be on vacation next week
15:07:07 * than is here
15:07:10 <Kevin_Kofler> And ltinkl? Vacation as well?
15:07:20 <rnovacek> Kevin_Kofler: I don't know
15:07:28 <than> ltink is on vacation too
15:07:34 <Kevin_Kofler> OK
15:07:52 <Kevin_Kofler> #info Kevin_Kofler, rdieter, rnovacek, than present.
15:07:57 <rdieter> a well-deserved break :)
15:08:03 <Kevin_Kofler> #info jreznik and ltinkl are on vacation.
15:08:16 <Kevin_Kofler> #chair rdieter rnovacek than
15:08:16 <zodbot> Current chairs: Kevin_Kofler rdieter rnovacek than
15:08:25 <Kevin_Kofler> #topic Agenda
15:08:32 <Kevin_Kofler> So, anything to discuss? :-)
15:08:56 <Kevin_Kofler> I'd like to bring up the default Plasma setup again.
15:09:09 <rdieter> small item, if there's nothing better to do:  status of google-gadgets/kdebase-workspace
15:10:23 <Kevin_Kofler> Other small item, a report on my GSoC work. :-)
15:10:52 <Kevin_Kofler> #topic Plasma+PackageKit GSoC 2011 (Kevin Kofler)
15:10:59 <Kevin_Kofler> I'll start with that because it's short. :-)
15:11:13 <Kevin_Kofler> My GSoC 2011 project is now complete, and it has reached Rawhide.
15:11:20 <Kevin_Kofler> #link https://kevinkofler.wordpress.com/2011/08/20/plasmarpmpackagekit-gsoc-work-now-in-rawhide/
15:11:48 <Kevin_Kofler> I'll see if it works sorta reliably before making a decision on whether to sneak this into F16 or not.
15:12:10 <Kevin_Kofler> It should be fine, but there was already a showstopper (broken dep in kdebase-workspace) which I fixed.
15:12:22 <Kevin_Kofler> Any comments on this or shall we move on?
15:13:28 <Kevin_Kofler> #topic Default Plasma setup
15:13:51 <Kevin_Kofler> So we left this last week in a "Let's ask for user feedback!" state. Do we have any feedback collected yet?
15:14:32 <rdieter> I *think* I was supposed to do that, and I suck and didn't.
15:15:00 <Kevin_Kofler> rdieter: Then please do it this week. :-)
15:15:13 <rnovacek> facebook poll hasn't any valuable results, 4 people answered so far
15:15:24 <Kevin_Kofler> #action rdieter to collect user feedback for the default Plasma setup
15:15:42 <rnovacek> including jreznik, ltinkl and me
15:15:44 <Kevin_Kofler> #info rnovacek posted a poll on Facebook, only 4 people answered so far.
15:15:49 <than> Kevin_Kofler: we just make upstream Default Plasma setup
15:15:54 <rdieter> rnovacek: ok, I missed that fb poll, I'll reference that in my ml query
15:16:03 <rnovacek> actually jreznik post it :)
15:16:11 <than> if more users complain it, we can also change it again
15:16:12 <Kevin_Kofler> #undo
15:16:12 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x13ba468c>
15:16:18 <Kevin_Kofler> #info jreznik posted a poll on Facebook, only 4 people answered so far.
15:16:24 <Kevin_Kofler> :-)
15:16:55 <Kevin_Kofler> than: I don't think a blank desktop is that great a default… :-/
15:17:20 <Kevin_Kofler> If we go with the blank desktop as default, we should at least override it for liveuser so liveinst is easily accessible.
15:18:04 <rdieter> http://www.facebook.com/questions/10150276652411513/?qa_ref=qd
15:18:33 * rdieter voted for folderview
15:19:05 <rdieter> Kevin_Kofler: agreed, implemenation-wise would be easier, imo, if we stuck to folderview, but meh.
15:20:18 <rdieter> it it feels a little wrong that the liveuser experience wouldn't match with our default (installed) user setup either.
15:20:26 <Kevin_Kofler> Let's see if we get more feedback during the week and bring it up again in the next meeting.
15:21:01 <Kevin_Kofler> Well, an icon plasmoid for liveinst wouldn't be that invasive, it makes sense for the icon to go away after installing and it wouldn't be a folder view.
15:21:07 <Kevin_Kofler> But we'd have to set up that icon plasmoid.
15:21:15 <Kevin_Kofler> It shouldn't be a problem though.
15:21:22 <Kevin_Kofler> (at least in principle)
15:22:52 <Kevin_Kofler> Let's move on…
15:22:58 <Kevin_Kofler> #topic status of google-gadgets/kdebase-workspace
15:23:04 <Kevin_Kofler> rdieter: That's your topic.
15:23:35 <rdieter> seems google-gadgets finally was officially dropped from f16+ (after being orphaned)
15:23:55 <rdieter> so, unless someone picks it up again, I'll toggle off support in kdebase-workspace later today
15:23:58 <than> rdieter: +1
15:24:27 <rdieter> fyi, I fixed up the ftbfs anyway, for anyone interested in maintaining it:  http://rdieter.fedoraproject.org/rpms/google-gadgets/
15:24:28 <Kevin_Kofler> Too bad that nobody cares about keeping these things working… :-(
15:24:39 <Kevin_Kofler> OTOH, I was never a fan of google-gadgets in the first place.
15:24:42 <rdieter> err, rdieter.fedorapeople.org
15:25:05 <Kevin_Kofler> It allows installing stuff under all sorts of dubious licenses and putting it on the desktop like a native plasmoid.
15:25:14 <rdieter> basically just dropping support for pieces that no longer build (networkmanager, xulrunner, gtk)
15:25:21 <Kevin_Kofler> (That said, in principle, GHNS/OCS allows that too.)
15:26:30 <Kevin_Kofler> The question is, is this dead upstream? Does Google no longer care about it? :-/
15:26:54 <rdieter> upstream code doesn't seem to have been touched in the past few months at least (when I checked, looking for fixes/patches)
15:27:05 <Kevin_Kofler> This is quite sad, Google often comes up with some shiny new stuff, advertises it all over the place, then suddenly discontinues it.
15:27:23 <rdieter> feels like a code dump to OSS folks... kind of thing
15:27:41 <rdieter> but I'm not familiar with it enough to say for sure
15:30:06 <Kevin_Kofler> #info google-gadgets dropped from F16+ (after being orphaned)
15:30:18 <Kevin_Kofler> #action rdieter to rebuild kdebase-workspace without google-gadgets support
15:30:28 <Kevin_Kofler> #topic Open Discussion
15:30:32 <Kevin_Kofler> Anything else to discuss?
15:31:18 <Kevin_Kofler> Last chance…
15:31:22 <rdieter> fyi, *lots* of stuff still on kde-review blocker still (telepathy-kde tack in particular)
15:31:28 <than> Kevin_Kofler: who is mainting our kde livecd?
15:31:53 <Kevin_Kofler> than: Mostly me, these days.
15:32:16 <Kevin_Kofler> The official maintainer was Sebastian Vahl, who has basically "vanished".
15:32:26 <Kevin_Kofler> (He did warn us that he's having less and less time for Fedora.)
15:32:53 * rdieter misses svahl, got spoiled having him around.
15:32:56 <than> Kevin_Kofler: ah ok
15:33:18 <Kevin_Kofler> #info fyi, *lots* of stuff still on kde-review blocker still (telepathy-kde stack in particular)
15:34:01 <than> Kevin_Kofler: link?
15:34:43 <Kevin_Kofler> #link https://bugzilla.redhat.com/show_bug.cgi?id=656997
15:35:02 <rdieter> https://bugzilla.redhat.com/showdependencytree.cgi?id=kde-reviews&hide_resolved=1 is nice too
15:35:38 <rdieter> and, since jreznik is on vacation, if someone interested in comaintaingin telepathy-qt4, can add the cvsadmin request on jreznik's behalf, would be nice.
15:35:52 <rdieter> https://bugzilla.redhat.com/show_bug.cgi?id=723123
15:36:04 <rdieter> .bug 723123
15:36:06 <zodbot> rdieter: Bug 723123 Review Request: telepathy-qt4 - A high-level bindings for Telepathy - https://bugzilla.redhat.com/show_bug.cgi?id=723123
15:36:37 <rdieter> I could, but would look bad, me being the reviewer in question (I do want to help comaintain it though)
15:37:37 <Kevin_Kofler> Oh, while we're speaking about new KDE-related packages, this one got released today: http://labs.qt.nokia.com/2011/08/23/accessibility-on-linux/
15:37:47 <Kevin_Kofler> That's the Qt AT-SPI2 bridge.
15:37:58 <Kevin_Kofler> It's needed for widget-level accessibility support in Qt/KDE.
15:39:37 <rdieter> nice
15:39:58 * rdieter could try looking at that closer later in the week
15:40:57 <rdieter> looks like it requires qt48, so f16+ only
15:41:35 <Kevin_Kofler> Hmmm, weird, it has been under development for a while and used not to require such a new Qt…
15:41:56 <Kevin_Kofler> I guess 4.8 must have fixed some of the issues which were preventing its release.
15:42:21 <rdieter> it just says this in the post:  Use Qt from gitorious and make sure to use the 4.8 branch....
15:42:34 <rdieter> not sure if that's actually required or just a recommendation though
15:42:46 <Kevin_Kofler> It might be required for the stuff to actually WORK properly. ;-)
15:45:21 <Kevin_Kofler> So, anything else?
15:46:54 <rdieter> download and test f16alpha! :)
15:49:38 <Kevin_Kofler> #help download and test f16alpha! :)
15:49:44 <Kevin_Kofler> #endmeeting