19:00:03 <rbergeron> #startmeeting Cloud SIG
19:00:03 <zodbot> Meeting started Fri Aug 26 19:00:03 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:07 <rbergeron> #meetingname Cloud SIG
19:00:07 <zodbot> The meeting name has been set to 'cloud_sig'
19:00:17 <rbergeron> #topic Who's here?
19:00:28 * tflink is here
19:00:29 * mgoldmann is here, maybe
19:00:31 <gholms> Chirp, chirp
19:00:37 * athmane is around
19:00:57 * msavy is here, there and everywhere
19:00:57 * gholms pokes kkeithley
19:01:08 * jsmith is here, lurking
19:01:10 * spevack waves hello from his new home @ Amazon
19:01:14 <kkeithley> hey
19:01:20 <rbergeron> how's Windows treating you?
19:01:25 * quaid is not here
19:01:29 <jsmith> spevack!
19:01:34 <gholms> spevack!
19:01:36 <spevack> hey jsmith
19:01:37 <msavy> rbergeron: Windows? is that a fork of Lindows?
19:01:38 * jforbes is here
19:01:39 <spevack> hi gholms
19:02:08 <quaid> #info rbergeron: fwiw, I think the 'cudcon as part of fudcon' is clearly dead, and we need to  keep ongoing about a general conference for open source cloudiness
19:02:29 <rbergeron> #info present - mgoldmann, clalance, tflink, athmane, gholms, jsmith, spevack, jforbes, quaid, msavy, kkeithley
19:02:36 <rbergeron> #chair quaid gholms jforbes
19:02:36 <zodbot> Current chairs: gholms jforbes quaid rbergeron
19:02:38 <rbergeron> quaid: noted :)
19:02:45 <gholms> rbergeron: meetbot already logs attendance
19:02:51 <quaid> thx, have to jet; great list discussion fwiw :)
19:02:52 <gholms> rbergeron: It's at the bottom of the minutes. ;)
19:02:55 <rbergeron> yeah, i know.
19:03:01 <rbergeron> #topic EC2
19:03:04 <rbergeron> jforbes: hi
19:03:29 <jforbes> Still working on making the F16 alpha work with pvgrub
19:03:34 <rbergeron> welcome back from vacation and travel
19:03:38 <jforbes> thanks :)
19:03:46 <rbergeron> what's up with pvgrub?
19:03:58 <jforbes> It expects grub1 config files
19:04:11 <jsmith> Oooh, lovely...
19:04:30 <rbergeron> le sigh
19:04:31 <jforbes> jsmith: not as horrible as it sounds
19:04:53 <jforbes> And at least this is being discovered now instead of at release time
19:05:11 <rbergeron> #info F16 alpha on EC2 in progress; pvgrub complaining about grub1 files, F16 has moved to grub2
19:05:19 <rbergeron> jforbes: indeed
19:05:32 <jforbes> it doesnt really complain, in fact it is completely silent on the issue :)
19:05:40 <rbergeron> is this something you need help from other with, or just handling on your own?
19:06:02 <jforbes> I've got it, unless mgoldmann happens to already have a solution?
19:06:04 <rbergeron> others... man, my typing sucks today.
19:06:06 <mgoldmann> it's easy to handle - we just generate required config
19:06:21 <mgoldmann> jforbes: correct, new BG support F16 alpha
19:06:38 <jforbes> mgoldmann: oh, there is an update?
19:06:48 * jforbes should have alpha images done by monday then :)
19:06:49 <mgoldmann> jforbes: will be out in... 10 minutes
19:07:23 <jforbes> mgoldmann: thanks!
19:07:25 <rbergeron> #info new BG in F16 (will be available in about 10 minutes) handles grub issues, thanks mgoldmann/msavy :)
19:07:34 <gholms> Yay!
19:07:35 <rbergeron> jforbes: so you'll just hold till monday then?
19:07:45 <msavy> rbergeron: this is an mgoldmann party trick
19:08:02 <mgoldmann> rbergeron: let's talk about BG in the last stage of this meeting
19:08:10 <jforbes> rbergeron: Well, I will start tonight, but it's my son's birthday, so I am guessing not much will be done
19:08:13 <mgoldmann> so msavy has some time to push the blog post and we could link it
19:08:24 <rbergeron> #action jforbes to try building F16 alpha images mondayish after new BG pushes out, should be able to build without grub1/2 problems
19:08:31 <rbergeron> mgoldmann: sounds good
19:08:31 <mgoldmann> one thing
19:08:42 <mgoldmann> curent Fedora 16 kernel is broken for EC2
19:08:46 <rbergeron> WHAT
19:08:53 <rbergeron> IF ONLY WE KNEW SOMEONE WHO WORKED ON KERNELS FOR A LIVING
19:08:57 <gholms> Got a link to the bug?
19:08:59 <tflink> current STABLE kernel
19:09:00 <mgoldmann> please ,pleas bump karma on kernel which is in updates -testing
19:09:04 <mgoldmann> gholms: one sec
19:09:22 <mgoldmann> https://bugzilla.redhat.com/show_bug.cgi?id=733313
19:09:24 <rbergeron> #info f16 kernel is broken for ec2, please bump karma on kernel which is in updates -testing
19:09:26 <mgoldmann> same issue as with F15
19:09:31 <mgoldmann> https://admin.fedoraproject.org/updates/kernel-3.1.0-0.rc3.git0.0.fc16
19:09:36 * athmane will test the new kernel
19:09:36 <mgoldmann> ^^ bump, bump!
19:09:59 <mgoldmann> with this kernel - AMis work as expecte
19:10:00 <rbergeron> gholms, oh wise meetbot expert - does the bot pick up links from non-chaired people?
19:10:16 <rbergeron> mgoldmann: so jforbes should wait until that issue is resolved as well?
19:10:30 <gholms> #info kernel-3.0.1-3.fc16 is broken in EC2; please test kernel-3.1.0-0.rc3.git0.0.fc16
19:10:33 <gholms> rbergeron: Yes
19:10:35 <mgoldmann> it is resolved in new kernel - we need to make it to stable ASAP
19:10:56 <gholms> https://admin.fedoraproject.org/updates/kernel-3.1.0-0.rc3.git0.0.fc16
19:11:06 <jforbes> Right, so monday :)
19:11:18 <mgoldmann> yah :)
19:11:19 <rbergeron> #action jforbes to also wait on new kernel update/fixes/karma/etc. before pushing out an f16 alpha as kernel is not happy at the moment
19:11:22 <gholms> mgoldmann: Is the one in updates-testing the right one?
19:11:38 <mgoldmann> gholms: correct
19:11:49 <mgoldmann> https://github.com/boxgrinder/boxgrinder-build/blob/master/integ/appliances/jeos-f16.appl
19:11:55 <rbergeron> cool. mgoldmann, thanks for the tips :)
19:11:57 <mgoldmann> this is a working F16 build
19:12:15 <rbergeron> saving us (mostly justin) time as always
19:12:24 <mgoldmann> yw!
19:12:32 <jforbes> Indeed, thanks a lot!
19:12:38 <rbergeron> alrighty. anything else in ec2-land to discuss?
19:12:52 <jsmith> rbergeron: Just out of curiosity
19:12:56 <rbergeron> jsmith: yes?
19:13:01 <jsmith> rbergeron: How many people took you up on the EC2 testing offer?
19:13:17 * jsmith meant to ask a couple of weeks ago, and forgot
19:13:58 * ke4qqq shows up late
19:14:00 <rbergeron> You mean the $5 dolla offer?
19:14:01 <rbergeron> Nobody.
19:14:05 <rbergeron> But people still tested.
19:14:08 <jsmith> Did most folks that did testing just foot the bill themselves, or did some want the $5?
19:14:12 <jsmith> Ah, good to know.
19:14:18 <jsmith> Sorry to hold up the meeting... I was just curious.
19:14:21 <ke4qqq> BG does micro instances - super cheap (not that it isn't already)
19:14:29 <rbergeron> No problem :)
19:14:38 <rbergeron> #topic Aeolus
19:14:43 <mgoldmann> yep, and F16 on micro works - tested today
19:14:46 <rbergeron> clalance: hi there.
19:15:11 <clalance> rbergeron: Hello :).
19:15:14 <athmane> jsmith: I used the free plan
19:15:16 <rbergeron> anything new?
19:15:17 <clalance> rbergeron: Hate to be a broken record, but not a lot to report.
19:15:35 <rbergeron> clalance: that's okay. Just like to check in.
19:15:51 <clalance> rbergeron: I'll build new packages into F-16 the week of Labor Day.
19:15:58 <clalance> To get them in for the 9-13 beta deadline.
19:16:14 <clalance> (and my packages that were stuck in testing have now been moved to the f-16 tag, so we are good there)
19:16:40 <clalance> Development is of course ongoing.
19:16:42 <clalance> And that's about it.
19:17:15 <rbergeron> #info clalance will be building new aeolus packages into F16 during week of Labor Day (Sept. 5th-ish) to make the beta freeze deadline
19:17:21 <rbergeron> Cool. Thank you :)
19:17:27 <rbergeron> #topic HekaFS
19:17:28 <clalance> rbergeron: You are welcome :).
19:17:33 <rbergeron> kkeithley: your turn :)
19:18:14 <rbergeron> if you're still about
19:18:17 <rbergeron> that is
19:18:18 <rbergeron> :)
19:18:26 <kkeithley> yup
19:18:32 <kkeithley> too fast for me
19:18:36 * rbergeron grins
19:18:46 <kkeithley> jdarcy on PTO this week.
19:19:10 <kkeithley> I've got rpms for latest upstream glusterfs in the updates-testing repo
19:19:24 <kkeithley> still not sure if those need karma to get out of testing
19:19:39 <rbergeron> #info rpms for latest upstream glusterfs in updates-testing repo
19:19:46 * rbergeron looks around for an answer to kkeithley's question
19:19:57 <tflink> kkeithley: looks like they still need karma
19:20:11 <tflink> pushed to testing 3 days ago, -0 karma
19:20:17 <tflink> s/-0/0
19:20:25 <kkeithley> that's 3.2.3 btw, and there's a hekafs for that
19:20:28 <gholms> -0 == 0, so you're ok ;)
19:20:36 <rbergeron> #info rpms still need karma, please feel free to apply love.
19:20:59 <tflink> is there a decent walkthrough for setting up gluster or hekafs?
19:21:00 <kkeithley> yeah, so ditto for hekafs rpm
19:21:11 * tflink is being lazy and hadn't looked but wants to try them out
19:21:24 <athmane> I was going to ask the question as tflink
19:21:29 <kkeithley> there is docs/mgmt--- something or other that tells how to set it up
19:21:35 <athmane> the same question
19:21:51 <tflink> kkeithley: you mean glusterfs docs or hekafs?
19:21:54 <rbergeron> tflink: gluster has a lot of documentation on their website
19:21:54 <kkeithley> and I'm rewriting my fedorapeople page about how to set it up
19:21:59 <kkeithley> hekafs
19:22:10 <kkeithley> hekafs doc on how to set it up
19:22:13 <rbergeron> http://gluster.com/community/documentation/index.php/Main_Page#GlusterFS_Documentation
19:22:16 <kkeithley> in the git tree, not in the rpm
19:22:44 <rbergeron> #info kkeithley is working on hekafs documentation for how to setup/get running
19:22:51 <tflink> ok, I've been trying to figure out what problems are solved by glusterfs but that is a question for google :)
19:22:59 <kkeithley> yeah, but hekafs does things differently, so the gluster docs will only get you so far
19:23:21 <rbergeron> kkeithley: yup, I just figured it would at least be a start for him :)
19:23:51 <ke4qqq> tflink: scalable, distributed, redundant storage
19:24:39 <kkeithley> anyway, for my rewrite I figured I ought to start from scatch, and now was as good a time as any, so I reinstalled my dev machine with F15 (from F14), so right now I'm just trying to get back to where I was.
19:24:57 <rbergeron> kkeithley: :)
19:25:28 <rbergeron> alrighty. well, if you want anyone to "test" how well your documentation works, be sure to let us know :)
19:25:48 <rbergeron> i'm sure there are a few folks who would be happy to give it a walkthrough
19:25:56 <kkeithley> yep
19:25:59 <ke4qqq> kkeithley: can you pass that sparks or me when you get it written for the cloud guide?
19:26:08 <kkeithley> yes
19:26:15 <ke4qqq> awesome
19:26:21 <tflink> ke4qqq: I;m still trying to figure out more specifics than that but like I said, probably not a great question/discussion for here :)
19:26:22 <kkeithley> sparks?
19:26:32 <rbergeron> #action kkeithley to pass docs info by ke4qqq or sparks when it's ready, so it can be integrated into the cloud docs for f16
19:26:38 <kkeithley> see jdarcy's hekafs.org blog
19:26:39 <ke4qqq> #fedora-cloud is good for that tflink
19:26:40 <rbergeron> kkeithley: sparks is one of our fabulous docs contributors
19:27:24 <rbergeron> he's working on having some comprehensive documentation covering a lot of the fedora cloud pieces for this release, AIUI
19:27:34 <rbergeron> and i think ke4qqq may be helping him out
19:27:39 <kkeithley> okay
19:28:12 <rbergeron> ke4qqq: do you want to say a bit about what we're doing for documentation, or do you not know entirely?
19:28:53 <ke4qqq> we are just documenting what it is and how to use it really briefly. kind of a quick start for the cloudy stuff in fedora
19:28:56 * zoglesby notes that we are going to work on the cloud guide at OLF
19:29:09 <rbergeron> ahh, excellent
19:29:57 <rbergeron> #info Docs team is working on a Cloud Guide for F16 - mostly quickstart information for the cloudy projects in Fedora. Will be working on it some at Ohio Linux Fest in a few weekends.
19:30:09 <rbergeron> zoglesby: thanks for the tip :)
19:30:09 <gholms> Thanks!
19:30:26 * jsmith is trying to help out as well
19:30:32 <rbergeron> And i'm sure they can use our help a bit, at least for pointers, so if you see anyone asking around on-list, helping them out would be fabulous.
19:30:46 <rbergeron> #topic OpenStack packaging status
19:30:54 <rbergeron> markmc: hi there.
19:30:58 <rbergeron> #chair markmc
19:30:58 <zodbot> Current chairs: gholms jforbes markmc quaid rbergeron
19:31:05 <rbergeron> I saw a fabulous update mail from you today.
19:31:05 <markmc> rbergeron, hello hello :)
19:31:14 <markmc> yeah, I think that about covers everything
19:31:21 <rbergeron> #link http://lists.fedoraproject.org/pipermail/cloud/2011-August/000764.html
19:31:21 <markmc> kinda curious has anyone tried the packages?
19:31:23 <gholms> Heh
19:31:37 <gholms> I tried the packages until I found out that I had to shut off selinux. :(
19:31:51 <markmc> gholms, yeah, we need to get that sorted
19:31:56 <gholms> I'm a little surprised that there isn't a packaging guideline for that.
19:31:59 <markmc> gholms, thanks for trying that far
19:32:04 * ke4qqq is sure we could get dwalsh to help out with that......and upstream would prolly be thrilled with a policy
19:32:30 <rbergeron> #info nova package needs further review - https://bugzilla.redhat.com/707199
19:32:37 <markmc> gholms, well, I suspect if package reviews bottleknecked on that, dwalsh would get a very hard time of it :)
19:32:52 <markmc> ke4qqq, yep - I filed an selinux bug for glance and cc-ed dwalsh
19:33:08 <markmc> rbergeron, right, openstack-nova needs review!
19:33:10 <rbergeron> #info testing of openstack is problematic in terms of selinux policy - needs attention
19:33:18 <markmc> but luckily, mdomsch is around to save the day :)
19:33:22 <markmc> mdomsch, right ? :)
19:33:26 <gholms> markmc: Still, writing a policy for something as complex as a cloud platform can be a lot of work.  Best of luck!
19:33:35 * gholms is writing the policy for euca
19:33:38 <rbergeron> #info selinux bug filed for glance, dwalsh is cc'd.
19:33:40 <mdomsch> markmc: what can I help with?  package review of the new combined pkg?
19:33:48 <rbergeron> gholms: ;) you're a brave, brave, awesome man
19:33:48 <markmc> mdomsch, that'd be awesome
19:34:01 <mdomsch> yeah ok
19:34:04 <clalance> gholms: Wow, best f luck.
19:34:11 <markmc> gholms, yeah, I've forgotten so much about SELinux, I'd be starting from scratch
19:34:12 * clalance is brave, but not that brave
19:34:19 <markmc> mdomsch, cool stuff
19:34:27 <clalance> best *of* luck.
19:34:28 <mdomsch> I thought the dozen or so subpackages was a bit overkill
19:34:28 <rbergeron> markmc: are you thinking of taking the issue more upstream to talk about it more generally?
19:34:33 <clalance> (my 'o' key apparently sticks now)
19:34:46 <markmc> mdomsch, take a look at https://github.com/markmc/openstack-fedora-specs if you want to understand any changes I made
19:34:48 <rbergeron> as ke4qqq suggested
19:34:54 <markmc> mdomsch, I made the commit messages fairly detailed
19:35:12 <msavy> clalance: you'd better not do the docs then!
19:35:13 <markmc> rbergeron, perhaps, but I'm not sure how much upstream will care about SELinux
19:35:16 <clalance> msavy: Haha.
19:35:39 <markmc> rbergeron, I'll talk to dwalsh - e.g. I'm not sure these days whether the policy would go upstream to SELinux or modular policy in OpenStack itself
19:35:45 <rbergeron> markmc: yup.
19:35:53 <ke4qqq> with some of the KVM stuff thats been talking about recently (eg jumping to a different ring) i imagine it's important.
19:36:15 <mdomsch> ha - you forked mine - I had forked Mirantis
19:36:24 <markmc> mdomsch, right :)
19:36:36 <markmc> mdomsch, it's a pity the Mirantis guys have gone quiet
19:36:44 <markmc> mdomsch, it would have been awesome for them to co-maintain
19:37:04 <rbergeron> markmc - do you want tto copy the cloud-sig list in on that discussion with dwalsh?
19:37:06 * markmc got no response to his mail to them
19:37:13 <markmc> rbergeron, sure
19:37:16 <rbergeron> i think having a few different perspectives might be helpful there, ke4qqq seems to be the selinuxmastah
19:37:20 <rbergeron> i should buy him a crown
19:37:24 <rbergeron> or a pie
19:37:24 <markmc> cool
19:37:49 * ke4qqq lol - certainly not. /me just admires selinux from a distance :)
19:37:52 <rbergeron> #action markmc to take discussion of selinux policy w/dwalsh to cloud sig list, for others to pipe in on if they want
19:38:03 <markmc> ke4qqq, how is swift coming along?
19:38:16 <markmc> ke4qqq, I haven't actually played with it yet
19:38:21 <ke4qqq> I pushed 1.4.0 to F16 and rawhide
19:38:32 <markmc> cool
19:38:36 <ke4qqq> later than that requires some of the auth stuff you were working on
19:38:46 <rbergeron> #info swift 1.4.0 pushed to f16 and rawhide
19:38:56 * ke4qqq is really frustrated they are making major changes in 1.4.x (or what I view as major changes)
19:39:00 <ke4qqq> but such is life
19:39:13 <jsmith> ke4qqq: Yeah, I was surprised by that as well
19:39:20 <markmc> ke4qqq, wonder could we add swift into the mix of https://fedoraproject.org/wiki/Getting_started_with_OpenStack_Nova
19:39:29 <markmc> ke4qqq, or a similar getting started page
19:39:44 <ke4qqq> markmc: I am happy to help document.
19:39:47 <terminhell> hello
19:40:04 <markmc> ke4qqq, cool
19:40:08 <markmc> terminhell, hi; welcome
19:40:30 <ke4qqq> I guess the question is do we want to get 1.4.x in to f16 (if so there are some big changes afoot and I need to get that going soon)
19:40:53 <ke4qqq> .0 still had all of the account and auth stuff in swift itself (and had st as the binary name
19:40:56 <ke4qqq> )
19:41:11 <terminhell> happy bday linux :)
19:41:12 <markmc> ah, and 1.4.x uses keystone?
19:41:22 * markmc hasn't been following
19:41:47 <ke4qqq> markmc: yep
19:41:58 <markmc> ke4qqq, that's no fun
19:42:06 <mdomsch> markmc, do you feel openstack-nova.spec is in good enough shape that if review succeeds, app will run and work as expected?
19:42:07 <markmc> ke4qqq, I doubt you want to get into that for F-16
19:42:29 <markmc> mdomsch, to the level of https://fedoraproject.org/wiki/Getting_started_with_OpenStack_Nova at least, yes
19:42:44 <ke4qqq> markmc: I didn't really want to (and have honestly been dragging my feet - but at the same time, don't want to keep the latest greatness out either.
19:43:38 <markmc> ke4qqq, yeah, but maybe getting it into rawhide is enough ?
19:43:39 <rbergeron> do we want to decide now, or do you guys want to wait and see a bit?
19:43:52 * rbergeron wonders if any documentation-type stuff rides on the version decision
19:44:04 <markmc> ke4qqq, dunno, depends on how many swift-on-fedora users you think there currently are
19:44:05 * rbergeron also throws a rock at her vpn
19:44:38 <ke4qqq> markmc: I have no feel for it.
19:45:01 <rbergeron> i don't think any of us have a feel for it, unfortunately
19:45:21 <rbergeron> though that probably means the number is lowish
19:45:34 <markmc> ke4qqq, if you had keystone packaged soonish then, maybe just go for it in F-16
19:45:39 * markmc shrugs
19:45:53 <markmc> if that screws any swift users, at least we'll know someone's using it :)
19:45:59 <rbergeron> lol
19:46:19 <ke4qqq> yeah - /me thought yuo were packaging keystone :)
19:46:43 <mgoldmann> who needs tests? - there are users! :)
19:47:09 <markmc> ke4qqq, could happen :)
19:47:20 <rbergeron> mdomsch: so you're going to look at the nova review then?
19:47:32 <mdomsch> rbergeron: sure
19:47:36 <markmc> happy face
19:47:41 <rbergeron> #action mdomsch (and anyone else kind) to look at nova review
19:48:18 <rbergeron> #action markmc and ke4qqq to sort out the swift/keystone/versioning dilemma, one of them to package keystone, rock paper scissors or however they decide that. :)
19:48:35 <rbergeron> markmc: thanks for all hte work you're picking up here, much appreciated.
19:48:48 <markmc> rbergeron, thanks
19:48:49 <ke4qqq> thats rock, paper, scissors, cloud :) and cloud beats them all
19:48:53 <mdomsch> markmc, what's this dep: https://bugzilla.redhat.com/show_bug.cgi?id=733238
19:49:04 <mdomsch> Please update to eventlet 0.9.16
19:49:16 <rbergeron> ke4qqq: that's your new shirt, you know, the one i STILL DONT HAVE ONE OF
19:49:18 <markmc> mdomsch, https://answers.launchpad.net/nova/+faq/1485
19:49:26 <markmc> mdomsch, small fix that nova requires
19:49:35 <markmc> mdomsch, soren patches ubuntu with it AFAIK
19:49:45 <markmc> mdomsch, nova-volumes doesn't start without it, I think
19:49:47 <mdomsch> .whoowns eventlet
19:49:48 <zodbot> mdomsch: No such package exists.
19:49:57 <markmc> .whoowns python-eventlet
19:49:57 <zodbot> markmc: abbot
19:50:11 <markmc> and keven fenzi AFAIR
19:50:20 <rbergeron> ah, nirik.
19:50:39 <markmc> right
19:50:39 * nirik looks up. wha?
19:50:47 <markmc> nirik, https://bugzilla.redhat.com/show_bug.cgi?id=733238
19:50:49 <rbergeron> nirik: talking about python-eventlet
19:50:50 <nirik> ah yeah.
19:50:58 <nirik> I haven't gotten to updating that... but I can.
19:51:06 <markmc> nirik, awesome :)
19:51:12 <nirik> or if any of you guys want to co-maintain and do so, I'd be happy to have you
19:51:12 <mdomsch> untouched by abbot in a year
19:51:28 <markmc> nirik, happy to do it myself, either
19:51:39 <rbergeron> #action nirik to update https://bugzilla.redhat.com/show_bug.cgi?id=733238 - dep for nova
19:51:40 <nirik> markmc: feel free to apply in pkgdb and I will ack.
19:51:45 <markmc> nirik, great
19:51:59 * nirik is happy to have co-maintainers.
19:52:07 <mdomsch> +1 for comaintainers
19:52:07 <rbergeron> #action markmc to comaintain python-eventlet, apply in pkgdb and nirik will ack
19:52:11 <rbergeron> sweet, thanks guys :)
19:52:52 <rbergeron> okay, anything else on the openstack front?
19:53:00 <markmc> nirik, done
19:53:01 * rbergeron knows markmc put most of it in his previously-linked email
19:53:03 <markmc> rbergeron, not from me, thanks
19:53:42 <rbergeron> #info Thoughts/help welcomed on updating https://fedoraproject.org/wiki/Getting_started_with_OpenStack_Nova .. possibly add swift to that documentation
19:53:45 <rbergeron> okay
19:53:52 <rbergeron> #topic BoxGrinder
19:53:59 <mgoldmann> yay!
19:54:01 <rbergeron> #chair mgoldmann
19:54:01 <zodbot> Current chairs: gholms jforbes markmc mgoldmann quaid rbergeron
19:54:07 <rbergeron> mgoldmann: sorry ;) your turn!
19:54:12 <rbergeron> #chair msavy
19:54:13 <zodbot> Current chairs: gholms jforbes markmc mgoldmann msavy quaid rbergeron
19:54:17 <mgoldmann> msavy: wanna take it?
19:54:29 <msavy> ah sure.
19:54:47 <msavy> http://boxgrinder.org/blog/2011/08/26/boxgrinder-0-9-5-released/
19:54:47 <rbergeron> Thanks for sticking around on a friday night, guys (and you too, markmc)
19:55:01 <msavy> rbergeron: especially mgoldmann and i. its completely dark outside :P!
19:55:08 <msavy> (or anyone else in europe)
19:55:10 <mgoldmann> (and hot!)
19:55:59 <msavy> the release is primarily bugfixes
19:56:26 <msavy> including an error that was caused in the rebase before release of 0.9.4
19:56:37 <rbergeron> #info New BG release is primarily bugfixes
19:56:41 <msavy> but .. drumroll
19:56:56 <msavy> mgoldmann has speedily introduced GRUB2 support
19:57:01 <msavy> so we have F16 build support now
19:57:03 <msavy> huzzah!
19:57:32 <msavy> look on the blogpost for how to work around the current kernel issue to test it out on EC2
19:57:54 <mgoldmann> it seems that the kernel is NOW pushed to stable
19:58:01 <mgoldmann> being*
19:58:18 <gholms> Yay
19:58:19 <msavy> #info 0.9.5 adds support for Fedora 16
19:58:20 <mgoldmann> so, expect to have working F16 tomorrow or so
19:58:46 <verdurin> just wanted to thank mgoldmann and msavy for being very helpful in #boxgrinder
19:58:55 <mgoldmann> yw!
19:59:03 <msavy> thanks!
19:59:12 <rbergeron> #info GRUB2 is now supported in BG, so we have build support for F16 now
19:59:26 <mgoldmann> so, basically now we want to do some really cool stuff after 0.95
19:59:27 <rbergeron> #info keep an eye out for blogpost on how to work around current kernel issue to test it on EC2
19:59:42 <mgoldmann> like... cloudstack support
19:59:52 <mgoldmann> and openstack too (glance)
20:00:09 <markmc> woo
20:00:12 <mgoldmann> so, onward to 0.10
20:00:24 <mgoldmann> not sure if it makes into F16 - would be awesome
20:00:26 <mgoldmann> we'll try
20:00:33 <msavy> a new boxgrinder meta release will be out that adds a few little extras, but remember the current releases auto-update themselves at boot. so once 0.9.5 hits stable you will get the latest release automatically with meta.
20:01:38 <mgoldmann> I think that's all
20:01:42 <mgoldmann> msavy: anything else?
20:01:49 <rbergeron> #info BG planning on doing cloudstack and openstack glance support after 0.95 release
20:02:00 <mgoldmann> 0.9.5 :)
20:02:09 <rbergeron> #undo
20:02:09 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x16c933cc>
20:02:19 <msavy> ke4qqq --^
20:02:25 <mgoldmann> 0.95 is planned in 2023
20:02:25 <rbergeron> #info BG planning on doing cloudstack and openstack glance support after 0.9.5 release
20:02:30 * ke4qqq is very happy about that
20:02:30 <msavy> rofl
20:02:40 <rbergeron> i assume you guys know where to go for assistance on cloudstack ;) it certainly seems like it
20:02:57 <mgoldmann> yep, we're in touch with ke4qqq
20:03:06 <msavy> yes, we have some kind offers of a server to do test builds too
20:03:08 <msavy> so many thanks for that
20:03:54 <rbergeron> very cool. looking forward to seeing that stuff take shape.
20:04:18 <msavy> that's it from me. glad rbergeron remembered this time :P!
20:04:28 <rbergeron> hey, somedays my memory is on, what can i say :)
20:04:30 <msavy> poor boxgrinder monkey felt left out last week
20:04:39 <rbergeron> everyone at linuxcon loved your stickers, btw
20:04:51 <rbergeron> i had to tell like 100 people what it was for ;)
20:05:04 <mgoldmann> ha :D awesome - thanks!
20:05:07 <msavy> it is for grinding monkeys!
20:05:10 <rbergeron> #topic Any Other Business?
20:05:13 * msavy wishes to clarify this is not the case
20:05:13 <rbergeron> monkeys are tasty.
20:05:17 <rbergeron> I MEAN
20:05:19 <rbergeron> um
20:05:23 <jforbes> heh
20:05:23 <mgoldmann> ouch
20:05:23 * markmc has an urgent matter!
20:05:25 <rbergeron> crap, my sekrit is out
20:05:28 <rbergeron> markmc: yes?
20:05:37 <markmc> no ops on #fedora-cloud, very sad!
20:05:40 <Southern_Gentlem> taste like chicken
20:05:41 <rbergeron> oh
20:05:46 <rbergeron> jforbes: you can do that, can't you?
20:05:48 <markmc> spot needs to type "/msg ChanServ access #fedora-cloud add markmc +voOtriRfAF" into his irc client
20:05:49 <jforbes> I can
20:05:54 <mgoldmann> Southern_Gentlem:
20:05:55 <markmc> and repeat for a bunch of other people :)
20:05:57 <mgoldmann> uh
20:06:04 <mgoldmann> Southern_Gentlem: everything tastes like chicken
20:06:05 <markmc> jforbes, not sure you can, if I understand the perms thing
20:06:17 <jforbes> I have ops, or can get it if I msg chanserv
20:06:21 <rbergeron> markmc: he already has them
20:06:27 <rbergeron> he just needs to tell the channel to hand them over
20:06:43 <markmc> rbergeron, that doesn't give auto-op on join, though
20:06:51 <markmc> need to tell ChanServ that
20:07:11 <Southern_Gentlem> markmc,  why is auto-op needed
20:07:11 <markmc> and need "  +f - Enables modification of channel access lists."
20:07:26 <rbergeron> i think chanserv already does that for jforbes, he just never leaves, ever
20:07:27 <markmc> and jforbes has "+votriA"
20:07:30 <rbergeron> lol
20:07:46 <markmc> Southern_Gentlem, because people come and go and should regain op on return?
20:07:53 <markmc> anyway
20:07:58 <markmc> that's my urgent matter :)
20:08:07 <Southern_Gentlem> markmc,  and freenode docs frown on auto ops
20:08:30 <markmc> Southern_Gentlem, got a pointer?
20:08:42 <Southern_Gentlem> freenode FAQ
20:08:43 <markmc> rbergeron, feel free to carry on, /me only kidding really
20:08:47 <rbergeron> #info would be nice to have jforbes have ops on in #fedora-cloud if he feels motivated
20:08:57 * jforbes has it
20:08:59 <Southern_Gentlem> rbergeron,  he has it
20:09:12 <markmc> jforbes, thanks
20:09:15 <rbergeron> #undo
20:09:15 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x12ea334c>
20:09:18 <rbergeron> alrighty then
20:09:28 <rbergeron> okay.
20:09:32 <rbergeron> Any other URGENT MATTERS????
20:09:34 * rbergeron grins
20:10:30 <rbergeron> okay, well then.
20:10:35 <rbergeron> Everyone have a lovely weekend.
20:10:36 <rbergeron> Oh,
20:10:43 <mgoldmann> hve grt eveng!
20:10:45 <mgoldmann> :)
20:10:58 <clalance> See you.
20:11:07 <rbergeron> #info If you have any interest/input in a multi-vendor cloud conference type thing for users/developers, NOT ATTACHED TO FUDCON, feel free to pipe up on the cloud sig list.
20:11:13 <markmc> see ya :)
20:11:14 * rbergeron does as she promised for karsten
20:11:19 <rbergeron> have a good one, folks.
20:11:21 <rbergeron> #endmeeting