15:06:37 <spot> #startmeeting Fedora Packaging Committee
15:06:37 <zodbot> Meeting started Wed Sep  7 15:06:37 2011 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:06:42 <spot> #meetingname fpc
15:06:42 <zodbot> The meeting name has been set to 'fpc'
15:06:47 <spot> #topic Roll Call
15:06:50 * abadger1999 here
15:06:55 * limburgher here
15:08:14 <spot> racor: ping?
15:08:36 <spot> SmootherFrOgZ: ping?
15:10:27 <racor> here (sorry, was temporarily distract)
15:11:14 <spot> ok, racor makes 5, just barely quorum
15:11:53 <spot> i think the only item on the agenda today is the revisions to the systemd guidelines
15:12:04 <spot> #topic Systemd cleanups, definitions
15:12:23 <limburgher> Where are we?
15:12:33 <tibbs|h> I'm still making some changes but it's mostly there.
15:12:36 <spot> tibbs|h: iirc, you were going to make the last pass of cleanups and we'd revisit it today
15:12:39 <tibbs|h> https://fedoraproject.org/wiki/PackagingDrafts:SystemdClarification
15:12:57 <tibbs|h> I pulled up the definitions and reworded the confusing stuff we discussed last week.
15:14:45 <spot> the definitions look good to me
15:14:59 <spot> we may want to reconsider this sentence from the socket activation section:
15:15:02 <spot> "Similar to inetd, using socket activation for on-demand loading will impose a startup time penalty so we currently do not use this feature in Fedora. "
15:15:07 <tibbs|h> Lately I've just been going over the thing making sure that stuff is consistently wrapped in <code>.
15:15:34 <tibbs|h> Hmm.
15:15:36 <spot> Is that still accurate?
15:15:55 <spot> (i believe the intent was to allow cups to use the socket to load on demand)
15:16:01 <tibbs|h> Well, the startup time penalty is as accurate as it always was.
15:16:14 <tibbs|h> But I never understood how that was a reason either way.
15:16:43 <spot> Perhaps just dropping that sentence entirely and the following "However," is appropriate.
15:16:58 <tibbs|h> I mean, there's talk of optionally socket activating things like the MTA or sshd, which I would generally agree with.
15:17:20 <tibbs|h> And as far as I know, nobody actually made any sort of decision that socket-activated services were banned.
15:17:43 <tibbs|h> Also, explicit mention of inetd is odd since Fedora has never used inetd.
15:18:03 <spot> Since FESCo has to review all packages that want to include a .socket file
15:18:12 <spot> i think it is safe to simply drop the sentence and the However,
15:18:21 <abadger1999> well...
15:18:31 <abadger1999> they don't have to review them anymore do they?
15:18:47 <spot> "In practical terms this means if the upstream tarball ships with a socket file you need to contact FESCo to get permission to enable your service on boot"
15:18:53 <abadger1999> Didn't we decide that systemd actually doesn't do on-demand-loading of disabled services?
15:19:00 <spot> "Once you have permission, you can package the .socket file and use the systemd scriptlets that enable the service by default."
15:19:20 <spot> The implication there is that packaging the socket file requires permission
15:19:26 <abadger1999> spot: That follows from the previous paragraph: "Since Fedora currently doesn't want any services to do on-demand loading, all socket activated services must autostart."
15:19:43 <spot> hmm, yes
15:20:15 <spot> So, i suppose the question is "Does Fedora want to permit on-demand loading of socket activated services?"
15:20:35 <abadger1999> I'm not against taking this out... I just want to point out that hte assumption is present in that whole section.
15:20:50 <spot> abadger1999: yeah, its a good point, we would need to reword the whole section
15:20:51 <tibbs|h> I know my opinion, but I honestly do not recall the outcome of the most recent fesco discussion on the matter.
15:20:57 <spot> nirik: around?
15:21:24 <nirik> sorta...
15:21:26 * nirik reads up
15:21:50 <spot> nirik: do you know if FESCo has said whether or not on-demand loading of socket activated services is permitted?
15:22:06 <spot> (if they have not decided, i'll open a ticket and we'll wait for their answer to proceed)
15:22:41 <nirik> I'm not 100% sure on that either. I think we said 'not now, but we should revisit' and then we didn't revisit.
15:22:49 <spot> okay, i'll open a ticket
15:22:55 <nirik> yeah, sounds good.
15:23:25 <tibbs|h> OK, so we should probably not go messing with this much currently.
15:25:00 <tibbs|h> What remains to do, then?
15:25:07 <tibbs|h> Or should we table this until FESCo gets to meet?
15:25:22 <spot> tibbs|h: i think thats fine
15:25:36 <spot> nirik: https://fedorahosted.org/fesco/ticket/666
15:25:40 <spot> (oh, thats ominous)
15:25:43 <racor> Could somebody elaborate, why on-demand loading of socket activated services should be disallowed?
15:25:55 <nirik> hurray. What a ticket number.
15:26:07 <tibbs|h> I can't think of a reason for a blanket denial.
15:26:16 * abadger1999 can't think of one either
15:26:22 <tibbs|h> The I really can't be arsed to dig up the whole history of that bit.
15:26:59 <spot> i don't remember writing that bit, perhaps it was lennart?
15:27:25 <racor> ... except of potential technical limitations of systemd, I can't imagine any, either.
15:27:49 <tibbs|h> I think there's a lot of confusion in the document. Which is kind of why we're messing with it.
15:27:56 <abadger1999> <nod>
15:28:11 <limburgher> MmmHmmm.
15:28:27 <tibbs|h> OK, so... back on hold.
15:28:42 <tibbs|h> Anything else I can mess with in the meantime?
15:29:20 <spot> tibbs|h: i don't think so, the other cleanups look fine to me
15:30:16 <tibbs|h> Then I guess we can move on.
15:30:20 <abadger1999> tibbs|h: If the other cleanups are done, I'd vote to put those in now.
15:30:37 <abadger1999> (the definitions and updating the main doc to use the defined terms)
15:32:05 * spot is fine with that
15:32:26 <tibbs|h> I'm sure we can find some more minor things to tweak, but if everyone agrees I can go ahead and push the changes into the guidelines.
15:32:27 <spot> +1 on the cleanups as is, we'll revisit the socket activation part after FESCo responds
15:32:31 <abadger1999> +1
15:32:39 <tibbs|h> +1
15:33:22 <limburgher> +1
15:33:46 <racor> +1
15:34:03 <spot> #action cleanups and definition changes approved (+1:5, 0:0, -1:0)
15:34:16 <tibbs|h> OK, I'll write it up.
15:34:33 <spot> #topic Bundle request for rtmidi - https://fedorahosted.org/fpc/ticket/104
15:34:51 <tibbs|h> I have to run for a couple of minutes.  BRB.
15:35:12 <spot> Just FYI, in case you missed the comments here, I made an rtmidi package and the reporter on this ticket is following up with the rtmidi upstream
15:35:26 <spot> so this probably will not need a bundling exception
15:35:59 <spot> #topic Streflop bundling exception - https://fedorahosted.org/fpc/ticket/105
15:36:18 <spot> I also made a streflop package, but the ticket reporter has not responded yet
15:37:10 <spot> #topic PIE - https://fedorahosted.org/fpc/ticket/93
15:37:21 <spot> nirik: i think we are still waiting on FESCo/ajax here
15:37:36 <nirik> yeah, he was going to add the macro stuff there...
15:37:44 <nirik> which should be all finalized.
15:38:13 <spot> okay, can you ping him to complete the draft?
15:38:44 <nirik> yep. Or I can try and just do so.
15:40:37 <spot> either way works
15:40:51 <spot> #topic Open Floor
15:42:15 <spot> If there is no topics on the floor by 1545, i'll close out the meeting
15:42:21 <spot> s/is/are
15:42:53 <abadger1999> Nice work on all the bundled libs stuff!
15:43:35 <spot> thanks. not too hard, except for the CMake stuff.
15:44:55 <tibbs|h> Back.
15:45:19 <spot> okay, i see no topics on the floor
15:45:29 <tibbs|h> I do have a question.
15:45:36 <spot> okay, shoot
15:46:06 <tibbs|h> Well, it just seems that with our anti-bundling stance we're ignoring the whole deviation from upstream thing.
15:46:17 <tibbs|h> And I wonder if that balance has been articulated anywhere.
15:47:52 <tibbs|h> Anyway, it's no big deal.
15:48:17 <spot> https://fedoraproject.org/wiki/PackageMaintainers/WhyUpstream is the closest place to a "stance"
15:48:54 <spot> probably okay to add a bullet point there to reference bundling removals as an exception
15:49:11 <tibbs|h> Yes, I think so.
15:49:22 <tibbs|h> I'll take care of it.
15:49:24 <spot> tibbs|h: thanks
15:50:49 <spot> okay, i think we're done
15:50:50 <tibbs|h> That's it for me.
15:50:51 <spot> thanks everyone
15:50:54 <spot> #endmeeting