18:59:46 <rbergeron> #startmeeting Cloud SIG
18:59:46 <zodbot> Meeting started Fri Sep 16 18:59:46 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:59:49 <rbergeron> #meetingname Cloud SIG
18:59:49 <zodbot> The meeting name has been set to 'cloud_sig'
19:00:28 <rbergeron> #topic Roll call, yo
19:00:33 <rbergeron> who's about?
19:00:34 * mgoldmann is here
19:00:43 * jforbes is here
19:00:45 * kkeithley is here
19:01:01 <rbergeron> it's a party!
19:01:03 * rbergeron passes out hats
19:01:14 * clalance here
19:01:19 <jforbes> rbergeron: you must lead a really boring life :)
19:01:51 <rbergeron> jforbes: duh
19:01:55 <rbergeron> #topic EC2
19:02:02 <kkeithley> arizona, hot, dry, stay inside all day
19:02:12 <jforbes> I have not heard anything new
19:02:13 <rbergeron> jgreguske or dgilmore: any news/questions/etc?
19:02:19 <rbergeron> jforbes: noted ;)
19:02:53 <jgreguske> nothing from me, dgilmore has been busy though
19:03:15 <jgreguske> in his absence I can explain what he's up to I suppose
19:03:15 <rbergeron> dgilmore: are you about by chance?
19:03:20 <rbergeron> okay, go for it
19:03:26 <rbergeron> #chair jforbes
19:03:26 <zodbot> Current chairs: jforbes rbergeron
19:04:03 <dgilmore> rbergeron: right now i need to fix appliance-ttols to even be able to compose an image
19:04:08 <jgreguske> we've been advised by the anaconda folks that grub2 is "the way forward" so he's working on getting appliance-tools (which is the backend for BG and koji) to install that by default instead of grub1
19:04:14 * jgreguske defers to dgilmore
19:05:04 <dgilmore> because of how appliance-tools were written and some bugfixing thats gone on, its currently not possible to make a working image using appliance-tools
19:05:11 <dgilmore> so his week ive been working on that
19:06:01 <rbergeron> #info dgilmore is working on getting appliance-tools to work with grub2 by default instead of grub1
19:06:14 <rbergeron> is there a ticket on that separately from the other ticket in the fedora rel-eng queue?
19:06:36 <mgoldmann> jgreguske: we worked around of this
19:07:00 <rbergeron> mgoldmann: it's probably easier to get it working in appliance-tools so you guys don't have to
19:07:10 <dgilmore> mgoldmann: your workaround is busted and no longer will work
19:07:10 <mgoldmann> +1 :)
19:07:13 <jgreguske> mgoldmann: yeah, but we figured we'd fix it at the common area so both you and koji benefit
19:07:34 <mgoldmann> dgilmore: hm, what changed since monday?
19:07:37 <tflink> heck, you can't even install BG on F16 anymore
19:07:43 <mgoldmann> hm
19:07:48 * mgoldmann was on vacations
19:08:07 <tflink> unless something changed in the last 2 days
19:08:22 <clalance> Gah, if someone found the time to make an Oz backend for BG, this wouldn't even be an issue.
19:08:25 <mgoldmann> tflink: I'll take a look on monday
19:09:03 <mgoldmann> clalance: sure, if it the speed would be comparable to appliance-tools on vms :)
19:09:07 <clalance> Well, I guess the fact that you can't install BG would still be an issue :).
19:09:12 <tflink> mgoldmann: I'll try to get an issue filed for it
19:09:13 <clalance> mgoldmann: Yes, there is that.
19:09:35 <mgoldmann> I can even make this happen if it would be 2x slower, but not 2+ hrs :(
19:09:47 <mgoldmann> vms is the primary platform for BG
19:09:50 <mgoldmann> are*
19:10:01 <dgilmore> mgoldmann: grub conflicts with grub2
19:10:14 <dgilmore> and grub2 is pulled in regardless
19:10:20 <mgoldmann> dgilmore: I fixed that here: https://github.com/boxgrinder/boxgrinder-build/blob/master/lib/boxgrinder-build/plugins/os/fedora/fedora-plugin.rb#L79
19:10:24 <mgoldmann> hm
19:10:25 <dgilmore> mgoldmann: appliance-creator need to be fixed
19:10:26 <mgoldmann> ouch
19:10:45 <mgoldmann> I'm pretty sure I fixed the conflict issue
19:10:59 <mgoldmann> tflink: 0.9.7 was release - did you checked updates-testing?
19:11:01 <dgilmore> mgoldmann: so you have to have grub2 installed and cant have grub installed but appliance-creator needs grub installed
19:11:27 <jforbes> dgilmore: I thought the fix for that was in updates-testing
19:11:27 <mgoldmann> right, I'll confirm this on monday hopefully
19:11:43 <dgilmore> jforbes: there is no fix for that
19:11:47 <tflink> mgoldmann: yeah, I was using updates-testing
19:11:52 <mgoldmann> ok
19:11:59 <tflink> it installs fine on F15, F16 is where it doesn't work
19:12:16 <dgilmore> jforbes: its like it is intentionally
19:12:17 <jforbes> libguestfs required grub1 until yesterday, that has been fixed
19:12:31 <dgilmore> jforbes: that libguestfs
19:12:34 <mgoldmann> btw, I have a fork on github: https://github.com/goldmann/appliance-tools
19:12:44 <dgilmore> nothing to do with how appliance-creator works
19:13:11 <jforbes> sure, but it is relevant information for boxgrinder
19:13:13 <dgilmore> mgoldmann: please dont fork things, just work upstream and develope and fix things there
19:13:29 <mgoldmann> dgilmore: I want to send patches upstream
19:13:48 <dgilmore> mgoldmann: please do
19:13:54 <mgoldmann> don't take this as fork - just github makes things easier for me :)
19:14:32 <dgilmore> http://koji.fedoraproject.org/koji/taskinfo?taskID=3354041
19:14:41 <dgilmore> thats my appliance build from yesterday
19:14:57 <dgilmore> DEBUG util.py:247:  Unable to create appliance : Failed to build transaction : grub conflicts with 1:grub2-1.99-5.fc16.x86_64
19:15:09 <dgilmore> thats using f16 rc1 content
19:16:10 <mgoldmann> right, so something pulls grub2 where on friday/monday it hasn't
19:16:59 <dgilmore> mgoldmann: regardles its something tha needs fixed  and not worked around
19:17:17 <mgoldmann> well, I agree
19:17:43 <dgilmore> and it should be fixed as low down the tool chain as possible
19:17:51 <dgilmore> anyways thats what im working on
19:18:04 <mgoldmann> I agree too
19:18:21 <rbergeron> okay.
19:18:36 <rbergeron> mgoldmann: if you have any patches or help can you send it in the way of appliance-tools? :)
19:19:06 <mgoldmann> rbergeron: not yet, I'm not sure what is the best way way to process patches for appliance-tools
19:19:20 <rbergeron> dgilmore: is ther ea ticket or anything where this is tracked? or not really
19:19:37 <mgoldmann> my first idea was: commit somehing and ask bkearney or dhuff to pull this to upstream
19:19:40 <dgilmore> rbergeron: there is not
19:20:57 <rbergeron> okay.
19:21:00 <rbergeron> Well.
19:21:17 <rbergeron> ONWARDS, unless someone has an aswer for mgoldmann on how to get things upstream, o rhas a nice link explaning how
19:22:27 <rbergeron> anyone? anyone?
19:22:30 <rbergeron> okay, well
19:22:42 <dgilmore> rbergeron: send patches
19:23:07 <dgilmore> rbergeron: if he doesnt hear anything i can test and apply patches to fedora git andbug folks as well
19:23:24 <jgreguske> yeah, I don't know how much of an upstream there is
19:23:36 <jforbes> There isn't
19:23:38 <jgreguske> dhuff and bkearney are both active on different things these days, no app-t
19:23:41 <mgoldmann> there is no upstream at this point IIRC :)
19:23:43 <jforbes> Though perhaps there should be
19:23:53 <jgreguske> last I heard anaconda was taking over the project
19:24:05 <jgreguske> since they wanted to have app-t share the same code paths and such
19:24:27 <rbergeron> is someone willing ot find out where appliance-tools is upstream-wise and who is owning it these days so we can actually have people working collaboratively
19:24:35 <rbergeron> and maybe solve *that* problem?
19:24:45 <rbergeron> I think we have enough brains in the room to solve things, but if nobody knows where to go, that's a problem
19:25:07 <rbergeron> anbd given the number of other projects not even related to us that use appliance-tools, you'd think it would be helpful for it to have a heartbeat and stuff.
19:25:10 <rbergeron> at least i would
19:25:16 <mgoldmann> rbergeron: I can contact dhuff and ask about the status and how we can help
19:25:21 <jgreguske> some of the anaconda team sits next to me, so I can ping them
19:25:28 <mgoldmann> or this ^ :)
19:25:28 <rbergeron> mgoldmann: thank you, and jgreguske: thank you.
19:25:53 <rbergeron> #action mgoldmann to ask dhuff about status/how to help with appliance-tools, jgreguske to ping anaconda-team in his immediate vicinity.
19:25:57 <rbergeron> work both angles ;)
19:25:58 <rbergeron> lol
19:26:01 <rbergeron> okay.
19:26:03 <mgoldmann> cool
19:26:10 <jgreguske> if they have a useful answer I'll make sure the list sees it
19:26:29 <rbergeron> #info We all want to get things fixed in appliance-tools, mgoldmann is willing to help, we just need to know how the heck ot get involved/get patches in/ know community status
19:26:35 <rbergeron> coolio. thanks, everyone
19:26:40 <rbergeron> #topic Aeolus
19:26:46 <rbergeron> clalance: hi there.
19:26:50 <clalance> rbergeron: Hello.
19:27:14 <clalance> rbergeron: Not really a whole lot to report.
19:27:31 <rbergeron> clalance: it's all good. just checkin' in.
19:27:49 <clalance> Another Oz release, the stuff that is in F-16 is relatively stable now.
19:27:59 <clalance> I expect more bugfixes to go in the next couple of weeks, but that's about it.
19:28:35 <clalance> mmorsi: Anything to add?
19:29:01 <rbergeron> #info Another Oz release, stuff in F16 is relatively stable now. More bugfixes over the coming weeks.
19:29:29 <clalance> Oh, you know, that was meant to be 2 separate things.
19:29:35 <clalance> (sorry)
19:29:40 <rbergeron> #undo
19:29:40 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x19caa60c>
19:29:40 <clalance> 1)  Another Oz release
19:29:48 <rbergeron> #info Another Oz release, stuff in F16 is relatively stable now.
19:29:56 <rbergeron> no, no.
19:29:58 <rbergeron> #undo
19:29:58 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x172d736c>
19:29:58 <clalance> 2)  aeolus overall in F-16 is relatively stable, expect more bugfixes in the next couple of weeks.
19:30:06 <rbergeron> #info Another Oz release is out.
19:30:21 <rbergeron> #info aeolus overall in f16 is relatively stable, expect more bugfixes in the next couple of weeks.
19:30:25 <rbergeron> ;)
19:30:28 <rbergeron> LOL
19:30:31 <rbergeron> OKAY THEN
19:30:35 <rbergeron> clalance: thank you sir.
19:30:41 <clalance> rbergeron: Thanks.
19:30:42 <rbergeron> #topic HekaFS
19:31:10 <jdarcy> Mostly negotiating about west-coast trip, and working out replication details.
19:31:10 <rbergeron> jdarcy, kkeithley: hi hi
19:31:12 <kkeithley> I don't have much to report
19:31:17 <rbergeron> west-coast trip?
19:31:48 * rbergeron is near the coast
19:32:03 <jdarcy> Yeah, a couple of potential users/customers.  One in SF, one near LA, which is a bit of a hassle.
19:32:22 <rbergeron> Ah. fun
19:32:22 <jdarcy> Oh yeah, and *lots* of time spent reviewing upstream code.  Those guys are busy right now.
19:32:50 <rbergeron> yup.
19:33:09 <rbergeron> everything about LA is a hassle :)
19:33:27 <kkeithley> I made some nit fixes to the UI, and added a couple of ops to  the uidmap xlator that snuck in late in the gluster 3.2.x line. Will merge those to main and run another build for f17, f16 on Monday I suppose, digging deeper in the rest of the source, mainly by getting hekafs to build with the latest glusterfs
19:34:00 <kkeithley> hey, I grew up in L.A. It may be a sh*thole, but it's my sh*thole
19:34:03 <rbergeron> LOL. That's a lot for "not much to report" :)
19:34:06 <rbergeron> HAHA
19:34:19 <jdarcy> I might be giving a talk about HekaFS at BBLISA (Back Bay, Boston) in October, if anyone's interested.
19:34:47 <rbergeron> is that different from regular LISA?
19:35:01 <jdarcy> Not sure of the relationship.  Same sort of crowd, certainly.
19:35:11 * rbergeron nods
19:35:17 <rbergeron> i know lisa is in boston this year, but i think in december
19:35:29 <rbergeron> if ke4qqq was paying attention he'd tell us, since he's going to give talks there.
19:35:40 <rbergeron> anyway.
19:35:49 <jdarcy> Note to self: ping ke4qqq about LISA.  ;)
19:36:16 <rbergeron> jdarcy: let us know when it gets closer so we can make sure to make some noise about it.
19:36:25 <jdarcy> OK.
19:37:10 <rbergeron> #info kkeithley has been doing stuff upstream, working on things, testing, UI work, etc
19:37:31 <rbergeron> #info jdarcy is possibly speaking at BBLISA, not sure how this is different from regular LISA, but he should beep at ke4qqq regardless
19:37:34 <rbergeron> okay.
19:37:40 <rbergeron> #topic BoxGrinder
19:37:44 <rbergeron> mgoldmann, msavy: hello there
19:37:58 <mgoldmann> hey
19:38:09 <mgoldmann> I *just* got back from vacations, but...
19:38:18 <rbergeron> a what?
19:38:28 * rbergeron has heard of those, hasn't had one in a long time
19:38:28 <rbergeron> :)(
19:38:32 <mgoldmann> we release another minor version: http://boxgrinder.org/blog/2011/09/12/boxgrinder-build-0-9-7-and-beyond/
19:38:50 <mgoldmann> rbergeron: it's that few days you dink more beer than ususal
19:38:56 <mgoldmann> drink*
19:39:19 <jdarcy> I hear that can affect your typing.
19:39:24 <ke4qqq> is BB lisa - Bay Area LISA?
19:39:39 <mgoldmann> jdarcy: that's coreasct
19:39:43 <jdarcy> ke4qqq: Back Bay (Boston)
19:39:57 <ke4qqq> ahhh cool
19:40:18 <rbergeron> mgoldmann: ahh
19:40:30 <jdarcy> Nice writeup, Marek.
19:40:31 <mgoldmann> this was a bugfix, so I don't know what to add, but it seems that we need to work on appliance-tools side to fix F16 permamently
19:41:05 <mgoldmann> jdarcy: thanks, I try to not cheat my readers :)
19:41:14 <rbergeron> #info bugfixes (details in link), seems we need to work on appliance-tools for permanent fix
19:41:38 <mgoldmann> and yes - I'm going to look at appliance-creator in the near future to make it usable :)
19:41:59 <mgoldmann> help of course appreciated
19:42:06 <rbergeron> #info mgoldmann to be looking at appliance-creator in the near future to make it usable
19:42:10 <rbergeron> ;)
19:42:11 <rbergeron> cool. anything else?
19:42:15 <rbergeron> you're going to JUDCon?
19:42:17 <rbergeron> and fudcon?
19:42:20 <mgoldmann> yes
19:42:21 <mgoldmann> yes
19:42:25 <rbergeron> linuxcon?
19:42:48 <mgoldmann> no :)
19:42:51 <rbergeron> #info mgoldmann will be at judcon in london, fudcon in milan for those who want to sync up and learn about boxgrinder
19:42:54 <rbergeron> okay.
19:42:56 <rbergeron> ;)
19:43:00 <rbergeron> ummm
19:43:00 <rbergeron> oh
19:43:08 <rbergeron> #topic OpenStack
19:43:15 <mgoldmann> hanks!
19:43:17 <mgoldmann> :)
19:43:23 * rbergeron doesn't see a markmc around, but knos there are things ongoing
19:43:52 * mgoldmann wants to note that openstack plugin for BG is almost finished and is waiting for 0.10
19:44:02 <rbergeron> #info FESCo accepted OpenStack as a feature for F16
19:44:15 <rbergeron> #info openstack plugin for boxgrinder is almost finished, waiting for 0.10
19:44:40 <rbergeron> mgoldmann: are you talking to them in their project-land about that?
19:44:50 <rbergeron> might get you some eyeballs and stuff.
19:44:55 <rbergeron> or maybe once it's out.
19:44:56 <rbergeron> ;)
19:45:15 <mgoldmann> so far I checked only uploading to glance
19:45:21 * rbergeron nods
19:45:33 <mgoldmann> I haven't started these, but it seems images are registered and ready for launch
19:46:02 <mgoldmann> I'll ping markmc once we move appliance-tools forrward :)
19:46:10 <rbergeron> :) sounds good
19:46:14 <rbergeron> #topic Docs
19:46:17 <rbergeron> So i just wanted to cover a few things here
19:46:21 * rbergeron wonders if sparks is around
19:46:35 * rbergeron yells sparks' name a little louder
19:46:38 <rbergeron> okay, he's not here.
19:46:45 <rbergeron> so you may have seen on the mailing list htat we had a little hackfest yesterday
19:46:56 <rbergeron> getting stuff together at least somewhat framed for F16 Cloud guide.
19:46:58 * rbergeron looks for links
19:47:21 <rbergeron> #link http://lists.fedoraproject.org/pipermail/cloud/2011-September/000825.html
19:47:48 <rbergeron> #info We had a Cloud Guide get-together on IRC yesterday, grabbing basic information to get the docs folks started on having a guide for all the f16 cloud stuff we have.
19:48:06 <rbergeron> #info if you have any commentary, or think we've missed things, please comment on the cloud list
19:48:28 <rbergeron> #link http://docs.fedoraproject.org/en-US/Fedora_Draft_Documentation/0.1/html/Cloud_Guide/index.html
19:48:36 <rbergeron> #info Draft is definitely a work in progress
19:48:49 <rbergeron> okay, next topic.
19:48:52 <mgoldmann> rbergeron: I just skimmed it, I'll add my comments if I have
19:48:58 <rbergeron> mgoldmann: cool, thanks :)
19:49:02 <rbergeron> #topic Test Day
19:49:10 <rbergeron> So i've been slacking and still haven't gotten together a test day page.
19:49:16 * rbergeron hails in tflink
19:49:52 <tflink> yes?
19:50:04 <rbergeron> I was just talking about testing.
19:50:18 <rbergeron> I know you popped in here at the beginning of the meeting so i was just making sure to say your name in case you had some burning question
19:50:50 <dgilmore> rbergeron: releng meeting is in 10 mins
19:51:15 <tflink> nothing comes to mind right now
19:51:16 <rbergeron> #info Test Day planning is underway, sort of, but we could use some help driving it/getting test plans together. please pipe up on the cloud list if you can help
19:51:22 <rbergeron> tflink: yeah.
19:51:22 <tflink> have you reserved the test day?
19:51:26 <rbergeron> #action rbergeron still needs to reserve a test day
19:51:27 <rbergeron> no
19:51:32 <rbergeron> we're taking like the last freaking one
19:51:53 <rbergeron> I'm tring to look at the test day page but i'm getting no response
19:51:55 <rbergeron> but
19:51:57 <rbergeron> ;)
19:52:37 <tflink> no repsonse from who/what?
19:53:04 <rbergeron> the internet
19:53:06 <tflink> oh, the wiki
19:53:08 <rbergeron> Error 503 Service Unavailable
19:53:12 <rbergeron> yeah
19:53:14 <rbergeron> Anyway.
19:53:22 <rbergeron> I'll do that this afternoon if it kills me.
19:53:36 <rbergeron> #topic Any other business?
19:54:05 <jdarcy> Whatever happened to Cloud Researchers, Users and Developers con?
19:54:14 <rbergeron> ah, cudcon.
19:54:36 <rbergeron> So the idea of having it held concurrently with a fudcon kind of got shot down.
19:55:02 <rbergeron> But we'll still have tracks at regular fudcon (and presumably judcon), and I think the idea of having a more stand-alone, vendor-neutral one is out there.
19:55:08 <rbergeron> I've been pinging a few people.
19:55:38 <rbergeron> But doing it at the same time or before/after fudcon just makes it really difficult for poeple who need to be at both, and tends to just drain one or the other event.
19:56:14 <jdarcy> OK.  Just didn't know if it was still being worked on.  Thanks.
19:56:32 <rbergeron> yup.
19:56:33 <rbergeron> anyone else?
19:56:44 <rbergeron> alrighty.
19:56:53 <rbergeron> well, thanks for coming, everyone, have a good weekend :)
19:56:55 <rbergeron> #endmeeting