19:00:17 <rbergeron> #startmeeting Cloud SIG
19:00:17 <zodbot> Meeting started Fri Sep 23 19:00:17 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:20 <rbergeron> #meetingname Cloud SIG
19:00:20 <zodbot> The meeting name has been set to 'cloud_sig'
19:00:33 <rbergeron> #chair gholms jforbes jsmith
19:00:33 <zodbot> Current chairs: gholms jforbes jsmith rbergeron
19:00:48 * gholms teleports into the room
19:00:53 <rbergeron> #topic Who's here
19:00:57 <rbergeron> Speak now
19:00:59 * jsmith is here
19:01:00 <rbergeron> or forever hold your cloud
19:01:07 <bertux> !fas bertux
19:01:08 * kkeithley is here
19:01:09 * tflink is lurking but busy testing for beta
19:01:14 <jdarcy> :P
19:01:16 <rbergeron> tflink: thank you sir
19:01:23 * bertux is here
19:01:33 <rbergeron> hey, bertux! thanks for joining :)
19:01:39 * mull is here
19:01:57 <bertux> rbergeron: thank you to welcome me ;)
19:02:06 <rbergeron> of course. and hello to mull, as well
19:02:09 * rbergeron cheers for new people
19:02:14 <mull> hi, rbergeron
19:02:21 <mull> and hi, bertux -- it's been a while.  :-)
19:02:29 <rbergeron> okay, so, we may have a light crowd today - we shall see.
19:02:49 * rbergeron will hold another moment whlie she grabs caffeine
19:03:03 * jdarcy only wishes "light crowd" could apply to him.
19:03:05 <bertux> yes mull it's been a while, it's nice to see you
19:03:38 <bertux> mull: we have came here at the same time :p
19:03:55 <rbergeron> alrighty
19:04:13 <rbergeron> #topic EC2
19:04:37 <rbergeron> So - I suppose to update - dgilmore sent a note to the cloud list the other day reporting in on F16 beta.
19:05:05 <rbergeron> He was having some problems being able to ssh in, etc.
19:05:12 * gholms has info on that :)
19:05:17 <rbergeron> oh, go ahead
19:05:21 <rbergeron> use the power of the chair, yo
19:05:47 <gholms> So yesterday I ported cloud-init to systemd and not-Ubuntu.
19:05:57 <dgilmore> rbergeron: i just now got a image i could log into
19:06:02 <rbergeron> dgilmore: ORLY
19:06:13 <gholms> dgilmore loaded cloud-init onto a test image and he can now log in. :)
19:06:14 <dgilmore> rbergeron: thanks to cloud-init from gholms yes
19:06:29 <rbergeron> #info good news, everyone! dgilmore now has an image he can log into
19:06:35 <dgilmore> rbergeron: so we are going to get cloud-init into fedora and use it :)
19:06:49 <rbergeron> #info thanks to gholms porting of cloud-init to systemd
19:06:53 <rbergeron> is that a package we don't have?
19:07:02 <dgilmore> rbergeron: yes
19:07:06 <gholms> Full disclosure: it needs a lot of patches to work on Fedora that I hope to get upstream.
19:07:11 * dgilmore will let gholms describe it
19:07:20 <rbergeron> gholms: can you info it plz :)
19:07:31 <rbergeron> #info cloud-init is a package not (yet) in fedora
19:07:42 <gholms> #info cloud-init currently needs a bunch of patches to work on Fedora
19:07:58 <gholms> #action gholms will work on upstreaming the cloud-init patches
19:08:23 <dgilmore> gholms: while thats happening we should still get it into fedora
19:08:35 <dgilmore> once its up for review and you point me at it ill review it
19:08:38 <rbergeron> what the hell is cloud-init, for those of us who aren't the sharpest knives in the drawer?
19:08:51 <gholms> For those who are curious, cloud-init does basic VM setup when you start EC2 instances.  It also let you do all kinds of fancy things by passing it a "user-data" file when you launch them.
19:09:06 <jdarcy> Like setting up ssh keys so you can log in.
19:09:26 <dgilmore> jdarcy: yeah, that bit in rc.local wasnt working for me
19:09:31 <gholms> We previously added custom stuff to rc.local to do that.
19:10:37 <gholms> [Awkard silence]
19:10:42 <rbergeron> okay.
19:11:03 <rbergeron> Sooooo
19:11:13 <rbergeron> Are we going to block uploading images based on the fact that it's not in fedora?
19:11:19 <rbergeron> or ... what?
19:11:25 <rbergeron> block *on* uploading images
19:11:27 <rbergeron> i mean
19:12:13 <rbergeron> [awkward lack of responses]
19:12:17 <rbergeron> dgilmore: does that block us? or not really
19:12:17 <dgilmore> rbergeron: we cant call it fedora with it in.
19:12:29 <gholms> dgilmore has offered to review it as soon as I manage to get the request in.
19:12:37 <rbergeron> But do we have to have hte patches upstream as well?
19:12:39 <dgilmore> rbergeron: but, as soon as its past review and built i can pull it in
19:12:56 <dgilmore> rbergeron: we dont have to have the patches upstream
19:13:00 <dgilmore> but they should go there
19:13:00 <rbergeron> coolio
19:13:28 <rbergeron> okay, well, we (for better or worse) have a week+, so do you think we'll be able to make it all come together for beta release-day availability? :D
19:13:36 <gholms> #action dgilmore to review gholms's package review for cloud-init once it is submitted
19:13:48 <dgilmore> rbergeron: so i dont belive this will stop us from releasing a beta at the same time as the rest of fedora
19:14:14 <rbergeron> #info Assuming all goes well with packaging, we should be able to release a beta at the same time as the rest of Fedora
19:14:17 <rbergeron> Whee!
19:14:38 <dgilmore> rbergeron: im happy to make the ami public if we want people to test
19:14:38 <gholms> Nice job, everyone!
19:14:50 <dgilmore> treat it like a nightly compose
19:14:59 * rbergeron nods
19:15:11 * rbergeron wonders about the costs of nightly composes and uploads....
19:15:31 * dgilmore does not know
19:15:57 <rbergeron> gholms: do you think that would be insane cost-wise
19:16:05 <rbergeron> or anyone else with extensive experience
19:16:05 <mull> the upload itself should be cheap, as long as you aren't storing all of the nightlies forever
19:16:16 <gholms> Uploading is cheap.
19:16:21 <mull> upload == pennies
19:16:32 <gholms> Storage is the biggest cost center.
19:16:52 <rbergeron> okay, so i guess the second question is - is it worthwhile / useful to do so, or would it be better to just have TCs/RCs posted?
19:18:04 <gholms> We don't have to keep many nightlies up at a time.
19:18:08 <mull> S3 storage is 0.140/GB/mo at the high end (gets cheaper the more you have)
19:18:53 <rbergeron> okay. so... Dennis: I think that sounds dandy, so let's just do that, and we'll see how useful it is. Sound good?
19:18:55 <mull> so now we're talking dimes instead of pennies.  :-)
19:19:44 <rbergeron> #action dgilmore to post nightlies/TCs/RCs/whatever as he sees fit
19:19:51 <rbergeron> dgilmore: when you post, can you put that info on the wiki page?
19:19:53 * rbergeron digs for link
19:20:06 <dgilmore> rbergeron: i can try to remeber to
19:20:33 <rbergeron> https://fedoraproject.org/wiki/Cloud_SIG/EC2_Images
19:20:48 <rbergeron> dgilmore: maybe it's something we could script somehow with the mediawiki-python thing
19:21:01 * rbergeron is just thinking aloud
19:21:18 <dgilmore> rbergeron: yeah, i have some plans on redoing how releng does stuff.
19:21:30 <gholms> Ubuntu has a system for rolling images automatically.  Perhaps we could eventually steal some of their code.
19:21:37 <rbergeron> coolio. thanks dgilmore :)
19:21:45 <dgilmore> rbergeron: part of my thoughts is a status page
19:22:10 <dgilmore> where you can see whats stable/eol, and latest compose info for in development releases
19:22:34 <rbergeron> dgilmore: that would be muy cool
19:23:29 <rbergeron> okay. i'll move on
19:23:31 <gholms> http://cloud.ubuntu.com/ami/
19:23:37 <gholms> ^ A status page for images
19:23:57 <rbergeron> #info take a look at Ubuntu's AMI status info, maybe some decent ideas there
19:24:03 <rbergeron> #topic HekaFS
19:25:08 <jdarcy> Lots of staring at GlusterFS code, lots of writing up ideas for the next release.
19:25:36 <kkeithley> some tinkering, some reinstalling my dev system after I borked it
19:25:39 <jdarcy> Gluster has asked if 3.2.4 could get into F16, I told them it seemed unlikely.
19:26:05 <rbergeron> why unlikely? no cycles to do the work?
19:26:13 <kkeithley> wondering why the hekafs rpm is still (stuck) in updates-testing instead of the F16 fedora repo
19:26:24 <rbergeron> kkeithley: because we're in beta freeze
19:26:54 <rbergeron> it should go to stable after that
19:26:56 <kkeithley> we can do the work, the question is will they get it out in time
19:27:01 <rbergeron> (LOOK, SHE'S LEARNING THINGS)
19:27:02 <jdarcy> 3.2.4 doesn't even exist yet.  Even if they squeeze it out early next week, we'd have to rush to beat freeze deadlines.
19:27:03 <rbergeron> oh
19:27:46 <jdarcy> And when I say "we" I mean Kaleb, since I'm about as useful as a beached manatee when it comes to packaging.
19:28:34 <rbergeron> so final change deadline is 10/24
19:28:35 <kkeithley> otherwise it'll go out after GA. I suppose there's an element of "nice" associated with it being in the GA, but I'm not sure it really matters.
19:29:11 <rbergeron> #info gluster looking to see if 3.2.4 could get into F16, but it's not out yet, so possibly unlikely
19:29:16 <jdarcy> That's all I had.  Not one of my better weeks.
19:29:53 <kkeithley> same here, borking my system was not a high point
19:30:15 <rbergeron> okay.
19:30:19 <rbergeron> <grouphug>
19:30:35 <rbergeron> #topic Aeolus
19:30:36 <kkeithley> mwah
19:30:48 <rbergeron> i don't see clalance about, or anyone else.
19:31:05 <rbergeron> #info lutter is presenting on aeolus later this afternoon on list-mentioned puppetconf live feed, for those interested
19:31:38 <jdarcy> Kaleb and I both checked.  No clalance.
19:31:42 * rbergeron nods
19:31:46 * rbergeron thinks about who *is* here
19:31:54 <bertux> i will try to watch this stream if it's not too late for France
19:32:10 <rbergeron> cool. it's in about 3.5 hours, iirc
19:32:54 <bertux> It's already 21:35 in France
19:32:59 <rbergeron> :)
19:33:05 <rbergeron> #topic Anything else?
19:33:07 <verdurin> Apparently the videos will be available after the conference
19:33:08 * rbergeron isn't sure who else is here.
19:33:27 <gholms> Anyone heard anything from BoxGrinder-land this week?
19:33:37 <rbergeron> verdurin: yup. or live, http://puppetlabs.com/puppetconf-live/
19:33:41 <rbergeron> gholms: not really
19:34:18 <bertux> Not this week but there was the new release 0.9.6
19:34:32 <rbergeron> #info Boxgrinder new release - 0.9.6
19:34:53 <bertux> and i plan to create a version for Vmware ESX of the BoxGrinder MetaAppliance
19:34:59 <verdurin> 0.9.7, I think
19:35:15 <rbergeron> bertux: very cool
19:35:27 <rbergeron> #info or 0.9.7, we have varying reports :)
19:35:41 <gholms> Heh
19:36:21 <bertux> and i will blog in french about it
19:36:34 <rbergeron> bertux: cool, I'm sure everyone will appreciate that :)
19:36:43 <bertux> to let BoxGrinder team link it in the official blog
19:37:16 <rbergeron> excellent.
19:37:21 * rbergeron waves at russellb
19:37:39 <bertux> do you know already about the new juju project of Ubuntu ?
19:37:49 <rbergeron> yup, i read about it a bit earlierthis week
19:38:23 <mull> juju, f.k.a. ensemble
19:38:24 <bertux> Yesterady i was at OpenWorld Forum in Paris to listen to Redhat presentations
19:38:48 <rbergeron> bertux: nice, lucky you :)
19:39:00 <bertux> but the juju is a south african word as ubuntu is
19:39:14 <bertux> juju means magic in south african
19:39:14 * russellb waves back to rbergeron
19:39:43 <rbergeron> bertux: you'll be in milan, correct?
19:39:58 <bertux> yes i've confirmed it to marek
19:40:12 <rbergeron> cool. i'll see you there :)
19:40:15 <rbergeron> hi, obino :)
19:40:20 <bertux> I will be in the same hotel than him
19:40:24 <obino> hi rgergeron!
19:40:40 <obino> yeah I'm still drunk from last night :/
19:40:44 <rbergeron> LOL
19:40:57 <rbergeron> i heard you guys went to ground kontrol.
19:41:08 <bertux> cool, it would be a pleasure for me to meet you rbergeron and speak french ;)
19:41:09 <obino> I have seen picuters :)
19:41:16 <obino> I"m not in portland ... sadly
19:41:23 <rbergeron> obino: oh, lol
19:41:35 <rbergeron> bertux: I can speak a little. :)
19:42:01 <bertux> rbergeron: i can help you practice your french
19:42:14 <rbergeron> awesome. :)
19:42:22 <rbergeron> okay, guys, anything else?
19:42:24 * rbergeron looks arond
19:42:31 <gholms> [You hear the sound of distant drums]
19:42:39 <Southern_Gentlem> bertux,  help her find the restroom and how to order an appletini
19:42:50 <bertux> I'm waiting for OpenStack testday
19:42:58 <rbergeron> bertux: yeah, so..
19:43:14 <rbergeron> #info rbergero still sucks at getting test day stuff going. Sorry :(
19:43:20 <bertux> i've seen there is already a QuickStart guide so i plan to try it already
19:43:51 <rbergeron> yup!
19:44:00 <bertux> to have questions ready for the tesday ;)
19:44:02 <rbergeron> They have a ton of documentation on their site as well.
19:44:08 <rbergeron> Just not very fedora-related, sadly.
19:44:09 <rbergeron> Yet.
19:44:16 <bertux> exactly
19:45:44 <bertux> on what channel can i discuss about openstack in fedora ?
19:45:56 <rbergeron> bertux: we're normally hanging out in #fedora-cloud
19:46:04 <rbergeron> and of course the mailing list :)
19:46:51 <bertux> have you already announced that the RedHat Enterprise Virtualization Manager has been open sourced by Redhat at overt.org ?
19:47:21 <bertux> i mean ovirt.org of course
19:47:58 <bertux> it was announced at RedHat Enterprise Virtualisation conference in OpenWorld Forum
19:48:03 <gholms> #info RHEV-M is now at http://www.ovirt.org/
19:48:36 <gholms> It will not be released for another month or so, right?
19:48:38 <bertux> i'm coming back at OpenWorld Forum tomorrow to see a demo of OpenStack running on Ubuntu by Nicolas Barcet
19:48:40 <rbergeron> oh, that's a good point.
19:48:42 <jdarcy> Maybe we can let it languish for a couple of years and then re-use the site for yet a third barely-related project, just to confuse/annoy people even more.
19:49:02 <bertux> jdarcy: i agree :p
19:49:05 <rbergeron> yeah, the code isn't posted yet
19:49:09 <gholms> jdarcy: Yeah... :(
19:49:10 <rbergeron> jdarcy: how do you really feel :) lol
19:49:18 <bertux> that is exactly was the RedHat speaker said me ;)
19:49:34 <jdarcy> rbergeron: Snarky, as always.  ;)
19:49:40 <rbergeron> lol
19:49:47 <rbergeron> that's a cloud sig membership requirement
19:50:05 <bertux> but Suse and Canonical already hope the code to be posted because they announced they will contribute to it
19:50:11 <rbergeron> Yup.
19:50:13 <rbergeron> and IBM, cisco.
19:51:03 <gholms> [Everyone stares at rbergeron]
19:51:10 <rbergeron> okay, i'm ending this thang.
19:51:14 <rbergeron> Have a good weekend, folks :)
19:51:22 <gholms> Thanks, everyone!
19:51:22 <rbergeron> #endmeeting