20:01:18 <stickster> #startmeeting Insight
20:01:18 <zodbot> Meeting started Tue Oct  4 20:01:18 2011 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:01:25 <stickster> #meetingname Insight
20:01:25 <zodbot> The meeting name has been set to 'insight'
20:01:27 * asrob is here
20:01:31 <stickster> #topic Roll call!
20:01:40 <asrob> o/
20:01:42 <stickster> #chair asrob
20:01:42 <zodbot> Current chairs: asrob stickster
20:02:17 <stickster> asrob: Do you know if pcalarco was going to make it this week?
20:02:49 <asrob> stickster, no, I do not
20:03:23 <stickster> Well, let's get started then :-)
20:03:31 <stickster> #topic Last week's action items
20:03:58 <stickster> #link http://meetbot.fedoraproject.org/fedora-meeting/2011-09-27/insight.2011-09-27-20.24.html <-- last week's notes
20:04:26 <asrob> #info asrob's item is done, http://drupal.org/node/1298294
20:04:47 <stickster> #info The puppetization of devel, staging and production should all be done now
20:05:03 <stickster> That includes the production pull of features + theme.
20:05:41 <stickster> asrob: This means that changes to the 'master' git branch of the features will now go to the production server
20:05:57 <asrob> stickster, I got it
20:06:32 <stickster> Any time you want to do a merge from 'devel' -> 'staging' should be fine
20:06:55 <stickster> Once the staging host tests OK, you can merge 'staging' -> 'master'
20:07:11 <stickster> Note that staging host syncs every 30 minutes, so there is a small delay
20:07:26 <stickster> Production host syncs every 4 hours
20:07:27 <asrob> I see
20:07:40 <stickster> So when you do a merge, it could take up to that long for the server to react.
20:08:11 <stickster> This works for the theme too
20:08:43 <asrob> cool
20:08:47 <stickster> Any questions on this? If not, asrob, you have the "keys to the kingdom" for git and can start managing with the git repos any time you like
20:09:12 <asrob> I have no question
20:09:22 <stickster> nirik: It should be possible to remove the drupal6-fedora-insight-theme package from the infrastructure repo now
20:09:38 <stickster> Well, I mean, possible + harmless. :-)
20:09:49 <stickster> I know we like to minimize the content there.
20:10:13 <stickster> #action stickster notify nirik + infra on their list they can remove that RPM package from their repo
20:10:26 <stickster> Anything else on puppet or git repos asrob?
20:10:55 <asrob> negative, so far I understand correctly ;)
20:10:58 <stickster> #topic Drupal 7, packaging, etc.
20:11:08 <stickster> I see that limb put in a BUNCH of modules today!
20:11:09 <nirik> sure, makes sense.
20:11:27 <nirik> stickster: oh, there was an error I was going to run by you sometime...
20:11:30 * nirik looks for it
20:11:44 <asrob> stickster, yeah, I'm building them
20:12:05 <nirik> insight02.dev has a error. I can run it by you out of meeting, or can mention it here if you like.
20:12:18 <stickster> #info stickster has filed a bunch of bugs for package reviews... they are all blocking the "InsightReviews" tracker bug, so you can find them in one place, here: https://bugzilla.redhat.com/show_bug.cgi?id=InsightReviews
20:12:29 <stickster> nirik: Yeah, it's fine to mention here. That's the lesser-used (thus far) D7 host
20:12:35 <nirik> Error 400 on SERVER: Invalid parameter insightDbHostname at /var/lib/puppet/git/manifests/nodes/insight02.dev.fedoraproject.org.pp:53 on node insight02.dev.fedoraproject.org
20:12:55 <stickster> nirik: Thanks, I'll take a look
20:13:06 <nirik> huh... insight01 might be doing the same.
20:13:18 <nirik> or wait, thats old.
20:13:28 <stickster> nirik: Which? Both? Or just insight01?
20:13:46 <nirik> I think it's just insight02.dev... the other is old, but I can check.
20:15:01 <stickster> nirik: I think insight01's would have been fixed when I corrected all the drupal6 manifest stuff.
20:15:10 <nirik> yeah.
20:15:12 <nirik> I can confirm
20:15:15 <stickster> nirik: I don't think I've done the same with drupal7 so that error's not totally unexpected
20:16:45 * stickster removes theme package from manifest for the d6 hosts now that they're all being overridden anyway
20:17:57 <stickster> #action stickster resolve this: Error 400 on SERVER: Invalid parameter insightDbHostname at /var/lib/puppet/git/manifests/nodes/insight02.dev.fedoraproject.org.pp:53 on node insight02.dev.fedoraproject.org
20:18:14 <stickster> asrob: Which packages are you currently worknig on for D7?
20:19:03 <asrob> stickster, flexifilter, feeds, strongarm and pathauto
20:19:14 <asrob> stickster, https://fedoraproject.org/wiki/Insight_Drupal_7_Dependencies
20:19:48 <stickster> asrob: Cool
20:20:15 <asrob> it's almost done
20:20:21 <stickster> asrob: I didn't see backup_migrate in that list
20:20:26 <stickster> Don't we need that for testing purposes
20:20:55 <asrob> yeah, I think that list isn't full
20:21:09 * stickster also is taking care of login_destination since we have a ticket that depends on that, probably
20:21:16 <stickster> Also the 960 base theme for the Fedora theme
20:21:18 <asrob> for example, mediawiki_api module doesn't have drupal 7 version
20:21:20 <stickster> Yeah
20:21:41 <stickster> #info stickster has submitted D7 backup_migrate, diff, login_destination, ninesixty (theme) modules
20:22:28 <stickster> asrob: If there are any other bugs needing review, can you please make them block 'InsightReviews' so they'll appear in that bug's dependency tree?
20:22:51 <asrob> stickster, sure, I can
20:23:02 <stickster> That's easier than updating the wiki when it comes to knowing what's reviewed and what's not
20:23:40 <asrob> yeah, absolute
20:24:02 <stickster> #action asrob make sure other package review bugs block 'InsightReviews' bug
20:24:16 <stickster> OK, anything else on D7 and packaging?
20:24:40 <asrob> -
20:25:51 <stickster> #topic Calendar
20:26:20 <stickster> I know I've seen the calendar topic come up somewhere on a list recently. I think I recall nirik sort of pointing our way, as a matter of fact.
20:26:30 <nirik> yeah.
20:26:38 <asrob> yeah, that's good idea
20:26:38 <nirik> RE: zarafa.
20:26:42 <stickster> However, I still don't have the impression that either asrob or I has cycles to sort of jump into action to make a calendar happen.
20:26:50 <nirik> :(
20:26:52 <stickster> s/has/have/ ? Sorry for poor grammar.
20:27:03 <nirik> I don't think I really do either... but we really would like to have one.
20:27:09 <stickster> Everyone would.
20:27:14 <nirik> I can see about trying to drum up some more folks.
20:27:33 <stickster> I can *possibly* do some work on it in following the end of October.
20:28:07 <stickster> But lots of people wanting it isn't going to make it magically happen. Unfortunately $DAYJOB is not really leaving me the 20% time I hoped for Fedora stuff.
20:28:30 <nirik> yeah, it's not as simple a problem as people think.
20:28:39 <stickster> What would be great is if someone could wrangle the appropriate folks, like a designer, to make a visual representation of what people want.
20:28:43 <nirik> most of the solutions are not at all what we want.
20:29:15 <stickster> I think we have a list of some use cases but we also need to know what it is people want to see on the screen. IIRC that may be the next step.
20:29:55 <nirik> yeah. That takes time too. ;(
20:29:58 <stickster> Otherwise we end up with a "geek's eye view" for a calendar which isn't necessarily going to be a great solution for the cases described
20:30:36 <stickster> If no one does that, I can take my best shot starting in November
20:30:39 <stickster> But it could take me a while.
20:31:30 <stickster> nirik: In the meantime, I think it would be really helpful if, when anyone points to the Insight team, that's always accompanied by "And they need some help." Drupal isn't that hard to learn, I did it after all.
20:31:52 <nirik> ok. I can see if I can find folks interested in that effort.
20:32:07 <stickster> There are a lot of resources both online and in print, which is really helpful. And the API and everything under the hood is fantastically well documented.
20:32:24 <asrob> yeah
20:32:32 <stickster> So even a crummy wannabe hacker like me can figure stuff out given a little time
20:32:37 <asrob> :)
20:33:21 <Southern_Gentlem> interested just time laiden at the moment
20:33:46 <Southern_Gentlem> stickster,  maybe a couple insight howto sessions friday at FUDcon
20:33:48 <stickster> Southern_Gentlem: Not like you don't have a FUDCon to work on :-)
20:34:00 <stickster> Southern_Gentlem: That sounds like a GREAT idea. I would be happy to run something like that.
20:34:12 <asrob> :)
20:34:29 <stickster> #action stickster sign up for a session or two at FUDCon on Drupal and/or Insight.
20:34:41 <stickster> Southern_Gentlem: Is there a place for me to sign up on the wiki page now?
20:35:05 <Southern_Gentlem> yep hackfest or classroom
20:35:17 <stickster> Southern_Gentlem: OK, I'll do that
20:35:40 <stickster> I can't teach from the POV of "great Drupal developer," but I can certainly teach from the POV of "guy who figured some stuff out, here's how I did it"
20:35:40 <Southern_Gentlem> http://fedoraproject.org/wiki/FUDCon:Blacksburg_2012#Hackfest-_Workshops
20:36:10 <Southern_Gentlem> better in my opinion
20:36:19 * stickster notes that doesn't happen until January so either the calendar will be a case study... or a TODO
20:36:58 <asrob> oh no, we will do this until January ;)
20:37:13 <stickster> :-)
20:37:19 <stickster> OK, <eof> for me
20:37:29 <stickster> Anything else on this topic?
20:37:33 <asrob> nothing
20:37:57 <stickster> #info stickster will try to free up some time starting in November for working on the calendar but desperately wants and needs help.
20:38:07 <stickster> #topic Open floor, all other business
20:39:15 <stickster> asrob: Do you think it would be smarter to plan calendar work on D7, and expect that you will help us migrate the existing Insight to D7 before we put anything else new in production?
20:40:01 <asrob> stickster, yeah, definetly
20:40:52 <asrob> stickster, 1. migrating from 6 to 7, 2. calendar work, 3. anything else
20:41:07 <stickster> OK, that's what I thought we had talked about before, just making sure :-)
20:41:16 <asrob> yeah yeah ;)
20:41:23 * stickster doesn't have any other topics and will keep floor open for a minute for other people
20:42:23 <asrob> -
20:42:39 <asrob> you can close it
20:46:26 <stickster> Okey dokey :-)
20:46:28 <stickster> #endmeeting