15:03:10 <adamw> #startmeeting Fedora QA Meeting
15:03:10 <zodbot> Meeting started Mon Oct 31 15:03:10 2011 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:13 <adamw> #meetingname fedora-qa
15:03:13 <zodbot> The meeting name has been set to 'fedora-qa'
15:03:17 <adamw> #chair tflink
15:03:17 <zodbot> Current chairs: adamw tflink
15:03:24 <adamw> #chair kparal
15:03:24 <zodbot> Current chairs: adamw kparal tflink
15:03:27 <brunowolff> http://lists.fedoraproject.org/pipermail/test/2011-October/104153.html repots a regression in an rc.
15:03:34 * j_dulaney is here
15:03:34 <brunowolff> s/repots/reports/
15:03:38 * pschindl is here
15:03:40 * kparal present
15:03:52 <brunowolff> Does look like it would be a blocker.
15:03:59 <brunowolff> s/does/doesn't/
15:04:07 <adamw> it's from chuck, which means i don't care.
15:04:09 <brunowolff> I can't type this morning.
15:04:17 <adamw> the dude is programmed to provide utterly useless bug reports.
15:04:21 <jskladan> me lurks
15:04:41 * tflink is still here
15:05:00 <adamw> #topic roll call
15:05:04 <adamw> now do it all again, suckers!
15:05:10 * brunowolff is here
15:05:13 * j_dulaney has his harmonica out and is blowing it
15:05:17 * kparal does it again
15:05:30 * jskladan can use the irc command now
15:05:32 <j_dulaney> After spending last night stroking my big wood instrument and polishing my flute
15:06:48 * tflink might be here, isn't sure if it changed in the last 2 minutes
15:06:50 * adamw covers brunowolff's ears
15:06:59 <adamw> tflink: I CAN'T HEAR YOU
15:07:26 <tflink> adamw: well, you don't need to shout
15:07:57 <adamw> alright, let's get this dog and pony show on the road
15:07:58 <adamw> heh
15:08:02 <j_dulaney> It's only dirty if you have a dirty mind or don't know that I play standup bass
15:08:03 <adamw> #topic Previous meeting follow-up
15:08:15 <adamw> why are you here anyway? didn't I fire you?!
15:08:28 <tflink> many times
15:08:42 <j_dulaney> ???
15:08:44 <adamw> uh, hey, this is going to be a short section, as there appear to be no actions from the previous meeting
15:08:47 <kparal> there were more people fired as I recall :)
15:09:09 <j_dulaney> Red Hat sudenly laying off?
15:09:11 <adamw> YOU'RE ALL FIRED
15:09:13 <tflink> yeah, I think that jskladan was the last once to get fired
15:09:20 <jskladan> oh yeah
15:09:24 <j_dulaney> Yay, I can go home
15:09:25 <jskladan> I did not work on state holiday
15:09:28 <j_dulaney> Oh, wait
15:09:35 <kparal> the more close to release date, the larger fire mood for adamw :)
15:09:41 <tflink> j_dulaney: no, adamw just gets cranky and fires us
15:09:44 <brunowolff> Was the quote "Good night tflink. Sleep well. I'll most likely kill you in the morning."?
15:09:50 <adamw> you know what a holiday is? it's an opportunity for you to work undisturbed by others!
15:10:14 <j_dulaney> LOL
15:10:19 <tflink> brunowolff: huh? I missed that one
15:10:23 <adamw> okay, so last meeting we mostly just reviewed blockers, and we're gonna have to do it again
15:10:24 * tflink looks through the logs
15:10:36 <adamw> #topic Fedora 16 prep: blocker review
15:10:42 <adamw> tflink: it's a Princess Bride joke.
15:10:47 <adamw> if you don't get it, you're fired.
15:10:51 <jsmith> tflink: "Have fun storming the castle!"
15:10:51 <adamw> also, you get to have a drink with me...
15:11:03 <rbergeron> HOOORAY
15:11:09 <brunowolff> Well I probably should have changed it to "Good night tflink. Sleep well. I'll most likely fire you in the morning."
15:11:11 <kparal> is that a threat?
15:11:15 <rbergeron> i promise i didn't just hop in because i saw the word drinks
15:11:28 <adamw> rbergeron: no, you have an alert on the phrase 'princess bride'. admit it.
15:11:32 <jsmith> rbergeron: You saw the word "princess"?
15:11:38 * jsmith ducks
15:12:08 <tflink> adamw: you should really add that to the job description @ hiring time. First Dr. Horrible and now Princess Bride?
15:12:14 * j_dulaney fingers his big wood instrument some more
15:12:29 <j_dulaney> Dr. Horrible is here?
15:12:44 <brunowolff> I have a t-shirt with "I have a PhD in horribleness" on it.
15:13:03 <Dr_Horrible> I will use my Freeze Ray on you all!!!
15:13:03 <tflink> j_dulaney: no, adamw fired me for not having seen Dr. Horrible around beta
15:13:06 <fenrus02> Dr_Horrible, just dont talk about the hammer
15:13:22 <adamw> all right, simmer down, children
15:13:39 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=750228
15:14:13 <adamw> so, it seems like somehow efidisk.img sometimes gets broken in generation. i'm probably +1 blocker on this, and i assume we can just fix efidisk.img without screwing up anything else
15:14:40 <j_dulaney> That seems right
15:14:47 * j_dulaney is also +1 blocker
15:14:51 <adamw> dgilmore: poke!
15:15:53 <kk4ewt> +1
15:16:24 <adamw> criterion is "Where platform support exists, all dedicated installer images (except efidisk.img, which offers no options) must boot to the graphical boot menu and allow the user to select install options. If no option is selected, the installer should load after a reasonable timeout " from alpha
15:16:32 <tflink> +1
15:16:50 <j_dulaney> Indeed
15:16:51 <adamw> propose #accepted 750228 is a blocker per criterion ""Where platform support exists, all dedicated installer images (except efidisk.img, which offers no options) must boot to the graphical boot menu and allow the user to select install options. If no option is selected, the installer should load after a reasonable timeout "
15:16:52 <kparal> +1
15:17:13 <j_dulaney> +1
15:17:16 <kk4ewt> so with that it cant be a blocker
15:17:38 <tflink> ack
15:17:40 <adamw> it can, though it's a bit poorly worded
15:17:52 <adamw> efidisk.img isn't meant to be excepted from the entire criterion, just the requirement to display options
15:18:17 <adamw> so for efidisk the requirement is 'boot to graphical boot menu and load installer after a reasonable timeout'
15:18:29 <kk4ewt> +1
15:18:39 <adamw> #accepted 750228 is a blocker per criterion ""Where platform support exists, all dedicated installer images (except efidisk.img, which offers no options) must boot to the graphical boot menu and allow the user to select install options. If no option is selected, the installer should load after a reasonable timeout "
15:18:48 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=748272
15:18:56 <tflink> #accepted?
15:19:30 <kk4ewt> should be #agreed
15:20:07 <adamw> guh
15:20:10 <adamw> #undo
15:20:10 <zodbot> Removing item from minutes: <MeetBot.items.Accepted object at 0x4728bd0>
15:20:26 <adamw> #agreed 750228 is a blocker per criterion ""Where platform support exists, all dedicated installer images (except efidisk.img, which offers no options) must boot to the graphical boot menu and allow the user to select install options. If no option is selected, the installer should load after a reasonable timeout "
15:20:34 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=748272
15:20:52 <adamw> so, this is just a needsinfo , and people REALLY need to stop adding bugs to the blocker list so damn late...
15:21:08 <adamw> cra: *shakes fist*
15:21:32 <tflink> it almost sounds like this might have been with an older compose
15:21:43 <j_dulaney> Indeed
15:21:54 <j_dulaney> I'm not running into UEFI problems with RC2
15:21:56 <adamw> tflink: the initial report is from beta
15:22:31 <adamw> he claims in comment #4 to still see teh bug with tc2 but provides no new logs
15:22:53 <adamw> so i don't think we can do anything with this till we get some logs
15:23:16 <tflink> yeah
15:23:19 <pjones> it's entirely possible the bootloader isn't installing correctly due to a firmware bug.
15:23:38 <pjones> that certainly has been something we've seen on some machines (though it's the first report I've seen on that one)
15:24:06 <adamw> pjones: there's a claim that ubuntu 11.10 works
15:24:08 <pjones> but yeah - we need logs to know what's going on with any degree of certainty.
15:25:28 <adamw> k
15:25:29 <cra> adamw: don't shoot the messenger :-)
15:25:39 <adamw> cra: i will if he's late ;)
15:25:54 <adamw> #agreed more information is needed to determine the status of 748272
15:26:13 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=651305
15:26:42 <adamw> so, wow, this is annoying.
15:26:44 <rdieter> hi
15:27:13 <adamw> rdieter: we're on https://bugzilla.redhat.com/show_bug.cgi?id=651305
15:27:15 <tflink> yeah, I'm also -1 on this. it doesn't crash the app and doesn't happen on boot
15:27:16 <adamw> what's your read on this?
15:27:23 <adamw> tflink: er what?
15:27:30 <adamw> tflink: this is the kde upgrade bug
15:27:44 <rdieter> finally fully understand this one, can plug in some workaround(s) easy enough in a bit.
15:28:09 <tflink> adamw: sorry, I was on a different one
15:28:16 <rdieter> in short, upgrader's will hit a case where kdm is non-functional due to awol theme
15:28:34 <rdieter> only affects DVD
15:28:42 <adamw> is there any way you can fix / workaround it which does not involve us having to respin f16?
15:28:44 <rdieter> (which is why I never saw it)
15:29:12 <rdieter> adamw: the easiest fix I had in mind was a newer kde-settings pkg with a hard-coded dep
15:29:21 <adamw> right, which needs a respin.
15:29:30 <adamw> (and boy, are dgilmore's arms tired)
15:29:36 <rdieter> adamw: another approach would be to jigger DVD creation to include a couple other pkgs
15:29:38 <kk4ewt> +1 blocker
15:30:10 <rdieter> ie, add kde themes from the last 1-2 fedora releases.
15:30:26 <adamw> as far as respinning's concerned those are the same.
15:30:34 <adamw> if we have to respin to fix it the kde-settings fix sounds like the safest.
15:30:36 <rdieter> hmm...
15:30:39 <j_dulaney> Yeah, I'll say +1 blocker on this, as well, since this does kill KDE and thus hits criteria
15:31:02 <rdieter> adamw: what mods can we do that would avoid a respin?
15:31:10 <j_dulaney> Curses
15:31:16 <adamw> i was hoping you'd have something you could pull out of your ass. =)
15:31:17 <rdieter> comps ?
15:31:20 <adamw> some kind of fix to *f15* would avoid it
15:31:27 <adamw> but that seems unpossible
15:31:37 <rdieter> oh, ok, yeah, hard.  sorry.
15:31:48 <rdieter> I'll fixup kde-settings here in a bit
15:32:08 <adamw> sigh. well, we can spin again to fix this, i guess, if the fix only touches kde that limits the scope of possible borkage, which is good.
15:32:26 <kk4ewt> in short other than telling kde users with the DVD to enable updates there is not way to fix without res[in
15:32:43 <adamw> yeah, seems that way.
15:33:14 <adamw> i'm not sure you even get the repo choice on an upgrade.
15:33:45 <kk4ewt> so borkage  +1 respin
15:34:17 <adamw> propose #agreed 651305 is accepted as a blocker per criterion "The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria."
15:34:22 <adamw> anyone want to argue against?
15:34:35 <adamw> kk4ewt: how come the nick change?
15:34:38 <tflink> ack
15:34:39 <j_dulaney> adamw:  What happens if you use (CD, I know) a KDE CD to upgrade a Gnome system?
15:34:55 <kparal> ack
15:34:56 <kk4ewt> j_dulaney, still missing a dep
15:35:08 <j_dulaney> Ok
15:35:11 <j_dulaney> +1
15:35:17 <kk4ewt> livecds dont upgrade
15:35:19 <adamw> er, what?
15:35:23 <adamw> yeah
15:35:32 <adamw> you can't do that
15:35:40 <j_dulaney> That's right
15:35:40 * j_dulaney forgot
15:35:57 <adamw> this affects the case where you use the DVD to upgrade a system that uses KDM as the login manager, basically.
15:36:08 <j_dulaney> Indeed
15:36:14 <j_dulaney> Still, +1 blokcer
15:36:17 <adamw> it doesn't quite meet the criterion
15:36:27 <adamw> since the criterion refers to a 'default install', which this is not
15:36:34 <adamw> but it does seem like something we really ought to fix
15:36:42 <j_dulaney> Indeed
15:36:47 <tflink> you mean since it's KDE instead of gnome?
15:37:08 <adamw> yeah. to get that you had to change the package selection, hence, not default.
15:37:09 <tflink> nvm
15:37:13 <kk4ewt> default from any medium which covers it
15:37:19 <adamw> that criterion is mostly just a hedge against 'you can't test every damn thing', though.
15:37:29 <adamw> kk4ewt: oh, right, if you installed kde live then dvd upgrade you'd hit this.\
15:37:47 <kk4ewt> they have an full updated kde livecd install
15:37:54 <adamw> #agreed 651305 is accepted as a blocker per criterion "The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria."
15:38:16 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=748921
15:38:42 <tflink> now that I'm looking at the right bug, I'm also -1 on this
15:38:53 <tflink> since it doesn't crash anything and doesn't happen on boot
15:39:06 <adamw> yeah, doesn't meet either criterion
15:39:28 <adamw> i'm not super keen on NTH for this either, as selinux-policy upgrades are big and can break anything
15:39:38 <adamw> i think we just leave this one to get fixed by upgrades
15:39:39 <tflink> yeah
15:40:00 <j_dulaney> -1 for blocker
15:40:55 * j_dulaney doesn't see how it really affects usability, either, since SELinux complaints _can_ be ignored
15:41:19 <kk4ewt> -1
15:41:42 <kk4ewt> next
15:42:03 <kparal> -1 blocker
15:42:13 <adamw> propose #agreed 748921 is not a blocker, doesn't meet either the selinux or abrt criteria
15:42:18 <tflink> ack
15:42:19 <j_dulaney> ack
15:42:30 <brunowolff> I have had the time/date applet crash a few times, but it seems to happen rarely when first signing on. I don't know if this is exactly the same bug.
15:42:31 <kparal> ack
15:43:13 <brunowolff> But since it is rare and the effect is small (you can remove and add the applet from the menu) I wouldn't think it would be a blocker.
15:43:19 <adamw> #agreed 748921 is not a blocker, doesn't meet either the selinux or abrt criteria
15:43:37 <brunowolff> In my case I am using fallback mode, which may make a difference.
15:43:39 <adamw> alright, that's the lot, i think
15:44:16 <adamw> does anyone with strong psychic powers know what the hell Chuck Forsberg's "Final Release Candidate Regression" mail is saying?
15:44:42 <adamw> #topic Fedora 16 final prep: blocker review: any other blockers
15:44:43 * j_dulaney (as Dr. Horrible) doesn't
15:44:50 <brunowolff> Didn't he have some post about 3TB disk drive partitions a few weeks ago?
15:44:56 <kparal> I have one bug to discuss
15:45:14 <j_dulaney> brunowolff:  I think so
15:45:21 <drago01> adamw: parse error
15:45:29 <tflink> it sounds like it's an issue with partitioning but I'm not sure that there's enough info to figure out whether its pilot error or not
15:45:37 <cra> sounds like reusing a BIOS BOOT partition fails
15:45:42 <kk4ewt> adamw, so i think we may have only on blocker which may be the kde stuff
15:46:08 <brunowolff> It was annoying that the spin kickstarts needed a few changes. Unless someone thinks it is critical to have the actual kickstarts on the media, I'll just do this as an update.
15:46:14 <adamw> cra: well, we can confirm/deny that easy enough
15:46:33 <tflink> I just reused a BIOS boot partition about 5 minutes ago so if there is a failure there, it's not with all machines
15:46:34 <adamw> brunowolff: i'm not sure if there's any legal implications to that?
15:46:45 <adamw> tflink: ah. good. in that case i'm all for ignoring chuck
15:46:56 * adamw projects the Spot Beam
15:46:59 <adamw> spot: legal q!
15:47:23 <brunowolff> Jesse used to care about this, but I didn't understand the full reason. He would be a good person to check with.
15:48:30 <brunowolff> It's not like the source won't be available somewhere, as the source tar ball will be on fedorahosted as well as the srpm being in updates.
15:48:50 <adamw> yeah. we'd best check with him before doing rc3 spin. okay
15:48:59 <adamw> kparal: which bug did you want to discuss? the text upgrade one?
15:49:26 <kparal> https://bugzilla.redhat.com/show_bug.cgi?id=742207
15:49:26 <brunowolff> If you get an answer from him, I'd like to hear it so I can write it down on the spins wiki.
15:49:30 <adamw> k
15:49:36 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=742207
15:49:48 <adamw> so i did know about this one at beta
15:50:01 <adamw> and i'm still pretty much -1 blocker on it. though i was hoping anaconda team would fix it, i admit.
15:50:21 <adamw> kparal: yes, we knew about the weird 'it'll proceed if you select nothing' case too
15:50:41 <kparal> basically if you don't select the option properly, it will destroy your data without you wanting to
15:50:53 <adamw> destroy data is a rather strong way to describe 'mess up bootloader config'
15:51:03 <kparal> ok, overwrite bootloader
15:51:13 <adamw> when we talk about destroying data we're usually talking about actual, you know, User Stuff
15:51:35 <kparal> ok, destroy bootloader
15:51:40 <kparal> to put it into correct words
15:51:50 <kparal> I just wanted to highlight that issue
15:51:59 <kparal> I am not also sure whether to vote it as a blocker
15:53:03 <adamw> yeah, i mean, it sucks, but...text mode upgrade. ehhhh.
15:53:14 <adamw> we don't really have criteria for it.
15:53:16 <brunowolff> I think it is not a blocker. It is rare to do text upgrades and based on the description requires user error (even if easy to do) to cause an issue.
15:53:33 <kparal> actually it's extremely easy to do
15:53:41 <kparal> I made the error
15:53:49 <brunowolff> Given it's anaconda and we have no time left, I wouldn't make it NTH either.
15:53:51 <kparal> I had upgraded countless times
15:54:34 <adamw> any other votes?
15:54:36 <tflink> I think that I'm of pretty much the same mind brunowolff is, if it was earlier ... maybe
15:54:37 <kk4ewt> -1
15:54:37 <brunowolff> We could document how to recover from it for the few people who might run into it.
15:54:48 <tflink> yeah, definitely document the bug
15:55:00 <kk4ewt> +1 brunowolff
15:55:09 <kk4ewt> doc in common bugs
15:55:41 <adamw> propose #agreed 742207 is not a blocker: text mode upgrade isn't really covered by criteria and the likely impact of this is too small to really worry about
15:55:49 <adamw> s/small/narrow/
15:55:57 <j_dulaney> ack
15:55:59 <brunowolff> +1
15:56:15 <kk4ewt> +1
15:56:40 <tflink> adamw: have you looked at https://bugzilla.redhat.com/show_bug.cgi?id=750216 ?
15:56:59 <tflink> since you've been working with preupgrade more than most of us have?
15:57:02 <adamw> #agreed 742207 is not a blocker: text mode upgrade isn't really covered by criteria and the likely impact of this is too narrow to really worry about
15:57:10 <adamw> tflink: not yet
15:57:25 <tflink> it might be blocker material if there is no pilot error
15:57:44 <tflink> but it sounds like the preupgrade issue that we've had for a while
15:58:03 <adamw> it sounds incoherent to me
15:58:06 <tflink> and if the fix required something from F15 updates-testing, I'm wondering if it just needs retesting
15:58:09 <adamw> the reproduction steps are clearly incomplete
15:58:18 <adamw> there's no really useful logs there
15:58:21 <tflink> took me a while to figure out what he was talking about and I'm still not sure
15:59:49 * j_dulaney must go AFK for a few minutes,. will return
16:00:02 <kk4ewt> should be tested but not a blocker as its reported at the moment
16:00:42 <adamw> yeah, i think we just need to keep getting info from hongqing on that one.
16:00:42 <kk4ewt> and the preupgrade was pointed at Alpha Beta or what
16:01:09 <adamw> i've tested preupgrade and it works, couple of other people have reported it working too, the actual .ks written there looks correct, so i'm not hugely concerned
16:01:35 <adamw> okay, so we're over time
16:01:38 <adamw> let's skip along quickly
16:01:47 <adamw> #topic proventester / autoqa updates
16:01:58 <adamw> anything on the autoqa front, kparal or tflink? or has it been all f16 stuff?
16:02:38 <tflink> mostly f16 stuff and trying to get ready to test the next release of autoqa
16:02:39 <kparal> nothing big from me
16:03:19 <adamw> k
16:03:24 <adamw> #topic upcoming qa events
16:03:32 <adamw> there ain't any, aside from getting f16 done :)
16:03:35 <adamw> #topic open discussion
16:03:49 <adamw> anything else? might be stuff i've been missing with the focus on f16, don't be shy
16:05:09 <kk4ewt> how does one point preupgrade to the latest spin
16:05:20 <adamw> kk4ewt: it uses the repos, it doesn't know about spins.
16:06:56 <kk4ewt> so how would one test with preupgrade and pull from the rc2 tree
16:07:16 <adamw> one doesn't, really. but one should get the latest packages pushed to stable, which is good enough.
16:07:19 * adamw sets fuse for 2 mins
16:07:55 <kparal> this time we have chairs :)
16:08:35 <adamw> *shakes fist*
16:08:41 <adamw> you little...
16:08:50 <kparal> I was wondering if you get it
16:08:55 * jskladan *misfire*
16:09:08 <adamw> does anyone actually know where dgilmore is today?
16:09:38 <adamw> #endmeeting