15:07:45 <rdieter> #startmeeting kde-sig -- https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2011-12-20
15:07:45 <zodbot> Meeting started Tue Dec 20 15:07:45 2011 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:07:51 <rdieter> #meetingname kde-sig
15:07:51 <zodbot> The meeting name has been set to 'kde-sig'
15:08:07 <rdieter> #topic roll call
15:08:15 <rdieter> hi ho, who's present today?
15:08:23 * rnovacek is here
15:09:04 <rdieter> than: ping
15:09:23 <rdieter> rnovacek: might be the quiet and quick meeting (yay)
15:09:24 <Kevin_Kofler> Present.
15:09:30 <than> present
15:09:35 <rdieter> #info rnovacek than Kevin_Kofler rdieter present
15:09:39 <rdieter> #chair rnovacek than Kevin_Kofler
15:09:39 <zodbot> Current chairs: Kevin_Kofler rdieter rnovacek than
15:10:34 <rdieter> #topic agenda
15:10:44 <rdieter> I added qt-4.8.0/kde-4.7.4 updates to agenda initially
15:10:50 <rdieter> anything else we should discuss today?
15:11:28 <than> rdieter:  perhaps kde splits state
15:12:03 <rnovacek> btw: 4.8rc1 should be tagged today
15:13:54 <rdieter> rnovacek: yay
15:14:00 <rdieter> well, let's get started
15:14:14 <rdieter> #topic qt-4.8.0/kde-4.7.4 updates
15:14:53 <rdieter> in short, the qt/kde stuff in updates-testing is ready for stable, I think
15:15:08 <rdieter> qt still has the nagging issue of what to do with libicu support, though
15:15:46 <rnovacek> nice, +8 karma
15:15:55 <rdieter> currently, qt tries to dlopen libicu at runtime, and gives some qWarning output on failure
15:16:12 <than> rdieter: i think it's time to push kde-4.7.4 in stable
15:16:37 <rdieter> #agreed kde-4.7.4 to be queue'd for stable updates today
15:17:54 <rdieter> wrt qt, before queuing for stable, options include: 1 do nothing, push as-is, 2. revert adding icu support, 3. silence the qWarning, 4.  add a hard dep on libicu, 5. something else better?
15:18:24 <rdieter> opinions?
15:18:30 <Kevin_Kofler> IMHO, 4. is cleanest, but I'm worried about the impact on future (F17+) live image sizes.
15:18:44 <Kevin_Kofler> So 3. might be the best solution after all.
15:18:50 <rdieter> right, libicu is non-trivial size-wise
15:19:09 <rnovacek> I'm for 3. and adding to @kde-desktop
15:20:22 <rdieter> ok, I'm going to be a little naughty here, suggest we do both 1 and 3.  1 push what we have (0.29.rc1) to stable, 3. build qt-4.8.0 (final) silencing the qWarning and send that to updates-testing asap
15:20:41 <than> 3 is ok with me
15:20:52 <rdieter> rnovacek: and +1 for comps
15:21:07 <Kevin_Kofler> rdieter: I think that's OK.
15:21:36 <rnovacek> rdieter: I agree
15:22:05 <rdieter> I can do the qt patching, I'm familiar with looking at the qlocale stuff already
15:22:36 <Kevin_Kofler> OK, great.
15:22:56 <rdieter> #action rdieter to queue qt-4.8.0-0.29.rc1 for stable updates, prep new qt-4.8.0 (final) update with silenced libicu qWarning
15:23:18 <rdieter> anything else wrt kde-4.7.4 or qt-4.8.0 updates?
15:24:29 <rdieter> #topic kde-4.8 pkg split status update
15:24:32 <rdieter> ok, moving on...
15:24:58 <rdieter> https://bugzilla.redhat.com/showdependencytree.cgi?id=kde-4.8&hide_resolved=1
15:25:17 <rdieter> according to this tracker, we've only a handful of items remaining
15:25:34 <rnovacek> I can do them tomorrow
15:25:37 <rdieter> most of kdeutils is done and in rawhide, minus kde-printer-applet
15:25:54 <rdieter> jovie review is done, just not closed (or imported?) yet
15:26:33 <rdieter> I suppose there's a handful of bindings-related ones to do yet too, which I may or may not get to.
15:26:41 <Kevin_Kofler> What about all the other accessibility stuff?
15:26:46 <Kevin_Kofler> Is that already in?
15:27:10 <rdieter> Kevin_Kofler: I'll have to double-check honestly, but I *think* so (minus jovie)
15:27:26 <rdieter> and I'll work on a kdeaccessiblity metapackage for upgrade path
15:27:33 <Kevin_Kofler> Re the bindings, that stuff should have been done 6 months ago. :-/
15:27:37 <rdieter> similar to how we've handled pkg spilts in the past
15:27:56 <Kevin_Kofler> I KNEW it would end up that way when you decided to just go with the split packaging without having everything packaged.
15:27:58 <rdieter> Kevin_Kofler: you're welcome to work on it. :)
15:28:16 <Kevin_Kofler> We should have completed the monolithic multi-tarball SRPM instead, I even offered to help with that.
15:28:19 <rdieter> I'd argue if someone wants it and is interested in it, they can help work on it.
15:28:23 <Kevin_Kofler> It'd just have meant some CMake patchery.
15:28:50 <rdieter> you're willing to work on monolithic hackery, but not split packaging?
15:29:07 <Kevin_Kofler> I think it would have been the better long-term solution.
15:29:14 <rdieter> *shrug*, we've already had that discussion
15:29:23 <Kevin_Kofler> One small patch to maintain instead of a bazillion of specfiles to update at every single release.
15:29:43 <rdieter> Kevin_Kofler: I've scripted most of it now.  it's not too bad
15:29:44 <Kevin_Kofler> But now that basically everything's split, of course it doesn't make sense to unsplit only kdebindings.
15:30:00 <Kevin_Kofler> (also considering that it was all subpackaged anyway)
15:30:08 <rdieter> while we're at it, I guess we've hinted at renaming a few modules to match upstream, like
15:30:16 <rdieter> kde-baseapps, kde-runtime, kde-workspace
15:30:22 <Kevin_Kofler> Right.
15:30:36 <rdieter> anything else beyond that?
15:31:04 * rdieter checks
15:31:16 <Kevin_Kofler> Maybe I can get some split kdebindings first, but I want to fight with a parted2 compat package first, to unbreak kde-partitionmanager and qtparted.
15:31:31 <rdieter> oh, we're purposely using kde-printer-applet vs (upstream) printer-applet
15:32:00 <Kevin_Kofler> The problem there being that the parted packaging is black magic, using git rather than %patch to apply patches, among other weird things.
15:32:05 <rdieter> Kevin_Kofler: ok, I can do the bindings, the parted stuff seems better suited to you
15:32:27 <Kevin_Kofler> There are also tons of patches, even on 3.0, worse on 2.x.
15:32:32 <Kevin_Kofler> It's going to take a while to sort out.
15:32:38 <rdieter> the only other modules that don't match is:  oxygen-icon-theme vs oxygen-icons
15:32:41 <Kevin_Kofler> (That's why I haven't managed to do it yet.)
15:32:53 <rdieter> and PyKDE4 vs pykde4
15:33:14 <rdieter> the icons would should probably keep as-is, imo
15:33:28 <rdieter> and I'm loathe to re-review just for the case-change
15:34:04 <rnovacek> PyKDE4 is at least similar to PyQt4
15:35:06 <Kevin_Kofler> OTOH, uppercase sucks…
15:35:12 <Kevin_Kofler> (in package names)
15:35:21 <rdieter> anyone able/willing to work on kde-* rename reviews?  I can do it, but I've already got 3-4 things to do today
15:35:26 <Kevin_Kofler> Maybe we should use pyqt4 too.
15:35:29 <than> imo we should rename oxygen-icon-theme to  oxygen-icons to match upstreaem too
15:35:46 <Kevin_Kofler> than: The problem is that all the other icon themes use *-icon-theme.
15:35:56 <Kevin_Kofler> It's a Fedora naming convention, why does Oxygen need to be different?
15:36:39 <rnovacek> I think we should prefer Fedora conventions before KDE conventions
15:36:50 <rnovacek> so stick with -icon-theme
15:36:52 <rdieter> I have mixed feelings wrt oxygen
15:37:14 <than> Kevin_Kofler: it's good question, i prefer upstream naming
15:38:13 <rdieter> regardless, we can and should add a Provides: oxygen-icons  , to handle the case if anyone expects to use the upstream name, at least.
15:39:24 <Kevin_Kofler> Another good question would be why the upstream tarball is named just "-icons". Aren't the other popular icon themes also using -icon-theme naming upstream?
15:39:44 <Kevin_Kofler> (I'm not convinced we can get them to rename though…)
15:40:00 <rdieter> honestly, I don't think all that much thought went into the project/git module names kde uses, esp how it would impact packaging
15:40:03 <than> Kevin_Kofler: we should rename pyKDE4 to python-kde4 if we prefer fedora convention
15:40:06 <rdieter> so... :)
15:40:53 <rdieter> than: there's a packaging guideline exception for python pkgs with a py* prefix
15:42:07 * than is checking...
15:42:40 <rnovacek> than: https://fedoraproject.org/wiki/Packaging/NamingGuidelines#Addon_Packages_.28python_modules.29
15:42:49 * rdieter doesn't care strongly, less exceptions for pkg name != tarball name makes my scripting updates all that easier. :)
15:42:55 <rnovacek> "If the upstream source has "py" (or "Py") in its name, you can use that name for the package. So, for example, pygtk is acceptable. "
15:43:49 <than> ok, then it's fine with pykde4 :)
15:44:43 <rdieter> ok, let's put it another way, anyone object to using pykde4 ? (provided someone is willing to work on the new renamed pkg)
15:45:10 <Kevin_Kofler> No objection.
15:45:16 * rdieter has no objection, but someone else needs to do the work. :)
15:45:51 <than> rdieter: no objection, i can take care of it
15:45:58 <rdieter> okie dokie
15:46:05 <rnovacek> no objection from me either
15:46:08 <rdieter> #action than to work on pykde4 pkg rename
15:46:32 <rdieter> #action rdieter to work on kde-baseapps, kde-runtime, kde-workspace renames
15:46:37 <rnovacek> and how about PyQt4?
15:46:39 <than> how about PyQt4?
15:46:55 <than> imo we should rename it too
15:47:08 <rdieter> no opinion, in that case, upstream is CamelCase too
15:47:46 <rnovacek> it would be better to at least add Provides: pyqt4
15:47:52 <rdieter> camelcased pkg names are a bit silly these days
15:47:56 <rdieter> rnovacek: sure
15:48:17 <rdieter> than: if you want to do pyqt4 while you're at it, that's fine with me too
15:48:22 <Kevin_Kofler> I guess the recommendation is to keep the SillyCamelCaseName when upstream uses it.
15:48:44 <Kevin_Kofler> I don't like those SillyCamelCaseNames though… :-/
15:50:22 <than> ok, we keep the upsstream name and just add provides: pyqt4
15:50:41 <than> Kevin_Kofler: +1, i hate SillyCamelCaseName too
15:50:58 <rdieter> ok, I think that covers all the kde-4.8 split packaging
15:51:08 <rdieter> #topic open discussion
15:51:13 <rdieter> anything else for today?
15:52:45 <Kevin_Kofler> rdieter: Why did you queue only the F16 Konversation to stable and not the F15 one too?
15:52:59 <rdieter> Kevin_Kofler: bodhi rules for f15 are different
15:53:00 <rnovacek> I have a question. Where I can get kde tarballs after tagging and before release?
15:53:05 <rdieter> ie, it wouldn't let me
15:53:09 <Kevin_Kofler> WTF…
15:53:28 <than> rdieter: ftpmaster.kde.org
15:53:29 <rdieter> rnovacek: i'll show you after meeting
15:53:32 <than> rnovacek: ftpmaster.kde.org
15:53:48 <rnovacek> rdieter: ok
15:54:10 <Kevin_Kofler> You need your SSH public key registered for a user account there though, we can add it to ftpfedora.
15:54:18 <Kevin_Kofler> That server is intentionally NOT public.
15:54:33 <Kevin_Kofler> It's packager-only SFTP/SCP access.
15:55:30 <rdieter> ok, let's wrap things up, thanks everyone!
15:55:32 <rdieter> #endmeeting