18:00:34 <jwb> #startmeeting
18:00:34 <zodbot> Meeting started Fri Feb  3 18:00:34 2012 UTC.  The chair is jwb. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:43 <jwb> #meetingname fedora-kernel
18:00:43 <zodbot> The meeting name has been set to 'fedora-kernel'
18:00:57 <jwb> #meetingtopic Fedora Kernel meeting
18:01:23 <jwb> everybody ready?
18:01:27 <davej> let's get this party started.
18:01:39 <jwb> #topic Release overview
18:01:57 <jwb> so, F15
18:02:08 <jwb> you want to cover f15/f16 davej?
18:02:10 <davej> sure
18:02:23 <davej> I'll get the 15 update built and pushed out today.
18:02:26 <davej> rebasing to 3.2.3
18:02:41 <davej> and a similar update to 3.2.3 for 16 at the same time
18:02:57 <davej> if all looks well, I'll push 15 live sometime next week
18:03:26 <davej> bug situation is still awful (shocker).
18:03:35 <davej> nothing else is new I don't think ?
18:03:38 <jwb> #info F15/F16 will be updated to 3.2.3 today
18:03:50 <jwb> #action davej to push 3.2.3 updates
18:04:02 <jwb> no, nothing new that i can think of either
18:04:09 <davej> F15	F16	Rawhide
18:04:10 <davej> open:
18:04:10 <davej> 389 	451 	144 	(984)
18:04:16 <davej> creeping awfully close to 1000 again :(
18:04:28 <davej> hopefully the 15 rebase will fix a bunch
18:04:43 <jwb> i don't think anyone has really looked at the f15 pile in a while
18:04:47 <jwb> most of the focus has been on f16
18:04:54 <davej> yeah
18:04:59 <davej> even so, 16 is a mess
18:05:42 <jistone> are there specific areas you need help, or just general bug zapping?
18:05:54 <jwb> the numbers are high, but we seem to hit a lot of individual issues
18:05:57 <davej> just general help would be appreciated.
18:05:59 <jwb> (aside from wireless)
18:06:03 <davej> especially things like looking for dupes
18:06:25 <jwb> oh, and hibernate is still horrible
18:06:33 <davej> yeah, still not sure wtf to do there.
18:06:48 <davej> I'm curious if that has been showing up on other distros
18:06:56 <jwb> we have that bug open to disable it.  perhaps we should push for that in rawhide
18:06:59 <davej> might have a look through ubuntu's bugs later
18:07:16 <jwb> anything else on f15/f16?
18:07:39 <jwb> ok, moving on
18:07:43 <jwb> f17/rawhide
18:07:54 * Southern_Gentlem waits for the updates to push new livecds
18:07:56 <jwb> so we rebased to 3.3-rc1 right after FUDCon
18:08:09 <jwb> things, overall, have gone pretty smoothly
18:08:11 <jwb> however
18:08:23 <jwb> i'm kind of convinced that is because nobody is using rawhide kernels
18:08:37 <davej> that might pick up after alpha ?
18:08:48 <brunowolff> I am running 3.3 and it's working well for me.
18:08:48 <jwb> hope so... there were a large number of compat-wireless bugs that popped up in f16 that we never even got reported on rawhide
18:09:13 <jwb> even though it was the same stack
18:09:19 <brunowolff> I don't use wireless on that machine though.
18:09:25 <davej> I think we're always going to get more people on the release than rawhide, so it's not totally surprising I guess.
18:09:26 <jwb> yeah, me either on my box
18:09:52 <jwb> at any rate, i haven't seen anything that is majorly broken so it seems to be the status quo there
18:10:01 <jwb> #info Rawhide/F17 at 3.3-rc2-gitx
18:10:18 <jwb> one thing coming up that slightly impacts us is the UsrMove feature
18:10:36 <jwb> harald has a patch to have the kernel start installing modules to /usr/lib/
18:11:07 <jwb> if that lands (which seems like it would soon), then there  might be some minor fallout from it
18:11:31 <jwb> i believe the "kernel update after conversion results in broken initramfs" bug has been fixed, so that is good
18:12:13 <jwb> on the feature-ish front, about the only thing I can think of is that the gma500 (poulsbou) drivers moved from staging to REAL DRIVERS now
18:12:16 <jwb> so we're building those
18:12:39 <davej> some bits of it are still in staging though right ?
18:12:46 <davej> or was that something else
18:12:56 <jwb> yeah, for some intel embedded stuff we don't really care about
18:12:59 <davej> ok
18:13:00 <jwb> and maybe a fb thing
18:13:25 <jwb> the original requester for DRM_PSB filed a bug to get us to switch and reported the moved drivers are working well, so i think we're good
18:14:00 <jwb> i spent some time looking at merge_config.sh, which seems to be a wash
18:14:18 <jwb> the details are on the kernel list.  follow up is to see if we can get some other tool for verification
18:14:41 <jwb> and unless i've missed something, i think that covers rawhide...
18:15:03 <davej> upstream seems to have slowed down a bit as we get deeper into -rc
18:15:27 <jwb> yeah, which is good
18:15:39 <davej> I think Linus has started getting more conservative about that the last release or two
18:15:45 <davej> even refusing to pull some peoples trees
18:15:45 <tibbs> If you really want people testing rawhide kernels, make sure they can install them with F16 userspace.
18:15:56 <davej> tibbs: right now, that should work
18:16:02 <davej> if we do the usrmove thing though..
18:16:08 <tibbs> Yeah, who knows.
18:16:18 <jwb> oh, right.  so i wanted to ask kay about that combination
18:16:31 <tibbs> I'm thinking that if you know it works, tell people it works and how to do it and you'll get more testing.
18:16:32 <jwb> but he's at FOSDEM, so it will have to be next week
18:16:49 <tibbs> Note to self: Kay is a he.
18:17:03 <jwb> tibbs, 'yum update --enablerepo=rawhide kernel'
18:17:11 <jwb> ignoring usrmove, that should work just fine
18:17:20 <tibbs> Well, sure _I_ know how to do it.
18:17:27 <tibbs> But if you want general testing....
18:17:50 <jwb> i'm missing what your suggesion is
18:17:55 <davej> we might try that more often when diagnosing f16 bugs (ask the user to try rawhide)
18:18:01 <tibbs> Tell the masses how to do that if you want more testers.
18:18:19 <jwb> davej, maybe with a caveat of "ignore the slowness, it's the debug options"
18:18:23 <davej> heh
18:18:47 <jwb> on usrmove, i'm thinking if we don't apply harald's patch then everythign will still work backwards and forwards
18:19:02 <jwb> because modules will still go to /lib and it's a symlink in rawhide
18:19:17 * nirik notes usrmove just tagged into rawhide. ;)
18:19:28 <tibbs> Oh, much fun.
18:19:41 <jwb> #action jwb to talk to Kay and Harald about usrmove and installing on older releases
18:19:43 <drago01> jwb: yeah leaving as is should work just fine
18:19:58 <jwb> nirik, that's fine for now.  the patch hasn't gone in
18:20:08 <jwb> well, "fine" for the kernel anyway
18:21:25 <jwb> anything else on rawhide?
18:21:51 <jwb> #topic questions
18:21:58 <jwb> any questions?
18:22:06 <jwb> anyone bring patches so they can yell at us?
18:22:26 * tomspur wonders if these 'power limit notification' are really safe to ignore: https://bugzilla.kernel.org/show_bug.cgi?id=36182
18:22:35 <tomspur> the patch would be to revert the bad commit ;)
18:23:08 <davej> that sounds like something mjg59 was poking at a while ago
18:23:16 <davej> where we were reading things in the wrong order or something
18:23:46 <tomspur> can I help with testing there somehow?
18:23:54 <jwb> bug report has it with a 3.2 kernel, so i don't think the issue is fixed
18:24:50 <jwb> tomspur, not sure.  you might as in the kernel.org buzilla
18:25:22 <brunowolff> I haven't seen any change on yum allowing multiple versions of kernel-modules-extra to be installed at the same time by default.
18:25:52 <jwb> that's a yum bug, right?
18:26:05 <jwb> or a feature request against yum i should say
18:26:16 <brunowolff> Yes, but you guys may have more influence than me in getting it changed.
18:26:36 <jwb> i agreed to it in the bug after initially being stupid
18:26:45 <jwb> i guess i can bug james and seth a bit more
18:26:58 <brunowolff> bug 770444
18:27:09 <jwb> #action jwb to pester skvidal about bug 770444 for kernel-modules-extra
18:27:50 <brunowolff> Thanks
18:27:55 <jwb> sure, thanks for the reminder
18:27:58 <jwb> anything else from anyone?
18:29:04 <jwb> you are all very chatty today
18:29:13 <jwb> ok, i think that does it for the meeting
18:29:24 <davej> yeah, justin is on vacation I think
18:29:31 <jwb> he is.
18:29:33 <davej> he was going to give an update on the testing framework thing
18:29:38 <davej> next time.
18:29:39 <tibbs> The problems I have are only very rarely kernel-related.
18:30:10 <davej> also, I had an action from the last meeting to look into bundling up some tests etc. since I got back from vacation, I've not had chance to look at that at all. hopefully by next time.
18:30:10 <jwb> #info jforbes will enthrall us with a dictation on kernel-related autoqa testing next time.
18:30:12 <tibbs> At least from my perspective, things have been great recently.
18:30:54 <jwb> #action davej will bundle up thoughs on what tests to throw into the autotest framework (for real this time!)
18:31:13 <davej> ok, end early ?
18:31:17 <jwb> indeed
18:31:25 <jwb> thank you all for coming
18:31:33 <jwb> #endmeeting