18:59:58 <rbergeron> #startmeeting Cloud SIG
18:59:58 <zodbot> Meeting started Fri Feb 10 18:59:58 2012 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:03 <rbergeron> #meetingname Cloud SIG
19:00:03 <zodbot> The meeting name has been set to 'cloud_sig'
19:00:17 <rbergeron> #topic Welcome to the meeting, let's gather.
19:00:25 * rbergeron waits for people to pop in.
19:00:41 <kkeithley> so when I come back on Monday am I going to have 500 emails about /usrmove -> about the future in my inbox?
19:00:46 <gholms> Hai
19:00:54 <rbergeron> kkeithley: yes
19:00:55 * rackerhacker waves
19:01:11 <kkeithley> that's just wonderful
19:01:25 * ke4qqq shows up - but is in another meeting simulaneously.
19:01:39 <jdarcy> Ditto.
19:01:48 <tdawson> Howdy
19:02:02 <rbergeron> kkeithley: i could be proven wrong though
19:02:03 <rbergeron> ;)
19:02:08 <rbergeron> hey tdawson. :)
19:02:19 * jforbes is here
19:02:23 <rbergeron> well then. I suppose it's time to pass out the hot dogs and get started
19:02:25 * gholms waves to everybody
19:02:39 <rbergeron> hidey-ho to everyone!
19:02:46 * rbergeron wonders if dgilmore is around by chance
19:02:53 <kkeithley> Are they Tommy's hot dogs, with extra chili?
19:03:02 <rbergeron> They are delicious hot dogs, from Your Imagination.
19:04:00 <rbergeron> #topic Feature-y statuses
19:04:03 <rbergeron> OH LOOK. it's mull.
19:04:07 <mull> o/
19:04:13 <dgilmore> rbergeron: i am here
19:04:14 <rbergeron> not to put all eyes on you....
19:04:31 * rackerhacker mulls around
19:04:31 <mull> hi, rbergeron
19:04:31 <rbergeron> dgilmore: will ping back shortly, just wanted to ask some ec2-ish stuff in a momento
19:04:36 <dgilmore> rbergeron: watching the snow fall outside the window in the airport
19:04:39 <rbergeron> mull: how is euca coming? :)
19:05:05 <mull> rbergeron, getting there... some other upgrade in rawhide threw me for a loop this week (jgroups 3 & jetty 8)
19:05:30 <gholms> (There's a jetty 8?)
19:05:32 <mull> but I have got us building against groovy 1.8 now (instead of our bundled 1.7) which is good progress
19:05:38 * rbergeron saw your page got updated to a healthy 70% or .. something close to that
19:05:46 <gholms> If you need me to do any reviewing let me know.\
19:06:05 <mull> rbergeron, yeah, I updated to more accurately reflect the real state of things
19:06:22 <mull> gholms, please review wss4j ... should be simple
19:06:24 <rbergeron> #info Eucalyptus is coming along; now building against groovy 1.8, some upgrades in rawhide caused a little blip; feature status is now appropriately updated
19:06:41 <rbergeron> #info mull kindly requests gholms to review wss4j
19:06:46 <mull> gholms, how is the axis2c review?
19:06:52 * gholms gives rbergeron an #action
19:06:54 <gholms> mull: Stalled.
19:07:00 <gholms> spot is a busy man.
19:07:12 <rbergeron> gholms: are you accepting?
19:07:14 <mull> ok, but it's in his court now?
19:07:24 <gholms> rbergeron: shur-y-not
19:07:28 <rbergeron> #info axis2c review is in spot's court
19:07:38 <rbergeron> #action gholms to review wss4j as requested
19:07:40 <rbergeron> :D
19:07:54 <rbergeron> ke4qqq: how is cloudstack coming :)
19:08:27 * rbergeron wonders if sparks is around too
19:09:01 * rbergeron wonders if anyone else who is owning features is around but doesn't think so
19:09:33 * rkukura is here
19:09:53 * rbergeron notes casually that there were some people on the advisory-board mailing list who were lightly discussing packaging chef, if anyone's interested in that.
19:10:04 <rbergeron> rkukura: can you talk about openstack statusy type things?
19:10:09 <rkukura> sure
19:10:21 <rbergeron> #chair gholms
19:10:21 <zodbot> Current chairs: gholms rbergeron
19:10:44 <rkukura> I think essex-3 snapshots of most things, except horizon, are packaged now
19:11:06 <rbergeron> #info essex-3 snapshots of most things, except horizon, are packaged now
19:11:15 * rackerhacker would like to start contributing a bit to the OS effort if help is needed
19:11:31 <rkukura> The linuxbridge plugin for quantum just got merged upstream today, so I'll update that package in the next few days.
19:12:13 <rkukura> The openvswitch kernel module is now being built, and the cdub is working on packaging the userspace tools.
19:12:15 <rbergeron> #info rackerhacker is willing to pitch in and contribute a bit to the OS effort if help is needed
19:12:32 <rbergeron> #info linuxbridge plugin for quantum got merged upstream yesterday, package will get updated in the next few days
19:12:45 <rackerhacker> i'm doing internal .deb packaging at rackspace for OS now but i'd like to get back to RPM's for my sanity ;)
19:13:02 <rbergeron> #info openvswitch kernel module is now being built, cdub is working on packaging the userspace tools
19:13:04 <rkukura> I think that's about it
19:13:06 <rbergeron> rackerhacker: LOL
19:13:17 * rbergeron sends rackerhacker her condolesnces
19:13:23 <gholms> Heh
19:13:24 <rbergeron> condolences
19:13:31 <rkukura> rackerhacker: lets chat offline
19:13:35 <jdarcy> Seems like a good way to get the right dependency lists, etc.
19:13:44 <dprince> rackerhacker: dprince feels your pain
19:14:33 <rbergeron> lol
19:14:43 <rbergeron> OKEEDOKEE THEN
19:14:51 * rbergeron still pokes at ke4qqq who is in a meeting
19:15:07 <rackerhacker> dprince knows where i'm comin' from ;)
19:15:45 <rbergeron> rackerhacker: is it well described in a long poem by dante aligheri?
19:15:50 <rbergeron> oh, wait, never mind ;)
19:15:56 * rbergeron moves onwards to ec2-ish things
19:15:58 <rackerhacker> rkukura: sure, we can sync up
19:16:01 <rbergeron> #topic EC2
19:16:10 <rbergeron> dgilmore: pingy now that i'm ready, lol
19:16:22 <rbergeron> just curious if we were set to have Alpha/Beta going with ec2
19:16:30 <rbergeron> or are we not doing that
19:16:38 * rbergeron assumes we are
19:17:01 <mull> seems like a reasonable thing to do
19:17:11 * mull is willing to test
19:17:31 <dgilmore> rbergeron: ok
19:17:36 * gholms needs cloud-init testers, too
19:17:38 <rbergeron> mull: very cool :)
19:17:47 <dgilmore> rbergeron: im making some TC2 images now
19:17:47 <rbergeron> gholms: can you... elaborate?
19:18:13 <dgilmore> rbergeron: this is the firsttime that ive tried to make images since f16 ga
19:18:33 <rbergeron> mull: speaking of testing - i know that there is going to be an openstack test day, are you planning on doing anything eimilar?
19:18:45 <rbergeron> dgilmore: should it just work?
19:18:54 <dgilmore> rbergeron: hopefully
19:18:54 <rbergeron> or will it just break
19:18:58 <dgilmore> rbergeron: we will see
19:18:58 <rbergeron> okay
19:18:59 <mull> rbergeron, would love to if we can get the packages in soon enough
19:19:12 <rbergeron> mull: *nod* gotcha
19:19:22 <gholms> When you go to test cloud images, it would be useful to know what parts of cloud-init still need work, is all.
19:19:27 <dgilmore> rbergeron: the image was created ok. ill upload to ec2 later and see if it actually boots
19:20:00 * dgilmore is also trying to make a qcow2 based image for people at home to use
19:20:07 <rbergeron> #info on TC2 for alpha currently, dgilmore created an image, he will upload to ec2 later
19:20:21 <rbergeron> dgilmore: can you let the list know when you did so people can poke around at it
19:20:34 <mull> dgilmore, I forgetare you using koji to create these images, or some other process?
19:21:58 <dgilmore> rbergeron: yep will post amis when they are up and i confirm i can ssh in
19:22:04 <dgilmore> mull: koji
19:22:15 <dgilmore> mull: the tasks are running in koji now
19:22:48 * abento has an interest in testing cloud-init on ec2 images.
19:23:41 <mull> dgilmore, ok, I ask because I want to test processes that folks who don't have special koji access can use to create images (BG, ami-creator, whatever)
19:24:35 <mull> I will volunteer to test your images, too, though
19:26:20 <dgilmore> mull: ok, well anyone can do it the way i am
19:26:33 <dgilmore> mull: its just a kickstart and appliance-creator
19:27:04 <mull> dgilmore, oh, ok, I thought there were special privileges needed.
19:27:32 <dgilmore> mull: there is in koji. but all its doing is calling appliance-creator
19:27:41 <dgilmore> mull: anyone can do that themselves
19:27:41 <mull> gotcha
19:27:46 <rbergeron> GAH INTERNET FAIL
19:28:10 <rbergeron> #action dgilmore to post amis when they are up and he can ssh in
19:28:36 <rbergeron> okay. anything else on ec2?
19:28:38 <rbergeron> thanks, dgilmore :)
19:28:49 <dgilmore> rbergeron: the ec2 image in qcow2 format is a 600mb image
19:29:23 <rbergeron> dgilmore: can you exlain the usefulness of that for my edification
19:29:23 <dgilmore> there has been quite a few requests to ship our ec2 images in a format people can easily use at home
19:29:46 <rbergeron> #info ec2 images in qcow2 format are 600mb; there have been requests to ship ec2 images in a format people can use at home
19:29:48 <dgilmore> rather than them installing they just spin up a vm with the image
19:29:49 <rbergeron> ah
19:30:05 <rbergeron> #info rather than installing they just spin up a vm with the image
19:30:07 <dgilmore> i tarrred and xz compresses the f16 10gb raw image
19:30:07 <jforbes> dgilmore: I thought the interest was less "use at home" and more "upload to other cloud services" which makes qcow less useful
19:30:11 <dgilmore> it was 114M
19:30:19 <rbergeron> dgilmore: does that count as a fedora spin? not to open pandora's stupid box
19:30:34 <dgilmore> jforbes: the requests ive personally seen have been for at home use
19:30:56 <rbergeron> dgilmore: or perhaps the question is "how do we advertise those for use"
19:30:58 <dgilmore> but i think we need to think about how we can ship something for use at home or in other cloud providers
19:31:17 <jforbes> cool, qcow2 is useful there, though so are tar xz compressed raw
19:31:29 <dgilmore> rbergeron: i guess it kinda is a spin. rbergeron there was a proposal recently on the spins list for a minimal spin
19:31:37 <rbergeron> dgilmore: would you be willing to send a mail to the cloud sig list to kind of start discussion on that thought (how we can ship something for use at home or in other cloud providers)
19:31:42 <rbergeron> dgilmore: /me nods
19:32:02 <dgilmore> jforbes: yeah the tar compressed raw is much smaller, but means people need to untar it after download
19:32:10 <dgilmore> maybe we can make sparse raw files
19:32:36 <dgilmore> rbergeron: sure i can send an email
19:32:40 <rbergeron> dgilmore: thanks!
19:32:52 <jforbes> dgilmore: Either way. The storage migration feature in F17 will make it easy to migrate it to whatever storage backing you want
19:33:01 <rbergeron> #action dgilmore to send an email to cloudsiglist to spur discussion on the "how we can ship something for use at home or in other cloud providers"
19:33:20 <rbergeron> #info minimal spin is also a discussion on the spins mailing list
19:33:40 <dgilmore> for the record the people i saw request it pointed me at http://uec-images.ubuntu.com/releases/10.10/release/
19:34:02 <rbergeron> #info requests came from people who were also pointing at http://uec-images.ubuntu.com/releases/10.10/release/
19:34:39 <tdawson> How often would be update these images?
19:35:39 <rbergeron> tdawson: i assume we'd just publish alpha/beta/final releases (someone can tell me if i'm wrong though)
19:35:47 <gholms> How about once per (pre)release?
19:35:58 <dgilmore> right
19:36:06 <dgilmore> it would be alpha beta and final
19:36:21 <rbergeron> (not nightlies, if that's what you're asking, tdawson)
19:36:28 <tdawson> And then we'd let the final sit until the next release comes around?
19:36:41 <tdawson> I was wondering if we'd have a monthly/quarterly update.
19:36:53 <tdawson> Definatly not nightly.
19:36:54 * mull guesses he was thinking "what if there's a remote root kernel exploit?" or something
19:37:04 <rbergeron> tdawson: any particular reason you're thinking along these lines?
19:37:21 <tdawson> My last job (with Scientific LInux) I was asked to provide images.
19:37:33 <tdawson> And that was the discussion, how often would I provide them.
19:37:37 <gholms> [Obligatory "GPL compliance" note]
19:37:45 <rbergeron> just in case there's some duh use case i'm not aware of :)
19:38:43 <tdawson> In the end, nobody agreed on how often I would provide them, so I ended up not providing any images. :)
19:39:12 <rbergeron> tdawson: LOL. which probably made you wonder just how important it really was to them if they couldn't come to an agreement :)
19:39:26 <tdawson> Yes
19:39:42 <gholms> Proposal: once per (pre-)release.  If someone needs them more frequently he or she is free to present a case for it.
19:39:51 <tdawson> Sounds good to me.
19:39:56 <gholms> +1/-1?
19:40:02 <tdawson> +1
19:40:06 * gholms is +1
19:40:14 <gholms> Anyone else?
19:40:24 * rbergeron looks at dgilmore and wonders if this works with how he might do other things
19:40:44 <jforbes> Umm, people can yum update the images anytime too
19:40:52 <mull> I'm neutral... I could be convinced that in the case of critical security flaws, we might occasionally spin an update
19:41:28 <mull> yum update doesn't fix the kernel on an AMI
19:41:47 <gholms> It does when all we provide are EBS images.
19:41:56 <gholms> ...with self-hosted kernels
19:42:28 <jforbes> Unless it is a remotely exploitable kernel issue that effects the select services in use on EC2, I don't think it matters much
19:42:35 <mull> gholms, you have to reboot though... are we going to tell everyone to update *then reboot* every image they launch?
19:43:10 <dgilmore> there will only be one alpha, one beta and one GA images shipped
19:43:11 <mull> jforbes, understood that the case may be rare, but I wouldn't mind leaving the door open to say we _might_ _occasionally_ decide to spin an update
19:43:19 <dgilmore> the same concerns could be said for livecds
19:43:25 <gholms> Oh, absolutely.
19:43:43 <gholms> That's what the "present a case" thing in my proposal is for.
19:43:51 <gholms> Well, part of it.
19:43:56 <jforbes> mull, that's pretty standard practice anywhere you are doing kernel updates.  LiveCD actually has more of a case for it since you are dealing with RO media
19:44:00 <rbergeron> present a case == worst case scenario? :)
19:44:09 <tdawson> I agree with mull, but I also think that falls into the "present a case" ... I think remote exploit of kernels could be a case, depending on how bad it is.
19:45:02 <mull> ok, I think we're all on the same page... default is nothing after the GA image... except for the possible critical kernel thing...
19:45:27 <rbergeron> So I think where we're at is ... alpha/beta/final (since that's the koji process and its built in already) and we can request the oh-crap fix in the event of a Bad Scenario and tackle it if we come to it, ie, "present a case" ?
19:45:54 <jsmith> Yeah, I think it's fine to say "we'll cross that bridge when we come to it"
19:46:07 <rbergeron> And dennis will bring the more general topic of having the "minimal spin" type thing to cloud sig list.
19:46:11 <rbergeron> yes?
19:46:18 * rbergeron looks around at everyone eating hotdogs
19:46:28 <gholms> +1
19:46:45 <jsmith> WORKSFORME
19:47:13 * tdawson takes a bite of his Chicago Dog and give a +1
19:47:27 <rbergeron> #agreed minimalspin/self-cloud can be alpha/beta/final, "present a case" if it's absolutely necessary and we'll figure it out if we have to at that point
19:47:29 * dgilmore should find the hotdog stand in ohare
19:47:46 <rbergeron> dgilmore: isn't there one every like 12 feet?
19:47:55 <rbergeron> ;)
19:48:00 <dgilmore> rbergeron: i know of 2 hotdog places in the airport
19:48:02 * rbergeron looks around for other ec2-related stuff
19:48:09 * dgilmore has nothing
19:48:20 <rbergeron> dgilmore: i'm glad to hear that you are indexing hotdoglocations in your brain :)
19:48:36 * rbergeron thinks "fedora dogs around the world" would be an excellent photo series
19:48:40 <rbergeron> #topic Other Business
19:49:00 * rbergeron opens the floor for comments questions flames requests etc
19:49:12 * verdurin was impressed with the Fedora takeover at FOSDEM
19:49:24 <rbergeron> verdurin: lol
19:49:57 <rbergeron> there were quite a few folks there.
19:50:14 <gholms> Do you have pix? :P
19:51:09 <rbergeron> of fosdem?
19:51:16 <verdurin> In fact there were so many that talk clashes couldn't be avoided
19:51:18 <rbergeron> In my imagination that i took on my imaginary trip
19:51:33 <gholms> Hehe
19:51:43 * dgilmore wonders if anyone will be in Brno next weekend?
19:52:22 <rbergeron> dgilmore: there will be lots of people, i don't think from here, though.
19:52:28 <jsmith> rbergeron: I'm going to Brno
19:52:33 <rbergeron> not sure if any of the openstack crowd is going to brno, maybe rkukura is
19:53:04 <rbergeron> i mean rkukura might be aware of who might be going
19:53:08 <rbergeron> from that crowd
19:53:19 <rbergeron> jsmith: ah, that's right
19:53:20 * dgilmore will be there and will be willing to talk to anyone about things
19:54:00 <rbergeron> dgilmore: i won't be there, but you have fun. and jsmith too.
19:54:30 <dgilmore> rbergeron: ill see if i can get you hotdog cloud pics :)
19:54:55 <rbergeron> :D
19:55:56 <gholms> [A tumbleweed drifts past]
19:56:11 <rbergeron> [A robyn hugs gholms]
19:56:18 <rbergeron> Alrighty, folks, thanks for coming.
19:56:21 <gholms> Oh, yeah, congrats to you, rbergeron.
19:56:24 <rbergeron> Keep those features humming along.
19:56:31 <rbergeron> gholms: thanks :)
19:56:43 * rbergeron sets fuse and whatnot
19:57:03 <rbergeron> see you all next week.
19:57:05 <rbergeron> #endmeeting