16:00:09 <adamw> #startmeeting Fedora QA meeting
16:00:09 <zodbot> Meeting started Mon Feb 13 16:00:09 2012 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:14 <adamw> #meetingname fedora-qa
16:00:14 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:19 <adamw> #topic roll call
16:00:24 <adamw> morning folks, who's here for some awesome meetage?
16:00:48 * pschindl is here
16:00:49 * j_dulaney waves
16:01:00 * jskladan likes his dinner-meeting :)
16:01:02 * mkrizek is present
16:01:02 * tflink is here
16:01:11 <j_dulaney> .fire tflink
16:01:11 <zodbot> adamw fires tflink
16:01:16 <kparal> lol
16:01:25 <tflink> huh?
16:01:42 <adamw> j_dulaney: I like it!
16:02:00 <adamw> jskladan: i too enjoy meeting dinner
16:02:04 <j_dulaney> adamw:  Trying to make your life easier
16:02:09 <tflink> so j_dulaney got zodbot to control adamw and fire me? That's a new one
16:02:10 <adamw> lemme try it
16:02:12 <adamw> .fire j_dulaney
16:02:16 <zodbot> adamw fires j_dulaney
16:02:23 <adamw> you're hired!
16:03:09 <j_dulaney> LOL
16:03:13 <adamw> #chair kparal tflink j_dulaney
16:03:13 <zodbot> Current chairs: adamw j_dulaney kparal tflink
16:03:36 <adamw> alrighty
16:03:55 <kparal> let's give zodbot a chair as well so that it can fire at will :)
16:04:01 <adamw> hehe
16:04:10 <adamw> #topic previous meeting follow-up
16:04:21 <adamw> so just one lonely little action item from last week..
16:04:45 <adamw> #info "adamw to co-ordinate with dgilmore on getting lorax updated and a new compose done" - done, TC2 was composed, and promptly exploded due to systemd.
16:05:10 <adamw> i can't see any other big issues from last week that need following up on
16:05:18 <adamw> anyone else?
16:05:53 * maxamillion is here .... late again, but here
16:06:04 <adamw> .fire maxamillion
16:06:04 <zodbot> adamw fires maxamillion
16:06:09 * adamw giggles like a schoolchild
16:06:28 <maxamillion> ahhh!!!!
16:06:33 * maxamillion stops, drops, and rolls
16:06:33 <adamw> yes. it's AUTOMATED now
16:06:36 * j_dulaney was running with the Devil down in Georgia
16:06:43 <maxamillion> @headdesk
16:06:44 <fedbot> http://www.math.vt.edu/people/jbwillia/computer.gif
16:06:44 <j_dulaney> Last week, that is
16:06:48 <adamw> how is the devil?
16:06:49 <maxamillion> :)
16:07:00 <maxamillion> also ... for good measure ....
16:07:02 <maxamillion> @gentoo
16:07:03 <fedbot> http://funroll-loops.info
16:07:05 <maxamillion> :D
16:07:09 <j_dulaney> adamw:  He married my cousin
16:07:13 <maxamillion> ok, I'm done making a mockery of hte meeting
16:07:18 <maxamillion> the*
16:07:27 <adamw> maxamillion: i only just got started!
16:07:40 <maxamillion> rocking .... it has been injected
16:07:42 <adamw> or, to put it in craig ferguson terms: that's what I do every week!
16:07:51 * maxamillion prepares for imgur and 9gag links to roll in
16:08:21 <adamw> alrighty
16:08:26 <adamw> #topic upcoming QA events
16:08:38 <adamw> so, we're scheduled to roll RC1 this week
16:08:51 <maxamillion> wooo!!!!
16:08:55 <j_dulaney> Yay!
16:09:01 <adamw> there's six open blockers, but that list looks manageable
16:09:12 <tflink> we still don't have 17 in bz
16:09:13 <j_dulaney> Does TC2 have the /usr move?
16:09:21 <adamw> #info RC1 scheduled for this week, open blockers at https://fedoraproject.org/wiki/Current_Release_Blockers
16:09:21 <maxamillion> did the SELinux denail of login get marked as a blocker? ... I can't remember
16:09:29 <adamw> j_dulaney: yes, and also a giant bug with systemd/selinux
16:09:30 <tflink> unless it's been done since I checked last night
16:09:31 <adamw> maxamillion: yes it is
16:09:42 <adamw> tflink: i will bug robyn about that, she said she'd make it happen
16:09:44 <maxamillion> adamw: rgr
16:09:50 <j_dulaney> adamw:  Lack of f17 in bugzilla is likely to be making the number of blocker bugs artificially low
16:10:21 <tflink> j_dulaney: I doubt it. I think most people who are testing pre-alpha can figure out that rawhide == 17 if there's no 17
16:10:25 <adamw> j_dulaney: i don't *think* so, at this point in testing most blockers come from active QA members' testing of the TCs, and we're on top of those reports
16:10:42 <j_dulaney> adamw:  Oddly, running TC2 on a VM last night/this morning did not hit any major bugs except the kernel CPU bug
16:11:07 <adamw> honestly, no-one goes through *every* bug filed against a release to check if it ought to be a blocker anyway, it has to be proposed by the filer or raised through the matrices or the test list or something to get on there
16:11:12 <j_dulaney> Which, I only hit with LXDE
16:11:28 <adamw> j_dulaney: well, everyone else is hitting http://bugzilla.redhat.com/show_bug.cgi?id=788829
16:11:34 <adamw> if you disable SELinux you'd miss it
16:12:18 <j_dulaney> adamw:  I did a default install from the DVD image in a VM, the only change being to go with LXDE instead of Gnome
16:12:25 <adamw> anyhoo, yeah, looking at that list of blockers we ought to be able to clear them
16:13:00 <maxamillion> j_dulaney: and on a fresh reboot you didn't have any issues logging in? with SELinux enabled?
16:13:13 <maxamillion> enabled/enforcing
16:13:28 <j_dulaney> maxamillion:  Not a one
16:13:35 <maxamillion> huh
16:13:38 <adamw> i'm not sure it's worth kicking that horse, we know there _is_ a bug there and dwalsh and mezcalero are aware of it and fixing
16:13:48 <j_dulaney> This is with TC2 download via wget around 2AM
16:13:53 <maxamillion> adamw: yeah, fair
16:14:15 <adamw> if j_dulaney didn't hit it it's lucky for him :)
16:14:19 <maxamillion> +1
16:14:25 * j_dulaney is wondering how
16:14:29 <maxamillion> j_dulaney: we're going to vegas!!!!
16:14:31 <maxamillion> >.>
16:14:36 <adamw> eddies in the space-time continuum
16:14:57 <adamw> so, no other major upcoming events, of course there'll be a blocker review on friday
16:15:03 <j_dulaney> Eddy's in the space-time continuum?  Why is he there?
16:15:09 <adamw> j_dulaney: he's looking for tea
16:15:29 <j_dulaney> I thought he was with Zaphod
16:16:04 <adamw> looks like we don't have any test days till early march
16:16:10 <adamw> though i still have to crowbar the x test week in there somewhere
16:16:41 <adamw> so, anyone have any concerns about 17 tc/rc or the schedule before moving on to autoqa?
16:17:58 <adamw> *crickets*
16:17:59 <adamw> excellent.
16:18:04 <adamw> #topic autoqa update
16:18:10 <adamw> kparal: any big news here?
16:18:49 <kparal> just small news - we found out that changes in f17's anaconda were not working with rats_install
16:19:06 <kparal> so hongqing is working on that, it should be ready this week I believe
16:19:28 <adamw> #info f17 anaconda changes have broken rats_install, hongqing is working to fix it
16:19:32 <kparal> (I am talking about the initrd/squasfs.img change)
16:19:35 <adamw> ok
16:19:47 <adamw> are you clearer on the status of rats in general now? what exactly it's capable of at present?
16:20:22 <kparal> it that fix hongqing posted works well, it installs automatically Fedora from kickstart
16:20:44 <maxamillion> oooo, swank
16:20:56 <kparal> I have to check that the daily composes are available
16:21:07 <kparal> so that we can watch for them and trigger daily tests
16:21:32 <j_dulaney> kparal:  Do the nightlies?
16:21:55 <kparal> I need kernel+initrd+squashfs composes
16:21:59 <kparal> not live images
16:22:23 <adamw> kparal: that would definitely be great. can i give you an action item on that one?
16:22:28 <kparal> sure
16:22:38 <kparal> I have it on my todo list anyway
16:22:40 <adamw> #action kparal to check with releng on the status of daily installer image builds for RATS testing
16:23:23 <kparal> ok, second change, I pushed a patch that creates Config class in autoqa, so that all our libraries don't have to parse all the configuration files again and again
16:23:28 <kparal> progress!
16:23:52 <adamw> #info kparal created a Config class in autoqa to avoid excessive config file parsing
16:24:10 <kparal> and jskladan pushed a change in depcheck behavior that marks ignored builds as passed instead of failed
16:24:30 <kparal> that means we will not report failed tests as often in bodhi when there is no real reason to report it as failed
16:24:51 * jskladan likes that green check marks ...
16:25:01 <j_dulaney> kparal:  Why not get them to say ignored but otherwise treat as passed?
16:25:04 <kparal> don't ask me what 'ignored builds' are, btw :)
16:25:11 <adamw> oh hey, i'm glad that drive-by comment produced useful result =)
16:25:27 <kparal> j_dulaney: that's basically it
16:25:41 <adamw> #info 'ignored builds' now treated as pass rather than fail to avoid excessively high failure counts and reports
16:25:53 <kparal> good wording, thanks
16:25:54 <tflink> kparal: IIRC, they're builds that were dropped out of the yum transaction during depcheck but didn't explicitly fail
16:25:56 <maxamillion> w00t!
16:26:02 <maxamillion> less email
16:26:10 <jskladan> j_dulaney: there still is info, that the build is "ignored" we just don't fail tests because of it
16:26:43 <kparal> and tflink fixed a bug in mock_fedorainfra
16:26:55 <kparal> that caused some of our tests to misbehave at staging
16:27:19 <adamw> #info tflink fixed a bug that caused some tests to misbehave at staging
16:27:23 <adamw> sounds like solid progress
16:27:28 <j_dulaney> Righteo
16:27:34 <kparal> what did I forgot?
16:27:39 <kparal> *forget
16:27:42 <adamw> when are we planning to announce resultsdb outside of the autoqa list?
16:27:49 <j_dulaney> kparal:  The sink
16:27:53 <kparal> ->jskladan
16:28:14 <jskladan> *shrugs* I'd announce it once it's on production
16:28:15 <kparal> j_dulaney: english idioms are tough, careful :)
16:28:39 <kparal> but I know this one :)
16:28:56 <adamw> jskladan: cool, when is that planned?
16:29:10 <jskladan> I guess with next autoqa release
16:29:23 <jskladan> which is... (kparal, help me out pls)
16:29:28 <kparal> asap
16:29:33 <adamw> okely dokely
16:29:34 <j_dulaney> kparal:  Good, since I don't think I could explain it
16:29:41 <jskladan> adamw: that ^^
16:29:42 <jskladan> :)
16:29:47 <adamw> #info resultsdb deployment to production planned for next autoqa release, which is coming ASAP
16:30:01 <j_dulaney> Which probably means post F17
16:30:02 <kparal> 'once it is done' might be better :)
16:30:15 <kparal> I'm waiting for rats_install basically
16:30:19 <kparal> after that I would like to release
16:30:24 <adamw> okay.
16:30:35 * jskladan thinks in terms like "never" or "on 31st of February"
16:30:48 <kparal> the second sounds better
16:30:59 <adamw> this is software. that's what ASAP *means*.
16:31:38 * j_dulaney should sleep more
16:31:52 <adamw> alrighty, guess that's all for autoqa
16:31:55 <adamw> thanks mad scientists
16:32:04 <adamw> #topic open floor
16:32:24 <adamw> so i have a quick one here - just wanted to check with j_dulaney, are you okay on the test day front? no assistance required?
16:32:46 <adamw> i did forward you a potential new test day last week while you were riding with the red fiery guy
16:32:46 <j_dulaney> adamw:  Now that my travels are over, I'll be able to handle it
16:33:01 <j_dulaney> Hmm
16:33:03 * j_dulaney looks
16:33:38 <j_dulaney> adamw:  What was it, exactly?
16:34:31 <adamw> j_dulaney: subject "Re: Request for testers of dnssec-trigger (now in rawhide)"
16:36:31 <j_dulaney> adamw:  Ah
16:36:51 * j_dulaney saw that, and it pinged his interest
16:37:15 <adamw> okey dokey.
16:37:24 <adamw> just let me know if you need help with anything, as always
16:37:39 <adamw> anything else for open floor, anyone?
16:37:40 <j_dulaney> Indeed
16:37:54 * j_dulaney is having Beefy Miracles for lunch
16:37:59 <j_dulaney> With bacon
16:38:09 * maxamillion makes really bad fake cricket noises
16:39:21 <adamw> .fire maxamillion
16:39:23 <zodbot> adamw fires maxamillion
16:39:31 <adamw> bad cricket noises are a firing offence!
16:39:54 * j_dulaney makes fake fart sounds with his armpit
16:39:56 * jskladan thinks, that zodbot is becoming too smart
16:39:56 <Cerlyn> That script should tell you how much your workload increases every time you fire someone, as well as the cost of hiring a replacement
16:40:24 * maxamillion rolls round once more to put out the flames
16:40:25 <jskladan> "Thou shalt not make a machine in the likeness of a human mind."
16:40:51 <j_dulaney> jskladan has been reading too much Dune
16:40:52 <maxamillion> I'm going to have to start showing up to these meetings with fire retardant(sp?) clothing
16:40:58 <adamw> Cerlyn: "not at all", and "one shiny nickel"
16:41:18 <maxamillion> or a super soaker
16:41:22 <maxamillion> which ever ....
16:41:37 * j_dulaney throws gasoline on maxamillion
16:41:41 <adamw> ooh, super soakers are mandatory for all meeting attendees from now on
16:42:13 * j_dulaney uses a super-soaker filled with gas on maxamillion
16:42:20 <maxamillion> ahhhh!!!!!
16:42:21 <adamw> alrighty, i guess this terribly important discussion means we're done!
16:42:49 <maxamillion> rgr, laters all :)
16:42:57 <adamw> thanks for coming everyone
16:43:02 <adamw> speak now or forever hold your super soaker
16:43:03 <maxamillion> thanks for hosting
16:43:05 * jskladan should find his Max-D then
16:43:50 <adamw> #endmeeting