19:00:44 <rbergeron> #startmeeting Cloud SIG
19:00:44 <zodbot> Meeting started Fri Mar  9 19:00:44 2012 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:50 <rbergeron> #meetingname Cloud SIG
19:00:50 <zodbot> The meeting name has been set to 'cloud_sig'
19:00:59 <rbergeron> #topic Gathering of the minds and roll call
19:01:04 * mull here
19:01:22 <tdawson_> Here
19:01:35 * jforbes is here
19:01:45 <rbergeron> oh hai!
19:01:59 * kkeithley raises his hand
19:02:38 <mgoldmann> did someone say... meeting?
19:02:45 <rbergeron> BUT OF COURSE
19:02:57 <rbergeron> it's your favorite meeting.
19:02:59 <rbergeron> meating, even.
19:03:24 * kkeithley wonders if he needs to be here
19:03:27 <rbergeron> okay, kids, let's get'er goin, maybe we'll gather some critical mass as we get into things
19:03:40 <rbergeron> kkeithley: not unless you have something you want to talk about. you are free to adjourn :)
19:03:53 <rbergeron> or to hover and look over occasionally for a good chuckle
19:03:54 <kkeithley> adios muchachos
19:03:54 * jforbes is working on non-critical mass (Yay girl scout cookies!)
19:04:01 <rbergeron> jforbes: ooh
19:04:05 <rbergeron> #topic Eucalyptus
19:04:11 <rbergeron> mull: the wheel of fate calls your name first
19:04:17 <mull> woohoo
19:04:32 <rbergeron> though we can talk to mgoldmann and ke4qqq if he's around and i suspect he isn't but i know you guys have all this intersecting FUN STUFF
19:04:41 <mull> so, things are going pretty well, only 5 or 6 packages left which actually need clean-up
19:04:51 <rbergeron> mull: wow, very nice
19:05:01 <mull> but many more need reviews
19:05:03 <mull> :)
19:05:21 <mull> so anybody who has time, feel free to check the eucalyptus wiki page.  :)
19:05:37 <mgoldmann> mull: if you have some easy reviews - I can swap for jboss-*-api packages
19:05:50 <mull> mgoldmann, ok, let's do that
19:05:58 <mgoldmann> I can take hard too, but ease for easy :P
19:06:04 <rbergeron> mull: is the wiki/Euca page up-to-date as far as what needs reviews and so forth?
19:06:17 <mull> mgoldmann, the Axis2 deps are easy (woden, neethi, etc.)
19:06:27 <mgoldmann> alright!
19:06:28 <mull> rbergeron, yes
19:06:52 <mull> ok, I need to give my update over in #eucalyptus-meeting now... carry on
19:07:10 <rbergeron> mull: your update is "gregdek needs to pick a better time" ... /me kids
19:07:10 <mgoldmann> haha :)
19:07:37 <rbergeron> #info Euca is very close to having packages done/cleaned-up with only 5 or 6 pkgs left, but many more need reviews
19:08:00 <rbergeron> #link https://fedoraproject.org/wiki/Eucalyptus
19:08:20 <rbergeron> #info Things needing review are listed on the Euca wiki page on fp.o and that page is up to date
19:08:38 <rbergeron> #action mull and mgoldmann to swap reviews because they both need them :)
19:08:46 <mgoldmann> badly
19:08:58 <rbergeron> #topic AS7 progress
19:09:09 <rbergeron> mgoldmann: is there anything else you want to plug in here about as7 progress? :)
19:09:10 <mgoldmann> hey, that's me!
19:09:15 <rbergeron> sure is, you're awesome
19:09:18 <mgoldmann> A LOT :)
19:09:24 <mgoldmann> watch out, pasting
19:09:24 <mgoldmann> 84 packages in total
19:09:25 <mgoldmann> 59 packages in Rawhide / F17
19:09:25 <mgoldmann> 24 packages in progress
19:09:26 <rbergeron> go for it
19:09:36 <mgoldmann> that's the current progress
19:09:47 <rbergeron> is that like - FULL as7 or bare-bones as7?
19:09:48 <mgoldmann> things are improving with every day
19:09:54 * rbergeron isn't quite sure if there is a difference or not
19:10:00 <mgoldmann> it's almost-web-profile-as-7
19:10:27 <mgoldmann> for the full AS7 we need some more packages and this is plan for F17+
19:10:28 <mull> I'm glad I didn't track my total from day one
19:11:05 <mgoldmann> we cleared some licensing issues that were blocking about 10 packages
19:11:11 <rbergeron> woo :)
19:11:19 <mull> mgoldmann, is JTA unblocked now?
19:11:24 <mgoldmann> mull: aye!
19:11:27 <rbergeron> #info AS7 has 84 pkgs in total; 59 in rawhide/f17, 24 in progress
19:11:39 <rbergeron> #info cleared licensing issues blocking about 10 pkgs, including JTA
19:11:42 <mgoldmann> rbergeron: I think we'll end up with about 100 packages
19:11:52 <rbergeron> #info will likely end up with about 100pkgs
19:11:55 <spstarr_work> :)
19:12:00 <mgoldmann> so, as you see - we're pretty close
19:12:01 <mgoldmann> :)
19:12:06 <rbergeron> indeed
19:12:09 <spstarr_work> rbergeron: i will give status at end
19:12:14 <rbergeron> light at the end of the tunnel eh :)
19:12:16 <mgoldmann> most important thing is:
19:12:32 <mgoldmann> I was able to deploy my first web app on Fedora JBoss AS 7 :)
19:12:57 <rbergeron> #info mgoldmann was able to deploy his first web app on Fedora / JBoss AS7 :)
19:13:00 <rbergeron> which is awesome
19:13:02 <mgoldmann> this everything makes me feel optimistic about the process
19:13:05 <rbergeron> yes
19:13:09 <rbergeron> i bet! :)
19:13:22 <rbergeron> hard work paying off in a visible way other than a shrinking number of packages :)
19:13:31 <mgoldmann> more - I'll have some additional help on packaging which should speed the process abit again
19:13:41 <rbergeron> mgoldmann: orly
19:13:47 <mgoldmann> aye :)
19:14:08 <rbergeron> alrighty then
19:14:24 <rbergeron> anything else? /me will move on otherwise
19:14:24 <mgoldmann> I'm also planning with Carlo to run TCK test on the resulting RPM
19:14:37 <mgoldmann> so we'll be sure that what we ship is "certified"
19:14:46 <mgoldmann> in other words - is what it really should be :)
19:14:51 <rbergeron> very cool
19:15:15 <rbergeron> #info also planning with carlo to run TCK test on the resulting RPM, so that what is shipped is "certified" - ie: it is what it really should be :)
19:15:19 <rbergeron> awesome.
19:15:23 <rbergeron> Okay
19:15:26 * rbergeron will plow ahead
19:15:29 <mgoldmann> sure
19:15:31 <rbergeron> #topic OpenStack
19:15:39 <rbergeron> russellb: tag!
19:16:38 <russellb> hi!
19:16:56 <rbergeron> have anything interesting to shrae? :)
19:16:59 <rbergeron> share
19:17:00 <rbergeron> rather
19:17:09 <russellb> yesterday we had a test day: https://fedoraproject.org/wiki/Test_Day:2012-03-08_OpenStack_Test_Day
19:17:36 <russellb> and even though the day is "over", the instructions are still a nice way to get started with OpenStack
19:17:47 * rbergeron nods
19:17:51 * rbergeron wonders if she should go end that meeting
19:18:04 <russellb> a number of bugs were filed, some SELinux issues, some integration issues between projects
19:18:10 <rbergeron> LOL
19:18:16 <spstarr_work> NOOO
19:18:20 <spstarr_work> Meeting isnt over...
19:18:33 <rbergeron> #info OpenStack test day is "over" but instructions are still a nice way to get started with openstack
19:18:39 <rbergeron> spstarr_work: in #fedora-test-day?
19:18:57 <rbergeron> #link http://meetbot.fedoraproject.org/fedora-test-day/2012-03-08/openstack_test_day.2012-03-08-13.08.log.html
19:18:59 <spstarr_work> i will update you on OpenNebula status when we're near end of this meeting
19:19:10 <russellb> Upstream the Essex release is coming along ... RC1 should be out soon
19:19:12 <rbergeron> spstarr_work: i know, i was talking about the end of the meeting log in the test day channel
19:19:17 <spstarr_work> oh *phew*
19:19:18 <spstarr_work> :)
19:19:23 <rbergeron> #info Essex release is coming along, RC1 should be out soon
19:19:25 <russellb> and we're chugging away helping with that
19:19:29 <russellb> so, I guess that's about it
19:19:38 <rbergeron> russellb: how many of you guys rae going to silly valley in april?
19:19:58 <russellb> hm, 5 at least
19:20:14 <rbergeron> okay
19:20:41 <russellb> btw, that quetsion was in reference to the Folsom design summit next month in San Franscisco
19:20:48 <rbergeron> #link https://fedoraproject.org/wiki/Test_Day:2012-03-08_OpenStack_Test_Day
19:20:51 <rbergeron> yes, it was
19:21:18 <rbergeron> russellb: want to be nice and plug hte log from that test day maybe into the wiki page somewhere (i don't know, might be helpful?)
19:21:27 <rbergeron> :D
19:21:34 <rbergeron> or i can later
19:21:50 <russellb> sure, i can do that
19:22:43 <russellb> anyway, that is all for now
19:23:08 <rbergeron> coo, thanks :)
19:23:16 <rbergeron> #topic AWS/S3
19:23:24 <rbergeron> mdomsch: howdy howdy, if you're still paying attention
19:23:43 <mdomsch> barely
19:24:03 <mdomsch> so, upstream hasn't taken my patches yet, but no comments either
19:24:06 <rbergeron> mdomsch: anything interesting going on with the mirror/s3 stuff at the moment, or not so much? :)
19:24:09 * rbergeron nods
19:24:16 <mdomsch> I'm going to build s3cmd for FI private use
19:24:29 <mdomsch> the server it will run on is bapp01 per yesterday's FI meeting
19:24:49 <mdomsch> however, that server will migrate from rhel5 to rhel6 in 10 days, and I'm OoO until then
19:25:09 <mdomsch> so we won't go live with the mirror until at least 3/19
19:25:55 <mdomsch> that said, the s3sync code seems to work well enough.  The md5 checking code is heavyweight on the FI storage back end, but necessary because repodata/* files change content but not names frequently.
19:26:11 <mdomsch> a better solution for that would be welcome
19:26:16 <rbergeron> #info won't be going live with mirror until at least 3/19 due to migrations, OoO stuff
19:26:17 <mdomsch> that's all
19:26:44 <rbergeron> #info s3sync code seems to work well eough; md5 checking code is heavyweight on the FI storage backend, but necessary because repodata/* files change content but not names frequently. better solution welcome.
19:26:54 <rbergeron> #info robyn having keyboard sadness today
19:27:16 <rbergeron> alrighty :) thanks, matt, for continuing to plug away at this
19:27:22 <rbergeron> i almost said chug, but chugging is for beer
19:27:26 <rbergeron> I think
19:27:33 <rbergeron> :D
19:27:42 <rbergeron> #topic OpenNebula
19:27:48 <spstarr_work> We have a package!
19:27:57 <rbergeron> #info THEY HAZ A PACKAGE!
19:28:00 <rbergeron> is it fully done?
19:28:05 <spstarr_work> I'm going to be working on cleaning it up this weekend so I can start using it in my cloud lab @ home :)
19:28:23 <spstarr_work> ive made a lot of changes to it, its currently in mock build testing right now
19:28:29 <spstarr_work> SELinux is OK we didnt run into issues
19:28:47 <rbergeron> #info currently in mock build testing right now; selinux looking okay, not running into issues; spstarr to work on cleaning it up more this weekend
19:29:08 <spstarr_work> I've split up the package so its modular oZones support is not going to be happening sadly since Ruby 1.9.x broke some functionality that isn't fixable since DataMapper hasn't been ported to Ruby 1.9 yet.
19:29:25 <spstarr_work> (and Upstream is getting rid of DataMapper in favour of Active)
19:29:53 * rbergeron nods
19:29:57 <spstarr_work> Once i have the package passing Mock and rpmlint properly will be submitting for reviews this weekend (Sunday), then can get the comps updated
19:30:06 <spstarr_work> i just cant touch the comps stuff until i have a package or... bad things happen
19:30:19 <rbergeron> right
19:30:30 <spstarr_work> then we're done :)
19:30:44 * rbergeron wonders if you're able to update your % complete on your feature page a bit more? :)
19:30:52 <spstarr_work> yes
19:30:54 <spstarr_work> 80%
19:30:55 <spstarr_work> :)
19:31:04 <spstarr_work> 75 -> 80%
19:31:06 * rbergeron notes this applies to mull and mgoldmann as well - any upgrades in % done are welcome on your pages, pretty please
19:31:23 <mgoldmann> rbergeron: I've done this today :)
19:31:29 <spstarr_work> we cant get to 100% until reviews + comps xml change
19:31:31 <rbergeron> mgoldmann: ooh, i haven't looked since this morning
19:31:38 <mgoldmann> np :)
19:31:41 <spstarr_work> so I will have a blocking status RSN
19:32:18 <spstarr_work> I am working in lock-step with upstream so any barriers are being destroyed as they are found
19:32:42 <rbergeron> #info spstarr working closely with upstream
19:32:45 <spstarr_work> see #opennebula :-)
19:32:53 * rbergeron grins
19:33:14 <rbergeron> okay, i'm moving along then
19:33:19 <spstarr_work> although they are in .es timezone so it is more difficult to coordinate we're managing however.
19:33:19 <rbergeron> to...
19:33:21 <rbergeron> hrmmmm
19:33:29 <rbergeron> spstarr_work: yeah, that's always fun :) the time juggle
19:33:33 <spstarr_work> yes
19:33:36 <rbergeron> #topic Open Floor
19:33:53 * russellb starts dancing on the open floor
19:34:36 <rbergeron> russellb: this goes perfect with your music feed on facebook ;)
19:34:47 <rbergeron> dgilmore: are you around
19:34:53 <russellb> i have a music feed on fb?
19:35:19 <rbergeron> russellb: something called turntable shows up in my timeline saying you awesomed something
19:35:27 <russellb> oh, dangit
19:35:29 <nirik> rbergeron: he's off today.
19:35:32 <russellb> i hate it when sites start posting when i don't know it
19:35:33 <rbergeron> nirik: ah
19:36:03 <rbergeron> I keep meaning to check out codingsoundtrack
19:36:08 <nirik> rbergeron: anything I can assist with?
19:36:11 <rbergeron> nirik: thanks for the heads-up
19:36:31 <rbergeron> nirik: no, just wanted to check in on his progress towards EC2/beta/appliance-tools/grub/etc. drama
19:37:40 <rbergeron> i mean unless you have a magical solutions there
19:37:50 <rbergeron> in which case you totally could assist, i would not cry
19:38:17 <nirik> nope. :) I know nothing. ;)
19:38:36 <rbergeron> alrighty
19:38:47 * rbergeron will light the fuse then
19:38:57 <rbergeron> speak now, peeps :)
19:39:47 <jforbes> Oh, one thing
19:40:05 <rbergeron> jforbes: yes? :)
19:40:13 <jforbes> EC2 images for F17 won't work until https://bugzilla.redhat.com/show_bug.cgi?id=801650 gets fixed
19:41:17 <jforbes> basically glibc fails in x86_64 xen guests
19:41:28 <jforbes> fix is upstream, shouldn't take long to get it into fedora
19:41:33 <rbergeron> so that's breaking things even more than they were broken anyway?
19:41:33 <jforbes> EOF
19:41:56 <rbergeron> #info EC2 images for F17 won't work until https://bugzilla.redhat.com/show_bug.cgi?id=801650 is fixed (fix is upstream, shouldn't take long to get to Fedora)
19:42:07 <jforbes> rbergeron: well, the previous breakage was process, so we couldnt even tell if the release was broken.
19:42:11 <rbergeron> right
19:42:42 <rbergeron> jforbes: might I be able to wheedle you or rackerhacker to send that in a mail to the mailing list just as an FYI for anyone who might be doing ec2 things as well
19:42:51 <rbergeron> since I know not everyone reads meeting minutes
19:42:53 <jforbes> Sure, I can do that
19:42:56 <rbergeron> despite my efforts to make them beautiful :)
19:43:12 <jforbes> needs more dragons
19:43:12 <rbergeron> #action jforbes to send a quick note re: bz 801650 to the cloud-sig list
19:43:51 <rbergeron> .---. __
19:43:51 <rbergeron> ,         /     \   \    ||||
19:43:51 <rbergeron> \\\\      |O___O |    | \\||||
19:43:51 <rbergeron> \   //    | \_/  |    |  \   /
19:43:51 <rbergeron> '--/----/|     /     |   |-'
19:43:53 <rbergeron> // //  /     -----'
19:43:56 <rbergeron> //  \\ /      /
19:43:59 <rbergeron> //  // /      /
19:44:01 <rbergeron> //  \\ /      /
19:44:03 <rbergeron> //  // /      /
19:44:06 <rbergeron> /|   ' /      /
19:44:09 <rbergeron> //\___/      /
19:44:11 <rbergeron> //   ||\     /
19:44:14 <rbergeron> \\_  || '---'
19:44:16 <rbergeron> /' /  \\_.-
19:44:19 <rbergeron> /  /    --| |
19:44:21 <rbergeron> '-'      |  |
19:44:24 <rbergeron> '-'
19:44:26 <rbergeron> oh, that's not a dragon
19:44:27 <pingou> \รณ/
19:44:29 <rbergeron> that's a hot dog
19:44:31 <jforbes> heh
19:44:32 <rbergeron> DARNIT
19:44:52 <tdawson_> Slay the Dragon  .... err ... Cook the Hot Dog!!!
19:45:03 <rbergeron> exactly.
19:45:10 <rbergeron> Okay, so, closing out now.
19:45:16 <rbergeron> Hope everyone has a lovely weekend :)
19:45:23 * rbergeron holds breath for 2 seconds before closing
19:45:29 <rbergeron> #endmeeting