18:59:36 <rbergeron> #startmeeting Cloud SIG
18:59:36 <zodbot> Meeting started Fri Mar 30 18:59:36 2012 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:59:40 <rbergeron> #meetingname Cloud SIG
18:59:40 <zodbot> The meeting name has been set to 'cloud_sig'
18:59:51 <rbergeron> #topic Gathering of the Cloudies
19:00:37 <gholms> Hiya
19:00:56 <rbergeron> HOWDY
19:01:05 * rbergeron will hold a momento
19:01:10 <rbergeron> (mostly to get a soda)
19:02:53 <rbergeron> alrighty
19:02:55 <rbergeron> well. quiet today
19:03:02 <tdawson> Greetings
19:03:04 <rbergeron> #topic Agenda
19:03:24 <tdawson> We were waiting for you to get back ... didn't want to talk to ourselves.
19:03:28 <rbergeron> I haz light-to-no agenda today, other than beta/ec2 stuff, and checking in a bit with various folks on how F17 is going
19:03:34 <rbergeron> hey, no shame in talking to yourself.
19:03:39 <rbergeron> #chair gholms
19:03:39 <zodbot> Current chairs: gholms rbergeron
19:03:56 <gholms> rbergeron: Relevant: http://i.imgur.com/gARYO.png
19:03:59 <rbergeron> #info Beta delayed by one week, so final is delayed as well
19:04:14 <rbergeron> oh, yes. absolutely.
19:04:18 <rbergeron> I just did that.
19:04:43 <rbergeron> Sooooooooooooooooooooooooooo I guess we'll get movin' on down the road.
19:04:50 <rbergeron> #topic EC2 and beta
19:04:54 <rbergeron> dgilmore: are you about
19:05:19 * gholms suspects login is still busted and no one knows why
19:05:31 * mull should really try testing that image
19:05:51 <rbergeron> mull: it would be super helpful if you could, we seem to be dead-end-ish or just not screaming enough aobut it.
19:05:56 <gholms> Please do.  We need some more eyes on it.
19:06:15 <mull> ok, I'll go scrounge up my amazon creds and fire it up
19:06:28 <rbergeron> I could probably see if I can get someone from that one place of employment who used to be an FPL to give some thought on it at least on the telephono or something.
19:06:56 <gholms> rbergeron: That applies to more than one person here, you know. :)
19:06:57 <mull> heh
19:07:04 <juliancdunn> you're talking about the F17 EC2 image?
19:07:11 <gholms> juliancdunn: Yes
19:07:13 <rbergeron> well i mean who now works closely with amazon :)
19:07:23 <juliancdunn> couldn't log in either... but bizarrely, no console output either
19:07:28 <rbergeron> possibly taking a paycheck from them
19:07:29 <rbergeron> ;)
19:07:51 <gholms> Even after a few minutes of waiting?
19:09:04 <gholms> juliancdunn: ^
19:09:08 <rbergeron> mull: let us know if you get a chance :)
19:09:31 <rbergeron> gholms: have you tried it out or just had that bit of "if the crap isn't in the other directory then we probably have a problem" advice
19:09:38 <mull> so, stupid question:  is there any point in actually launching the image, or should I just be mounting a copy of it in an instance to look at what might be wrong?
19:10:06 <juliancdunn> thought the problem was that /home/ec2-user/.ssh/authorized_keys was missing
19:10:46 <rbergeron> Oh.
19:10:48 <rbergeron> I didn't see that mail.
19:10:55 <gholms> If that doesn't exist after you supply a keypair to the instance-running command then there is a problem.
19:11:06 <gholms> I can't recall which image I tested most recently.
19:11:23 <rbergeron> okay, i guess we don't know all the steps that were taken here. mull: maybe you could start there, though I have no answers to your stupid question.
19:11:53 <mull> I thought maybe gholms could answer my question
19:12:10 <gholms> mull: How would you get a copy of an instance if you haven't launched one?
19:12:30 <juliancdunn> pretty sure I was testing the one dgilmore built... ami-3fb16f56
19:13:13 <gholms> mull: I suppose dgilmore could make the snapshot available to you, though that may not help with cloud-init debugging.
19:13:20 * gholms shrugs
19:13:31 <mull> ah, the snapshot itself isn't public, right
19:13:47 <mull> sorry, so used to being on my own little private cloud.  :)
19:14:44 <rbergeron> LOL
19:15:04 <rbergeron> is there some magic that can be done in ec2 to make it available to mull?
19:15:18 <gholms> Yes.
19:15:33 <rbergeron> without making it open and broken to the whole universe?
19:15:35 <gholms> I suspect running an instance would result in more useful data, though.
19:15:40 <mull> don't worry about it.  gholms is right, having logs from a launch is useful
19:15:46 <rbergeron> okay
19:16:24 <rbergeron> well, i can ... make that happen if it does seem like it would be more useful at some point
19:16:48 <rbergeron> so you need logs from a launch or are you going to try and do those logs yourself? :)
19:17:47 <gholms> If authorized_keys is indeed missing and you supplied a keypair as you ran the instance then please file a cloud-init bug.
19:18:30 * rbergeron is glad you guys are here :)
19:18:30 <mull> rbergeron, I'll just launch it myself
19:18:34 <mull> doesn't take long
19:18:59 <rbergeron> mull: thanks, can you just update the mailing list with any ... progress (and file bug as gholms noted if that's the problem)
19:19:03 * rbergeron sends mull a hug
19:20:07 <rbergeron> okay, well, in the absence of other feedback i shlal move onwards
19:20:10 <rbergeron> AHOY CLOUDIES
19:20:15 <rbergeron> #topic OpenStack
19:20:30 * rbergeron thought she saw russellb roll in here
19:20:47 <russellb> ohai
19:20:56 <russellb> 2 security releases this week: 1 for keystone, 1 for nova
19:21:09 <russellb> Essex release is scheduled for April 5th: http://wiki.openstack.org/EssexReleaseSchedule
19:21:43 <russellb> um, that's about all the news that's news on that front i think
19:21:57 <rbergeron> #info 2 security releases this week, 1 for keysone, one for nova
19:22:04 <rbergeron> #info essex is scheduled for april 5
19:22:08 <rbergeron> okay
19:22:32 <russellb> mad props to dprince
19:22:37 <russellb> he found both of the security issues :)
19:22:37 <rbergeron> is it just the 4 of you folks on the wiki going next month
19:22:50 <russellb> rbergeron: can you link me to the wiki?  i think it was 5
19:22:57 <rbergeron> i was the fifth
19:23:05 <rbergeron> https://fedoraproject.org/wiki/OpenStackSummitConf_April2012
19:23:12 <russellb> me, dprince, markmc, eglynn, cdub
19:23:23 <russellb> and bob
19:23:34 <rbergeron> okay
19:23:37 <russellb> so eglynn and cdub aren't on that list
19:23:43 <rbergeron> well i didn't see eglynn or cdub
19:24:22 <rbergeron> i guess it is still up in the air if anyone wants to do a BoF type thing on thursday night but i can rattle up some money for that if necessary
19:24:44 <russellb> may be a conf party that night or something too
19:24:47 <rbergeron> i guess i can send a mail about that
19:24:48 <rbergeron> oh yes
19:24:49 <rbergeron> it's openstack
19:24:52 <rbergeron> there is a party every night
19:24:56 <russellb> sweeeeeeeet
19:25:20 <rbergeron> the schedule is posted now also
19:25:31 <russellb> how about a stash of fedora shirts for us to wear all week?  :)
19:25:41 <rbergeron> so you can see whose startup money you are drinking
19:25:50 <russellb> ha
19:26:21 <rbergeron> russellb: i can see if i can find some i f freedom shirts but i think beyond that i may not have anything, unless we magicaly come up with a fedora cloud logo or something
19:26:41 <rbergeron> i guess we will get to it over the next few weeks
19:26:54 <russellb> k, no worries
19:27:00 <russellb> i have an i f freedom shirtr
19:27:08 <russellb> which btw, i hesitate to wear in the general public ...
19:27:18 <rbergeron> LOL
19:27:28 <rbergeron> ARE YOU FROM FACEBOOK
19:27:38 <gholms> Heh
19:27:42 <russellb> you do what to freedom?!  o.O
19:27:51 <rbergeron> i fedora it, yo
19:27:59 <rbergeron> okay, I'm going to move onwards :)
19:28:06 <rbergeron> #topic Other Stuff
19:28:19 <rbergeron> Now is the time of the meeting when anyone has other stuff to talk about can bring it up. :)
19:28:36 <rbergeron> And I can poke at tdawson about the coming of the code that powers openshift
19:28:40 <rbergeron> oh! I do have something
19:28:58 <rbergeron> http://www.opencloudconf.com/
19:29:13 <rbergeron> #info OpenCloudConf is Apr. 30 - May 3
19:29:22 <tdawson> OpenShift is supposed to OpenSource their OpenCode at the OpenCloud conference.
19:29:23 <rbergeron> #action rbergeron to make an event page for it maybe
19:29:34 <rbergeron> Indeedy.
19:29:44 <russellb> tdawson: so, it'll be Open is what you're saying
19:29:54 <tdawson> Yes indeed.
19:29:59 <russellb> \o/
19:30:23 <rbergeron> russellb: It will be given out as well fedora remix style
19:30:29 <rbergeron> from what i understand
19:30:36 <rbergeron> russellb: i hear you may be in attendance
19:30:43 <russellb> neato
19:30:47 <rbergeron> that our resident conference pimp johnmark may be roping you in :)
19:30:51 <tdawson> That's what I hear.   That they will make a F16 live remix.
19:30:56 <rbergeron> or perhaps cdub will be?
19:31:00 * rbergeron isn't entirely clear
19:31:06 <russellb> no, not planning on being there.  2 people organizes 2 different tracks both had openstack things lined up
19:31:11 <russellb> i deferred to cdub
19:31:20 <rbergeron> okay
19:31:28 <rbergeron> that will work just as well
19:31:59 <russellb> yup
19:32:28 <rbergeron> anyway, that was the one thing i randomly remembered
19:32:48 <rbergeron> and openshift will be doing things there. hooray
19:32:54 <russellb> sounds cloudy
19:33:07 <rbergeron> it's even on the way home from LFNW in northern washington
19:33:13 * tdawson wonders if it is going to rain during the whole conference.
19:33:13 <rbergeron> in SJC
19:33:17 <rbergeron> (on the way home for me)
19:33:20 <rbergeron> so that will be exciting.
19:33:25 <rbergeron> HOORAY WEATHER
19:33:27 <rbergeron> hi rackerjoe!
19:33:38 <rackerjoe> Hi All - sorry I am late
19:33:39 <russellb> rackerjoe: we were just talking about you!
19:33:43 <rackerjoe> oh noes
19:33:47 <russellb> rbergeron: shhh
19:33:48 <gholms> :)
19:34:12 <rbergeron> lol
19:34:41 <rbergeron> rackerjoe: we were just sort of wrapping up. I know you had some stuff you were talking about last week wrt openstack so feel free to pipe in anytime, we're mostly just... chatting about events and such
19:36:10 <gholms> [You hear the sound of distant drums]
19:36:46 <rbergeron> [I hear the sound of gholms typing clever stuff]
19:36:48 <rbergeron> :)
19:36:55 <rbergeron> that sound is actually my stomach rumbling
19:37:05 <rackerjoe> cool.  Our work is still progressing on the chef cookbooks for fedora and we are currently in a sprint to get it completed.  We should have something by the Summit next month
19:37:21 <russellb> cool
19:38:28 <rbergeron> rackerjoe: awesome :)
19:40:15 <rbergeron> rackerjoe: do you have a blog or anything where you're notating this stuff?
19:40:29 * rbergeron can't remember and thinks she asked last week but ... well, i'm nutty
19:41:12 <rackerjoe> We are storing everythin in github right now and it is open
19:41:48 <rbergeron> excellente :)
19:41:55 <rackerjoe> https://github.com/rcbops/chef-cookbooks.  We are working on the ubuntu-precise branch right now but the repository is going to be re-worked and everything merged into trunk soon'ish
19:42:15 <rbergeron> rackerjoe: so you're going to be there next month? we should, you know, hang out, and stuff.
19:42:56 <rackerjoe> My entire team (RCB Ops) will be there and we should certainly hang out :)
19:43:12 <rbergeron> okay.
19:43:28 <rbergeron> i am sure we'll be talking about it a bit more as we approach :)
19:43:33 <rbergeron> does anyone else have anything?
19:45:28 <rbergeron> that sounds like a no.
19:45:29 <rbergeron> :)
19:45:42 * rbergeron thanks everyone for coming and shall see y'all soon. like next week, or before. :)
19:45:49 <rbergeron> mull: let us know what you find if anything in ec2-land :)
19:45:54 <rbergeron> #endmeeting