16:04:34 <threebean> #startmeeting Messaging_SIG
16:04:34 <zodbot> Meeting started Tue Apr  3 16:04:34 2012 UTC.  The chair is threebean. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:04:52 <threebean> #topic Roll call
16:05:07 <threebean> Please speak up if you're here for the messaging SIG meeting.
16:05:29 * j_dulaney waves
16:06:23 <threebean> j_dulaney: allright, let's do this.
16:06:35 <threebean> #topic reports
16:07:24 <threebean> Last week we set the longterm goal of getting all the sending of messages done inside the next 6 months and the goal of getting hooks into at least one app by this week's meeting.
16:08:06 <threebean> There's still nothing in the stg environment yet, but I got hooks into branches in fas and bodhi1.
16:09:01 <threebean> Those branches getting merged in and tested out were blocking on a rewrite of the config file format for fedmsg, but I finished that this morning.  All that's left is to review the messaging branches with the fas and bodhi maintainers and see if we can push them to stg.
16:10:08 <threebean> Lots of misc work and cleanup all around the place happened, too.  ;)
16:10:26 * j_dulaney does a Git clone to see the changes
16:10:38 <threebean> j_dulaney: We should blow that six months goal out of the water.
16:10:48 <j_dulaney> Indeed
16:11:17 <j_dulaney> Do you have any docs on doing the hooks?
16:11:31 <j_dulaney> I would like to go ahead and get started on AutoQA
16:11:32 <threebean> yes, it's buried in fedmsg/docs/proposal.rst
16:11:41 <j_dulaney> Roger
16:11:54 <threebean> j_dulaney: is AutoQA a lot of bash scriptage?
16:12:02 <j_dulaney> Python
16:12:06 <threebean> cool.
16:12:26 <j_dulaney> In fact, I can think of only one or two bash scripts in it, and they're for initial setup
16:12:55 <threebean> there's a fedmsg-logger command to support things that hinge on bash scripts, but it requires that we stand up a fedmsg-relay service first.
16:13:27 <threebean> j_dulaney: hmm.. the fedmsg-config.py file isn't documents in the docs/ dir.  I'll get on that asap
16:13:39 <threebean> #action document the fedmsg-config.py file
16:14:19 <threebean> #topic for the next week
16:14:26 <j_dulaney> I'm thinking I can get some rough patches done by Friday if things aren't too difficult
16:14:41 <threebean> j_dulaney: cool.  bug me anytime if you have questions.
16:14:51 <j_dulaney> At the least I can replace our watcher scripts
16:15:13 <j_dulaney> Sending messages out may take a tad more doing, but shouldn't be too difficult
16:15:44 <j_dulaney> What hooks do you have in Bodhi so far?
16:15:59 <threebean> j_dulaney: I bet the reverse will actually be the case for you.  The supporting code in fedmsg to consume messages is the least mature.  The code for producing messages is done (nearly done? (it's never done!))
16:16:20 <j_dulaney> LOL
16:16:23 <j_dulaney> Righteo
16:16:36 * threebean finds j_dulaney a link
16:18:05 * threebean stumbles through trac
16:18:56 * j_dulaney is familiar with such
16:19:06 <threebean> j_dulaney: It's all here in model.py -- https://fedorahosted.org/bodhi/browser/bodhi/model.py?rev=5ac1cafb9cb5abd1b18c193ee0a6ee7c3fadf347#L446
16:19:15 <threebean> That's the bodhi1-fedmsg branch.
16:19:26 <j_dulaney> thx
16:19:53 <threebean> 'self' there works only because Update defines a __json__(self) method.  fedmsg looks for that and uses it if it can.
16:21:05 <threebean> #action fully document the list of messages being emitted from fas, bodhi, and tagger.
16:21:12 * j_dulaney sees how it is used
16:21:17 <j_dulaney> Easy enough
16:21:31 <j_dulaney> Actually, simpler than the old way, I think
16:21:39 <threebean> j_dulaney: Cool.  I've been aiming for simple.
16:23:11 <j_dulaney> Hmm
16:23:16 <threebean> ?
16:23:20 <j_dulaney> Chicken and egg problem
16:23:58 <j_dulaney> It would be easier to figur out how to send messages to Bodhi once I know what format those messages should take
16:24:19 <threebean> Right.  That's the heart of why this has taken so long to take off (imho).
16:25:05 <threebean> I say we just start sending messages, any kind of message.
16:25:19 <threebean> It's up to you to decide how much information to include or not include.
16:25:33 <threebean> For Bodhi I was lucky; the objects already had __json__ methods that defined a format for me.
16:25:38 <j_dulaney> Well, I reckon I would include everything that is already being included
16:25:55 <j_dulaney> If that makes sense
16:26:08 <threebean> Yeah.  I think that makes sense everywhere, except for FAS.
16:26:23 <threebean> For FAS we send minimal information, just because it could be sensitive.
16:26:25 <j_dulaney> I don't know if AutoQA does __json__ or not
16:26:39 <j_dulaney> Indeed
16:27:03 <tflink> j_dulaney: json interface from python is easy
16:27:28 <tflink> we don't use much json right now but I'm not sure that would be much of an impediment
16:27:40 <tflink> assuming that I didn't completely misunderstand from coming in late
16:27:51 <j_dulaney> No, I think you've got it
16:27:55 <threebean> Writing a __json__ method is not a requirement, it just helps you write simpler sending code.
16:28:10 <threebean> Here's the fedmsg encoder (and the only reference to __json__ inside fedmsg) - https://github.com/ralphbean/fedmsg/blob/develop/fedmsg/json.py#L9
16:28:13 <j_dulaney> Which is a plus in its favour, I think
16:28:39 <tflink> and hopefully keeps you from making silly mistakes like misnaming fields
16:28:56 <j_dulaney> I only did it once!
16:28:59 <threebean> :)
16:30:41 <threebean> So, my goal for next week is to dig into scm/git and see if we can install global post-receive hooks to emit messages.
16:31:59 <threebean> To really do that in stg will require standing up an instance of fedmsg-relay like I mentioned before, which makes it trickier.
16:32:02 <j_dulaney> And I guess mine is to get AutoQA to be belcing profanity
16:32:10 * threebean cannot wait for the profanity.
16:32:25 <threebean> :)
16:32:44 <j_dulaney> I guess the idea will be to get something out there, and then refine what that something is later on
16:32:44 <tflink> j_dulaney: I could be wrong, but I don't think that's going to be incredibly easy - depending on what exactly you have in mind
16:32:57 <threebean> j_dulaney: exactly.
16:33:27 <j_dulaney> tflink:  I was thinking getting it to listen would be easier, but that part of fedmsg doesn't seem to be there quite yet
16:33:42 <tflink> j_dulaney: agreed, listening would be much easier
16:33:56 <j_dulaney> tflink:  I understand the watchers quite well from the self test project
16:34:36 * tflink thinks we're derailing the meeting a bit, stops with the autoqa discussion
16:34:50 <threebean> tflink: It's actually really helpful.  :)
16:35:20 <threebean> And this is actually our last point.  Any other comments or topics before we close?
16:36:34 <threebean> #endmeeting