16:09:05 <threebean> #startmeeting messaging_sig
16:09:05 <zodbot> Meeting started Tue Apr 10 16:09:05 2012 UTC.  The chair is threebean. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:09:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:09:10 <threebean> #topic roll call
16:09:37 <threebean> Anyone in for the messaging SIG meeting?
16:10:01 * abadger1999 here but has nothing to say :-)
16:11:16 <threebean> :)
16:11:28 <threebean> #topic reports
16:12:13 <threebean> For the last few weeks I've been trying to get sending hooks into other services.  Reported last week that we had hooks in SCM branches for bodhi1, bodhi2, fas, and tagger.
16:12:19 * tflink is around but trying to get some GSoC stuff done at the last minute
16:13:01 <threebean> j_dulaney was going to take on emitting messages from autoqa and I was going to do the same for scm.
16:13:47 <threebean> the work for scm necessitated some more work on fedmsg, specifically the fedmsg-relay need to be improved and rebuilt on top of moksha.
16:14:04 <threebean> previously it 'worked', but spun on a while True loop eating 100% cpu.
16:14:07 * nirik arrives late. reads up
16:15:05 <threebean> it works now as a moksha consumer on top of Twisted, is very efficient, but it makes moksha a dependency of fedmsg.  this has slowed the work on deployment as we need to go through and package up all of moksha's latest deps for el6.
16:15:46 <threebean> a couple of those got into bodhi today.
16:16:04 <threebean> this one is still outstanding (and other depend on it that haven't been submitted yet):
16:16:18 <threebean> https://bugzilla.redhat.com/show_bug.cgi?id=720818
16:17:11 <threebean> that's about it from me for reports.  I haven't heard from j_dulaney since last week and am not sure how the AutoQA work is going.
16:18:19 <tflink> I haven't seen him around much this week, either
16:18:49 <tflink> but we've pretty much been consumed with F17 beta testing, so he might not have had the time to work on this much
16:19:31 <threebean> tflink: definitely.  I'm sure we'll hear from him soon.
16:19:43 <abadger1999> threebean: last week we talked about schemas and validation -- did you end up deciding to remove that?
16:19:53 <threebean> abadger1999: yes, I did.
16:20:38 <abadger1999> ah -- validate is still a parameter to send_message() -- it's just not used in the function anywhere.
16:20:52 <threebean> ah, should be removed.
16:21:02 <abadger1999> <nod>  /me was just confused by that
16:21:11 <abadger1999> Cool
16:21:34 <threebean> #topic any future work, next steps, ideas
16:22:02 <nirik> it would be cool to have a small test setup... a producer and consumer...
16:22:07 <nirik> so people could see how everything works out.
16:22:45 <threebean> nirik: I think you should be able to do that now from the source tree.
16:22:57 * threebean checks to see how well documented that is
16:23:08 <nirik> cool.
16:23:27 <threebean> not very well documented.  I'll put it right in the front-page README.
16:23:44 <threebean> #action document how to set up an example producer and consumer in the README.
16:25:21 <threebean> nirik: once all this initial packaging gets done, the next thing on my plate is setting up a fedmsg-relay in stg.  I'll come to ask you about it, if that's cool.
16:25:33 <nirik> sounds great.
16:26:12 <threebean> any other items, ideas out there?
16:26:45 <threebean> other things before I close the meeting?  :)
16:27:24 <threebean> Hmm, can anyone here volunteer to review https://bugzilla.redhat.com/show_bug.cgi?id=720818 ?
16:27:39 <abadger1999> .bug 720818
16:27:42 <zodbot> abadger1999: Bug 720818 Review Request: python-tw2 - Web widget creation toolkit based on TurboGears widgets - https://bugzilla.redhat.com/show_bug.cgi?id=720818
16:27:57 <nirik> I could try... I have several others I should review too sometime this week.
16:28:10 <nirik> (but it wouldn't hurt my feelings if someone beat me to it :)
16:28:17 <abadger1999> threebean: Can we retire python-tw when tw2 goes in?
16:28:30 <abadger1999> or are they not compatible enough?
16:28:33 <threebean> abadger1999: no, they're incompatible.
16:28:36 <abadger1999> k
16:28:44 <threebean> the old tg stack will still need python-tw
16:29:48 <threebean> if everyone here is too overloaded, don't worry about it.  I'll ask around in #fedora-devel again.
16:30:47 <threebean> ok, last call - any other items/ideas?
16:31:42 <threebean> :) great.  thanks!
16:31:48 <threebean> #endmeeting