19:59:31 <jonmasters> #startmeeting
19:59:31 <zodbot> Meeting started Wed Apr 25 19:59:31 2012 UTC.  The chair is jonmasters. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:04 <jonmasters> #topic Fedora ARM weekly sync meeting - Wednesdays at 20:00UTC (4PM EDT, 9PM BST)
20:00:52 <jonmasters> ctyler, djdelorie, dmarlin, pbrobinson, dgilmore: it's time, folks
20:00:59 <djdelorie> already here
20:01:01 * pbrobinson is here
20:01:21 * nirik is lurking.
20:02:10 <jonmasters> ok, let's give it a few moments. Some people probably haven't realized we're moving channel and not doing the phone call. I'll dial in now to see if anyone is on the phone anyway and let them know
20:02:10 * maxam waves
20:03:52 * jonmasters found linville, welcome!
20:04:10 <linville> :-)
20:04:38 <jonmasters> ok, today's agenda is posted here: http://lists.fedoraproject.org/pipermail/arm/2012-April/003172.html
20:05:16 <jonmasters> (with apologies to aph that yes, I clearly forgot Mountain time. I was going to make a cleaver remark about "depends on how far South you are" but I figure not everyone looks at timezone maps)
20:05:28 <jonmasters> anyway, shall we...
20:05:37 <pbrobinson> we shall....
20:05:40 <jonmasters> #topic 0. Current build status
20:05:50 <jonmasters> so, where do we stand, then?
20:06:01 <jonmasters> pbrobinson: want to do a general koji-shadow update for us?
20:06:04 <pbrobinson> major blocker on F-17 is llvm
20:06:25 <jonmasters> right, as it was last week, too. Remind us what it's affecting? llvm_pipe, etc. right?
20:06:33 <pbrobinson> it's blocking quite a bit of stuff, I believe ctyler volunteered to look into that but I've not heard a thing
20:06:56 <jonmasters> yea, he and I spoke. I'll ping Jeff Law and our tools team after this
20:07:08 <jonmasters> #action jonmasters to ping tools team in RH about helping on llvm
20:07:10 <pbrobinson> basically mesa and a few other bits low down depend on it and it tiers up through most of the gnome stack as a result
20:07:26 <jonmasters> right, so clearly that needs to be fixed
20:07:34 <jonmasters> what else?
20:07:46 <pbrobinson> I've unblocked some of it manually but it's a problem
20:08:09 <jonmasters> yea
20:08:44 <jonmasters> ok, other blocking packages?
20:09:01 * jonmasters is looking at the latest email
20:09:02 <pbrobinson> for the rest of F-17 we now have a few minor ones that need closer attention but they're mostly esoteric bits like fpc (pascal from mem) that blocks a number of games, and a few things that are broken on v5 due to the item further down the list
20:09:20 <jonmasters> right, atomics, yea
20:09:51 <jonmasters> still eclipse, some python, some ruby, etc. too
20:10:10 <jonmasters> oh and cups blocks samba
20:10:13 <pbrobinson> a few issues with some java packages, and I think a few that are broken on mainline and hence ARM as well
20:10:55 <pbrobinson> On F-18/rawhide we have a few other failures, but alot of those are failing on mainline too
20:11:08 <jonmasters> ok, any other specific build issues? What should we do to advance fixing these (other than llvm)?
20:11:40 <jonmasters> does a VFAD really make sense? I mean, basically, these just need people to look at them at any time
20:11:40 <dgilmore> jonmasters: we have eclipse now, and eclipse-cdt is being worked on
20:11:51 <jonmasters> dgilmore: good, ok
20:11:59 <pbrobinson> on rawhide there's dlm which blocks a lot of the lower stuff, I've filed a bug report
20:12:08 <djdelorie> do we need some better scanning scripts, to try to identify "hot spots" in the build dependencies?
20:12:22 <pbrobinson> I can send a mail about breakages to the mailing list as a start
20:12:22 <jonmasters> we actually discussed that before
20:12:40 <jonmasters> the guys at Seneca were going to write a script to look at the koji delta between not attempted, attempted, etc.
20:12:54 <jonmasters> I think they've been busy with exam week last week. Paul or Chris, any thoughts?
20:12:57 <jonmasters> ctyler: ^^^
20:13:10 <jonmasters> maxam: ^^^ ?
20:13:24 <pwhalen> I spoke with Jon earlier in the week but he was very busy, will see how his progress goes
20:13:27 <maxam> jonmasters: fossjon was working on it
20:13:38 <maxam> what pwhalen says
20:13:45 <pbrobinson> djdelorie: relatively easy to work it out from koji-shadow but it only takes a single low level failure to branch out through the entire tree. In most cases the low level ones are transient failures though now
20:14:11 <jonmasters> ok, so that's a good medium term strategy. But for right now, should we set aside some time to scrub the list for packages that need TLC?
20:14:36 <jonmasters> I wonder if a VFAD just to figure out what needs doing might make sense?
20:14:58 <pbrobinson> I can work most of what's needed by grepping logs
20:15:10 <djdelorie> yeah, my thought was to try to robo-detect the failures that have lots of dependencies waiting on them, to prioritize where eyeballs should go
20:15:13 <jonmasters> pbrobinson: sure, do you want to start by posting some problem children to the list?
20:15:18 <pbrobinson> pki-core is another one on the list now I look at it
20:15:23 <pbrobinson> sure
20:15:25 <jonmasters> yea, saw that, it's a hotspot
20:15:40 <jonmasters> ok, we'll come back to this in a few min, under F17 release status
20:15:44 <pbrobinson> jonmasters: want to action me for it
20:15:58 <jonmasters> #action pbrobinson to send email with a list of problem children packages
20:16:05 <dgilmore> pbrobinson: i fixed osutil that  is needed by the pki stack. there could be some other dep needing love
20:16:25 <jonmasters> #chair jonmasters dgilmore pbrobinson pwhalen djdelorie ctyler
20:16:25 <zodbot> Current chairs: ctyler dgilmore djdelorie jonmasters pbrobinson pwhalen
20:16:51 <jonmasters> any more package hotspots to discuss before the next subtopic?
20:17:09 <jonmasters> going once...
20:17:25 <jonmasters> ok, so onto the next subtopic...
20:17:37 <jonmasters> #topic 0.1 - Atomics on older processors (v5) - the future of v5, etc. etc.
20:18:11 <jonmasters> so Brendan raised this issue, which is that older <armv6(k) processors don't have the same level of support for e.g. atomic load of 64 bit quantities
20:18:34 <djdelorie> are there any armv5 SMP chips?
20:18:52 <jonmasters> the kernel has a kuser_helper (like a VDSO, but not quite) that gcc/glibc uses, but you have to use the standard atomic operations to benefit, whereas doing your own atomic ops in asm you won't see these
20:18:57 <djdelorie> or is this a problem for armv7-running-armv5 setups?
20:19:22 <jonmasters> djdelorie: this is a problem on UP because userspace tasks can be pre-empted or have an interrupt hit, etc.
20:19:46 <pbrobinson> from the thread it seems it's not just a problem for ARM
20:19:53 <djdelorie> for example, a pthreads app?
20:20:05 <jonmasters> djdelorie: ARMv6 onwards introduces a real load/store reservation architecture with a reservation engine that is used in all later ARM chips (part of v8 too), and is also common on other arches
20:20:15 <jonmasters> indeed, this is not ARM specific
20:20:33 * dgilmore doesnt see any point in changing the basearch for sfp
20:20:46 <jonmasters> most modern arches do reservations now rather than SWP-like stuff. e.g. seqlocks, etc.
20:20:51 <jonmasters> (similar to)
20:21:02 <dgilmore> most of the sfp only hardware thats interesting to run fedora on is v5tel
20:21:10 <dgilmore> exception being the pi
20:21:16 <jonmasters> dgilmore: I'm in agreement with you on this. There were not that many ARMv6 chips made, really only cellphone parts, like the Broadcom one in the Pi
20:21:22 <pbrobinson> I don't either, but there appeared to be a reasonable solution on the mailing list which is basically not to use hand crafted ASM
20:21:34 <jonmasters> pbrobinson: right, that is generally the answer
20:21:54 <jonmasters> anything after about 2.6.16(?) kernel wise supports the necessary kuser helpers
20:21:59 <pbrobinson> and that will benefit other arches, so the question is how hard is it to fix that
20:22:08 <jonmasters> so we should push back on upstreams to fix their code properly
20:22:15 <dgilmore> jonmasters: and we have nothing in use less that 3.x.x
20:22:37 <jonmasters> dgilmore: right, what I'm saying is that it's been fixable for a long enough time that everyone should be able to get behind it :)
20:22:50 <jonmasters> (even people rebuilding 2.6.32 "enterprise" style on ARM :) )
20:23:01 <dgilmore> jonmasters: right. so we push back to upstreams to use the kernel to help
20:23:05 <dgilmore> and simplify
20:23:20 <jonmasters> the question is, how many packages, and what's the immediate impact. That wasn't clear to me
20:23:34 <jonmasters> we're not really going to know without looking at individual build failures
20:23:35 <dgilmore> jonmasters: i think the number is small
20:23:46 <pbrobinson> do we have people that are able/interested in writing patches to submit upstream to assist?
20:23:53 <jonmasters> dgilmore: indeed, I'm inclined to say it's just a bug like any other and we push back until it becomes a huge problem
20:24:02 <jonmasters> pbrobinson: I am able, short on time
20:24:10 <jonmasters> pbrobinson: however, I could document how to fix this
20:24:17 <jonmasters> (that's probably a good thing to do)
20:24:18 <pbrobinson> jemalloc/openmpi are two that come to mind.
20:24:26 <dgilmore> earlier today  we were at 10737 packages the same on arm as primary
20:24:33 <pbrobinson> jonmasters: that wasn't a question directed at you in particular
20:24:43 <jonmasters> ok, could someone harass me with a list of example packages with this problem so I can put together an example?
20:25:04 <dgilmore> jemalloc openmpi openjdk
20:25:14 <jonmasters> yea, ok, I guess jemalloc is a good starting point
20:25:15 <dgilmore> and the openjdk folks are on top of it
20:25:20 <jonmasters> right
20:25:36 <pbrobinson> the first two are probably the good ones and maybe the java guys can use the example to deal with openjdk
20:25:44 <jonmasters> still, perhaps a good example is if they decide to fix it using the kernel helpers then we can point people to the patches
20:25:57 <dgilmore> jonmasters: exactly
20:26:07 <dgilmore> one fixes it the rest can follow easily
20:26:10 <jonmasters> yea, ok I'll look at jemalloc if I get time this week, other volunteers welcome
20:26:42 <jonmasters> (if you get bored, you can read about reservation engine implementations in a variety of books - my favorite bedtime reading)
20:27:03 <jonmasters> ok, so for v5 I think status quo for now?
20:27:18 <jonmasters> we have no plan to drop it or change course with same level of support as v7?
20:27:38 <jonmasters> I think in general we plan to drop v5 within a release or two of e.g. a v7 based Pi becoming available at some point
20:27:43 * jsmith sees no compelling reasons at this time
20:28:09 <djdelorie> worst case, we buy 1000 RPi's and build a pi-specific repo ;-)
20:28:22 <jonmasters> :)
20:28:36 <pbrobinson> I think we leave it as is and review moving forward
20:28:41 <jonmasters> ok, so we'll table further discusson of v5 for now and keep reviewing
20:28:48 <dgilmore> jonmasters: right, at some future point i think we can look at dropping sfp support
20:28:51 <jonmasters> #agreed keep reviewing long term status of v5 over time
20:29:05 <jonmasters> ok, any more on this subtopic?
20:29:08 * maxam thanks djdelorie .... Possible Dream Come True Situation!
20:29:10 <pbrobinson> nope
20:29:14 <jonmasters> then...
20:29:22 <jonmasters> #topic 1. Secondary Architecture Promotion
20:29:40 <jonmasters> clearly FESCo did meet, there are now some requirements, and an obligatory LWN story
20:29:51 <pbrobinson> we have the criteria so now we need to work out and action plan for moving towards it and the time frame
20:29:55 <jonmasters> where do we stand? Who has had time to review the meeting minutes or ponder that?
20:30:32 <jonmasters> I think we broadly committed to monthly status reports in general for this project, to be sent to devel@ (and I was hoping I could joint own that with Peter, Dennis, and Brendan for example)
20:30:38 <pbrobinson> I've skimmed the final proposal but not had time to do anything else
20:30:53 <pbrobinson> works for me
20:31:15 <jsmith> jonmasters: I think regular blog posts from people like you, Peter, Dennis, and Brendan would also go a long ways towards helping with the communications gap
20:31:18 <jonmasters> Brendan (who has is vacation today) and I discussed this some and I think we agreed it would be good to answer the 10 points with where we are today, too
20:31:27 <dgilmore> jonmasters: i will work on coming up with a list of tasks that we will need to do
20:31:45 <jonmasters> jsmith: I agree. Clearly, I have a G+/FB addiction too, the former being more public. I'll try to get back into regular ARM related blog posts
20:32:06 * dgilmore needs to regullary blog
20:32:13 <jonmasters> #action jonmasters et al. to co-ordinate response on current status of 10 promotion requirements as pertains to ARM
20:32:24 <jonmasters> #action dgilmore to come up with a list of tasks that we will need to do
20:32:44 <jonmasters> I think if we do those two actions, we can then look forward, perhaps next week?
20:32:45 <pbrobinson> I've been a bit slack on blog posts of late, I was planning a post about the promotion criteria and how it pertains to ARM at some point soon
20:33:08 <jonmasters> Also, I think we should retract our promotion request for F18
20:33:24 <jonmasters> #idea retract F18 promotion request, revisit for F19
20:33:36 <djdelorie> jonmasters: which criteria are we not going to be able to meet for F18 ?
20:33:42 <jsmith> Just for the sake of argument, why?
20:33:47 <jonmasters> djdelorie: we won't have server hardware in PHX in time
20:33:47 <dgilmore> jonmasters: no
20:33:51 <pbrobinson> jonmasters: I think we're better off wording it slightly better than that but ultimately i think we're better aiming for F-19
20:34:16 <jonmasters> ok, we can keep it on the table for now. It's still (stretch) possible we'll have hardware in time
20:34:20 <dgilmore> jonmasters: lets leave it there and work towards it if we miss we miss, and retarget f19
20:34:24 <jonmasters> ok
20:34:33 <jonmasters> then I retract that proposal
20:35:03 <jonmasters> any other comments or input on the meeting from Monday? Did anyone not attend and not get chance to review what was said?
20:35:16 <pbrobinson> It's more a case of we'll be better aiming for f-19 now we have a proper criteria and know more about time lines for things like enterprise build hardware than specifically retracting f-18
20:35:37 <jonmasters> right
20:36:07 <jonmasters> I guess I'm partly saying this here because I know we're being watched, and I want the lurkers to realize we're not going to push for something that does not make sense
20:36:25 <jonmasters> (hello, you know who you are :) )
20:36:44 <jonmasters> ok, anyone else got anything on SA promotion?
20:37:01 <rbergeron> LOL
20:37:17 <jonmasters> #topic 2. Happy Birthday ARM
20:37:27 <dgilmore> jonmasters: f19 features can start being worked on and landed as soon as we branch of for f18 in git. I really want the arm to primary move to happen then if its possible.  assuming we miss f18 which means that its really only a matter of about 4-6 weeks difference in timelines
20:38:14 <jonmasters> So, ARM turns 27 tomorrow. Unfortunately, the folks in the UK office I work with are out tomorrow, so I can't have a birthday cake delivered. But more seriously, what are we doing tomorrow? Canonical is releasing a 5 year LTS and don't think they haven't thought about the date, because I'm sure they have.
20:38:15 <pbrobinson> dgilmore: agreed, we should have everything in place prior to that ready to turn on the moment we've branched F-18
20:38:44 <jonmasters> IOW, where do we stand with being able to do a beta?
20:38:47 <jonmasters> etc. ?
20:39:00 <pbrobinson> in 24 hrs it's unlikely
20:39:09 <jonmasters> agreed
20:39:11 <pbrobinson> <24 hrs even
20:39:28 <dgilmore> jonmasters: I guess we need to really know what we will ship
20:39:32 <jonmasters> so what do we want to do? Anything? It would be sad to let everyone get all excited about Ubuntu and not feel the Fedora love :)
20:40:09 * pbrobinson is planning on building kernels and packages.... just like he has been since around the 26th birthday of ARM :-/
20:40:11 <jonmasters> pbrobinson: do we need to have llvm resolved to do a beta?
20:40:32 <jonmasters> pbrobinson: I'm of the opinion that we have enough actually to put something out, maybe not tomorrow, but very soon
20:40:53 <jonmasters> so it won't have a full GNOME desktop, but it's still very usable :)
20:40:59 <djdelorie> are blc's images good enough to "just work" yet?
20:41:08 <jonmasters> in the main, they do on e.g. TS
20:41:10 <pbrobinson> not particularly but i think having some scripts of some description for people to be able to build images easily and actually boot them is a lot more important
20:41:20 <jonmasters> so good news there
20:41:28 <jonmasters> dmarlin has live media stuff working
20:41:45 <pbrobinson> jonmasters: gnome desktop works fine, I've been using a F-17 gnome desktop on my XO for weeks :)
20:41:46 <jonmasters> dmarlin: want to update everyone on that?
20:41:56 <jonmasters> pbrobinson: oh, I mean the soft rendering
20:42:02 <djdelorie> maybe pick one or more of the better-behaved images, copy them so they won't be overwritten, and put links on the main Fedora page?
20:42:18 <dmarlin> jonmasters: I am able to use livemedia-creator to create trimslice disk images using a kickstart file...
20:42:27 <pbrobinson> jonmasters: there's more work than just llvm to make that work
20:42:31 <jonmasters> right
20:42:38 <dgilmore> djdelorie: we need to make some official beta bits and put on the mirrors
20:42:40 <dmarlin> jonmasters: the kickstart has to do some of the uboot work in %post, but it basically works
20:43:02 <jonmasters> so perhaps if dmarlin wrote up what he has done then we could use that to point folks at making images, pbrobinson ?
20:43:17 <jonmasters> it may not be perfect, yet, but it's pretty good as a starting point
20:43:22 <dgilmore> if that means i need to manulaly do a bunch of things to get us something that just works as a stopgap until we can use pungi, lorax, and anaconda so be it
20:43:38 <pbrobinson> that would be great, dmarlin what devices does it work with currently?
20:43:44 <dmarlin> jonmasters: note - the changes are not upstream yet, and it looks like they will not be put in f17... too late in the cycle
20:43:49 <jonmasters> at least trimslice and highbank
20:44:05 <pbrobinson> pandaboard, beagleboard?
20:44:11 <jonmasters> dmarlin: right, but since they're not all being used in PA anyway, it's ok for us to stash a side repo with the bits
20:44:33 * jonmasters has experienced problems on the Panda with 3.3+ kernels (unrelated to audit) - anyone confirm a working panda?
20:44:37 <dmarlin> pbrobinson: I have not done anything for the omap boards, since the u-boot requirement are much harder for an anaconda install
20:44:39 <dgilmore> jonmasters: i owuld like us to have a kirkwood, tegra, omap, highbank and qemu images
20:45:20 <jonmasters> dgilmore: yes, fair enough. If they're working, we should do that. If there's a blocker with e.g. kernel support for one that will take a while to fix, I think we'd skip it for the beta
20:45:21 <dgilmore> jonmasters: i need to update my pandaboard sdcards to f17
20:45:22 <pbrobinson> jonmasters: I'm working on kernel stuff now, probably a separate update
20:45:38 <jonmasters> ok, so how do we move this forward?
20:45:44 <jonmasters> I think we can say:
20:46:06 <jonmasters> #action dmarlin to post some bits and a wiki page on fp.o about making images with lorax/livemedia-creator
20:46:23 <jonmasters> but what else, and when are we targeting the beta release?
20:47:39 <jonmasters> pbrobinson, dgilmore: what do you think?
20:48:25 <pbrobinson> jonmasters: I think some means of building an image (which we have it seems) and some working kernels (which I'm working on to the best of my ability) and some sample kickstart files for making them
20:48:46 <dgilmore> jonmasters: we need to make some images and do some testing
20:49:05 <jonmasters> ok, so once dmarlin posts those bits, we make some test images, do some testing, and hope to have progress on beta images by next week?
20:49:17 <dgilmore> sure
20:49:18 <jonmasters> should we set a goal of having some beta images before the end of next week?
20:49:33 <jsmith> Sounds reasonable to me
20:49:41 <jsmith> Of course, I'm not the one making the images :-p
20:50:17 <jonmasters> #agreed Plan is to have beta images available before May 7th
20:50:23 <jonmasters> (taking silence to mean yes)
20:50:39 <jonmasters> ok, anyone else got anything on F17?
20:50:52 <jonmasters> Because otherwise, we should talk about rawhide/F18 status
20:51:25 <maxam> I may have some cycles to pitch in for the kickstarts
20:51:26 <pbrobinson> kernel but it's easily covered in rawhide too
20:52:33 <maxam> I will definitely need help from dmarlin and possibly dgilmore
20:53:13 <jonmasters> right. I'm looking at the kernel issues too (some of them). I did find that the problem booting was not systemd directly (although its error handling is not great in this case). The problem was with audit. I think I'm tracking that down and I'm going to ping sgrubb about it being his problem soon :)
20:53:21 <dmarlin> maxam: I appreciate your help.  I'll let you know as soon as I get the bits posted and some notes
20:54:00 <jonmasters> ok, so other rawhide issues. I'm a little behind on package build status for rawhide. pbrobinson, could you summarize?
20:55:10 <pbrobinson> kernel update: from my side I'm cleaning up the arm kernel configs to ensure we properly pull everything in from the generic configs and don't override it so we get all the things that we need for a Fedora kernel and centralising generic ARM options so that all the kernels get those
20:55:20 <jonmasters> pbrobinson: +1
20:55:42 <jonmasters> what about other packages? I think Brendan was concerned that we weren't as up to date on builds in F18
20:55:50 <pbrobinson> our kernels are a bit of a mess at the moment so that should allow us to get things more even across all devices
20:56:15 <jonmasters> (but my take on it is things aren't actually that bad in F18)
20:57:11 <jonmasters> ok, well maybe we'll come back to rawhide
20:57:12 <pbrobinson> so rawhide in mainline is in a bit of a mess generally which is causing us some issues. things like dlm which did build on mainline are now FTB eg  https://bugzilla.redhat.com/show_bug.cgi?id=816218
20:57:31 <dmarlin> pbrobinson: just one request... we need to test all kernel variants with the config changes to ensure no breakage.  some are very finicky regarding config options
20:57:42 <dgilmore> win 31
20:58:07 <jonmasters> and we'll also figure out ways to get upstream ARM kernel folks testing with Fedora config options turned on
20:58:10 <pbrobinson> dmarlin: yep, known and once we're mostly clean I'll get some scratch builds out for people to test and feed back on
20:58:26 <dgilmore> jonmasters: having nightly images should help :)
20:58:26 <dmarlin> pbrobinson: thanks
20:58:28 <jonmasters> #action jonmasters to followup on getting upstream ARM kernel folks to test with more Fedora-like configs
20:58:47 <pbrobinson> so using dlm as an example it blocks lvm2 which in turn blocks just about everything
20:58:55 <jonmasters> dgilmore: right, but even people not running Fedora. Just people doing ARM kernel stuff generally use defconfigs intended for embedded, without cgroups, audit, etc. etc.
20:59:07 <jonmasters> pbrobinson: lovely. Ok, but that's a PA FTB
20:59:17 <pbrobinson> yep
20:59:23 <jonmasters> pbrobinson: anything ARM specific you can think of in F18 right now that needs special love?
20:59:40 <jonmasters> (clearly we'll benefit from the automated analysis in the medium term)
21:00:00 <pbrobinson> and there's some other stuff with the entire gnome stack being a complete mess because of inheritance breaking due to other packages soname bumping etc
21:00:10 <jonmasters> la la la
21:00:13 <jonmasters> :)
21:00:29 <jonmasters> ok, we're on the hour now. Shall we do any other business?
21:00:35 <pbrobinson> but again that's mainline issues and they're being worked on by people other than me which is a good thing :-D
21:00:44 <jonmasters> #topic 3. Any other business. Open Floor.
21:00:47 <pbrobinson> and all the rest it mostly just humming along
21:00:49 <djdelorie> pending hardware status?
21:01:01 <jonmasters> djdelorie: you mean the "enterprise" class hardware?
21:01:04 * djdelorie is still waiting for his RPi
21:01:16 <djdelorie> any relevent hardware status
21:01:20 <jonmasters> ah, so we don't have a specific update from the foundation yet on that, but we know they're very busy
21:01:38 * pbrobinson is too :-(
21:01:42 <jonmasters> ctyler: can you update us soon on the status of the Pi availability? We also do still need to pay them for the coupons
21:01:45 <djdelorie> I got an email that said element14 orders would be out by end of June
21:01:58 <djdelorie> (if you ordered before a week or two ago, that is)
21:02:03 <jonmasters> I think they're suffering from classical scaling problems with a wildly successful new business
21:02:15 <pbrobinson> is ctyler even here? Not seen a peep
21:02:24 <djdelorie> yeah, too bad the last minute change of vendor plans messed up the coupons and such
21:02:28 <jonmasters> right, but hopefully he'll see scrollback and respond to us on #fedora-arm later
21:02:45 <jonmasters> we'll straighten that out
21:03:00 <jonmasters> as to the enterprise hardware. There is good progress there, nothing I can share...yet. But soon.
21:03:12 <djdelorie> on the blue-sky side, blc got a shell on his quad-core tablet, /me wonders if a quad-core trimslice is in the works...
21:03:26 <jonmasters> that would be fun to have
21:03:35 <jonmasters> I wouldn't object to an A15 part either :)
21:03:56 <djdelorie> no new ponderings about merging multiple small arm machines into a big one, either.  Would have to be a full HAL migratable solution
21:04:10 * jonmasters is pondering setting up one of the ARM A15 software models at some point to see how well we work. I think it's fair to mention those here since Linaro publicly state their existence.
21:04:46 <jonmasters> (but A15 models are proprietary and non-redistributable, but it would give some coverage as to how well Fedora ARM works on them anyway)
21:04:54 <pbrobinson> is there any other business as we should probably move discussion about wishes for hardware back to #fedora-arm
21:05:08 <jonmasters> yea, indeed. Anything else? Or shall we call time on this?
21:05:14 <jonmasters> going once...
21:05:19 <jonmasters> going twice...
21:05:23 <nb> if anyone finds a way to order them, ambassadors wants to order probably 10
21:05:34 <jonmasters> #endmeeting