20:00:00 <jonmasters> #startmeeting
20:00:00 <zodbot> Meeting started Wed May  9 20:00:00 2012 UTC.  The chair is jonmasters. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:15 * Frojoe is here
20:00:17 <bconoboy> .fas blc
20:00:17 <jonmasters> and it's that time again. It's 4pm Eastern on a Wednesday, do you know where your Fedora ARM systems are?
20:00:17 <zodbot> bconoboy: blckspder 'Antoni Sousa' <blckspder@gmail.com> - blc '' <blc@redhat.com>
20:00:20 * pwhalen is here
20:00:22 * maxam is here
20:00:24 * djdelorie is here
20:00:31 * ctyler is here
20:00:32 * fossjon is here
20:00:41 * Frojoe is here
20:00:45 <jonmasters> #chair jonmasters fossjon bconoboy pwhalen djdelorie maxam ctyler pbrobinson dgilmore
20:00:45 <zodbot> Current chairs: bconoboy ctyler dgilmore djdelorie fossjon jonmasters maxam pbrobinson pwhalen
20:01:01 <Frojoe> I guess I'll stand then
20:01:02 * nirik is lurking around.
20:01:16 <jonmasters> ok then...before we start, does anyone have anything they'd like to add to the agenda?
20:01:18 <jonmasters> #chair jonmasters fossjon bconoboy pwhalen djdelorie maxam ctyler pbrobinson dgilmore Frojoe
20:01:18 <zodbot> Current chairs: Frojoe bconoboy ctyler dgilmore djdelorie fossjon jonmasters maxam pbrobinson pwhalen
20:01:19 <agreene> agreene is here
20:01:41 * agreene is here
20:01:59 * dmarlin__ is here
20:02:07 <jonmasters> Ok. Let's do it then
20:02:10 <fossjon> we have a big group
20:02:17 * orc_fedo is here
20:02:18 <jonmasters> #topic 0. Current build status - Gnarly bugs and build failures
20:02:19 * giallu is sort of here
20:02:37 <jonmasters> First, let's all congratulate fossjon on producing some very nice stats for us
20:02:48 <jonmasters> very helpful, thanks Jon
20:02:58 <fossjon> thanks i hope its a bit useful
20:03:00 <pbrobinson> I'm documenting all things that need direct attention here https://fedoraproject.org/wiki/Architectures/ARM/Fedora17_rawhide#broken_on_arm_general_packages
20:03:10 <cwickert> sorry, but what meeting is this?
20:03:16 <ctyler> yay fossjon!
20:03:18 <bconoboy> cwickert: ARM
20:03:28 <pbrobinson> cwickert: ARM
20:03:33 <cwickert> this meeting is not listed in the timetable
20:03:34 <fossjon> cwickert the fedora arm meeting
20:03:36 <jonmasters> pbrobinson: would you like to call out anything in particular? I reviewed the latest koji compare last night and it looked pretty good actually. It seemed that after I get through some of these atomics, it's not major stuff left?
20:03:53 <cwickert> the EMEA ambassadors are to supposed to meet here now
20:04:16 <pbrobinson> cwickert: you haven't for the last month?
20:04:28 <cwickert> pbrobinson: we usually meet biweekly
20:04:48 <pbrobinson> cwickert: did you miss the last one?
20:04:51 <jonmasters> cwickert: well either we can move to #fedora-meeting-1 or you can
20:05:07 <cwickert> we'll move
20:05:29 <jonmasters> thanks, appreciated. We'll get this meeting on the calendar and next time we'll go to #fedora-meeting-1 if we clash with you. Sorry
20:05:43 <cwickert> alright
20:05:50 <jonmasters> #action add this meeting to the official calendar, move to #fedora-meeting-1 on days that conflict with EMEA ambassadors
20:05:53 <cwickert> Sesivany: we are in #fedora-meeting-1
20:06:06 <Sesivany> ok
20:06:18 <jonmasters> ok so, meanwhile in ARM land...
20:06:25 <jonmasters> pbrobinson: anything you'd like to call out specifically?
20:06:45 <pbrobinson> jonmasters: wherever we move it permanently so as not to have confusion
20:07:02 <pbrobinson> jonmasters: no, nothing in particular to call out, just would like some attention on any/all of them if possible
20:07:39 <jonmasters> pbrobinson: ok
20:07:58 <jonmasters> #agreed if we move this meeting we move it every time to #fedora-meeting-1
20:08:14 <jcapik> jonmasters: I would move the meetings to fedora-meetings-3 ... it's almost always empty
20:08:14 <pbrobinson> I'm slowly moving through the whole list of packages and fixing a lot of mainline FTBFS in the process. Like I fixed one the other days that was FTBFS from F-11!
20:08:24 <fossjon> +1 for a consistent meeting room
20:08:29 <jonmasters> pbrobinson: right, many of the issues in koji compare are fortunately things like SMM/biosdevname, etc. stuff that we don't even have on ARM
20:08:58 <jonmasters> pbrobinson: bconoboy was suggesting we send a list to devel@ of FTBFS packages we've found
20:09:07 <pbrobinson> jcapik: the advantage of not being in #3 means we get more visability, if we go to #3 we may as well do it on #fedora-arm
20:09:15 <ctyler> jonmasters: I just updated [[Meeting_channel]] on wiki to -1
20:09:32 <jonmasters> pbrobinson: there was a proposal a while back that stuff not built in two Fedora releases would be marked for removal automatically. What's the status of that? (I do not endorse that approach, but it would incidentally help with this)
20:09:39 <pbrobinson> jonmasters: I'll add my list of non ARM architecture builds to the wiki too for reference
20:10:02 <jcapik> pbrobinson: ok :] hopefully we're not gonna clash with others too often
20:10:36 * jonmasters favors exponential backoff. If we clash with them, they can go back to using x86 systems ;)
20:10:44 <pbrobinson> jonmasters: it was approved and there was a chunk of things blocked but I discovered too late that it needed to have a FTBFS bug filed. I've also since had a number of dead packages blocked
20:11:18 <jonmasters> ok so it's a $random_enjoyable_fedora_be_excellent_to_each_other kind of problem. Awesome.
20:11:37 <jonmasters> pbrobinson: shall we have bconoboy send that list of FTBFS stuff?
20:11:48 <pbrobinson> I'm now filing bugs for mainline issues actively so it won't be a problem moving forward
20:11:50 <bconoboy> I'd need a list
20:12:00 <jonmasters> bconoboy: fossjon 's stats have the list
20:12:07 <pbrobinson> I've already blogged about them and I can send a list
20:12:15 <jonmasters> bconoboy: hmm...I guess they don't quite
20:12:15 <bconoboy> jonmasters: His list includes stuff that is FTBFS on x86?
20:12:18 <fossjon> i wrote another script to analyze what the failures were
20:12:30 <fossjon> whether it was from arch/deps/reqs/configure/make/etc...
20:12:34 <pbrobinson> ultimately I don't really see the point as there was dozens of emails over the mass rebuild and they were generally ignored
20:12:34 <jonmasters> yea, easiest option is to go with pbrobinson 's list for right now
20:13:14 <bconoboy> pbrobinson: I'm picturing 1 email with a complete list, including who we think should be fixing it attached to each package
20:13:16 <jonmasters> pbrobinson: well the issue is if something is FTBFS in PA and we specifically called it out, it can't be held against us later - it's hardly an ARM problem if PA is using a package build from the stone age
20:13:24 <fossjon> there was this one i did a while back -> http://lists.fedoraproject.org/pipermail/arm/2012-March/002973.html
20:13:29 <pbrobinson> bconoboy: the FTBFS on x86 is easy. Get a list of all packaged in f-17, if it's got a none fc17 build it's FTBFS on x86 :)
20:13:42 <jonmasters> yea true, there was a mas rebuild
20:13:46 <jonmasters> * mass
20:13:50 <jonmasters> so that's the easy option
20:14:12 <pbrobinson> I've sent lists before actually
20:14:17 <pbrobinson> but I'll send it again
20:14:43 <jonmasters> #action bconoboy to send a super polite and lovely email to devel@ reminding folks there are whole bunches of FTBFS packages on PA for which we never had ARM builds and can't make them as a result
20:14:58 <jonmasters> pbrobinson: feel free to own that action if you prefer?
20:15:23 <pbrobinson> I think it's easier, I've had for a while a multi prong action
20:15:35 <bconoboy> #action pbrobinson to do that instead
20:15:39 <jonmasters> ok bconoboy can provide input
20:15:55 <jonmasters> ok anything else on build failures? etc.?
20:15:55 <pbrobinson> including bugs, emails and just fixing them myself because it's at times plain quicker
20:16:20 <jonmasters> #topic 0. Current build status - Sending out regular problem package emails
20:16:22 <pbrobinson> people just review the list here https://fedoraproject.org/wiki/Architectures/ARM/Fedora17_rawhide#broken_on_arm_general_packages
20:16:42 <pbrobinson> and helping to fix :)
20:16:44 <jonmasters> so I think this next item is covered by the work fossjon has done and the mails pbrobinson has sent
20:17:02 <jonmasters> anything else on the problem email front?
20:17:08 <pbrobinson> nope
20:17:11 <jonmasters> pbrobinson: you were going to send fossjon input on things to add, etc.?
20:17:33 <fossjon> i can try to add other useful things if you guys have any suggestions
20:17:42 <jonmasters> well, if you have any input (anyone) please send to fossjon
20:17:46 <bconoboy> jonmaster: Don't know if it's the right time, but the big delta between FC17 and FC18 packages is concerning and we should discuss
20:17:46 <pbrobinson> jonmasters: yes, i forgot about that and since you reminded me yesterday I haven't had time
20:17:51 <ctyler> fossjon: maybe you should add that link ( https://fedoraproject.org/wiki/Architectures/ARM/Fedora17_rawhide#broken_on_arm_general_packages ) to the daily mails
20:18:00 <jonmasters> #agreed feedback to fossjon on things to add to his nightly koji compare stats
20:18:06 <jonmasters> ctyler: +1
20:18:11 <pbrobinson> fossjon: poke me directly as I have some feedback and suggestions
20:18:20 <fossjon> ok will do then
20:18:26 <jonmasters> #action fossjon to add a link to the wiki page of broken packages to the nightly email
20:18:27 <jcapik> ctyler: +1
20:18:36 <jonmasters> ok, anything else on this topic?
20:18:40 <djdelorie> is it possible to auto-update the wiki page too?
20:18:53 <fossjon> djdelorie thats what i was thinking of too
20:18:57 <djdelorie> like the pretty charts I used to generate?
20:19:02 <fossjon> it'd be cool if wiki was more dynamic possibly
20:19:13 <bconoboy> it'd have to be a separate page
20:19:18 <djdelorie> perhaps <iframe> to a separate page?
20:19:29 <thunderbirdtr_> fossjon, +1
20:19:33 <jonmasters> or just link to it :)
20:19:36 <ctyler> or pull in a template page
20:19:37 <pbrobinson> well the wiki page is aimed at packages that need direct manual intervention. Some of the non builds are not building due to dependencies on the wiki page
20:19:55 <jonmasters> I favor keeping the wiki page manual, but actually updating it as we go (trying to do that myself)
20:20:00 * djdelorie is just thinking, email is more transient than a web page, and web pages are more findable
20:20:03 <pbrobinson> so I'm not sure how you'd reflect that in the wiki page
20:20:05 <jonmasters> but an auto page with more general stuff is a good idea
20:21:37 * pbrobinson is not bothered
20:22:05 <jonmasters> #topic 0. Current build status - Atomics on older processors (v5)/LLVM/etc.
20:22:06 <bconoboy> if somebody wants to make an automated page go ahead, but let's keep the manual page. It's been working well for us.
20:22:38 <jonmasters> So. I started working on this, did a DirectFB build (which actually fails to build due to missing sources elsewhere...fixed)
20:22:50 <jonmasters> I'll send on patches for DirectFB and go through some more of them
20:22:59 <jonmasters> LLVM we think is actually - amusingly - just a config issue
20:23:20 <jonmasters> sadly, it took someone looking at this with fresh eyes to realize we hadn't configured LLVM as we would any other toolchain on v7
20:23:36 <jonmasters> (i.e. it was building as soft float default)
20:23:51 <jonmasters> so I have a scratch build in Koji now building with the right config
20:23:55 <jonmasters> maybe that will fix LLVM
20:24:15 <jonmasters> (sufficient for now - longer term, it needs better ownership on the ARM front in general - not just Fedora)
20:24:19 <pbrobinson> the think that is most amusing is that the same package builds on ARM rawhide fine and passes all tests fine!
20:24:34 <pbrobinson> s/think/thing
20:24:47 <jonmasters> well, it'll be transient if it's ABI. It'll really come down to luck of which system it runs on, what library calls are made, etc.
20:24:58 <jonmasters> but yea
20:25:21 <jonmasters> anyhoo
20:25:25 <pbrobinson> so jonmasters are you sending patches for atomics issues to the list / me to commit?
20:25:31 <jonmasters> pbrobinson: exactly
20:25:44 * pbrobinson looks forward to them :-)
20:25:45 <jonmasters> #action jonmasters to send atomics/instrinsics fixing patches
20:26:01 <jonmasters> pbrobinson: yea, I've got one for DirectFB ready for you - scratch build succeeded
20:26:31 <fossjon> should we grep all source rpms for a ldrex instruction?
20:26:34 <pbrobinson> jonmasters: we should look at how we get those upstreamed properly as well
20:26:44 <jonmasters> pbrobinson: you'll need to also make some changes to the SPEC file to add in the new davinci so libraries and also add the missing files...hmm. Let me send you a link to the scratch build so you can see that for context too
20:26:54 <bconoboy> jonmasters: atomics patches should go to true upstream as well- else they'll break the next time the packager updates to a new version
20:26:57 <jonmasters> fossjon: that is one option
20:26:59 <pbrobinson> fossjon: sure if you have around 8 TB of fast storage hanging around
20:27:26 <fossjon> we can check the unbuilt pkgs as of today and pull them in one at a time and inspect them possibly
20:27:27 <jonmasters> or even slow storage - doesn't need an answer this moment
20:27:36 <jonmasters> fossjon: I like that idea
20:27:43 <jonmasters> why not, if you've got time
20:27:43 <pbrobinson> bconoboy: that's what I meant by upstream
20:27:56 <bconoboy> fossjon: even if we find them it doesn't follow that it's an issue- they're okay to use on armv7hl
20:28:09 <bconoboy> pbrobinson: Oh, the *real* upstream. okay :-)
20:28:33 <jonmasters> fossjon: I suggest instead that you look for any package that has inline assembly
20:28:44 <pbrobinson> bconoboy: yes to be a good community member for other distros too
20:28:46 <jonmasters> fossjon: if a package has inline assembly, it potentially needs review
20:28:55 <fossjon> i can play around with a script that attempts that
20:28:59 <jonmasters> cool
20:29:26 <bconoboy> jonmasters: we should trust the compiler to throw up errors if there is a problem with the inline assembly or a mismatch of capabilities
20:29:43 <jonmasters> pbrobinson: yea, upsteaming these is important. However e.g. for DirectFB the fix would really be for them to replace all of the arch specific functions with just one meta-set that use the gcc atomics I'm using on ARM
20:30:03 <jonmasters> bconoboy: yea, but there are relatively few packages with inline assembly, so a list is useful to have
20:30:39 <jonmasters> the GCC atomics stuff I'm using is fresh on 4.7 but there's an alternative available since forever on 4.6 or earlier
20:30:41 <pbrobinson> yes, ultimately there's less than a dozen or so that we've encountered that do this
20:31:03 <jonmasters> pbrobinson: so we'll mark on the wiki status where we are with upstreaming
20:31:15 <jonmasters> I'll try some, might want some help just getting folks to ping upstreams, etc.
20:31:16 <pbrobinson> perfect
20:31:27 <jonmasters> I'll let you guys know - I need to get some other stuff done later this week
20:31:56 <jonmasters> ok, and I think I need to write up a page on these so you guys can make the fixes too if needed in the future, etc.
20:32:05 <jonmasters> anyway...anything else on this topic?
20:32:11 <pbrobinson> nope
20:32:19 <jcapik> no
20:32:19 <bconoboy> nope- good work
20:32:29 <jonmasters> #topic 1). Fedora 17 Beta - What are the remaining constraints on getting this out?
20:32:47 <jonmasters> bconoboy: let's also thank kteitz for pointing out the softfp issue :)
20:33:10 <jonmasters> anyway, on F17 beta. I suggest we just fix up bconoboy 's images and test them and bless as our official F17 betas
20:33:32 <djdelorie> +1 if qemu runs with a frame buffer :-)
20:33:36 <jonmasters> I am about done with the idea of "just another week..." while we get ready with image creation, etc. Everyone is busy doing good stuff, can we just go with that?
20:33:37 <bconoboy> I'd like to suggest we need a versatile express image for beta.
20:33:39 <pbrobinson> what happened to the details of creating an image using official tools?
20:34:17 <jonmasters> pbrobinson: dmarlin__ is working feverishly on stuff, but I'd like to not wait for the official tools for beta. We'll have them soon enough but bconoboy has images today that will suffice IMO
20:34:46 <pbrobinson> wasn't dmarlin__ going send an update to the list?
20:34:59 <jonmasters> yea, I suspect he will, dmarlin__ ?
20:35:01 <ctyler> I advocate using the release criteria (at least testing, we can adjust as needed)
20:35:13 <dmarlin__> yes, I'll send an update
20:35:28 <jonmasters> ctyler: ok, so how about we take bconoboy 's images, test them according to the criteria and then make that the beta?
20:35:55 <jonmasters> between us we ought to be able to test what bconoboy has stashed up on fedorapeople
20:35:58 <pbrobinson> jonmasters: a side note (I'll update in any other business) but bconoboy now has a vexpress kernel to test with
20:36:08 <jonmasters> yes, this I know, excellent
20:36:10 <ctyler> sounds good. We should set a date to eval against the criteria, do a vfad/no-nogo on that
20:36:37 <jonmasters> pbrobinson: PA beta is done how long ago now, remind me?
20:36:44 <jonmasters> (it slipped, and then again...)
20:36:51 * bconoboy cannot be trusted to keep his images in good working order.  I'm okay with using them as a basis for the beta release, but they should be hosted elsewhere
20:37:02 <jonmasters> bconoboy: fine
20:37:03 * pbrobinson agrees with jonmasters that once we add a decent qemu image we should just tag and announce and move forward
20:37:21 <jonmasters> bconoboy: we'll test them, stash known good versions and call that beta
20:37:24 <fossjon> can i ask an unrelated question, does koji-shadow take into account the "missing" builds labelled by the koji-compare script?
20:37:35 <fossjon> how important are they?
20:37:38 <jonmasters> pbrobinson: ^^^
20:37:39 <pbrobinson> jonmasters: AOB for kernel stuff
20:37:43 <jonmasters> ok
20:37:59 <jonmasters> fossjon: let's do that discussion on #fedora-arm after this
20:38:09 <fossjon> oh ok sorry :)
20:38:24 <jonmasters> so on the subject of beta, we need to review the release criteria, test images, and go
20:38:41 <pbrobinson> fossjon: ask me there later
20:38:45 <jonmasters> it seems vexpress is the last true blocker, right? We have a working Tegra kernel now, OMAP works (no device tree, but it's ok)
20:38:52 <jonmasters> I think it's just vexpress?
20:39:10 <djdelorie> frame buffer?  Has anyone tested the tegra fb ?
20:39:12 <pbrobinson> jonmasters: yes, and device tree was never on our list for F-17
20:39:15 <ctyler> we're two weeks behind PA beta and 2 weeks to PA GA (as of yesterday)
20:39:23 * djdelorie thinks a working fb is a blocker
20:39:33 <jonmasters> djdelorie: I disagree
20:39:39 <pbrobinson> there is no tegra FB yet, there's patches but not upstream yet and have other dependencies
20:39:47 <bconoboy> frame buffer: my imagines have a working rpi+x image, but that's the only one tested with X
20:39:53 <bconoboy> ... and that isn't using an fc17 kernel
20:40:07 <jonmasters> I think it's important that some devices have an FB, but I think it's not a requirement for beta for the vexpress
20:40:15 <djdelorie> qemu+fb should be doable, and it's the only way to "natively" test a lot of Fedora parts
20:40:19 <pbrobinson> there's a KMS driver enabled for OMAP now
20:40:23 <ctyler> (don't get me started on rpi upstreaming issues, argh)
20:40:28 <jonmasters> Versatile isn't a speed daemon anyway, and I think most people using it are doing so on a serial console
20:40:42 <ctyler> Versatile FB isn't terrible.
20:40:51 <jonmasters> djdelorie: agree on it being doable, just disagree on the need for it to block us from beta
20:40:59 <jonmasters> I'd like to get beta squared away *this week*
20:41:28 <jonmasters> I'm thinking we just need bconoboy to make a vexpress image that we test and if it works, we run through the testing in the plan ctyler and pwhalen created, and then shoot it out
20:41:41 <jonmasters> does anyone object to that? Or see a reason we can't just get that done by the weekend?
20:41:47 <pbrobinson> djdelorie: tegra isn't achievable for beta. OMAP is, raspberry pi isn't upstream
20:41:48 <bconoboy> #agreed bconoboy will make a vexpress+x image and test it out
20:42:06 <jonmasters> any reason we can't do beta this week?
20:42:55 <bconoboy> jonmasters: Who is testing according to beta release criteria?
20:43:00 <ctyler> jonmasters: well, if we have enough cycles to do testing in the next 2 days
20:43:02 <jonmasters> ctyler: did you really want to have a testing VFAD before we release beta? If so, I guess we either do that Friday (seems optimistic) or we do that Mon or Tue?
20:43:10 <pbrobinson> jonmasters: likely just a vexpress f-17 kernel. I can merge the changes back once I get affirmation it's working based on my test kernel. But an official kernel takes a while to build
20:43:23 <ctyler> Mon/Tue is right out for me, agreene, maxam
20:43:30 <ctyler> Friday AM is doable
20:43:36 <ctyler> or tomorrow
20:43:43 <bconoboy> friday is better
20:44:06 <jonmasters> ok bconoboy can you make a vexpess image and test it before this time tomorrow so pbrobinson can kick off a final kernel build before Friday?
20:44:17 * pbrobinson can participate earlier on Fri and Tues is right out
20:44:17 <jonmasters> bconoboy: then you can pull those kernels into images and we can test them on Friday?
20:44:32 <bconoboy> ctyler: how does testing vfad affect koji downtime?
20:44:33 <jonmasters> does this plan vaguely work?
20:44:45 <jonmasters> can we just move the downtime?
20:44:56 <djdelorie> we shouldn't need koji to test a pre-built image
20:45:10 <ctyler> we can move the downtime, or half-staff the vfad on this end
20:45:14 <ctyler> in the afternoon
20:45:38 * ctyler doesn't yet have a firm guarantee that the SSD will be in house by Friday in any case
20:45:51 <bconoboy> ctyler: okay, if you can move the downtime I'm for friday
20:46:08 * pbrobinson wonders why it takes 5 hours to add disks
20:46:17 <bconoboy> separate topic
20:46:22 <pbrobinson> ok
20:46:30 <bconoboy> jonmasters: I think we're agreed on friday testing vfad
20:46:39 <ctyler> Ok, let's tentatively reschedule the downtime for next Wed
20:46:41 <jonmasters> ctyler: can we move the outage to next week?
20:46:45 <jonmasters> ok
20:46:55 <jonmasters> I'd like to just get F17 beta out and then move on...yea
20:47:02 <jonmasters> ok
20:47:33 <bconoboy> #agreed #fedora-arm VFAD for f17-arm beta testing, exact time TBD
20:47:39 <jonmasters> #agreed testing VFAD on Friday. bconoboy to make a vexpress based test image before then, test, then pbrobinson will make a kernel build to update images we will use on Friday
20:48:18 <jonmasters> pbrobinson: so I expect bconoboy will come back to you tomorrow with an update on how the vexpress image works in time for you to make a kernel build
20:48:31 * pbrobinson is happy with that
20:48:40 <jonmasters> I suggest everyone read the testing criteria before Friday too
20:48:54 <pbrobinson> is there a link?
20:49:00 <jonmasters> #idea Everyone read the testing criteria before Friday - ctyler to send a reminder pointer to it out
20:49:11 <jonmasters> ctyler: please post a link on the list
20:49:24 <jonmasters> shall we go to the next topic?
20:49:32 <jcapik> link +1
20:49:41 <djdelorie> topic++
20:49:48 <jonmasters> #topic 2). Secondary Architecture Promotion - Update on our current status wiki page and response to reqs.
20:50:07 <jonmasters> so bconoboy and I talked about this and he's got the ball on creating said wiki page
20:50:16 <jonmasters> do we have any other comments on this, or shall we move on?
20:50:35 <bconoboy> I haven't made any progress on this in the last week.  Should have time this week.
20:50:50 <jonmasters> not a problem - and certainly lower priority than F17 beta I would say
20:50:57 <ctyler> +1
20:51:01 <jonmasters> ok, anyone else got something on this, or shall we move on?
20:51:11 <ctyler> topic++
20:51:15 <jonmasters> #topic 3). Your topic here
20:51:20 <jonmasters> Ok. Any other business?
20:51:27 <jonmasters> pbrobinson: anything else on the kernel front?
20:51:50 * pbrobinson hasn't had time to look unfortunately
20:51:51 <jonmasters> The Tegra USB thing seems solved. I know Dennis had some problems, but they appear to be his hardware
20:52:14 <jonmasters> I will get back to OMAP dtb in due course, but it's not a priority - only really useful for persistent MAC e.g. in builders
20:52:25 <jonmasters> (but we're ok as we are for the moment)
20:52:53 <jonmasters> And beyond that I think there's the need for a generic means to determine platform that I discussed with some folks
20:52:55 <ctyler> There were some nice smsc95xx patches that went in recently
20:53:07 <jcapik> jonmasters: I consider persistent MAC very important
20:53:11 <pbrobinson> is that the end of the agenda, I'm just aware we're nearing the end of the hour
20:53:20 <jonmasters> jcapik: agreed, it'll get done, it's just not a beta blocker
20:53:27 <jonmasters> pbrobinson: it is
20:53:33 <jonmasters> anyone got anything else?
20:53:39 <pbrobinson> quick kernel update
20:53:45 <jonmasters> ok?
20:54:02 <pbrobinson> basically I committed a big clean up to the arm configs today
20:54:33 <pbrobinson> a new build is in process at the moment and once it's complete I'll send a call for testing out to the list
20:54:57 <jonmasters> excellent
20:55:07 <jonmasters> pbrobinson: does it include what you did in the vexpress kernel already?
20:55:15 <pbrobinson> it more closely aligns us to generic configs and mainline bits
20:55:18 <pbrobinson> adds the vexpress kernel
20:55:18 <pbrobinson> and will hopefully make our life easier going forward
20:55:24 <pbrobinson> but I'm sure I've missed some minor bits
20:55:43 <jonmasters> so the build in process is the test kernel to which you were referring earlier?
20:55:49 <jonmasters> s/earlier/before/ ?
20:56:02 <pbrobinson> and I might have found a bug in Fedora binutils too
20:56:11 <jonmasters> oh I found one too
20:56:24 <jonmasters> well actually libbfd I think
20:56:36 <jonmasters> I can make objdump crash for shits and giggles
20:56:43 <jonmasters> ;)
20:57:07 <jonmasters> oh I'll look at the build-id at some point unless someone else has cycles - if you do just let me know
20:57:11 <jonmasters> anything else?
20:57:22 <pbrobinson> yes
20:57:34 <pbrobinson> Once I have a build for people to test I'll send out a list with some more details
20:57:38 <jonmasters> cool
20:57:54 <jonmasters> pbrobinson: but you already did a separate just vexpress that bconoboy has, right?
20:58:26 <bconoboy> jonmasters: yes
20:58:40 <jonmasters> ok cool
20:58:45 <jonmasters> coming up on time...anything else?
20:58:58 <jonmasters> we are going once...
20:59:10 <jonmasters> going twice...
20:59:30 <jonmasters> #endmeeting