19:01:05 <rbergeron> #startmeeting Cloud SIG
19:01:05 <zodbot> Meeting started Fri May 25 19:01:05 2012 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:09 <rbergeron> #meetingname Cloud SIG
19:01:09 <zodbot> The meeting name has been set to 'cloud_sig'
19:01:16 <rbergeron> #topic Who's here, while I crack open a soda
19:01:18 * mdomsch 
19:01:21 * jsmith is here
19:01:22 <rbergeron> mdomsch :)
19:01:31 * tdawson is here.
19:01:50 * jgreguske waves
19:02:31 <rbergeron> hai guys.
19:02:40 <rbergeron> It's a long weekend. I suspect we have few peeps, but we shall see.
19:02:46 <ianweller> soda sounds like a good idea.
19:02:55 <rbergeron> ianweller: you have no idea
19:03:11 <rbergeron> drumkilla!
19:03:15 <russellb> huzzah
19:03:16 <rbergeron> i mean, russell
19:03:32 <rbergeron> oh, dude, that name is *epic*
19:03:42 <rbergeron> okay, i'll.... start!
19:04:02 <rbergeron> #topic open.... (*spins wheel*)...stack!
19:04:09 <rustlebee> woooo
19:04:10 <rbergeron> rustlebee: you get to go first
19:04:12 <rbergeron> yo
19:04:23 <rustlebee> a couple of interesting things to note
19:04:36 <rustlebee> the first milestone for the Folsom release, folsom-1, went out this week.
19:04:45 <rustlebee> we'll start updating rawhide soon
19:05:04 <rbergeron> anything new or exciting coming down the pipe
19:05:08 <rustlebee> the other thing is that there's a bit of dependency drama/debate going on upstream in the last couple of days
19:05:15 <rbergeron> (or dreadful)
19:05:17 <rbergeron> (:D)
19:05:32 <rustlebee> the Horizon project (web UI) is proposing adding a Node.js dependency
19:05:40 <rbergeron> #info first milestone for folsom (folsom-1) went out this week
19:05:52 <rustlebee> it would be the only thing in OpenStack that isn't Python ...
19:06:04 <rustlebee> but why that's relevant is that Node.js is *not* in fedora
19:06:09 <rbergeron> #info dependency debate going on upstream - horizon is adding a node.js dep
19:06:14 <rustlebee> in fact, it's just in Ubuntu and Debian ...
19:06:21 <tdawson> rustlebee, Do they know the reason't why it's taken node.js so long to get into Fedora?
19:06:27 <rbergeron> well, it sucks to package (properly)
19:06:33 <rustlebee> so hopefully we'll find some reasonable compromise that doesn't result in us having to help get node.js in ...
19:06:36 <rustlebee> they bundle libs
19:06:50 <rustlebee> i haven't looked into it too much yet, but that is the main problem
19:06:51 <rbergeron> rustlebee: i think tdawson has to get it in anyway, no?
19:06:57 <rustlebee> oh?
19:06:58 <rbergeron> (for openshift)
19:06:59 <rbergeron> ?
19:07:07 <rbergeron> tdawson: or am i on crack
19:07:09 <tdawson> Well, it's not a show stopper, but it is one of our most popular cartridges.
19:07:10 <mdomsch> that package has been under review for a long time: https://bugzilla.redhat.com/show_bug.cgi?id=815018
19:07:14 <rustlebee> that would be very good to know
19:07:25 <rustlebee> tdawson: ah, ok.
19:07:41 <rbergeron> #info node.js is a popular request for openshift (but not a requirement, but....)
19:08:03 <mdomsch> https://bugzilla.redhat.com/show_bug.cgi?id=732552 before that...
19:08:19 <rbergeron> how screwed is it? i don't recall offhand - is it just bundled libs or is there licensing drama also
19:08:30 <rustlebee> mdomsch: and one before that too i think, heh
19:08:41 <tdawson> Mainly bundled libs as far as I know.
19:09:32 <rbergeron> rustlebee: how likely is it that it might not go to node.js upstream?
19:09:44 <rustlebee> well it may be something for the cloud SIG to help drive, if we're going to end up wanting it for multiple things
19:09:57 <rustlebee> rbergeron: i can answer that in a week probably.  still seems pretty likely right now.
19:10:16 <rbergeron> rustlebee: okay
19:10:19 <rustlebee> despite my attempt to flame, heh
19:10:35 <rustlebee> (not really)
19:10:54 <rbergeron> ;)
19:11:05 <rbergeron> anything else?
19:11:13 <rustlebee> i think that's it for OpenStack land
19:11:30 <mdomsch> yes
19:11:34 <mdomsch> at the risk of blasphemy
19:11:43 <rustlebee> for OpenStack land from me :)
19:11:51 <mdomsch> do we need to think about making permanent a separate repo for each OpenStack release
19:11:59 <mdomsch> rather than rawhide / EPEL ?
19:12:16 <mdomsch> I saw the request to keep Diablo alive after Essex was pushed
19:12:24 <mdomsch> repeat for future releases
19:12:26 <rustlebee> it may make snese for EPEL.  It seems to work out ok for Fedora.
19:12:37 <mdomsch> that was accomplished via a private repo
19:12:50 * mdomsch is more concerned with EPEL really
19:12:53 <rustlebee> I think pbrady has been maintaining some backport repos ... but it may be good to have something more official, i agree
19:13:04 <rustlebee> let's chat about that on the list
19:13:10 <mdomsch> k
19:13:12 <rustlebee> want to kick it off?
19:13:33 <mdomsch> k
19:14:12 <mdomsch> simple argument - the EPEL lifecycle and the OpenStack lifecycles don't really line up
19:14:55 <rustlebee> right
19:16:33 <rustlebee> maybe maintained as long a sit is maintained upstream
19:16:50 * rbergeron nods
19:16:52 <rustlebee> which is a year i believe
19:17:50 <rustlebee> curious what the people doing most of the package updates thing though :)
19:18:15 <rbergeron> ;)
19:18:50 <rbergeron> rustlebee: want to investigate that portion of the question? :)
19:19:11 <rustlebee> well i figured they would speak up once it him the cloud sign list
19:19:25 <rustlebee> sig*
19:19:58 <rbergeron> ah
19:19:59 <rbergeron> ;)
19:20:15 <rbergeron> okay
19:21:01 <rbergeron> #info questions about making permanent a separate repo for each openstack release (rather than rawhide/epel) ... mdomsch to kick off on list, russellb to chat as well
19:21:05 <rbergeron> alrighty! moving on
19:21:09 <rbergeron> #topic open...shift!
19:21:13 <rbergeron> tdawson: hallo
19:21:20 <tdawson> Hello Hello
19:21:42 <rbergeron> so I saw that you sent a big mail to the list about getting started, which is awesome
19:22:10 <tdawson> Yep.  We have several people chomping at the bit, and with F17 getting released, we figured we'd get started.
19:23:05 <rbergeron> #link OpenShift packaging getting started
19:23:09 <rbergeron> #undo
19:23:09 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x2fd8a7d0>
19:23:16 <rbergeron> #info OpenShift packaging getting started
19:23:20 <rbergeron> #link http://lists.fedoraproject.org/pipermail/cloud/2012-May/001486.html
19:23:24 <rbergeron> That's better. lol
19:23:46 <rbergeron> well, i suspect you'll probably have people helping out there. :)
19:23:51 <tdawson> I don't know much more to say.  Hopefully things go smoothly, but you never know until you start.
19:24:21 <rbergeron> I'll wait to harass you guys and the other various stackycloudopens about "so when can we make them work on top of each other" later :)
19:24:37 <rbergeron> tdawson: indeed.
19:25:00 <rbergeron> Okay. I'll move onward, to:
19:25:05 <rbergeron> #topic Open Floor
19:25:19 <rbergeron> jgreguske, mdomsch: i'm not sure if either of you have anything else you wanted to bring up
19:25:26 * rustlebee dances on the open floor
19:25:38 <jgreguske> rbergeron: not today; just lurking
19:25:41 <jsmith> Anybody interested in reviving the work on the Cloud Guide?
19:25:42 <rbergeron> is that the rustlebee hustle?
19:25:46 <rbergeron> or the rustlebee bustle
19:26:12 <rustlebee> one of those
19:26:17 * jsmith hears crickets
19:26:34 <rbergeron> jsmith: ask in a week when everyone's not frazzled :)
19:26:53 <jsmith> rbergeron: When are they *not* frazzled :-p
19:27:03 <maxamillion> crap ... missed it
19:27:08 <maxamillion> o/
19:27:11 <rbergeron> jsmith: when they're not frazzled and mentally on vacation? :)
19:27:16 <rbergeron> maxamillion: howdysir
19:27:21 <maxamillion> rbergeron: hi! :D
19:27:33 <rbergeron> mdomsch: are you going to linuxcon NA?
19:27:34 <mdomsch> mail sent on EPEL/OpenStack
19:27:51 <mdomsch> I might be going to linuxcon NA.  That week sucks personally
19:27:55 <rbergeron> ah
19:27:56 <rustlebee> woah woah woah, slow down multitask master
19:27:58 <mdomsch> but I should be there
19:28:11 <mdomsch> re: S3 mirror
19:28:16 <rbergeron> ah! yes, go ahead
19:28:25 <rbergeron> #topic S3 mirror
19:28:27 <mdomsch> I started having S3 copy from us-east-1 to us-west-1 to start a new mirror there
19:28:41 <mdomsch> 5+ days later, it's still copying
19:28:48 <rbergeron> nice
19:28:48 <mdomsch> the tree is 300GB
19:28:55 <rbergeron> we're sure that's free,right
19:28:57 <rbergeron> ;)
19:28:57 <mdomsch> which yields about $11 in bandwidth charges
19:28:59 <rbergeron> oh
19:29:00 <rbergeron> okay.
19:29:39 <mdomsch> going forward, I'm going to have FI copy to each region directly
19:29:42 <mdomsch> I think that'll be faster
19:29:56 <rbergeron> yeah
19:30:07 <mdomsch> rather than phx2->us-east-1, then us-east-1 -> (other regions)
19:30:08 <rbergeron> oh, wait, let me rephrase that:
19:30:09 <rbergeron> yeah
19:30:18 <rbergeron> do you think that's faster?
19:30:27 <mdomsch> hard to believe it would be slower
19:30:28 <rbergeron> or do they just limit the bandwidth from region to region
19:30:32 <rbergeron> LOL
19:30:35 <rbergeron> no kidding
19:30:42 <mdomsch> <700KB/sec
19:31:07 <mdomsch> once I can prove we can manage 2 regions, I'll look at others
19:31:09 <rbergeron> at the speed of 2g phones!
19:31:10 <mdomsch> but no rush there
19:31:22 <rbergeron> cool :)
19:31:58 <mdomsch> new topic - CloudStack...
19:32:17 <rbergeron> #chair mdomsch
19:32:17 <zodbot> Current chairs: mdomsch rbergeron
19:32:21 <rbergeron> #topic Cloudstack
19:32:31 <rbergeron> sorry, i failed at that today.
19:32:59 <mdomsch> I haven't been following CS packaging in EPEL much lately, and my java chops are weak, but I'm interested again.
19:33:06 * rbergeron hails ke4qqq
19:33:14 <rbergeron> well, it's not even done being packaged in fedora.
19:33:23 <mdomsch> I think we'll have the same need wrt EPEL repo vs OpenStack repos, with CloudStack
19:34:07 <rbergeron> mdomsch: yep, though i don't think the CS folks have hashed out their plans, right?
19:34:09 <mdomsch> ke4qqq has made a really nice package installer for CS that uses only RHEL base DVD repos, plus carries its deps with it
19:34:15 * rbergeron has seen some discussion on list
19:34:38 <rbergeron> oh, interesting
19:35:01 <mdomsch> last I saw, there was only one package left CS needed to get pacakged
19:35:03 <rbergeron> #info will probably have hte same need wrt EPEL repo vs. openstack repos, with cloudstack.
19:35:05 <mdomsch> so I think it's close
19:35:41 <rbergeron> mdomsch: yeah, but i tihnk that was all stuff that was pre-ASF, does any of that matter?
19:35:43 <mdomsch> anyhow, I hope to have a CS instance I can hack on running in my lab pretty soon
19:36:04 <mdomsch> post-ASF just means there is an opportunity for more people to get involved more easily
19:36:11 <mdomsch> which I applaud
19:36:14 <rbergeron> mdomsch: ;)
19:36:41 <rbergeron> mdomsch: i just wasn't sure if there were licensing changes, etc. and i can't remember if they actually made that a new release that is post-what-is-currently-packaged
19:36:52 <rbergeron> mdomsch: basically, i'm senile
19:36:55 <mdomsch> CS 3.0.1 had the licensing change from GPLv3 to Apache 2.0
19:36:59 <mdomsch> in April
19:37:16 <mdomsch> CS 3.0.2 release a couple weeks ago was still done by the Citrix cloud.com team
19:37:26 <mdomsch> but they hope that'll be the last release they do outside the ASF framework
19:37:38 <mdomsch> and that all future releases are governed under ASF
19:37:39 * rbergeron nods
19:37:59 <rbergeron> i guess it would be up to you guys what it is that gets packaged anyway, since, well, i can't package unless it goes in a shipping box.
19:37:59 <mdomsch> ke4qqq is working this weekend on moving the git repos from github to Apache hosting
19:39:01 <mdomsch> re linuxcon, there's talk of having a CS meetup adjacent to linuxcon/cloudcon/Xen Conf
19:39:21 <mdomsch> so that week would be a good one to be in San Diego.  And it's a 3-day weekend in the US
19:39:24 <rbergeron> (i think there's a ovirt workshop and a gluster workshop as well)
19:39:30 <rbergeron> mdomsch: and, MY BIRTHDAY
19:39:45 <rbergeron> not that i matter, but, you know. good times. :)
19:40:08 * tdawson pulls the level that releases confetti "HAPPY BIRTHDAY!!"
19:40:12 <mdomsch> rbergeron: excellent.  And my wife's birthday, our anniversary, another kid's birthday, and the first week of school.  Kind of a bad week to be away.
19:40:39 <rbergeron> yes, my son's is sept. 1, daughter's is sep. 4. school starts a month earlier though.
19:40:42 <rbergeron> anyhoo.
19:40:46 * tdawson keeps pulling the lever for all the other anniversaries until there is no more confetti.
19:40:50 <rustlebee> my birthday is during RH summit, heh
19:40:50 <gholms> Heh
19:41:16 <rbergeron> rustlebee: we shall celebrate.
19:41:22 <rbergeron> rustlebee: :D
19:41:27 <rustlebee> \o/
19:41:34 <mdomsch> that's all for me
19:41:47 <rbergeron> mdomsch: okay. well, i guess re: cloudstack... i'm sure ke4qqq will have no objections to help.
19:42:05 <rbergeron> #info The whole universe will be at linuxcon
19:42:16 <rbergeron> #topic More Open Floor
19:42:20 <rbergeron> gholms: hi sir
19:42:23 <gholms> Hai!
19:42:23 <rbergeron> I saw you wander in.
19:42:26 <rbergeron> HAI!
19:42:30 <rbergeron> #chair gholms
19:42:30 <zodbot> Current chairs: gholms mdomsch rbergeron
19:43:16 <rbergeron> gholms: anything interesting going on in eucalyptoidland
19:43:23 <gholms> I am hard at work on making eucalyptus 3.1 usable/packageable/whatever.
19:43:40 <rbergeron> #info gholms hard at work on making euca 3.1 packageable and awesome
19:44:03 <rustlebee> i'd like to know more about the whatever
19:44:32 <gholms> rustlebee: Stable? :)
19:44:56 <gholms> Working on euca2ools where I can, ...
19:45:09 <rbergeron> rustlebee: consumable? :)
19:45:24 <gholms> But long story short, everyone in Eucalyptus is working on getting the code ready for release.
19:45:44 <gholms> It's time to lay Eucalyptus 2 to rest. ;)
19:45:44 <rbergeron> except gregdek, who is probably playing on farmville right now
19:45:56 * rbergeron loves to troll gregdek, till the end of time
19:46:21 <rbergeron> #info rbergeron will troll greg forever, spevack gave her special permission
19:46:27 <rbergeron> is it friday?
19:46:28 <gholms> WHAT?
19:46:29 <rbergeron> I think it's friday.
19:46:38 <gholms> rbergeron: How can I get that special permission?
19:46:58 <spot> /msg gholms you just need a copy of this picture, let me email it to you
19:46:59 <rbergeron> #action gholms to also troll gregdek, forever
19:47:01 <spot> err... uhhh
19:47:03 <spot> nm
19:47:12 <gholms> spot: :)
19:47:36 * rbergeron waves at spot
19:47:45 <rbergeron> okay, anyone else?
19:47:49 <tdawson> One quick thing.  I won't be here next week.  maxamillion has graciously volunteered to be harassed ... er ... give the OpenShift report.
19:48:00 <rbergeron> tdawson: okay :)
19:48:22 <gregdek> rbergeron: was sleeping off a redeye. :)
19:48:43 <rbergeron> gregdek: better than sleeping off a black eye, i suppose
19:48:53 <rbergeron> :)
19:49:03 <gregdek> rbergeron: don't start none, won't be none.
19:49:19 <gregdek> Or should we start comparing closets?
19:49:30 <rbergeron> My closet is filled with shoes.
19:49:39 <gregdek> Uh huh. :)
19:49:44 <rbergeron> And halos.
19:49:54 <rbergeron> Lotsssssssssssssssssss of halos. Shiny. Pristine.
19:49:56 * gholms doesn't want to know what is in gregdek's closet
19:49:58 <jgreguske> #info rbergeron's closet is filled with shoes
19:50:05 <gregdek> LOL
19:50:11 <gregdek> Yeah, that's not new #info.
19:50:18 * gholms whacks rbergeron with the on-task stick
19:50:21 <jgreguske> I'm not a #chair anyway
19:50:23 <rbergeron> Oh, right.
19:50:30 <jgreguske> it's for the best, really
19:50:31 <rbergeron> I should look official.
19:50:35 <rbergeron> eerrr.
19:50:36 <rbergeron> Official.
19:50:36 <gregdek> gholms showing his board chops!
19:50:38 <gholms> jgreguske: You don't need to be a chair to use #info.
19:50:43 <rbergeron> It is friday.
19:50:44 <jgreguske> gholms: oh ok
19:50:48 <rbergeron> It is a three day weekend in the united states.
19:50:49 <jgreguske> well good
19:50:53 <gregdek> Does #info only pick up if it's at the front of a line?
19:50:58 <gholms> Right
19:51:12 <rbergeron> I hereby encourage you all to go forth and ... bear halos.
19:51:19 <rbergeron> Or something.
19:51:24 * jgreguske prefers horns
19:51:29 * gholms looks for a picture with a bear with a halo
19:51:37 <rbergeron> jgreguske: me too.
19:51:40 <rustlebee> how about bare halos
19:51:48 <jgreguske> rbergeron: \m/
19:52:36 <rbergeron> http://images.clipartof.com/small/39800-Clipart-Illustration-Of-An-Angelic-Panda-Bear-With-Golden-Wings-And-A-Halo.jpg
19:52:48 <rbergeron> Oh, that's a panda, not a bear.
19:53:15 <rbergeron> Well, anyway.
19:53:19 <gholms> http://www.tomscoin.com/images/ty_beanie/halo_bear.gif
19:53:22 <rbergeron> Have a good weekend, y'all.
19:53:30 <rbergeron> there you go. gholms wins!
19:53:33 <gholms> \o/
19:53:40 * rbergeron hands gholms a bottle of mustard
19:53:42 <rbergeron> #endmeeting