15:05:30 <jreznik> #startmeeting kde-sig -- https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2012-06-05
15:05:30 <zodbot> Meeting started Tue Jun  5 15:05:30 2012 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:05:35 <jreznik> #meetingname kde-sig
15:05:35 <zodbot> The meeting name has been set to 'kde-sig'
15:05:42 <jreznik> #topic roll call
15:05:46 <jreznik> get ready!
15:05:50 * rnovacek is here
15:05:59 * jreznik knows rnovacek is ready
15:06:35 * ltinkl is here
15:06:52 <rdieter> hi
15:07:01 * than is present
15:07:41 <jreznik> #chair ltinkl rnovacek rdieter than
15:07:41 <zodbot> Current chairs: jreznik ltinkl rdieter rnovacek than
15:07:57 <jreznik> #info jreznik, rnovacek, ltinkl, rdieter and than present
15:08:03 <jreznik> #topic agenda
15:08:51 <jreznik> 4.8.80 and 4.8.4
15:08:55 <jreznik> anything else?
15:09:33 <jreznik> #chair Kevin_Kofler
15:09:33 <zodbot> Current chairs: Kevin_Kofler jreznik ltinkl rdieter rnovacek than
15:09:41 <jreznik> #info Kevin_Kofler present too
15:09:43 <jreznik> hi ;)
15:10:13 <jreznik> ok, let's start
15:10:27 <jreznik> #topic kde-4.8.80 status
15:10:54 <jreznik> current status - it's mostly build, still missing a few bits...
15:11:07 * jreznik is currently fixing kdegames, kstars fails to build
15:11:25 <jreznik> otherwise we have a few more splits (kdemultimedia)
15:11:35 <jreznik> and new package (pairs, under review)
15:11:53 <jreznik> you know the problems that caused delays...
15:13:22 <Kevin_Kofler> We may want to build things in a dedicated tag next time.
15:13:32 <Kevin_Kofler> Right now we're stuffing partially done stuff into Rawhide, which isn't that great.
15:13:42 <Kevin_Kofler> Plus, upstream got angry because the stuff went out too early. :-/
15:13:44 <jreznik> Kevin_Kofler: yep, that was my next thing to ask for...
15:14:05 <Kevin_Kofler> I think upstream is making a problem out of nothing, but…
15:14:12 <jreznik> and I agree - especially 4.8.80 was a big mess
15:14:38 <rdieter> wrt upstream, building on/for development branches has always been ok and acceptable practice
15:14:44 <jreznik> Kevin_Kofler: it's nonse to hide something hidden and for privileged people while it's being open source
15:15:04 <rdieter> but rawhide being broken for awhile isn't nice
15:15:10 <Kevin_Kofler> rdieter: Tell that to aacid.
15:15:17 <jreznik> rdieter: especially building development snapshot for development version... even some people consider rawhide usable as main os :)
15:15:21 <Kevin_Kofler> (and mgraesslin)
15:15:35 <rdieter> they may have not been aware the users in question were using rawhide
15:16:17 <jreznik> for f18 tag, I'm +1 to avoid mess in rawhide (looks like someone really runs it and uses... scary :D)
15:17:01 <jreznik> rdieter, ltinkl, than: what do you think?
15:17:05 <ltinkl> +1
15:17:21 <ltinkl> and next time make sure we have the complete set of tarballs before starting :)
15:17:34 <jreznik> #action ltinkl to take a look on kstars build failure http://koji.fedoraproject.org/koji/buildinfo?buildID=321755
15:17:39 <than> jreznik: i full agree here
15:17:39 <rdieter> +1 (to both jreznik, ltinkl )
15:17:40 <jreznik> ltinkl: I had it
15:17:47 <jreznik> (them)
15:17:49 <than> ltinkl: +1
15:17:51 <rnovacek> +1, seems reasonable
15:18:31 <rdieter> where it makes sense anyway, using a dedicated rawhide target for all releases is probably overboard
15:18:38 <jreznik> rdieter: yep
15:18:53 <jreznik> we are able to build minor release in a day now
15:18:54 <ltinkl> ye, people expect it to be broken :)
15:19:19 <jreznik> (but even minor releases could cause a harm but less than major one)
15:20:10 <jreznik> so I'm ok with a dedicated tag for bigger builds as another major release (or even more precisely - where we can expect big jump)
15:20:24 <rdieter> jreznik: indeed
15:20:26 <rnovacek> yes, first beta releases are usually broken, takes time to fix splitting and new packages. So separated target makes sense
15:20:30 <jreznik> on the other hand as Kevin_Kofler pointed out, we can silence upstream
15:20:43 <Kevin_Kofler> jreznik, ltinkl: The KStars problem seems to be a name conflict between a macro and an identifier used in indielement.h.
15:20:43 <jreznik> by building it not directly in rawhide...
15:20:54 <Kevin_Kofler> Some other header is #defining it as a macro, causing syntax errors.
15:20:58 <Kevin_Kofler> Probably needs an #undef somewhere.
15:21:24 <ltinkl> or a different var name
15:21:27 <jreznik> Kevin_Kofler: in indi lib probably, added a new header file... just quick look I observed the same
15:21:58 <Kevin_Kofler> I don't think libindi is defining macros which break its own headers. ;-)
15:22:02 <jreznik> rdieter: so, Kevin_Kofler is right we can make upstream partially happy by doing all builds in dedicated tag...
15:22:33 <rdieter> meh, upstream is ok with development builds, always has been anyway
15:22:53 <rdieter> 5555ttttttttt'
15:22:58 * rdieter curses cat
15:23:34 <rdieter> our users reporting bugs upstream probably need to be a litte more clear on that
15:23:35 <jreznik> rdieter: seems like they are not anymore... it was always unofficial and it depends on who does the builds...
15:23:58 <jreznik> rdieter: seems like there's proposed solution for this...
15:24:00 <rdieter> there's by no means any consenses on whether upstream is not ok with it. (afaict)
15:24:39 <jreznik> so let's agree we'd like to have a dedicated tag for big updates
15:24:48 <jreznik> and ask upstream for clarification
15:25:02 <jreznik> and if they say no, we can do all updates in dedicated tag
15:25:06 <rdieter> just a concern was raised, and discussion going on, let's see how the proposed solutions get feedback
15:25:13 <rdieter> ok
15:25:57 <jreznik> #info the kde-4.8.80 builds are mostly done, missing a few packages (kdegames, kstars) + on going package splits (kdemultimedia)
15:26:18 <jreznik> #agreed to build bigger updates in dedicated rawhide tag
15:27:00 <jreznik> #info for minor updates we need clarification from upstream, if they are ok with builds going directly to rawhide
15:27:23 <jreznik> any volunteer to help with more packaging/reviewing is welcomed
15:27:57 <jreznik> libkcompactdisc bundled wmlib but as upstream works there... should I ask FPC for exception or consider it more as part of sources
15:33:01 <rdieter> jreznik: hard to say, I can't seem to find any 'wmlib' upstream, can you?
15:33:39 <jreznik> rdieter: there's no
15:33:46 <rdieter> and the code in kdemm has no build sys or build scripts of it's own
15:33:54 <jreznik> and upstream maintainer is working in kde git
15:34:09 <rdieter> if there's no external upstream, one can easily argue then that it is not bundled. :)
15:34:16 <jreznik> so for me it's more part of code than bundled lib
15:34:22 <rdieter> agreed
15:34:34 <jreznik> rdieter: but I ask FPC just for stamp... makes sense
15:34:34 <rdieter> I wouldn't worry about it
15:34:44 <Kevin_Kofler> It doesn't really look like a bundled lib anymore.
15:35:17 <jreznik> ok
15:35:40 <Kevin_Kofler> Hmmm, the original upstream lib was called libworkman.
15:35:44 <Kevin_Kofler> (according to wmlib/README)
15:35:46 <jreznik> it's integral part of source code... no other releases, no other sw uses it and upstream guy works there
15:35:58 <jreznik> Kevin_Kofler: and there was workman cd player
15:36:02 <jreznik> seems dead too
15:36:19 <ltinkl> kscd looks dead to me as well, doesn't work at all
15:36:26 <Kevin_Kofler> But searching for libworkman finds only old versions of kdemultimedia from before this got integrated into libkcompactdisc.
15:36:26 * ltinkl makes a sidenote
15:36:56 <jreznik> Kevin_Kofler: yep
15:37:27 <jreznik> and upstream works on both and only in kde repo...
15:37:44 <Kevin_Kofler> ltinkl: Kscd works for me in F15, but IMHO the old Kscd from before the student project rewrote it was a lot better. :-(
15:37:44 <jreznik> I can make a note in SPEC, that's actually not a library
15:39:07 <Kevin_Kofler> A student project rewrote it, focusing on fancy SVG skins (instead of standard Qt widgets, grrr…), using the deprecated old version of the MusicBrainz API instead of FreeDB for some reason and removing most of the features and configuration options.
15:39:09 <jreznik> ok, I'll go with note in SPEC, we already had it this way for years...
15:39:12 <Kevin_Kofler> The old version was a lot better!
15:39:30 <jreznik> time to rewrite to QML :)
15:39:34 <Kevin_Kofler> And the new version seems just as unmaintained now, the students must have moved on.
15:39:56 <jreznik> ok, let's move on
15:39:57 <Kevin_Kofler> I think it was a big mistake to merge that rewrite into the trunk.
15:40:07 <jreznik> #topic kde-4.8.4 status
15:41:08 <jreznik> #info than is working on importing stuff to f17
15:42:05 <jreznik> #info rdieter prepared f16-kde f17-kde build targets
15:42:12 <jreznik> anything else for 4.8.4
15:42:14 <jreznik> ?
15:42:17 <than> i'm still working on it, mostly is already imported
15:43:01 <jreznik> than: thx
15:44:34 <jreznik> anything else today?
15:46:25 * jreznik should leave soon as otherwise he will be punched by one colleague :)
15:46:45 <rdieter> one thing
15:46:57 <jreznik> rdieter: go on
15:47:32 <rdieter> nirik let me know that svahl's fas email doesn't match his bugzilla one
15:47:49 <rdieter> and attempts to contact svahl have failed.
15:48:22 * nirik nods.
15:48:29 <Kevin_Kofler> Unfortunately, it's been ages since I last heard from svahl.
15:48:37 <rdieter> so, anyone know how to get in touch with him?  else, we'll likely have to (at least temporarily) remove ownership of his packages
15:49:52 <than> rdieter: have you tried fedora@deadbabylon.de?
15:50:19 * nirik tried that.
15:50:26 <nirik> also deadbabylon@googlemail.com
15:50:35 <rdieter> I'd propose nirik go ahead with the owner re-assignment asap.  we can pick up ownership of stuff as appropriate by the kde-sig
15:50:37 <nirik> no answer in about 2 weeks. ;(
15:51:19 <nirik> there are a few packages where they are the only owner... might have to talk to fesco or follow the unresponsive maintainer process to orphan those.
15:51:34 <Kevin_Kofler> svahl was also our live kickstart maintainer, I've been de-facto maintaining it lately (and rdieter also did some commits in it).
15:52:51 <jreznik> looks like he's really out...
15:53:27 <nirik> anyhow, on those packages that other kde sig folks have acls, I can just reassign if you like.
15:53:39 <rdieter> nirik: ok, please do
15:53:53 <nirik> here's a list of all their ownership/ccs: http://fpaste.org/Fbu5/
15:54:53 <rdieter> ok, for the ones that he's sole owner, imo, those can probably just go orphan
15:54:54 <than> nirik: please reassign the packages
15:55:17 <rdieter> and someone can pick them up if interested
15:55:35 <nirik> ok, who should be owner?
15:56:06 <than> nirik: polyester3 should be orphaned
15:57:10 <rdieter> any volunteer to take ownership of these?  (else, I can)
15:57:28 <than> nirik: you can reassign it to me
15:57:33 <Kevin_Kofler> Well, it's still useful in principle for qt3/kdelibs3 apps. Maybe whoever signs up for polyester may also want polyester3.
15:57:57 <nirik> than: ok.
15:58:09 <Kevin_Kofler> But I guess it can go through the normal process, i.e. orphan now, retire if not picked up by the next orphan cleanup.
15:58:26 <nirik> yeah.
15:58:36 <than> nirik: skanlite should be orphaned too
15:58:44 <Kevin_Kofler> than: Why?
15:58:48 <ltinkl> than: why?
15:59:00 <ltinkl> I use it quite regularly...
15:59:02 <Kevin_Kofler> It has a primary maintainer, slankes (killefiz), who's not AWOL.
15:59:21 <Kevin_Kofler> And it's maintained upstream and working.
15:59:29 <than> ltinkl: do you want to own this package?
15:59:41 <ltinkl> than: it has a maintainer
16:00:13 <than> ah slankes
16:00:15 <than> sorry
16:00:52 * rdieter has hard-stop top of hr, bye (will be back in ~1 hr)
16:01:36 <nirik> anyhow, thanks, I will reassign the ones that kde sig has acls for, and discuss the rest with fesco, and probibly just orphan them to get picked up
16:02:12 <Kevin_Kofler> nirik: +1, makes sense.
16:02:17 <than> nirik: it's fine , thanks
16:02:43 <jreznik> ok thanks
16:03:02 * jreznik is going to end the meeting, we're two minutes over :)
16:03:08 <jreznik> #endmeeting