05:03:40 <tagoh_> #startmeeting i18n
05:03:40 <zodbot> Meeting started Thu Jul 19 05:03:40 2012 UTC.  The chair is tagoh_. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:03:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
05:03:45 <tagoh_> #meetingname i18n
05:03:45 <zodbot> The meeting name has been set to 'i18n'
05:03:53 <tagoh_> #topic agenda and roll call
05:04:04 <tagoh_> https://fedoraproject.org/wiki/I18N/Meetings/2012-07-19
05:04:26 <tagoh_> hmm, didn't realized I was offline. anyway, time to have i18n meeting now
05:04:33 <paragan> hi
05:04:38 <epico> hi
05:05:27 <fujiwarat> hi
05:06:17 <tagoh_> feel free to add any topics you have in mind and good to update your feature pages if any. so we can talk about it efficiently :)
05:08:06 <tagoh_> okay, let's get started.
05:08:10 <tagoh_> #topic F18
05:08:34 <tagoh_> so catch up features one-by-one
05:08:47 <juhp> hi
05:08:59 <tagoh_> https://fedoraproject.org/wiki/Features/Typing-Booster
05:09:18 <dingyichen> hi
05:09:43 <tagoh_> anish_: I don't see any updates. guess there should be some progress on it. how is it going on?
05:11:03 <tagoh_> anish_: and just to clarify, are you planning to make it default engine for Indic?
05:11:49 <tagoh_> it's capable to work on other languages too though, how about for them?
05:12:14 <anish_> tagoh_, i have submitted review request for ibus-typing-booster
05:12:26 <tagoh_> I see ibus-m17n is still default engine for Indic in comps
05:12:42 <anish_> i am not making it default for indic languages
05:12:44 <tagoh_> anish_: yep, it has been accepted now :)
05:12:57 <tagoh_> anish_: aha
05:13:15 <anish_> tagoh_, thanks :) its been accepted
05:13:51 <anish_> it works for other languages as well
05:13:59 <tagoh_> anish_: okay, so what's current status? still 50% complete?
05:14:21 <anish_> yeah first i need to import it for f18
05:14:21 <tagoh_> and what tasks do you need to do?
05:14:40 <anish_> then i need to give setup UI
05:15:03 <tagoh_> okay, how's the review status then?
05:15:09 <tagoh_> bug#?
05:15:20 <anish_> paragan, is reviewing it
05:17:25 <tagoh_> anish_: okay, well, please keep up-to-date on feature page.
05:17:36 <anish_> sure thanks
05:17:51 <tagoh_> https://fedoraproject.org/wiki/Features/ibus-libpinyin
05:18:09 <tagoh_> epico: how is it going on?
05:18:19 <epico> ibus-libpinyin feature is accepted in F18.
05:18:50 <epico> lua script support is enhanced.
05:19:16 <tagoh_> is it possible to implement all of the features by alpha?
05:19:39 <tagoh_> it may be reasonable milestone to make it default.
05:19:54 <epico> yes, if skip optional stroke editor.
05:20:02 <tagoh_> okay
05:20:26 <tagoh_> fwiw alpha change deadline is August 14 in current schedule
05:22:19 <tagoh_> epico: btw is that "stroke editor" totally new feature and not available in older releases?
05:22:33 <tagoh_> I mean in ibus-pinyin?
05:23:00 <epico> not in ibus-pinyin.
05:23:05 <tagoh_> okay, good
05:23:46 <tagoh_> epico: thanks. keep the feature page up-to-date please :)
05:23:57 <tagoh_> https://fedoraproject.org/wiki/Features/Fontconfig2.10
05:24:34 <tagoh_> 2.10 is available in rawhide. still need to update google-draid-fonts for warning. otherwise almost work should be done.
05:24:37 <paragan> nice to see new fontconfig in rawhide :)
05:24:50 <tagoh_> paragan: thanks :)
05:24:51 <epico> tagoh_, welcome
05:25:00 <tagoh_> https://fedoraproject.org/wiki/Features/FontconfigEnableAutohinting
05:25:35 <tagoh_> just updated the page and finally decided to submit... will enable the autohinting once it's accepted.
05:25:54 <tagoh_> https://fedoraproject.org/wiki/Features/GNOMEIBusIntegration
05:26:03 <tagoh_> fujiwarat: how is it going on?
05:26:15 <juhp> he is editting the page a bit
05:26:21 <juhp> erm
05:26:23 <tagoh_> I see mclasen has updated a bit.
05:26:26 * juhp is editting the page a bit
05:26:32 <juhp> yes
05:26:35 <tagoh_> juhp: thanks
05:28:08 <fujiwarat> Currently upstream integrated some ibus patches. I checked gnome-settings-daemon in f18 does not have the feature of ibus yet.
05:28:40 <tagoh_> you mean g-s-d in GNOME 3.5.4 doesn't have that feature?
05:29:14 <fujiwarat> right
05:29:17 <tagoh_> aha
05:29:59 <tagoh_> so can you update again, what patches is merged into 3.5.4 and what patches is not?
05:31:04 <tagoh_> I was about to bring this topic up later though, I'm concerned about test days schedule on this feature.
05:31:15 <juhp> oh
05:32:04 <fujiwarat> I don't think it has much meanings to mention about the current fedora. I'll update the document regarding to the current upstream.
05:32:31 <juhp> fujiwarat, so some of the patches didn't make 3.5.4?
05:33:00 <fujiwarat> the feature of enabling ibus.
05:35:45 <fujiwarat> Actually ibus had to be updated to enable the ibus features in gnome.
05:35:58 <fujiwarat> I updated ibus yesterday.
05:36:10 <tagoh_> aha
05:36:46 <tagoh_> so.. what is the percentage of completion right now?
05:37:39 <fujiwarat> Maybe 50%. I think it's very good that the fist ibus patches are integrated in GNOME upstream.
05:38:55 <tagoh_> then can you elaborate what's the remaining 50% works that you may need to do in this feature?
05:39:49 <fujiwarat> yes, I will update the page later. I worked for other tasks in this week.
05:40:08 <tagoh_> okay
05:40:33 <tagoh_> https://fedoraproject.org/wiki/Features/Liberation_Fonts_2
05:40:42 <paragan> I think F18 mass-rebuild is still going on
05:41:10 <tagoh_> hmm, no pravins here?
05:41:24 <paragan> I see that pravins has submitted new package liberation-narrow-fonts
05:41:25 <tagoh_> paragan: right
05:41:31 <tagoh_> yeah
05:41:33 <paragan> I will review it soon
05:41:38 <tagoh_> cool
05:41:52 <tagoh_> okay
05:41:57 <tagoh_> https://fedoraproject.org/wiki/QA/Fedora_18_test_days
05:42:13 <tagoh_> as you may know the announce has been sent for test days
05:42:34 <tagoh_> it may be a good idea to have at least 2 slots for IM and fonts/rendering perhaps
05:42:53 <tagoh_> since we have a lot of features related to this, it may be hard to be done in 1 day
05:42:53 <juhp> what is the normal expection on % at Feature Freeze (alpha)?
05:43:03 <juhp> right
05:43:56 <tagoh_> juhp: I suppose no explicit expectation there.
05:44:32 <tagoh_> we just have to complete all of feature by beta change deadline
05:45:13 <tagoh_> though it would be good to have early testing. it gives us opportunities to improve it and get more feedback on alpha and beta
05:45:29 <juhp> okay
05:45:47 <juhp> fujiwarat, btw how about ibus-xkb?
05:46:17 <juhp> I guess it is not outside gnome of the GnomeIbusIntegration though
05:46:22 <fujiwarat> juhp: I think ibus-xkb has no update in fedora package review.
05:46:25 <juhp> gnome=scope
05:46:31 <juhp> fujiwarat, ah
05:46:51 <juhp> tagoh_, sorry so how about the i18n test days?
05:47:01 <fujiwarat> agreed
05:47:16 <tagoh_> after alpha, currently there are free slot at August 30 and September 6.
05:47:59 <juhp> my only worry is that there is a good chance that alpha will slip at least a week
05:48:23 <fujiwarat> I'm not sure if desktop team still try to update GNOME modules for alpha.
05:48:42 <juhp> perhaps we should ask Fedora QA about testing before/around alpha?
05:48:58 <juhp> hm
05:49:07 <tagoh_> fujiwarat: what's current milestone for merging other patches? when is comfortable for testing?
05:49:12 <tagoh_> juhp: perhaps
05:49:59 <juhp> fujiwarat, does ibus-xkb need a refresh? (no change since end of May)
05:50:13 <juhp> packaging I mean
05:50:14 <fujiwarat> I think the ibus features are available in beta at least since the basic features are upstreamed.
05:50:49 <juhp> testing after beta is quite late though for changing/fixing
05:50:57 <tagoh_> I suppose testing for fonts/rendering may be anytime okay if it's prior to the final change deadline
05:51:19 <juhp> maybe we could do the fonts testing before input?
05:51:21 <fujiwarat> juhp: Maybe yes
05:52:15 <aalam> juhp: tagoh_: can font/rendering testing can be include with translation test day? (1st week for Sep)?
05:52:35 <tagoh_> aalam: sure. no problem.
05:53:09 <juhp> hmm
05:53:18 <aalam> planing for 2012-09-04/2012-09-06
05:53:40 <tagoh_> aha
05:54:05 <juhp> so then no "fontconfig testday" required?
05:54:24 <tagoh_> juhp: you mean for auto-hinting right?
05:54:34 <juhp> yeah for example
05:55:22 <juhp> I guess there is also Liberation fonts, etc
05:55:38 <juhp> anyway it is an interesting idea
05:56:00 <tagoh_> well, I think people may pays more attention on checking fonts/rendering by checking translations.
05:56:13 <juhp> obvious l10n testing will also need working fonts/rendering etc and could cover some of it surely
05:56:20 <juhp> true
05:56:31 <juhp> okay
05:56:47 <tagoh_> we could add some column for fonts/rendering testing this time.
05:56:50 <juhp> but some people might be interested in the fonts testing but not l10n
05:56:56 <juhp> cool
05:57:45 <aalam> juhp: we can have two different test days, but in same week,
05:58:37 <juhp> yeah at least we need a separate day for input
05:58:54 <tagoh_> juhp: maybe checking strictly may be hard. rough feedback of feeling may be sufficient perhaps
05:59:04 <juhp> sure
06:00:01 <juhp> hard to measure probably without some tool I guess
06:00:38 <tagoh_> right. and it maybe kind of preference
06:00:45 <juhp> yes
06:01:34 <tagoh_> aalam: okay, so I'm willing to help for creating testcase etc. ping me if any.
06:01:56 <tagoh_> so how about for input? guess continue to discuss in next meeting?
06:02:02 <aalam> sure, we need
06:03:07 <juhp> seems we have to provide 1st and 2nd choice of date
06:03:22 <fujiwarat> ok, I will inform mclasen of the old gnome-settings-daemon. Maybe he would need the latest ibus patch which was upstreamed today.
06:03:28 <juhp> conversely also worried about all the "good slots" getting taken
06:03:47 <tagoh_> #agreed have a test day for fonts/rendering with l10n
06:04:14 <tagoh_> fujiwarat: aha
06:05:24 <juhp> aalam, so you're planning for 2 days already?
06:05:39 <juhp> or is that an "or"?
06:05:41 <aalam> yes, but within 1 week
06:05:42 <tagoh_> juhp: yeah, I guess we could request non-planned date to QA... anyway, good to decide early before we miss the day.
06:05:50 <juhp> "2012-09-04/2012-09-06"
06:05:58 <juhp> right
06:06:25 <juhp> aalam, so just to be clear - 2 days for translation testing?
06:06:45 <aalam> Desktop i18n  (generic, but can be small features added, which need to be a special Test day)
06:07:37 <aalam> s/need to be/need not to be/
06:07:55 <tagoh_> ah, as we have had in the past?
06:07:58 <aalam> juhp:  sorry, but 1 for i18n and other it l10n (like for Fedora 17)
06:08:00 <aalam> yes
06:08:34 <juhp> aalam, we have big changes for ibus under gnome and also new IMEs so we definitely need a day for that I think though we could reuse/recycle some previous testcases probably
06:09:11 <tagoh_> juhp: but many of them has to be updated I believe
06:09:13 <juhp> okay anyway we should coordinate on Desktop i18n test day
06:09:19 <juhp> probably yeah
06:09:31 <aalam> yes, Major i18n feature like ibus with gnome, we can cover with specific ibus Test day
06:09:39 <juhp> okay
06:09:48 <juhp> so you want to do a generic i18n day too?
06:10:10 <tagoh_> guess it's the effort of SIG?
06:10:32 <aalam> yes, where people can test font, desktop apps, rendering, printing
06:10:46 <aalam> tagoh_: yes
06:10:48 <juhp> ok
06:10:52 <tagoh_> okay
06:11:04 <tagoh_> guess we may need to discuss about it more later.
06:11:07 <juhp> SIG here means?
06:11:12 <juhp> okay
06:11:55 <tagoh_> FLTG, Fedora Language Testing Group
06:12:02 <juhp> ah right
06:12:12 <juhp> cool
06:12:35 <tagoh_> okay, anything more on f18?
06:13:00 <tagoh_> guess better postpone other topics to next meeting.
06:13:00 <juhp> so FLTG covers both general i18n and l10n testing? :)
06:13:41 <tagoh_> juhp: I think so
06:13:45 <juhp> nice
06:14:19 <tagoh_> #topic Open Floor
06:14:28 <tagoh_> any more topics to discuss prior to close this meeting?
06:14:37 <juhp> okay then guess we just need to fix the GnomeIBus testday as you say - hopefully by next week...
06:14:47 <tagoh_> yep
06:15:29 <tagoh_> need to make sure when all of the features is available in Fedora
06:16:47 <tagoh_> fujiwarat: can you confirm again, in upstream schedule and in fedora? including any possibility to backport patches first in Fedora?
06:17:53 <tagoh_> early testing may be required because this would be a big change for us.
06:18:14 <fujiwarat> tagoh_: I will inform mclasen of the old g-s-d in f18.
06:18:25 <tagoh_> okay, cool
06:19:45 <tagoh_> if no particular, close the meeting shortly
06:21:15 <tagoh_> okay, thanks everyone for the meeting!
06:21:18 <tagoh_> #endmeeting