15:00:24 <adamw> #startmeeting fedora-qa
15:00:24 <zodbot> Meeting started Mon Jul 30 15:00:24 2012 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:31 <adamw> #meetingname fedora-qa
15:00:31 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:47 <adamw> #topic roll call
15:00:58 * mkrizek is here
15:01:01 <adamw> who's around for the meetin?
15:01:23 * pschindl is here
15:01:26 * jskladan is here
15:01:27 * akshayvyas is here
15:01:32 * spoore is here
15:01:33 * nirik is lurking
15:01:56 * tflink is here
15:02:09 * satellit listening
15:02:56 * kparal rises from the grave
15:03:12 * adamw shoots zombie kparal
15:03:14 <adamw> .fire kparal
15:03:15 <zodbot> adamw fires kparal
15:03:29 * garretraziel is here
15:03:56 * kparal sews up the wound
15:04:01 <adamw> alrighty, thanks for coming folks
15:04:03 <adamw> hi dlehman
15:04:07 <jskladan> ^^ our new intern (garretraziel)
15:04:14 <adamw> i didn't know zombies could sew
15:04:20 <adamw> ahhhh, fresh intern meat!
15:04:24 <garretraziel> Hi all!
15:04:30 <tflink> he's an advanced type of zombie, I guess
15:04:39 * tflink is glad to be half a world away at the moment :)
15:04:51 <adamw> distance is no protection against a czech zombie
15:05:20 <tflink> sounds like it's time to start serious anti-zombie training, then
15:05:22 <kparal> zombie self-healing mechanisms - a needle and a thread
15:05:45 <adamw> #topic Fedora 18 preparation / newUI status
15:05:56 <adamw> alright, so this is kind of a lazy f18 catch-all topic
15:06:45 <adamw> for anyone who isn't aware - http://rbergero.fedorapeople.org/schedules/f-18/f-18-quality-tasks.html is one week behind
15:06:54 <adamw> so add one week to all those dates when looking at it, until that gets fixed
15:07:34 <adamw> so right now, we should be getting RATS results
15:08:21 <tflink> adamw: the automated RATS won't work w/o serial, though
15:08:25 <adamw> twu was going to run the RATS runs, but he's been off work for a few days, so we'll try and catch up on those this week. however, the results aren't going to be terribly relevant until newui merges
15:08:32 <adamw> tflink: newui isn't merged yet, so not technically a problem
15:09:14 <tflink> is there a whole lot of point in running RATS against pre-newui?
15:09:25 <adamw> yeah, i'm not sure. it may point up repoclosure issues, i guess.
15:10:30 <adamw> we should start crankin' on TCs in a week or so.
15:10:51 * nirik really wishes he knew how lives were looking... both space and working wise.
15:11:15 <adamw> yeah, i'm thinking about that too. we could always throw together some test images with livecd-creator, just to see where things are.
15:12:08 <adamw> #action adamw to do some test runs of f18 live image composes to see what problems lurk
15:12:21 <adamw> any other thoughts on f18 prep? anyone worried about anything we're not covering?
15:12:25 <tflink> is livemedia-creator working ATM?
15:12:32 <nirik> not sure.
15:12:33 * tflink had heard that it wasn't really working yet
15:12:39 <nirik> it also needs some changes to ks files.
15:12:53 <dlehman> adamw: you might want to talk to bcl about that -- he's sent a patch set that makes lorax work with livemedia-creator
15:12:57 <tflink> are we still going forward with replacing livecd-creator with livemedia-creator?
15:13:09 <adamw> last i heard we were, but the lack of status info does seem worrying
15:13:21 <nirik> yeah, I think that was still the plan.
15:13:31 <nirik> dgilmore still needs to teach koji to use it too. ;(
15:13:41 <adamw> bcl: what's the story on livemedia-creator status? if you're around
15:15:02 <adamw> i guess he's not!
15:15:12 <adamw> still, the good news is livecd-creator is always around to use as a backup if necessary
15:15:45 <nirik> the live's in koji aren't working... not sure what change caused the breakage tho
15:15:55 <pjones> he was around just a minute ago
15:16:01 <dlehman> adamw: he made a live image using newui on friday and had it booting
15:16:04 <adamw> yeah, we saw that the error messages are rather unusual, iirc
15:17:02 <adamw> dlehman: ah, that's good news.
15:17:09 <bcl> adamw: I got lmc working friday, making a f17 live with newui.
15:17:19 <tflink> dlehman: do you know which tool he used to make it?
15:17:41 * tflink is a little slow
15:17:47 <adamw> bcl: does it look like we should be able to use it for alpha? nirik, is there anything else you'd need?
15:17:52 <adamw> tflink: left your mind on vacation, huh :)
15:18:13 <nirik> well, koji support would be nice, but thats on dgilmore I think.
15:18:18 <bcl> should be able to, other than the ususaly rawhide annoyances.
15:18:18 <tflink> adamw: you're assuming that my mind has ever _not_ been on vacation :-D
15:18:49 <adamw> =)
15:19:00 <adamw> #info bcl says livemedia-creator ought to be ready for usage for the alpha compose
15:19:02 <bcl> note that I used virt, I'm looking at novirt mode this week.
15:19:24 <adamw> we can use 'by hand' construction for alpha, i think, so that shouldn't be an issue
15:19:32 <adamw> afaik
15:20:23 * cpuobsessed woke up from his nap
15:20:32 * adamw blows fanfare
15:20:44 <adamw> alrighty, so, the big topic in this area: newui readiness
15:21:27 <adamw> unfortunately clumens isn't around, but i think dlehman can give us a general summary of stuff that won't / may not be working for f18, alpha and final?
15:22:18 <adamw> apparently text mode will make it in after all and may even make it for alpha, last i heard.
15:22:53 <bcl> probably so.
15:23:14 <bcl> kickstart is working pretty well. most of the recent work on newui is around custom partitioning.
15:23:42 <adamw> the other big ticket item i think was rescue mode
15:23:51 <bcl> rescue may not make it, we've talked about moving that to dracut which really can do most of the things you'd want from a rescue.
15:23:59 <adamw> we talked about that a bit and one conclusion is rescue mode doesn't actually do a whole lot besides mount system partitions for you
15:24:21 <bcl> right.
15:24:32 <bcl> mount stuff and give you a shell with useful tools.
15:25:00 <adamw> right, and dracut does the 'shell with useful tools' stuff
15:25:10 <bcl> we'll still be using firstboot, the user customization stuff won't make it into f18.
15:25:43 <adamw> wait, you mean the 'initial experience' feature?
15:26:22 <bcl> I don't know who is calling which what these days :) but we have plans for firstboot-like customization while installing packages.
15:26:44 <adamw> oh. i'm talking about https://fedoraproject.org/wiki/Features/InitialExperience , which may be something different
15:26:52 <bcl> totally different.
15:26:54 <adamw> a desktop team feature for a gnome-specific firstboot replacement, is what it looks like to me.
15:27:49 <adamw> okay. so we may not be using firstboot, but it won't be your fault =)
15:27:52 <pjones> yes, totally different.
15:28:11 <adamw> so are we aware of any other big ticket anaconda bits which aren't going to be in place?
15:28:24 <bcl> well, firstboot isn't gnome specific so I expect we'll still use it.
15:28:40 <adamw> right, for non-gnome desktops. anyhoo.
15:28:43 <bcl> I'm not sure about advanced storage.
15:29:16 <adamw> iSCSI / fibre channel etc?
15:30:19 <dlehman> my understanding is that will be iBFT only -- no interactive configuration of those devices
15:31:02 <adamw> that was mentioned on the feature page, so obviously fesco's okay with it
15:31:57 <adamw> so if we're really only missing rescue mode, i guess that's pretty good news
15:32:03 <adamw> how's the merge-to-rawhide schedule looking?
15:32:16 <bcl> wednesday.
15:32:31 <adamw> well that's nice and specific. awesome.
15:32:38 <adamw> anyone from qa side have concerns remaining about newUI?
15:35:18 * nirik likes the idea of moving rescue to dracut
15:35:58 <adamw> oh, with the new text mode, will serial console also be working?
15:37:27 <adamw> dlehman: ^^
15:37:48 <dlehman> I _think_ that's safe to assume
15:37:49 <bcl> should be
15:38:21 <dlehman> we're certainly doing the text mode work with full awareness of serial console and dumb terminal limitations
15:38:25 <adamw> cool.
15:38:38 <adamw> of course the ui will be different so we'll presumably have to adjust scripted things, but that shouldn't be a terrible problem
15:39:46 <adamw> #info newUI is scheduled to merge to master on wednesday, text mode support should make it in, possibly for alpha
15:40:05 <adamw> #info rescue mode will likely not make it, but dracut can be used as a replacement
15:40:22 <adamw> alrighty, any more f18 concerns before we move on?
15:42:39 <adamw> okey dokey, thanks anaconda folks
15:42:41 <adamw> #topic AutoQA update
15:42:48 <adamw> tflink: kparal: any zombie news?
15:43:01 <kparal> you tell me
15:43:13 <tflink> nothing from me
15:43:39 <adamw> you're all fired
15:43:58 <adamw> this here is a LIVING PEOPLE shop, we don't want your kind
15:44:22 <tflink> and here I thought that tolerance/acceptance was important to us :)
15:44:50 <adamw> oh, sure, all this modern 'politically correct' 'differently living' nonsense
15:44:56 <adamw> well i ain't having any of it!
15:45:27 <adamw> alright, then
15:45:44 <adamw> #info no major AutoQA news, autoQA team is fired for excessive zombies
15:45:49 <adamw> #topic open floor
15:45:53 <adamw> any other business, anyone?
15:47:06 <adamw> worries, concerns, questions about appropriate zombie disposal - we've got it all
15:49:34 <adamw> man, it's almost like you people aren't excited by bureaucratic processes AT ALL
15:50:19 * tflink has already been fired due to claims of being a zombie, not sure what you're expecting
15:50:35 <adamw> you could file a grievance
15:51:14 <tflink> that sounds like too much work - kind of like counting the number of times I've been fired
15:51:28 <adamw> and yet here you still are
15:52:09 <adamw> alrighty, well, if that's all, guess we can all get back to our pinterest kitten collections
15:52:11 <adamw> WORK. i meant work.
15:52:52 <adamw> thanks for coming, folks
15:53:00 <jskladan> *thumbs up* for kittens!
15:53:27 <adamw> #endmeeting