14:00:30 <bcotton> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
14:00:30 <zodbot> Meeting started Mon Aug  6 14:00:30 2012 UTC.  The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:37 <bcotton> #meetingname Fedora Docs
14:00:37 <zodbot> The meeting name has been set to 'fedora_docs'
14:00:43 <bcotton> #topic Roll Call
14:00:51 <lnovich> lnovich
14:01:30 * jjmcd 
14:01:32 * Sparks is here
14:03:11 * randomuser feebly raises a hand in greeting
14:05:11 <bcotton> #topic Follow up on last week's action items
14:05:44 <bcotton> mark one complete for Sparks (man page website on mailing list)
14:05:49 <claneys> hi
14:05:55 <Sparks> oh yeah
14:05:56 <bcotton> #action Sparks to add relevant git commands to QA procedures
14:06:05 <Sparks> darn
14:06:07 <bcotton> #action bcotton to send call for volunteers for QA Wrangler to mailing list
14:06:18 <bcotton> #action ianweller to ask the guys behind the packages app if man pages is a thing they can do
14:06:28 <bcotton> #topic Using koji to publish docs.fp.o
14:06:35 <bcotton> #link https://fedoraproject.org/wiki/Automating_publishing
14:07:09 <bcotton> so rudi sent a message to the list yesterday (this morning?). it appears we'll have some doc cleanup to do before we can make the switch to koji
14:07:29 <lnovich> Is this content wrangler position something I can accept now and decline later if I see I can't make the time commitment needed?
14:08:00 <bcotton> lnovich: yeah, we can discuss when that topic comes up
14:08:19 <lnovich> ok
14:08:30 <bcotton> anything else re: koji?
14:09:09 <Sparks> Just ready for it to become a reality
14:09:20 <claneys> What is the cleanup thing to do in doc ?
14:11:14 <bcotton> claneys: there are some revision histories that don't meet spec and a few other formatting errors that publican 2 handles. publican 3 is a little more strict
14:11:34 <lnovich> is publican 3 out yet?
14:11:36 <Sparks> Do we just need to run Publican 3 and find the errors?
14:12:15 <bcotton> it sounds like rudi had tested at least a few docs. i'll see if he has a list started, but otherwise yeah
14:12:40 <claneys> bcotton: Ok, I don't have or found mail that you mention earlier. Is there a wiki page with some instructions or whatever to do ?
14:13:32 <bcotton> #link http://lists.fedoraproject.org/pipermail/docs/2012-August/014488.html
14:13:36 <bcotton> claneys: ^^
14:14:03 <bcotton> there's no wiki page yet. we'll have to see if the errors publican 3 gives are obvious enough or not
14:14:47 <claneys> bcotton: ok thanks
14:15:03 <bcotton> Sparks: refresh my memory. are we still waiting for others to throw switches for us, or is the ball back in our court?
14:15:22 <Sparks> bcotton: I *believe* we are waiting for releng
14:15:44 <lnovich> i think that is about right
14:16:52 <bcotton> Sparks: do we need to push again or should we be patient?
14:17:25 <Sparks> I think we should ask the question.  I don't know what it takes.  Do we remember the ticket number we submitted?
14:19:42 <Sparks> bcotton: I can try to find it and follow up on it today
14:19:51 <bcotton> Sparks: okay great
14:20:09 <bcotton> #action Sparks to follow up with releng on the progress of koji
14:20:36 <lnovich> sparks if there is something that you need to ask Rudi let me know
14:20:47 <lnovich> I have a meeting w/him tomorrow
14:21:25 <Sparks> lnovich: I usually 'see' him in the evenings
14:22:03 <Sparks> lnovich: But it would be good if you could poke him about it and see what's going on.
14:22:23 <lnovich> sure - just tell me what you want me to ask and I'll add it to the agenda
14:23:25 <Sparks> lnovich: Ask him why he doesn't have everything setup for us yet.  :)
14:23:53 <bcotton> anything else on this topic?
14:24:29 <Sparks> not from me
14:24:42 <bcotton> #topic Publish man pages
14:24:50 <bcotton> #info BZ 828669
14:25:00 <bcotton> Sparks, what's the general sense from the mailing list thread?
14:25:10 <lnovich> ok sparks
14:25:39 <Sparks> As far as I can tell, some people want nothing to do with it while others think it's a good idea IF it can be easily scripted and fast.
14:25:44 * randomuser has looked at the package app code
14:26:14 <randomuser> it it's doable, but probably requires a more compentent perl hacker than I
14:26:14 <Sparks> There *may* be a way to do it using the package app thingy.
14:27:25 <bcotton> i wonder if this is something we should table until the koji project is done. it seems like that will require some significant effort above our normal release cycle
14:28:10 <randomuser> there's enough information in the mailing list thread for someone to pick up the actual work; i don't see a reason to maintain a talking point in the meeting for it
14:28:17 <Sparks> IMO, it definitely has a lower priority
14:29:17 <bcotton> randomuser: i agree
14:29:30 <bcotton> any objections to leaving this out of meetings for a while?
14:29:30 <jjmcd> Isn't it kind of a script thingy.... no real effort per release once the scripts are done
14:29:39 <randomuser> jjmcd, yes
14:30:02 <jjmcd> But yeah Ben, not a lot of value to continuing to revisit it each week
14:30:13 <randomuser> it's basically rpm|cpio|man2html, with a little overhead
14:30:49 * randomuser will hack at it when he needs to practice perl
14:31:22 <bcotton> #agreed this topic is tabled as an agenda item
14:31:37 <bcotton> #topic QA recap
14:31:47 <bcotton> #link https://fedoraproject.org/wiki/Docs_QA_Procedure
14:32:13 <bcotton> so we're still waiting on me to call for a QA wrangler and for Sparks to add helpful git commands to the wiki
14:32:31 * Sparks will try to get that completed today
14:32:40 <bcotton> ditto
14:33:09 <bcotton> apart from that, i think we've pretty much covered the QA procedure and hopefully we'll make better use of it for f18
14:33:24 <lnovich> is there a list of the git commands in the order that they need to be done somewhere?
14:33:40 <bcotton> lnovich: sparks will be adding that to the link above
14:33:47 <lnovich> cool!
14:34:46 <bcotton> anything else on QA? I think we'll let this drop from the agenda as well
14:35:51 <lnovich> bcotton - have you had any "volunteers"
14:36:05 <bcotton> lnovich: haven't posted the call for volunteers yet :-)
14:36:12 <lnovich> ok
14:37:57 <bcotton> #topic Open Help Conference
14:38:09 <bcotton> #link http://openhelpconference.com
14:38:27 <bcotton> #info Open Help Conference is Aug 11-15 in Cincinnati, OH
14:38:37 <bcotton> final reminder :-)
14:38:40 * Sparks has a coworker that will be in attendance
14:39:47 <bcotton> #topic Outstanding BZ Tickets
14:39:53 <bcotton> #link http://tinyurl.com/lbrq84
14:40:25 <bcotton> i think the bug count has gone down slightly from last week, so hooray
14:40:52 <randomuser> the RFE for a custom BZ link in the guides turned up an exiting result
14:40:54 <Sparks> woot!
14:41:08 <bcotton> randomuser: oh?
14:41:10 <lnovich> excellent!
14:41:20 <lnovich> do share....
14:42:04 * randomuser searches
14:42:34 <randomuser> https://bugzilla.redhat.com/show_bug.cgi?id=808103
14:43:43 <randomuser> if we use an entity for the link tag that uses an entity for its URL, we can have a link directly to a form for that guide
14:43:48 <randomuser> so, hooray!
14:44:14 <bcotton> excellent
14:44:27 <Sparks> I can make that change in the brand but we need to determine if that change makes the line fuzzy in the translators
14:45:06 <randomuser> (i just mentioned it here, thanks sparks for driving this one)
14:45:09 <bcotton> any translators in the room right now?
14:45:31 <Sparks> bcotton: They probably wouldn't know unless they saw the line.
14:45:45 <Sparks> I can make the change and see if that makes the line fuzzy.
14:45:47 <randomuser> well, do they usually translate URLs?
14:46:17 <Sparks> randomuser: No, but we're changing a line... I'm not sure if that delta makes things fuzzy or not.
14:46:38 <randomuser> ah
14:46:47 <Sparks> We need to make sure everyone creates that entity in their guides before the brand gets updated.
14:47:07 <Sparks> AND if it does make that line fuzzy we'll need to get l10n on board pretty quickly
14:47:15 <bcotton> okay, Sparks. do you want to change a guide as a test and work with translation to get it tested?
14:47:50 <Sparks> I will
14:47:54 <Sparks> #action me
14:49:22 <bcotton> #action Sparks to test BZ entity in a guide and coordinate with l10n
14:50:53 <bcotton> anything else on bugs?
14:51:19 <Sparks> nope
14:51:30 <bcotton> #topic Open Floor Discussion
14:51:49 <claneys> Just for saying about guides translation that every guides have theirs duplicated team merged. Almost, it still left storage-administration-guide to be done. If someone with good rights can make me a maintainer, it will be glad :)
14:51:54 * Sparks has two items
14:52:32 <Sparks> #info The Fedora Accessibility package has been retired.  It was old and crusty needed to be shot.
14:53:23 <Sparks> #info OpenSSL guide has been moved to git and I'm going to try to resurrect it for F18.
14:53:56 <Sparks> Uh oh, bcotton has been split.
14:54:21 <jjmcd> gotta love netsplits
14:54:27 <Sparks> Yep.
14:54:32 <Sparks> Anyone have anything else?
14:54:42 <jjmcd> just like the old days ..
14:56:02 <Sparks> bcotton: Welcome back
14:56:09 <randomuser> bcotton, you're supposed to go down with the ship, captain
14:56:26 <bcotton> i never left. everyone jumped off except lnovich and me
14:56:55 <Sparks> Well, you'll just have to read the logs to see what kind of nasty stuff we said about you two
14:57:12 <bcotton> Sparks: did you get your second item in?
14:57:33 <Sparks> yes.
14:57:39 <Sparks> #info OpenSSL guide has been moved to git and I'm going to try to resurrect it for F18.
14:57:47 <bcotton> excellent
14:58:02 <bcotton> well then, is there anything else before we make room for the next meeting?
14:58:18 <Sparks> Not from me
14:58:21 <claneys> I'm good
14:58:37 <bcotton> #endmeeting