15:10:45 <rdieter> #startmeeting kde-sig
15:10:45 <zodbot> Meeting started Tue Aug  7 15:10:45 2012 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:10:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:10:54 <rdieter> #topic roll call
15:11:05 <rdieter> hi everybody, who's present today for kde-sig meeting?
15:11:15 * jgrulich present
15:11:18 <Kevin_Kofler> Present.
15:11:27 <rdieter> ltinkl, than  : ping
15:11:36 * ltinkl is present
15:11:38 <than> present
15:11:47 <rdieter> jreznik is on vacation
15:12:23 <rdieter> #info rdieter jgrulich Kevin_Kofler ltinkl than present
15:12:28 <rdieter> #topic agenda
15:12:45 <rdieter> don't have any agenda  ahead of time, so  what  to discuss today?
15:12:59 <than> rdieter:  4.8.5 status
15:13:07 <rdieter> off the top of my head:  kdm/systemd ( mbriza )
15:13:30 <than> yes, martin is working on systemd/kdm
15:13:53 <than> he could give some update status
15:13:55 <mbriza> i'll have the patch in a few minutes
15:14:09 <than> mbriza: great :)
15:14:19 <mbriza> once i build a rpm and test it
15:14:36 <rdieter> .bug 829881
15:14:39 <zodbot> rdieter: Bug 829881 Use polkit .rules files instead of .pkla files - https://bugzilla.redhat.com/show_bug.cgi?id=829881
15:14:44 <rdieter> probably should start on this one soon too
15:14:55 <Kevin_Kofler> mbriza: Great.
15:15:02 <Kevin_Kofler> rdieter: Oops, yes, that one needs to be fixed too.
15:15:10 <rdieter> ok, then...
15:15:13 <rdieter> #topic kde-4.8.5
15:15:36 <rdieter> current status is that 4.8.5 is all built and ready, except for kde-l10n (-da in particular is ftb fs)
15:16:13 <rdieter> (if you couldn't already tell, the space on my laptop is going wonky today)
15:16:39 <rdieter> and 4.8.5  builds are  in kde-testing repo
15:18:03 <rdieter> good feedback  so  far too
15:18:36 <Kevin_Kofler> Great, except for the kde-l10n bustage. :-(
15:19:20 <Kevin_Kofler> Can we expect upstream to fix their mess or should I try to fix it?
15:19:50 <ltinkl> chainsaw method works in this case :)
15:20:26 <rdieter> ltinkl: omit what's broken you mean?
15:20:40 <ltinkl> rdieter: yup, delete the offending docbook
15:21:05 <rdieter> ok, anyone care to work  on that?
15:21:55 <than> rdieter: i can take care of it
15:22:29 <rdieter> #action  than to look into kde-l10n-da-4.8.5 breakage
15:22:45 <rdieter> #info kde-4.8.5 builds mostly ready (sans kde-l10n)
15:22:51 <rdieter> yay
15:22:55 <rdieter> moving on...
15:23:09 <rdieter> #topic kdm/systemd unit support
15:23:27 <rdieter> #info mbriza is working on implementing systemd unit for kdm
15:23:45 <rdieter> mbriza: anything else worth mentioning yet?
15:24:14 <mbriza> not yet
15:24:20 <rdieter> ok :)
15:24:25 <rdieter> moving on...
15:24:35 <rdieter> #topic open discussion
15:25:16 <rdieter> oh, I guess I could mention that i've got koffice/calligra updates queue'd for msword filter security issue
15:25:53 <Kevin_Kofler> Good.
15:26:07 <Kevin_Kofler> So, do we have any volunteer for fixing the polkit mess?
15:26:23 <Kevin_Kofler> Otherwise, I guess it's me who's going to, uhm, be volunteered. :-(
15:27:33 <rdieter> i've been meaning to look at it for awhile, but busy busy
15:27:36 <Kevin_Kofler> (Grrr, IMHO, the .pkla system worked fine, I don't see why we got the new JavaScript-driven rule system instead, it's just yet another totally gratuitous incompatibility. :-( )
15:27:38 <ltinkl> Kevin_Kofler: is that again some last-minute F18 feature?
15:28:00 <rdieter> ltinkl: no, the bug to adjust rules was filed a long time ago
15:28:02 <Kevin_Kofler> No, it's a first-minute F18 feature, but we haven't managed to adapt kde-settings to it yet.
15:28:38 <ltinkl> isn't there some script to convert those formats?
15:28:39 <Kevin_Kofler> The contingency plan would be to just drop the .pkla file entirely, with no replacement. It would mean that users would have to enter a password to set the clock again.
15:29:37 <Kevin_Kofler> The rule allows users in the wheel group to set the clock without password. This used to be in polkit-desktop-policy, but that was killed with no replacement earlier, saying that this kind of policy decisions belongs to the packages.
15:29:50 <Kevin_Kofler> So I put it in kde-settings for KDE, but now the format changed.
15:30:06 <Kevin_Kofler> FWIW, I don't know how this is handled in GNOME now, since the demise of polkit-desktop-policy.
15:34:06 <than> move on please!
15:34:18 <rdieter> is there  anything else?
15:34:42 <rdieter> otherwise, we can close out the meeting in a minute or 2
15:35:21 <Kevin_Kofler> jreznik said something last week about news from RH, does anybody know?
15:37:20 <rdieter> I'm sure he'll share when able and appropriate.
15:37:36 <Kevin_Kofler> I guess we'll have to wait for him to come back from the national park. :-)
15:37:40 <rdieter> though we can complain that he's been  a big tease
15:37:56 <rdieter> :)
15:38:54 <rdieter> ok, let's end things for today,  thanks everyone.
15:38:56 <rdieter> #endmeeting