15:04:50 <jreznik> #startmeeting kde-sig -- https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2012-08-21
15:04:50 <zodbot> Meeting started Tue Aug 21 15:04:50 2012 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:50 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:57 <jreznik> #meetingname kde-sig
15:04:57 <zodbot> The meeting name has been set to 'kde-sig'
15:05:10 <jreznik> #topic roll call
15:05:17 <jreznik> hey ho, who's here?
15:05:24 <rdieter> hola
15:05:34 * jgrulich is present
15:05:38 <mbriza> me
15:05:50 <Kevin_Kofler> Present.
15:06:02 <than> present
15:06:53 <tdfischer> I'm here
15:06:56 <tdfischer> hola
15:07:41 <jreznik> #chair rdieter jgrulich mbriza Kevin_Kofler than tdfischer
15:07:41 <zodbot> Current chairs: Kevin_Kofler jgrulich jreznik mbriza rdieter tdfischer than
15:07:58 <jreznik> #info rdieter jgrulich mbriza Kevin_Kofler than tdfischer jreznik present
15:08:31 <jreznik> #topic agenda
15:08:49 <rdieter> F18Blocker-kde bugs
15:08:54 <jreznik> theming, kdm preset...
15:09:17 <jreznik> anything else?
15:09:25 <tdfischer> I have something I'd like to squeeze in the agenda for discussion if thats alright
15:09:33 <tdfischer> making apper a lot more visible for a fresh install
15:09:37 <rdieter> tdfischer: yes  please
15:09:56 <tdfischer> there's a lot of messy discussion in a kde channel about that, I figure I'd bring it up
15:10:03 <tdfischer> rdieter can probably find a lot of the backlog in -cafe
15:10:12 <rdieter> rats, I'm not in  there atm
15:10:23 <tdfischer> ah
15:10:25 <tdfischer> no biggie
15:10:35 <tdfischer> lets continue with the meeting though
15:10:46 <jreznik> ok, so let's start with F18Blocker-kde bugs
15:10:54 <jreznik> #topic F18Blocker-kde
15:11:02 <rdieter> .bug 829881
15:11:04 <zodbot> rdieter: Bug 829881 Use polkit .rules files instead of .pkla files - https://bugzilla.redhat.com/show_bug.cgi?id=829881
15:11:15 <rdieter> is the one I wanted to make sure gets addressed asap.
15:11:20 <jreznik> #link https://bugzilla.redhat.com/show_bug.cgi?id=846844
15:11:31 * Kevin_Kofler had no time to look into this, too busy preparing his conference talk he held today, sorry.
15:11:42 <Kevin_Kofler> (into #829881)
15:11:46 <rdieter> ok, I forgot who, was hoping  it wasn't me. :)
15:12:03 <rdieter> but I can look into it today later, if there's no one else able to do it earlier
15:12:14 <jreznik> good idea to solve it asap? any other volunteer?
15:12:16 <rdieter> I also have the new comps changes to review
15:13:25 <rdieter> hoping that this  one and the newly filed  849990 are related
15:13:31 <rdieter> .bug 849990
15:13:33 <zodbot> rdieter: Bug 849990 Apper: Authentization failed when trying to install updates - https://bugzilla.redhat.com/show_bug.cgi?id=849990
15:14:15 * jreznik is going to test it
15:14:41 <rdieter> hard to test/fix these things when the f18 tree is still in flux :-/
15:15:19 <Kevin_Kofler> That's not the same issue.
15:15:21 <jreznik> rdieter: I have semi-working F18 KDE installation
15:15:32 <Kevin_Kofler> We have only one .pkla file and that's for setting the clock.
15:15:40 <rdieter> Kevin_Kofler: ok, rats
15:15:41 <jreznik> yep
15:16:00 <rdieter> jreznik: how'd you get f18?  the  'yum  update' from f17 method?
15:16:13 <jreznik> rdieter: fresh install from TC3
15:16:14 <mbriza> i have a working one but i'm not sure if i could fix that in bearable time
15:16:16 <jreznik> not easy
15:16:34 <jreznik> to get it working
15:16:39 <mbriza> i've done it via distro-sync
15:17:19 <jreznik> maybe it's related to
15:17:25 <jreznik> .bug 841451
15:17:28 <zodbot> jreznik: Bug 841451 polkitd doesn't start in rawhide - https://bugzilla.redhat.com/show_bug.cgi?id=841451
15:17:43 <rdieter> oh, no polkitd would make polkit auth not work indeed
15:17:45 <jreznik> no polkit means no auth
15:17:56 <jreznik> but we are not sure we understand this issue
15:18:48 <rdieter> k, let's continue testing, debugging for now I guess,  since we have no answers
15:19:18 <rdieter> seems then that 829881 is less important, if it's just for setting the clock
15:19:30 <rdieter> not an alpha blocker, imo
15:19:38 <jreznik> yep
15:20:06 <rdieter> imo, move on then
15:21:03 * jreznik is trying to reproduce it
15:21:13 <jreznik> next bug pls
15:21:18 <jreznik> (if any ;-)
15:21:47 <rdieter> there's one more firstboot-related blocker, but I don't think there's much we here can do about that one
15:21:57 <rdieter> so, next topic :)
15:22:09 <jreznik> rdieter: the firstboot affects us a lot
15:22:22 <jreznik> vpodzime is working on it
15:22:24 <rdieter> true
15:22:41 <jreznik> (actually two separate bugs - one anaconda - no /etc/sysconfig/l18n generated)
15:22:53 <jreznik> (and gtk3 gobject issue in firstboot)
15:23:45 <jreznik> and another proposed blocker leads to
15:23:48 <jreznik> #topic theming
15:23:54 <jreznik> mbriza: what's the current status?
15:24:08 <mbriza> i've filed an update
15:24:18 <mbriza> and as i have tested, it should be okay
15:24:46 * jreznik should test it too
15:25:10 <mbriza> there's the firstboot problem though, i have to start kdm as a service after logging on root
15:25:29 <jreznik> yep, firstboot is broken now but it's not an issue
15:25:39 <jreznik> we need the new theming in next TC
15:25:53 <jreznik> I'll take care, it's proposed as Blocker bug
15:27:05 <jreznik> so pls test the theme
15:27:29 <mbriza> that works, as i said
15:27:39 <jreznik> #info mbriza prepared f18 theming update, proposed as Alpha blocker
15:27:53 <jreznik> mbriza: you know :) better to check by more people, I trust you of course :)
15:28:02 <jreznik> next topic?
15:28:17 <rdieter> testing theming on different resolution screens always is good
15:28:30 <rdieter> jreznik: yeah, next++
15:28:50 <jreznik> rdieter: I hope it's not problem this cycle, as we recycle old theming over and over (but still... different resolutions are different resolutions)
15:28:52 <mbriza> i don't trust myself :) i'll be more calm if someone confirms it
15:29:02 <Kevin_Kofler> rdieter: Yeah, I remember the KDM theme I did (IIRC fedorainfinity-kdm-theme) which was probably the most buggy ever.
15:29:14 <Kevin_Kofler> It had lots of resolution-related glitches.
15:29:31 <jreznik> next steps - QML KSplash and QML theme for LightDM-KDE :)))
15:29:48 <tdfischer> woo
15:29:49 <jreznik> actually I hope it should be less buggy than current theming...
15:30:05 <rdieter> woo woo
15:30:10 * jreznik hides, hopes Kevin_Kofler do not listen
15:30:16 <jreznik> does not
15:30:23 <Kevin_Kofler>15:30:55 <jreznik> but I'm not sure I'll have a time for it now... not easy to make fedora releasable :)
15:31:16 <jreznik> #topic display managers rework and kdm
15:31:24 <jreznik> any news here? /me lost track
15:31:44 <rdieter> jreznik: I think it's done
15:32:05 * jreznik should test it in his KDE F18 install
15:32:16 <rdieter> nucleo did some initial testing, we worked out one bug
15:32:53 <guest123321> .bug 847472
15:32:57 <zodbot> guest123321: Bug 847472 DM configuration migration on upgrade not working - https://bugzilla.redhat.com/show_bug.cgi?id=847472
15:33:15 <rdieter> jreznik: oh, I think we have one  thing to fix yet, supply some sort of present on kde spin  so  kdm  gets enabled by  default
15:33:25 <rdieter> s/present/preset/
15:33:52 <jreznik> yep, we need preset
15:34:37 <rdieter> anyone know how to do that yet?  (I don't, but could learn)
15:35:09 <mbriza> it's a config file somewhere in /usr/lib, i'll find the whole path
15:35:44 <rdieter> mbriza: could you file a new bug, against... hmm... spin-kickstarts I guess with the details?
15:36:16 <mbriza> okay
15:36:51 <mbriza> it's /usr/lib/systemd/system-preset/99-default.preset btw
15:37:09 <Kevin_Kofler> We should probably ship some package (kde-settings-kdm-default?) which installs that file…
15:37:36 <Kevin_Kofler> Or do you think writing to /usr from the live kickstart is better?
15:37:38 <jreznik> Kevin_Kofler: I'd say it should be for everything, not only kdm
15:37:54 <Kevin_Kofler> IMHO, this really belongs into /etc…
15:38:59 <jreznik> Kevin_Kofler: etc is obsolete :(
15:39:19 <Kevin_Kofler> Huh???
15:39:42 <Kevin_Kofler> This is not a distro default, it's a site default, which the KDE spin would only initialize.
15:41:15 <rdieter> kde-settings-kdm-default sounds reasonable, yeah, this can't be spin-specific come to think of it
15:42:03 <rdieter> I'd be curious how other spins are planning on handling it
15:42:08 <jreznik> rdieter: why not? the whole idea of presets is to be spin specific
15:42:14 <rdieter> esp what  happens if > 1 'dm default"  pkg gets installed
15:42:27 <Kevin_Kofler> That's why it should be in /etc, not /usr.
15:42:34 <rdieter> jreznik: what about dvd installs then?  that's not kde spin
15:42:46 <Kevin_Kofler> Does systemd really require this file to be in /usr? :-/
15:42:51 <Kevin_Kofler> (Then systemd should be fixed.)
15:43:00 <rdieter> Kevin_Kofler: let's not worry about implementation details yet
15:43:13 <rdieter> that's orthogonal to  this discussion
15:43:21 <Kevin_Kofler> Writing to /etc from the spin kickstart is acceptable, writing to /usr, ewww!
15:43:34 <jreznik> rdieter: hmm, DVD...
15:43:56 <rdieter> or kickstart/network installs
15:43:57 <jreznik> let's ask lennart how he designed it for this situations...
15:44:05 * jreznik is running out of time...
15:44:07 <Kevin_Kofler> jreznik: DVD users will not get any presets no matter what.
15:44:24 <mbriza> should i file the bug anyway? as a blocker?
15:44:38 <rdieter> mbriza: yes, we  need to fix it somewhere somehow. :)
15:44:54 * jaysonr is gonna try to work orthogonal into converstation at some point today now...
15:44:56 <rdieter> we just don't know the specifics yet
15:44:59 <jreznik> Kevin_Kofler: DVD still needs some generic DVD preset
15:45:43 <mbriza> okay, it's there: #850465
15:45:46 <rdieter> jaysonr: if you do, I have a shiny new geek membership card for you  ( jreznik lost his not knowing who liebnitz was earlier)  :)
15:46:16 <Kevin_Kofler> jreznik: Doesn't systemd do something sensible by default?
15:46:46 <jreznik> rdieter, Kevin_Kofler: let's ask lennart for clarification...
15:46:57 <jreznik> #action jreznik to ask for presets clarification
15:47:01 <Kevin_Kofler> Yeah.
15:47:06 * jreznik has to go now... anything else?
15:47:38 <rdieter> I'm guesing the default presets default to gdm, if it's present,  but not sure how it's handled if gdm is absent
15:47:51 <tdfischer> just my impromptu agenda item of #850445
15:47:53 <tdfischer> .bug 850445
15:47:55 <zodbot> tdfischer: Bug 850445 Apper is really really hard to find. - https://bugzilla.redhat.com/show_bug.cgi?id=850445
15:48:07 <rdieter> right
15:48:08 * tdfischer filed it during the meeting
15:48:10 <halfline> rdieter: it's just a copy and paste of the prefdm code
15:48:15 <jreznik> rdieter: could you please continue as a chair?
15:48:16 <mbriza> rdieter: i think it just boots to console logging
15:48:27 <rdieter> halfline: oh, yay.  then  we should be mostly ok.
15:48:34 <rdieter> halfline: thanks
15:48:49 <jreznik> the default one?
15:48:49 <rdieter> #topic apper is hard to find
15:48:59 <halfline> rpm -q --scripts systemd for details
15:48:59 <Kevin_Kofler> IMHO it's easy enough to find.
15:49:04 <Kevin_Kofler> (Apper)
15:49:12 <tdfischer> Kevin_Kofler: read the bug
15:49:29 <tdfischer> you can't easily infer that apper is the way to install new stuff if you don't know about it as a new linux user
15:49:33 <rdieter> tdfischer: so, any concrete suggestions  from the -cafe chat earlier
15:49:34 <rdieter> ?
15:49:37 <tdfischer> though I think it is pretty easy to find
15:49:42 <tdfischer> rdieter: some say a big icon on the desktop
15:49:46 <tdfischer> or making it a default menu item
15:50:03 <tdfischer> which would be a significant improvement I think over having it at the very bottom of the systemsettings dialog
15:50:19 <tdfischer> which, for a small display, means you need to scroll down
15:50:25 <rdieter> apper is in Administation/
15:50:28 <tdfischer> or even the default non-maximized window
15:50:29 <tdfischer> right
15:50:37 <tdfischer> but adding it to the favorites would be great
15:50:49 <tdfischer> since otherwise, users won't have the slightest idea where to start looking for such a core feature
15:50:55 <rdieter> favorites... nod, that I could go for
15:51:53 <tdfischer> the discussion in there started probably 3 hours earlier and lasted a good two, where it was determined that it is probably the distro's fault the user couldn't install KAlgebra easily
15:52:14 <tdfischer> some argue that kde.org shouldn't really say "Heres how you install it", and should be more of "here's how you use kalgebra"
15:52:30 <rdieter> PackageKit-command-not-found can handle  the  case of trying to run  it from the command line
15:52:36 <tdfischer> other arguments were that ubuntu does it really nicely with the software center being pretty much front-and-center in the unity UI
15:52:42 <tdfischer> right
15:52:51 <rdieter> when/if that ever works again (it's been broken on/off)
15:52:56 <tdfischer> in this user's case, she thinks the terminal is the black magic screen
15:53:05 <rdieter> k, true
15:53:09 <tdfischer> but for someone who uses exclusively GUIs, I think apper needs to be a lot more promiment
15:53:44 <rdieter> in a perfect world, would be cool if some krunner plugin could do  the same  thing  as PackageKit-command-not-found does for the  command-line
15:53:55 <tdfischer> totally
15:54:03 <rdieter> tdfischer: though I wonder if average/new users would use krunner much at first
15:54:17 <rdieter> but baby steps I guess
15:54:18 <tdfischer> I believe the kmenu search bar uses the same plugins that krunner uses
15:54:24 <Kevin_Kofler> Indeed, new users don't use KRunner!
15:54:28 <tdfischer> so it isn't as unrealistic as you think
15:54:32 <rdieter> tdfischer: oh really?
15:54:35 <rdieter> if so, neat
15:54:35 <tdfischer> iirc, yeah
15:55:10 <rdieter> but implementing that means work and coding, of course.
15:55:13 <Kevin_Kofler> Do new users use the Kickoff search bar? Do they even realize it's a search bar?
15:55:19 <tdfischer> yes
15:55:25 <tdfischer> that was what I was referring to by kmenu
15:55:30 <tdfischer> couldn't remember the name though
15:55:49 <rdieter> so,  adding apper as a favorite I think is a first  easy and no-brainer improvement in the short-term
15:55:57 <mbriza> sorry, guys, i have to go now, too, thanks for the advices and bye
15:55:58 <tdfischer> I think thats not really a relevant solution here though, as the user still needs to know what they're looking for
15:56:03 <rdieter> mbriza: ok
15:56:15 <tdfischer> but adding it as a default favorite shows them "Hey, here's how you do software stuff! Like android!"
15:56:31 <tdfischer> which I think is a very unobtrusive change that should be made
15:56:45 <rdieter> agreed,  any objections? (just in case there are any)
15:56:55 <Kevin_Kofler> Yeah, favorite makes sense.
15:57:12 <tdfischer> I'm still looking into other ideas to making this sort of stuff easier, so this would just be a first step
15:57:20 <rdieter> #agreed add apper to kickoff favorites menu to help address bug #850445
15:57:31 <tdfischer> groovy ^^
15:57:37 <rdieter> #topic open discussion
15:57:53 <rdieter> we're close to  the end of our hour, any last thoughts before closing the  meeting?
15:58:07 <tdfischer> none here
15:58:20 <Kevin_Kofler> None here either.
15:59:43 <rdieter> ok, thanks everybody, esp tdfischer for the nice suggestion(s)
15:59:46 <rdieter> #endmeeting