#fedora-meeting: Fedora QA meeting

Meeting started by adamw at 15:00:55 UTC (full logs).

Meeting summary

  1. roll call (adamw, 15:01:19)
  2. Incomplete anaconda functionality for Fedora 18 (adamw, 15:03:50)
    1. for the record, the recommendations are: (adamw, 15:53:13)
    2. 1. We consider it unlikely Alpha will be releasable by the time of go/no-go on Aug 29/30. (adamw, 15:53:25)
    3. 2. We don't believe that reverting to oldUI is a great idea. (adamw, 15:53:32)
    4. 3. We are generally of the opinion that a planned slip longer than 2 weeks should be accompanied by a period where the release freeze is lifted. (adamw, 15:53:44)
    5. AGREED: we submit the three recommendations drafted above to the fesco ticket (adamw, 15:53:52)
    6. ACTION: adamw to float proposed recommendation #4 on the mailing list and add it to the ticket if it gets sufficient support (adamw, 16:02:06)

  3. Fedora 18 Alpha mini blocker review (adamw, 16:06:47)
    1. 8 Proposed Blockers (tflink, 16:07:55)
    2. 2 Proposed NTH (tflink, 16:08:04)

  4. (851212) error: cannot invoke setopt() - perform() is currently running (tflink, 16:08:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=851212 (tflink, 16:08:35)
    2. Proposed Blockers, POST (tflink, 16:08:37)
    3. AGREED: 851212 - AcceptedNTH - This sounds kind of nasty but we need more data on how often it happens before deciding on blocker status for F18 alpha. More crashes could be masked by #851207. (tflink, 16:14:20)

  5. (851220) EFI syslinux contains wrong path to kernel pair (tflink, 16:14:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=851220 (tflink, 16:14:32)
    2. Proposed Blockers, ASSIGNED (tflink, 16:14:32)
    3. AGREED: 851220 - AcceptedBlocker - Violates the following F18 alpha release criteria for EFI systems: "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods" (tflink, 16:18:46)

  6. (849982) The default Fedora 18 artwork refers to the previous release in F18 Alpha TC3 (tflink, 16:19:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=849982 (tflink, 16:19:18)
    2. Proposed Blockers, NEW (tflink, 16:19:20)
    3. still waiting on information on or conversation with artwork/design team, will re-evaluate at next blocker meeting if new information is available (tflink, 16:21:46)

  7. (851207) DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist (tflink, 16:22:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=851207 (tflink, 16:22:07)
    2. Proposed Blockers, NEW (tflink, 16:22:09)
    3. AGREED: 851207 - AcceptedBlocker - Violates the following F18 alpha release criterion: "The installer must be able to complete package installation with the default package set for each supported installation method" (tflink, 16:27:18)

  8. (851295) splitsep doesn't correctly handle variables with escaped spaces (tflink, 16:27:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=851295 (tflink, 16:27:40)
    2. Proposed Blockers, MODIFIED (tflink, 16:27:43)
    3. AGREED: 851295 - AcceptedBlocker - Violates the following F18 alpha release criterion for USB media: "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods" (tflink, 16:31:31)

  9. (851274) Traceback during install - mount: /dev/sr0 is already mounted or /run/install/repo busy (tflink, 16:32:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=851274 (tflink, 16:32:45)
    2. Proposed Blockers, ASSIGNED (tflink, 16:32:47)
    3. AGREED: 851274 - AcceptedBlocker - Violates the following F18 alpha release criterion for netinstall images: "The installer must be able to complete package installation with the default package set for each supported installation method" (tflink, 16:35:38)

  10. (851500) UEFI boot: failure reading sector 0x40 from `cd0'. (tflink, 16:36:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=851500 (tflink, 16:36:06)
    2. Proposed Blockers, NEW (tflink, 16:36:06)
    3. AGREED: 851500 - RejectedBlocker AcceptedNTH - This does affect the booting of the installer on ~ 20% of UEFI systems but only with optical media. Since USB is an acceptable workaround, accepting as NTH, rejecting as blocker (tflink, 16:48:37)

  11. (849389) uefi boot fails on Asus motherboards (tflink, 16:48:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=849389 (tflink, 16:48:55)
    2. Proposed Blockers, ON_QA (tflink, 16:48:55)
    3. AGREED: 849389 - AcceptedNTH - Causes the installer to be non-bootable for Asus UEFI systems, doesn't seem to be enough systems to justify as blocker at this point in time (tflink, 16:56:31)

  12. (851323) anaconda tries to poke /etc/chrony.conf at the end of install even if chrony wasn't in the installed package set (tflink, 16:57:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=851323 (tflink, 16:57:57)
    2. Proposed NTH, POST (tflink, 16:58:00)
    3. AGREED: 851323 - AcceptedNTH - While the installed system is bootable after hitting this, it looks really bad and can interefere with other post-isntall tasks like log copying (tflink, 17:01:03)

  13. (851653) NTPconfigError: Cannot replace the old config with the new one (Invalid cross-device link) (tflink, 17:01:17)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=851653 (tflink, 17:01:20)
    2. Proposed NTH, POST (tflink, 17:01:23)
    3. https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-August/000803.html maybe (adamw, 17:08:34)
    4. AGREED: 851653 - It isn't clear exactly how this bug is triggered and it'd be nice to see more details before making a decision on NTH (tflink, 17:09:30)

  14. open floor (adamw, 17:12:45)


Meeting ended at 17:15:48 UTC (full logs).

Action items

  1. adamw to float proposed recommendation #4 on the mailing list and add it to the ticket if it gets sufficient support


Action items, by person

  1. adamw
    1. adamw to float proposed recommendation #4 on the mailing list and add it to the ticket if it gets sufficient support


People present (lines said)

  1. adamw (228)
  2. tflink (200)
  3. rbergeron (43)
  4. maxamillion (34)
  5. mjg59 (21)
  6. jreznik (19)
  7. nirik (17)
  8. brunowolff (16)
  9. zodbot (6)
  10. rwmjones (2)
  11. spoore (1)
  12. aspratyush (1)


Generated by MeetBot 0.1.4.