14:00:14 <bcotton> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:00:14 <zodbot> Meeting started Mon Sep 10 14:00:14 2012 UTC.  The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:22 <bcotton> #meetingname Fedora Docs
14:00:22 <zodbot> The meeting name has been set to 'fedora_docs'
14:00:26 * sgordon is here
14:00:28 <bcotton> #topic Roll Call
14:00:38 <Capesteve> Hello
14:00:53 <Capesteve> sgordon: too quick
14:00:54 <randomuser> good morning, all
14:01:15 <randomuser> $TIMEOFDAYAPPROPRIATEGREETINGS as well
14:02:04 <Capesteve> GDTY covers most time zones (from the days of Telex)
14:02:10 * jjmcd 
14:02:46 * claneys claneys
14:04:08 <bcotton> so who brought the coffee this week?
14:04:18 * randomuser isn't sharing
14:04:59 <bcotton> well if that's how you're going to be, let's get this party started
14:05:09 <bcotton> #topic Follow up on last week's action items
14:05:19 <bcotton> #action Sparks to add relevant git commands to QA procedures
14:05:48 * Sparks just got permission to use the source
14:09:14 <bcotton_> hey, you know what's awesome? when your computer has a seizure while you're trying to run a meeting
14:09:33 <Capesteve> and your distro is?
14:09:37 <bcotton_> that's what i get for not #chair'ing people
14:09:58 <bcotton_> Beefy Miracle :-)
14:10:11 <bcotton_> i think the hardware is on it's way out, it happens every so often
14:11:04 <shaiton> bcotton: that's why we have #chair :)
14:11:25 <bcotton> shaiton: i know, i really should do that at the outset, i just never think to
14:11:38 <bcotton> consider that glitch fixed, though :-)
14:11:39 <bcotton> okay
14:11:42 <bcotton> so where were we
14:11:45 * shaiton should read the backlog to its end before commenting :)
14:12:20 <bcotton> #topic Release Notes
14:12:28 <bcotton> #topic Release Notes
14:13:05 <bcotton> #info Alpha release date has slipped again
14:13:27 * randomuser has a release notes procedure question
14:13:34 <bcotton> #info Alpha RN (one page) due 14 September
14:13:56 <bcotton> #info wiki beats due 26 September
14:13:59 <bcotton> randomuser: go ahead
14:14:46 <randomuser> iin the last release, i noticed one instance of a dev/qa contributor updating their own beats page. Is this something we encourage directly?
14:15:30 <bcotton> dont see why not
14:15:56 <bcotton> there's something to be said for an independent view, but the developers know their beats the best
14:16:34 <jjmcd> Just keep in mind that the developers typically only cover part of a beat
14:16:41 <randomuser> i'm thinking of an announcement or appeal to select lists, in the tone of "make sure your contributions are documented, help us out"
14:16:55 <jjmcd> So while they know the topic very well, they probably know only a fraction
14:17:12 <jjmcd> randomuser, +1
14:17:18 <bcotton> randomuser: agreed
14:17:44 <randomuser> of course, docs folks should take responsibility for copy, wording, presentation, organization, etc
14:18:35 <bcotton> maybe a brief period for devs to leave snippets in the beats would be good. sometime between the beat gets cleared and when we ask people to start writing
14:18:56 <bcotton> that way, they can write around the notes that the devs have left behind
14:19:52 <randomuser> the instance i mentioned happened after beta... i don't suggest limiting them to a timeframe
14:20:51 <jjmcd> Yes, the important thing is to emphasize that they don't need to write elegant prose.  We can clean it up if they just let us know what's important
14:20:52 <bcotton> randomuser: they wouldn't be limited, per se, but this way they have a chance to put stuff in before someone writes it. once a person has written a beat, i wonder if they really go back and check it (or enable notifications)
14:21:04 <randomuser> the template could be adapted so they know when we've moved to git and stopped checking
14:21:23 <randomuser> jjmcd, +1
14:21:25 <bcotton> edits can always be done after a beat is written, but its easiest if its there beforehand, so that's what we want to encourage, i think
14:22:42 <randomuser> so, who should the appeal be sent to, and who should send it?
14:23:05 <randomuser> and are we too far along to do it for this release
14:23:14 <bcotton> fedora-announce seems like the broadest target, but there may be a better list
14:23:31 <bcotton> we're not too far along until the RN have been published ;-)
14:23:39 * randomuser smirks
14:23:44 <bcotton> but with the schedule delays, i think we have time to sneak in an appeal
14:24:12 <bcotton> jreznik: ping
14:25:07 <jreznik> bcotton: pong
14:25:42 <bcotton> jreznik: if you were going to send a "hey, developers, please help us write beats by letting us know what's important" email, what list(s) would you send it to?
14:27:50 <jreznik> bcotton: devel, yeah, I know it's for different purposes but as you need developers to take an action... or even devel-announce, it's low traffic list and I'd say it's ok to use it
14:28:21 <bcotton> okay, great
14:28:29 <bcotton> randomuser: want to be the one to send the email?
14:28:41 <randomuser> sure
14:28:59 <bcotton> #action randomuser to email devel-announce with an appeal for beat contributions
14:29:02 <randomuser> i might ask for help with the draft, to make sure i dont miss any good points
14:29:06 <bcotton> randomuser: sure thing
14:29:12 <bcotton> anything else on Release Notes?
14:29:25 <jreznik> randomuser: you can CC me too, I can take a look :)
14:29:38 <randomuser> thanks jreznik
14:29:48 <randomuser> bcotton, yes
14:30:26 <randomuser> does anyone want to take up a template change for the beats, to present a 'don't worry about presentation' reminder to participating developers?
14:30:38 <randomuser> i could do that as well, i suppose
14:31:21 <bcotton> i'm a little less enthused by that. i'd have to see the text. the presentation is important when the beats get sucked into git, so i don't want writers to think they shouldn't be concerned
14:31:58 <randomuser> fair enough
14:32:17 <bcotton> though i do agree that developers should be more focused on saying things instead of how they say it
14:33:49 <bcotton> something to consider, but not act upon just yet :-)
14:33:52 <bcotton> anything else on RN?
14:34:03 <sgordon> in my experience developers are rarely too overly focused on the presentation
14:34:09 <sgordon> so i doubt they need a reminder ;)
14:34:12 <bcotton> sgordon: fair point
14:34:35 <jjmcd> sgordon, but I think the concern they have is that they can't write great prose so they don't try
14:34:52 <bcotton> #topic Fedora 18 schedule
14:35:03 <bcotton> #link http://jreznik.fedorapeople.org/schedules/f-18/f-18-docs-tasks.html
14:35:21 <sgordon> jjmcd, i get that i just think it's something we say rather than something that actually happens
14:35:24 <bcotton> as i mentioned earlier, we've slipped again. this is good news from a "more time to get things written" perspective
14:35:47 <bcotton> #info Guides scheduled to be branched 2 October
14:38:31 <bcotton> oh for the love of...... okay, today is clearly a monday
14:38:51 <bcotton> what was the last thing i said (before my monday complaint)?
14:39:04 <bcotton> also
14:39:07 <bcotton> #chair jjmcd
14:39:07 <zodbot> Current chairs: bcotton jjmcd
14:39:25 <jjmcd> Guides scheduled to be branched 2 October
14:39:40 <bcotton> jjmcd: thank you
14:39:52 <bcotton> okay, anything else on guides or the schedule?
14:41:02 <bcotton> #topic Outstanding BZ Tickets
14:41:12 <bcotton> #link http://tinyurl.com/lbrq84
14:41:49 <bcotton> i've seen some discussion on the docs-qa mailing list, so i hope that translates into bugs getting squashed :-)
14:42:16 * nb responds to the roll call
14:43:30 <bcotton> hi nb
14:43:37 <bcotton> #topic open floor discussion
14:43:45 <bcotton> so, who has things to say?
14:44:07 <nirik> I have an item... ;)
14:44:42 <nirik> We setup long ago a publictest instance for docs folks to try and do some generating of docs or the like. Is that at all still in use? (I can get more details if needed)
14:44:55 <nb> idk, that was rudi's stuff i think
14:45:03 * nb hasn't talked to rudi lately
14:45:19 <jjmcd> We wanted to use that for nightly builds
14:45:23 <jjmcd> that we do for L10n
14:45:29 <nb> oh
14:45:32 <nirik> "Docs scripting and beta guides creation testing." yeah.
14:45:33 <jjmcd> But there was some publican thing holding it up
14:45:48 <jjmcd> I don't recall what it was
14:46:01 <jjmcd> Currently, I run nightly builds for L10n here at home
14:46:09 <jjmcd> Should be run on uor infrastructure
14:46:20 <jjmcd> s/uor/our
14:46:48 <nirik> well, rudi hasn't logged into that publictest instance since may. ;)
14:46:55 <jjmcd> I think it had to do with Fedora vs RHEL
14:47:11 <jjmcd> Well, rudi has had RL interfering
14:47:33 <nirik> so, what is the process? install tools, pull from git, generate stuff, sync it off?
14:47:40 <jjmcd> YEah
14:47:41 <nb> nirik, perhaps make docs01?
14:47:44 <nb> or docs01.dev?
14:48:05 <nb> i could assist with puppetizing it
14:48:06 <jjmcd> generate stuff - push to web
14:48:06 <nirik> well, if it's just quick jobs like that it may be better for the new cloud setup once it's ready for business.
14:48:12 <nb> ah ok
14:48:18 <jjmcd> It's pretty simple
14:48:26 <nirik> make instance, run stuff, pull data, destroy instance.
14:48:29 <jjmcd> One script but it takes a couple hours to run
14:49:08 <nirik> ok. Let me note this and we can circle back when our cloud is ready and see if it will work for this. ;)
14:49:21 <jjmcd> Yeah, that sounds like a good approach
14:51:30 <nirik> ok, just wanted to know if the pubtest instance was still needed.
14:51:37 <nirik> we could also just turn it off until rudi is ready to work on it again.
14:51:37 * nirik doesn't like things up sitting there doing nothing. ;)
14:52:20 <lnovich> do you want me to give rudi a poke about it?
14:53:40 <nirik> sure, if you could that would be great.
14:53:59 <lnovich> what exactly do you want me to ask him about nirik?
14:54:51 <nirik> is the publictest01 instance: currently needed or needed at all. (ie, can I just shut it off until needed, or can I just remove it if it's never going to be needed)
14:55:11 <lnovich> ok will do
14:55:23 <bcotton> anything else before we wrap up for the week?
14:55:44 <nirik> thanks lnovich
14:56:03 <lnovich> already sent him an email
14:56:07 <lnovich> will follow up tomorrow
14:57:26 <bcotton> okay, everyone. thanks for joining us today (and dealing with my technological cursedness) see you next week!
14:57:29 <bcotton> #endmeeting