15:01:54 <rdieter> #startmeeting kde-sig
15:01:54 <zodbot> Meeting started Tue Sep 11 15:01:54 2012 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:03 <rdieter> hi ho everyone
15:02:07 <rdieter> #topic roll call
15:02:20 <rdieter> who's present for kde-sig meeting today?
15:02:31 <Kevin_Kofler> Present.
15:02:39 <jgrulich> hi
15:02:53 * ltinkl is here
15:03:18 * jreznik is semi-present
15:03:26 * rnovacek is here
15:04:06 <rdieter> #info Kevin_Kofler jgrulich ltinkl jreznik rnovacek present
15:04:26 <rdieter> #chair Kevin_Kofler ltinkl jreznik rnovacek
15:04:26 <zodbot> Current chairs: Kevin_Kofler jreznik ltinkl rdieter rnovacek
15:04:42 <rdieter> good enough for now,
15:04:44 <rdieter> #topic agenda
15:04:54 <rdieter> goodies to discuss today?
15:05:00 * rdieter can to kde-4.9.1 status report
15:05:51 <Kevin_Kofler> F18 Alpha status?
15:06:13 <rdieter> if jreznik is still available, he may have best info available on that, sure.
15:06:45 <rdieter> well, let's start with that...
15:06:53 <rdieter> #topic f18 alpha
15:07:22 <rdieter> jreznik (or anyone else with info), so might we have a release anytime soon?
15:07:49 <jreznik> there's RC2 available
15:08:00 <rdieter> I suppose it's next tuesday at the earliest, right?
15:08:30 <jreznik> rdieter: yep, tuesday, I hope, QA guys found a few new issues but I'd say fixable
15:08:33 <Kevin_Kofler> And does RC2 have any chance of going gold or are we going to get up to RC32768? ;-)
15:09:07 <Kevin_Kofler> Are there still open blockers?
15:09:12 <Kevin_Kofler> And how many?
15:09:25 <Kevin_Kofler> And perhaps more importantly, any that we need to look into?
15:09:50 <jreznik> #link http://qa.fedoraproject.org/blockerbugs/current
15:10:40 <jreznik> http://fedoraproject.org/wiki/Test_Results:Current_Desktop_Test
15:11:44 <rdieter> offhand, I don't see anything directly actionable on our part (f18alpha blocker-wise)
15:12:27 <jreznik> yep, for kde there's no accepted blocker
15:12:30 <Kevin_Kofler> So it looks like there are still open blockers. :-( We're going to get far behind schedule. :-(
15:13:04 <Kevin_Kofler> There's a proposed NTH about ntpd being AWOL for some reason.
15:13:32 <Kevin_Kofler> I'm not sure it's our fault, it might be the compose tool? Weird.
15:13:36 <jreznik> Kevin_Kofler: the accepted blockers looks good, but we have a lot of proposed...
15:13:41 <Kevin_Kofler> We always had ntpd on the spin AFAIK.
15:13:53 <jreznik> Kevin_Kofler: that's one I'm not sure about
15:14:05 <rdieter> .bug 856090
15:14:08 <zodbot> rdieter: Bug 856090 ntpd not installed, causes firstboot to hang when user selects "Sync date and time over network" - https://bugzilla.redhat.com/show_bug.cgi?id=856090
15:14:24 <Kevin_Kofler> I see only 2 proposed blockers which refer to KDE in any way, and AFAICT those are both generic Anaconda bugs, not really KDE-specific.
15:14:26 * rdieter triaged that to firstboot, if firstboot hangs without ntp service, then a dep should be added
15:14:41 <jreznik> yep
15:14:44 <Kevin_Kofler> If there are others, they haven't been properly proposed, or maybe they have been rejected.
15:15:20 <jreznik> Kevin_Kofler: there were a few proposed but were rejected
15:15:50 <jreznik> probably video driver related
15:15:56 <Kevin_Kofler> Now why is ntpd not installed by default anymore in the first place?
15:16:07 <Kevin_Kofler> I think we can easily work around that by manually adding it to the kickstart.
15:16:22 <Kevin_Kofler> Then if another RC is spun (and that seems likely given the open blockers), it will automatically be fixed.
15:17:16 <rdieter> I'm not sure if firstboot needs ntpd or chrony, if anyone knows, feel free to add data to bug #856090
15:17:20 <jreznik> Kevin_Kofler: same problem could affect also gnome spin
15:17:36 <jreznik> so we definitely want "system" solution
15:17:37 <rdieter> jreznik: it doesn't use firstboot anymore... does it?
15:17:46 <jreznik> rdieter: yep, it still uses firstboot
15:17:50 <rdieter> ok
15:17:53 <jreznik> ie was postponed to f19
15:17:55 <Kevin_Kofler> jreznik: Yes, but adding it to the kickstart fixes the issue now.
15:18:12 <Kevin_Kofler> Adding it as a dep is the right thing to do, but needs an update to go through.
15:18:28 <jreznik> Kevin_Kofler: could be picked up for compose
15:18:39 <Kevin_Kofler> And FWIW, I think we want ntpd or chrony installed by default in the first place, even if nothing else requires it.
15:18:39 <jreznik> just it has to be accepted as NTH/Blocker
15:19:41 <rdieter> yeah, I guess kde's time kcm has checkbox: "set time/date automatically".  I assume that's usint ntpd
15:19:53 <rdieter> will have to double-check, maybe we ought to add a dep too
15:20:10 <jreznik> good spot
15:20:15 * jreznik has to leave now...
15:20:59 <rdieter> jreznik_n9: thanks
15:21:06 <rdieter> anything else blocker-wise to dicuss?
15:21:56 <rdieter> #action rdieter to see what kde's "set date and time automatically" checkbox implementation does exactly, and consider adding dependencies
15:22:13 <Kevin_Kofler> OK
15:24:00 <rdieter> relatedly, i've been waiting for a reasonably usable f18 live image (or f18 installable image) to take a closer look at comps changes for the new anaconda too... I'll likely not be able to or have time to do that thoroughly until after f18-alpha though.
15:24:26 <rdieter> any additional eyes or help reviewing that would be appreciated
15:24:51 <rdieter> for example, just earlier this morning, we'd noticed that twinkle had gotten installed by default, inadvertantly
15:25:17 <rdieter> which grew the spin by ~50mb due to qt3/kdelibs3 stack pulled in from it
15:25:39 <Kevin_Kofler> Yeah, the live kickstarts need updating too, for comps changes and for adjusting the size target.
15:26:09 <rdieter> yes, that's also something that will likely end up getting done post f18-alpha too
15:26:31 <rdieter> anyway, let's move on...
15:26:33 <Kevin_Kofler> Hmmm, we were at something like 750, was that with twinkle? So we're at 700 now?
15:26:47 <rdieter> Kevin_Kofler: that sounds about right
15:26:55 <Kevin_Kofler> So can we stick to CD size? :-)
15:27:12 <rdieter> until we start to add stuff, yeah. :)
15:27:36 <rdieter> hard to say for sure, I suspect there's other comps churn that went unnoticed too
15:27:59 <rdieter> anyway... let's move on...
15:28:03 <rdieter> #topic kde-4.9.1
15:28:14 <jreznik_n9> rc2 is bigger, 815
15:28:51 <rdieter> so, initial builds of kde-4.9.1 are done
15:28:57 <Kevin_Kofler> jreznik_n9: OK. :-(
15:29:00 <azril> ada indo gak ni
15:29:01 <rdieter> and bodhi updates prepped
15:29:07 <Kevin_Kofler> Looks like RC1 was missing a lot of stuff.
15:29:58 <jreznik_n9> yep
15:30:14 <Kevin_Kofler> Hmmm, Anaconda is also dragging in the GNOME nm-connection-editor now, I guess that also adds to the bloat. They should really use the native KDE one on the KDE spin, but I don't think we're going to get this into the Alpha, we're lucky if we can get it into the Beta. :-(
15:30:15 <rdieter> wrt f18, I'm tempted to suggest waiting until after f18-alpha to actually queue it for updates-testing... any opinions on that?
15:30:46 <Kevin_Kofler> It's one line of Python to run the right binary and something like 1 or 2 lines to check which one to use, but… :-/
15:31:09 <Kevin_Kofler> Unfortunately, when caravel reported the bug, he didn't paste my suggested fix in until after they already added the Requires.
15:31:14 <rdieter> hard to use a plasma applet... without plasma running though.
15:31:51 <rdieter> wait, this is anaconda, maybe it could be done (when on kde live image at least)
15:31:53 <Kevin_Kofler> 1. liveinst runs inside the Plasma session and 2. this runs a KCM, not a plasmoid.
15:32:05 <rdieter> ah, kcm, cool, nevermind
15:32:08 <Kevin_Kofler> I think it should work.
15:32:22 <Kevin_Kofler> But it would need testing and all. Probably only possible post-Alpha.
15:32:24 <jreznik_n9> it should be disabled on live
15:32:32 <jreznik_n9> network spoke
15:32:46 <rdieter> or that. :)
15:32:46 <Kevin_Kofler> Yeah, just disabling the network part on liveinst would also be a sensible fix.
15:32:56 <Kevin_Kofler> It's how it was done in the past.
15:34:56 <rdieter> fyi, the f17 kde-4.9.1 update also includes calligra-2.5.2 and digikam-2.9.0 (each needs rebuilding due to libkipi and friends soname bumps)
15:35:31 <rdieter> and other libkipi-using apps are included too, of course.
15:35:38 <Kevin_Kofler> OK
15:37:04 <rdieter> so... queue'ing the f17 update probably ought to wait for calligra-2.5.2 release announcment (it's only available to packagers so far)
15:37:23 <jreznik_n9> ok
15:37:53 <Kevin_Kofler> IIRC the release is scheduled for tomorrow.
15:38:40 <Kevin_Kofler> Yeah, Wednesday they said, so tomorrow.
15:38:43 <rdieter> wrt to f18, any opinions on when to submit it?  options include: asap, wait for f18-alpha, some phase of the moon ... ?
15:39:03 <ltinkl> I'd say after alpha
15:39:39 <Kevin_Kofler> Maybe after the dust settles and we know we won't have to queue a hotfix for some blocker.
15:39:58 <rdieter> yeah, that would... suck.
15:40:46 <rdieter> #agreed queue f17 kde-4.9.1 updates tomorrow (wed), after calligra-2.5.2 public release announcement
15:41:09 <rdieter> #agreed wait until after f18-alpha release to queue kde-4.9.1 for updates-testing
15:41:20 <rdieter> #topic open discussion
15:41:23 <rdieter> anything else for today?
15:41:47 <dvratil> https://bugzilla.redhat.com/show_bug.cgi?id=856086
15:41:51 <dvratil> (sorry, late again)
15:42:05 <rdieter> dvratil: hi
15:42:22 <dvratil> it's nothing major, but I think it would be NTH :)
15:42:26 <rdieter> that's... a strange bug
15:42:37 <rdieter> a kwin running ?
15:42:42 <dvratil> yup
15:42:55 <dvratil> just Anaconda does not use window decorations
15:43:08 <dvratil> (the title of the bug is malformed)
15:43:16 <Kevin_Kofler> WTF? If KWin is running, why are there no windecos?!
15:43:51 <dvratil> dunno, probably they disabled it by default?
15:44:34 <Kevin_Kofler> Might be that Anaconda is giving bad WM hints (which might happen to do the right thing on Metacity).
15:44:42 <rdieter> dvratil: yes, please do be propose it as blocker/nth
15:44:50 <dvratil> ok
15:45:21 * rdieter added to F18Blocker-kde tracker
15:46:06 <Kevin_Kofler> And please also adjust the summary and add a comment to report your latest findings (KWin running, but no windecos).
15:46:48 <rdieter> for giggles earlier today, I whipped up an initial try at qt-4.8.3-rc1 packaging, http://rdieter.fedorapeople.org/rpms/qt/
15:47:16 <Kevin_Kofler> Is that any different packaging-wise from 4.8.2?
15:47:17 <rdieter> might even take some time to start in on qt5-beta fun
15:47:31 <rdieter> Kevin_Kofler: no, shouldn't be
15:47:57 <rdieter> was simply rebasing patches, removing already-upstreamed ones
15:48:29 <rdieter> it has the QtScript-JIT thing included however, we may want to consider reverting that (like we did for our qt-4.8.2 builds) to avoid regressions
15:49:48 <Kevin_Kofler> Yeah.
15:49:54 <jreznik_n9> yep, we have to revert that
15:50:12 <jreznik_n9> it was toolate I reported it upstream
15:50:18 <Kevin_Kofler> Broken upstream "fix".
15:51:13 <rdieter> ok, i'll revert it then in the next iteration.
15:51:34 <rdieter> this only the pre-release test tarball, nothing official, so won't commit it anywhere yet
15:52:22 <rdieter> initial scratch build underway, http://koji.fedoraproject.org/koji/taskinfo?taskID=4475385
15:52:27 <rdieter> uploading it took awhile
15:52:44 <rdieter> anything else for today?
15:54:25 <rdieter> seems like a no.  keep hammering on f18 stuff.
15:54:28 <rdieter> thanks everyone
15:54:31 <rdieter> #endmeeting