18:00:01 <nirik> #startmeeting Infrastructure (2012-09-13)
18:00:01 <zodbot> Meeting started Thu Sep 13 18:00:01 2012 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:01 <nirik> #meetingname infrastructure
18:00:01 <zodbot> The meeting name has been set to 'infrastructure'
18:00:01 <nirik> #topic Welcome Starfighters!
18:00:01 <nirik> #chair smooge skvidal CodeBlock ricky nirik abadger1999 lmacken dgilmore mdomsch threebean
18:00:01 <zodbot> Current chairs: CodeBlock abadger1999 dgilmore lmacken mdomsch nirik ricky skvidal smooge threebean
18:00:11 * relrod_ here
18:00:21 * pingou 
18:00:29 * lmacken 
18:00:32 * Spack here
18:00:34 * _badboy_ here
18:00:44 * tflink is somewhat here
18:01:24 <nirik> ok, will wait a minute more for folks to wander in.
18:02:27 <smooge> here
18:02:32 <nirik> ok, I guess we should go ahead and get started in then...
18:02:36 <nirik> #topic New folks introductions and Apprentice tasks
18:02:56 <nirik> Any new folks like to introduce themselves? or apprentices have any questions/comments?
18:02:58 * abadger1999 here
18:03:14 <WITRChris> I'm a new folk, I haven't had a chance to send off an e-mail to the list yet
18:03:32 <nirik> welcome WITRChris.
18:03:44 <nirik> Are you more interested in the sysadmin or application devel side of things?
18:03:53 <WITRChris> I'm more interested in tye sysadmin side of things
18:04:00 <lmacken> WITRChris: welcome! WITR, like RIT's radio station?
18:04:05 <WITRChris> indeed
18:04:11 <lmacken> nice :)
18:04:25 * lmacken wears his witr shirt every now and then
18:04:34 <WITRChris> undergrad RIT student, working as a sysadmin on co-op (paid internship) in boston
18:04:35 <nirik> cool. See me after the meeting and I can get you setup as an apprentice and point you to tickets and such.
18:04:42 <WITRChris> sure :)
18:04:57 <nirik> and do feel free to ask questions or chime in on any of our irc channels. ;)
18:05:15 <Spack> !
18:05:21 <nirik> Spack: go ahead...
18:05:22 <Spack> little question
18:05:40 <Spack> trying to get ip and route config of hosts defined in nagios
18:05:51 <Spack> i succeeded for 60 hosts
18:05:57 <Spack> but i miss 134
18:06:06 <nirik> FYI, for apprentice/new folks, I remembered that I had a presentation on fedora infra early this year. The slides might be good as an overview of what we do, etc. See: http://kevin.fedorapeople.org/infrastructure-intro-2012-02-09.odp
18:06:13 <Spack> is there a way to get those info?
18:06:31 <nirik> Spack: I can probibly get that for you... those are hosts you cannot login to?
18:06:48 <Spack> little questionyes
18:06:57 <nirik> note that there is overlap... ie:
18:07:21 <nirik> proxy01.phx2.fedoraproject.org is also proxy01.vpn.fedoraproject.org and part of fedoraproject.org in dns.
18:07:26 <Spack> true bug with screen comming back
18:07:36 <nirik> hum?
18:08:04 <nirik> Spack: didn't get that last bit...
18:08:18 <Spack> sorry a bug with screen
18:08:29 <nirik> ah, ok. ;)
18:08:34 <Spack> so indeed ithose are hosts i cannot connect to
18:08:47 <nirik> ok, I can try and gather info you need after the meeting...
18:08:56 <Spack> ok thanks
18:09:10 <nirik> any other general apprentice questions? will move on if not...
18:09:23 <nirik> #topic Applications status / discussion
18:09:33 <nirik> ok, any application news this week or upcoming next?
18:09:43 <nirik> abadger1999 / pingou / lmacken / relrod / threebean ?
18:09:47 <pingou> I have been working on fedocal, still need a little bit of work but it's coming along
18:10:13 <pingou> nirik: early october, do you think we could deploy a test instance for it ?
18:10:18 <nirik> pingou: so, can you talk a bit about what fedocal is/does again?
18:10:22 <dgilmore> i really would love someone to help with my composedb
18:10:34 <abadger1999> Not in the past week.  I'll be spinning a new pkgdb release who's onl purpose is to consolidate the hotfixes we've accumulated in the coming week.
18:10:46 <tflink> dgilmore: composedb?
18:10:46 <abadger1999> for deployment after this freeze finally ends :-)
18:11:00 <abadger1999> (Thanks nirik for help with that :-)
18:11:04 <nirik> abadger1999: ok, cool. Let me know if I can help anymore...
18:11:27 <relrod> I tried upgrading staging FAS and ran into fancyflash issues. I'm mid-process for doing a new beta release without the commit that added fancyflash stuff, and will try the upgrade again when I get that done
18:11:51 <pingou> fedocal: the idea is to have a single place to handle calendar, be it #fedora-meeting(,-1,-2) or any other, this would also allow to send reminder automatically to the different email desired
18:13:17 <nirik> pingou: so, it's for meetings only or any other milestones? and it would have a web interface to add/edit/remove entires? and a ical feed?
18:13:45 <nirik> dgilmore: is there any specs for composedb? I wonder if we couldn't write up things and try and get people more exited by it.
18:13:46 <pingou> nirik: web interface, no ical at first (long term that would be nice)
18:14:02 <pingou> nirik: 'calendar' could be anything, even release schedule if we would like to
18:14:22 <pingou> or tests-days
18:14:33 <nirik> so everything appears on one? or it's seperate calendars per thing?
18:14:50 <pingou> one calendar at a time
18:15:08 <dgilmore> nirik: i should do that
18:15:39 <dgilmore> tflink: the idea is to have a single point where you can get the status of releng process and releases etc
18:16:43 <tflink> ok, I was planning to add the concept of "spins" to the blocker tracking app so that there is an easy way to figure out which blocker/nth fixes are in which spin (TC/RC/test)
18:16:50 <tflink> but it sounds like you were looking for a bit more than that
18:17:01 <tflink> s/was/am
18:17:09 <nirik> pingou: ok. I guess I feel uneasy about another application, but we have failed to find any existing thing we could use for this...
18:17:51 <pingou> nirik: agreed
18:18:14 <nirik> ok, any other apps news? or shall we move along to sysadmin side of things?
18:18:24 <pingou> nirik: I would be fine if we find a real calendar things in which we plugin a reminder system
18:18:54 <pingou> radical looked nice but it's not 100% caldav and thus not 100% supported everywhere
18:19:12 <nirik> yeah.
18:19:50 <pingou> and trying to make radical full caldav might be a little beyond my free-time possibilities :)
18:20:10 <nirik> yeah, understood.
18:20:24 <nirik> I guess it might be good to ping the list with what you have/are planning?
18:21:14 <nirik> and possibly cross post to the fedora-logistics list?
18:21:31 <pingou> nirik: I was thinking to do that with something to show/try
18:21:38 <nirik> ok
18:21:47 <abadger1999> nirik: something else that came up this week is what we want the future of web app accessibility to look like.
18:21:50 <pingou> or should I do that earlier ?
18:22:01 <nirik> pingou: up to you I guess... :)
18:22:27 <pingou> ok :)
18:22:32 <nirik> abadger1999: oh? yeah, our accessability is probibly poor. ;( we have audio on some captchas, but dunno anything else we have really.
18:23:19 <abadger1999> nirik: <nod>  We have been trying to make things generally accessible to blind users (but we do have some failings)
18:23:38 <abadger1999> nirik: But maybe it's time to revisit either how we do that or whether we need to do that.
18:23:59 <abadger1999> nirik: I'll likely send an email out to the list this week about it.
18:24:26 <nirik> sounds good. Perhaps thats something we could setup some kind of tracker for and/or usability checking...
18:24:34 <abadger1999> But if anyone knows about people who specialize in accessibility issues... I have some unanswered questions that would be nice to know about :-)
18:25:22 <nirik> perhaps we could ask gnome or kde folks... they might have some contacts.
18:25:35 <abadger1999> <nod>  I asked walters but he wasn't sure.
18:26:04 * abadger1999 will try to reach some other people.
18:26:04 <nirik> ok, anything else application wise?
18:26:12 <nirik> thanks
18:26:15 <nirik> #topic Sysadmin status / discussion
18:26:32 <nirik> On the sysadmin side... lets see.
18:26:48 <nirik> We have some new machines coming online soon. A osuosl02 machine.
18:26:54 <nirik> a new virthost machine in phx2
18:27:00 <nirik> and 2 new builder boxes.
18:27:26 <nirik> #info new machines: osuosl02, virthost14 and 2 new builders
18:27:51 <nirik> We continue to have a httpd issue on app servers. I should file a ticket to coordinate trying to fix it.
18:27:54 <nirik> It's getting anoying.
18:28:28 <nirik> We have our euca cloud instance up and working. Need to get some more folks accounts to test on it with.
18:28:43 <nirik> Our openstack cloud instance is proving troublesome. I might reinstall it again later today.
18:29:04 <_love_hurts_> !
18:29:12 <nirik> feel free to chime in anytime.
18:29:24 <_love_hurts_> which side I'm working on?
18:29:34 <_love_hurts_> sysadmin or devel :)
18:29:43 <_love_hurts_> nowhere I guess :D
18:29:44 <nirik> _love_hurts_: sysadmin. I guess.
18:29:50 <_love_hurts_> ok, thx
18:29:57 <nirik> well, or both. Docs apply to both I suppose. ;)
18:30:00 <pingou> nirik: you said that fedocal might be a nice test for the cloud ? :)
18:30:02 <_love_hurts_> do you have something for me in cloud side?
18:30:23 <nirik> pingou: yeah, I can make you an instance if you like... do you have something thats deployable ?
18:30:24 <_love_hurts_> I would love to do R&D on that
18:30:40 <pingou> nirik: I think I'll have early next week
18:30:46 <nirik> _love_hurts_: well, we are still just poking around on it, it's not production yet really. See:
18:30:55 <nirik> https://fedoraproject.org/wiki/Infrastructure_private_cloud
18:31:19 <nirik> I'd like to nail down some more cases and setup some more groups, then open it up to more people to test on.
18:31:21 <_love_hurts_> ok, let me know when you have something for me...
18:31:58 <nirik> can do.
18:32:09 <nirik> pingou: might work for a short term test instance, see me when you are ready.
18:32:29 <pingou> nirik: I want something short anyway, I'll be gone for few days after
18:32:41 <nirik> #topic F18 Alpha Release tickets/Freeze
18:32:55 <nirik> we are still in freeze. Perhaps next week or the week after we can actually release a Alpha. ;)
18:33:12 <nirik> I'll follow up on release tickets as we get closer to an actual release. ;)
18:33:24 <nirik> #topic Private Cloud status update
18:33:31 <nirik> I guess we already touched on this above
18:33:47 <nirik> probibly in the next few weeks we will open things up to more testing.
18:33:55 <nirik> #topic Security FAD update
18:34:10 <nirik> https://fedoraproject.org/wiki/FAD_Infrastructure_Security_2012
18:34:22 <nirik> so, our dates are in freeze, but I guess I won't care. ;)
18:34:40 <nirik> I'm going to try and gather up our budget needs and see where we are soon.
18:34:50 <nirik> So, if you are planning on attending, please update your info there.
18:35:13 <nirik> we will be working on irc too, so remote folks are always welcome.
18:35:39 <nirik> any question or comments on the fad?
18:36:26 <nirik> #topic WikiChanges page
18:36:50 <_love_hurts_> !
18:36:53 <nirik> so, puiterwijk has setup a wiki page with changes to the wiki.
18:36:54 * puiterwijk is here. sorry for being too late
18:37:20 <pingou> puiterwijk: s/too late/just on time/
18:37:21 <nirik> _love_hurts_: just chime in. We don't really use the meeting protocol. ;)
18:37:29 <nirik> https://fedoraproject.org/wiki/WikiChanges
18:37:29 <_love_hurts_> am I going to get some page for uploading and getting feedback on my work?
18:38:16 <nirik> _love_hurts_: I'd suggest making a page under your username to draft changes. When it's done/looks good, we can move it in place of the existing page...
18:38:56 <nirik> so, this WikiChanges page is to list changes we make the wiki. So folks can see whats been added/fixed.
18:38:57 <_love_hurts_> yes, but I need more info on that...
18:39:20 <_love_hurts_> how and where I will create page?
18:40:35 <nirik> _love_hurts_: just go to: https://fedoraproject.org/wiki/User:YourFASUSERNAME/Architecture
18:40:44 <_love_hurts_> ok...thanks!
18:40:54 <nirik> it will ask you if you want to create it, you do, import the info from the existing page (that you want to reuse)
18:41:30 <nirik> :)
18:41:34 <_love_hurts_> ok, I will do that :)
18:41:45 <puiterwijk> can I make a request for the WikiChanges page? :)
18:41:59 <nirik> puiterwijk: anything else on this? we just want anyone fixing things on the wiki to use this page to show changes?
18:42:04 <nirik> uh... sure!
18:42:28 <puiterwijk> I would like to ask anyone doing anything to the the wiki (plugins, configurations, bugfixes, ...), if they could update that page, or ask me to do so?
18:43:08 <nirik> yep. we will need to remember to keep it updated as we go.
18:43:36 <nirik> puiterwijk: might update the wiki sop in infra docs too with info about it?
18:43:39 <puiterwijk> maybe add a file UPDATEWIKICHANGES in puppet/modules/mediawiki? just to help us remember?
18:44:11 <nirik> sure, not sure that will help completely, but a note there would be probibly good.
18:44:17 <puiterwijk> but I'll update the docs to add it, but I just don't think everyone will check the docs everytime they change something ;)
18:44:47 <nirik> yeah, there's no foolproof way, we can just do the best we can
18:45:09 <puiterwijk> yeah. that's why you can also just ask me if you're busy with a quick bugfix ;)
18:45:35 <nirik> #info please record infra changes to the wiki in the https://fedoraproject.org/wiki/WikiChanges page, or ask someone to do so when you make infrastructure changes to the wiki.
18:45:41 * nirik nods.
18:45:53 <puiterwijk> (I might also ask others to do so if I'm busy ;))
18:45:58 <nirik> ok, anything more on wikichanges?
18:46:12 <puiterwijk> not from me. maybe others want to know anything about it?
18:46:54 <nirik> thanks puiterwijk. We should also advertise the page. I'll try and do some of that...
18:46:59 <nirik> #topic Upcoming Tasks/Items
18:47:10 <nirik> get ready for info dump... :)
18:47:13 <nirik> #info 2012-08-14 to 2012-09-18 F18 Alpha Freeze
18:47:13 <nirik> #info 2012-09-10 to 2012-09-24 Skvidal is out
18:47:13 <nirik> #info 2012-09-18 F18 Alpha release.
18:47:13 <nirik> #info 2012-10-09 to 2012-10-23 F18 Beta Freeze
18:47:13 <nirik> #info 2012-10-23 F18 Beta release
18:47:13 <nirik> #info 2012-11-13 to 2012-11-27 F18 Final Freeze
18:47:15 <nirik> #info 2012-11-20 FY2014 budget due
18:47:17 <nirik> #info 2012-11-26 to 2012-11-29 Security FAD
18:47:19 <nirik> #info 2012-11-27 F18 release.
18:47:21 <nirik> #info 2012-11-30 end of 3nd quarter
18:47:23 <nirik> #info 2012-12-24 - 2013-01-01 Red Hat Shutdown for holidays.
18:47:26 <nirik> #info 2013-01-18 to 2013-01-20 FUDCON Lawrence
18:47:29 <nirik> so, there is our upcoming stuff now. Anything to add/change?
18:47:32 * pingou will be afk from the 19th to the 30th
18:47:35 <nirik> of course if we slip again, the releases and freezes slip
18:47:37 <pingou> of this month
18:47:44 <nirik> pingou: cool. Going somewhere fun I hope.
18:47:51 <pingou> nirik: grappe harvest :)
18:48:23 <nirik> cool.
18:49:01 <nirik> ok, anything else upcoming?
18:49:09 <nirik> #topic Smolt
18:49:15 <smooge> KILL IT
18:49:22 <nirik> I started a wiki page: https://fedoraproject.org/wiki/Smolt_retirement
18:49:33 <nirik> this lists the things we need to get done to retire it, etc.
18:49:55 <nirik> We should look and see if we can get it done for f18...
18:50:02 <lmacken> how will old installs react when the smolt server ceases to exist? is the smoltClient smart enough to gracefully fail or will it spin?
18:50:16 <nirik> lmacken: we need to determine that. ;)
18:50:37 <nirik> we may need to keep up a discard service that just takes connections and /dev/nulls the input.
18:51:05 <nirik> if someone has time to investigate the things there/file bugs, etc... that would be great.
18:51:06 * lmacken nods
18:51:14 <puiterwijk> nirik: I can look into this all?
18:51:27 <nirik> puiterwijk: sure. :)
18:51:31 <puiterwijk> both how the client handles no server availability, and in case needed a /dev/null server?
18:52:08 <nirik> that would be great if you want to look into it.
18:52:27 <puiterwijk> sure
18:52:46 <nirik> #action puiterwijk will take a look at how clients handle server down and if we need a discard service
18:53:24 <abadger1999> lmacken: I don't think it will be graceful (think it'll wait for a timeout of some sort)
18:53:29 <nirik> we will need to file some bugs (firstboot, spins kickstarts) and see if we need an update for the existing clients in releases.
18:53:54 <nirik> of course there will always be many more unupdated clients out there.
18:54:15 <abadger1999> smooge's idea was to just take data,  mock up a success reply, and discard the data.... seemed reasonable to me.
18:54:41 <puiterwijk> abadger1999: yeah, that's what I meant with a discard service ;)
18:54:45 <nirik> yeah, we may need to go that route indeed.
18:54:54 <nirik> #topic Open Floor
18:55:02 <nirik> well, we have about 5min left. Anything for open floor?
18:55:21 <smooge> not me
18:55:34 <threebean> Well, not much time.  Anyone have any comments on lmacken's email about composedb?  http://lists.fedoraproject.org/pipermail/infrastructure/2012-September/012148.html
18:55:58 * lmacken votes to just adding the branched/rawhide fedmsg hooks asap
18:56:06 <lmacken> (since the patch is already done)
18:56:13 <threebean> dgilmore: Its related to what we were talking about yesterday.
18:57:14 * abadger1999 thinks its really up to dgilmore and the other releng people
18:57:30 <nirik> yeah, I'd be ok with that, but it's up to dgilmore... and probibly after freeze.
18:57:41 <abadger1999> but composedb may be a long way off so hooking it up to the scripts does make sense.
18:57:50 <dgilmore> i had a quick look at the patch. as a stop gap it would work
18:58:04 <dgilmore> there are many other areas that we could and should hook up notifications
18:58:19 * nirik nods. message bus the world! :)
18:58:26 <threebean> yeah, if we can defer choosing those to once composedb is done... I'm fine with that.
18:58:41 * lmacken notes https://github.com/ralphbean/fedmsg/blob/develop/doc/status.rst -- if you can think of more, let us know
18:59:05 <nirik> cool, so wait for freeze to be over and push that change sound ok to everyone?
18:59:18 * threebean nods
18:59:34 <nirik> cool. well, we are out of time...
18:59:39 <lmacken> sounds good
18:59:45 <nirik> so continue over in #fedora-admin and #fedora-apps and #fedora-noc. ;)
18:59:45 <_love_hurts_> :)
18:59:53 <nirik> Thanks for coming everyone
18:59:55 <nirik> #endmeeting